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PC*MILER® 31 Product Line 
END-USER LICENSE AGREEMENT 

 
1. Grant of License:  Subject to the terms, conditions, use limitations and payment of fees as set 

forth herein, ALK Technologies, Inc. ("ALK") grants the end-user ("you") a non-assignable, 
non-transferable, non-exclusive license to install and use the PC*MILER solution(s) 
(including traffic data or any other subscriptions as applicable) you have purchased 
("PC*MILER") on a single personal computer.  The PC*MILER software, data and 
documentation are provided for your personal, internal use only and not for resale.  They are 
protected by copyright held by ALK and its licensors and are subject to the following terms 
and conditions which are agreed to by you, on the one hand, and ALK and its licensors 
(including their licensors and suppliers) on the other hand. 

  
2. Title:  You acknowledge that the PC*MILER computer programs, data, concepts, graphics, 

documentation, manuals and other material owned by, developed by or licensed to ALK, 
including but not limited to program output (together, "program materials"), are the exclusive 
property of ALK or its licensors.  You do not secure title to any PC*MILER program materials 
by virtue of this license. 

  
3. Copies:  You may make one (1) copy of the PC*MILER program materials, provided you 

retain such copy in your possession and use it solely for backup purposes.  You agree to 
reproduce the copyright and other proprietary rights notices of ALK and its licensors on such 
a copy.  Otherwise, you agree not to copy, reverse engineer, interrogate, or decode any 
PC*MILER program materials or attempt to defeat protection provided by ALK for preventing 
unauthorized copying or use of PC*MILER or to derive any source code or algorithms 
therefrom.  You acknowledge that unauthorized use or reproduction of copies of any program 
materials or unauthorized transfer of any copy of the program materials is a serious crime and 
is grounds for suit for damages, injunctive relief and attorney's fees. 

  
4. Limitations on Transfer:  This license is granted to you by ALK.  You may not directly or 

indirectly lease, sublicense, sell, disseminate, or otherwise transfer PC*MILER or any 
PC*MILER program materials to third parties, or offer information services to third parties 
utilizing the PC*MILER program materials without ALK's prior written consent.  To comply 
with this limitation, you must uninstall and deactivate PC*MILER from your computer prior 
to selling or transferring that computer to a third party. 

  
5. Anti-Piracy Protection:  PC*MILER may include product activation and other technology to 

prevent unauthorized use and copying.  If provided with an install product key code (the 
"Product Key Code"), or any other similar mechanism, you will need to activate PC*MILER 
with the associated method in order to use it.  If you try to activate or install an excessive or 
unauthorized number of times or in an unauthorized environment, the ALK Anti-Piracy 
Protection may cause PC*MILER to lock and prevent you from further activating or using 
PC*MILER.  Refer to ALK's help page at https://activate.alk.com for more information about 
our Product Activation and Anti-Piracy Protection. 
 

6. Limitations on Network Access:  You may not allow end-users or software applications on 
other computers or devices to directly or indirectly access this copy of PC*MILER via any 
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type of computer or communications network (including but not limited to local area networks, 
wide area networks, intranets, extranets, the internet, virtual private networks, Wi-Fi, 
Bluetooth, and cellular and satellite communications systems), using middleware (including 
but not limited to Citrix MetaFrame and Microsoft Terminal Server) or otherwise (including 
but not limited to access through PC*MILER interface products), or install or use PC*MILER 
on a network file server, without first notifying ALK, executing a written supplemental license 
agreement, and paying the license fee that corresponds to the number and types of uses to 
which access is to be allowed. 

  
7. Limitations on Data Extraction:  You may manually extract data (including but not limited to 

program output such as distances, maps, and driving directions) from PC*MILER and use it 
in other applications on the same computer on which PC*MILER is legally licensed and 
installed, as permitted below.  You may not transfer data extracted from PC*MILER onto any 
other computer or device unless you have licensed PC*MILER for that computer or 
device.  You agree that you will not, nor will you permit your trade partners or anyone else to, 
use content derived from PC*MILER, including route line data, nor display such data or 
integrate such data into another provider's service, including, but not limited to, Google or 
Bing.  You agree not to pre-fetch, retrieve, cache, index, or store any data, content, or other 
portion of the product output at any time, provided, however, that you may temporarily store 
(for less than thirty (30) days) limited amounts of such content for the sole and exclusive 
purpose of enhancing the performance of your implementation due to network latency, and 
only if you do so securely and in a manner that: (a) does not permit use of the content outside 
of the scope of this Agreement; (b) does not manipulate or aggregate any content or portion 
thereof; (c) does not prevent ALK from accurately tracking usage; and (d) does not modify 
attribution of the product in any way. 

  
8. Limitations on Mobile Communications:  Without limiting the generality of the foregoing, you 

may not transmit PC*MILER street-level driving directions through mobile communications 
systems such as satellite, or cellular services or to mobile devices such as computers, telematics 
systems, on board or mobile computers or Smartphones, handhelds, pagers, electronic 
recording devices or telephones without first executing a written supplemental license 
agreement with ALK and paying the license fee that corresponds to the number and types of 
devices and systems to and through which transmission is to be permitted. 

  
9. Limitations on Disclosure:  You may disclose PC*MILER distances to trading partners, in the 

course of their providing services to you, for specific origin-destination moves for which you 
provide transportation services and use PC*MILER distances as a basis for payment.  You may 
not make any other disclosure of PC*MILER programs and materials, including, but not 
limited to, program output, to anyone outside the legal entity that paid for and holds this 
license, without prior written permission of ALK.  You acknowledge that the PC*MILER 
programs and materials, developed by or licensed to ALK are very valuable to ALK and its 
licensors, and their use or disclosure to third parties, except as permitted by this license or by 
a written supplemental license agreement with ALK, is strictly prohibited. 

  
10. Security:  You agree to take reasonable and prudent steps to safeguard the security of the 

PC*MILER program materials and to notify ALK immediately if you become aware of the 
theft or unauthorized possession, use, transfer or sale of the PC*MILER program materials 
licensed to you by ALK.  



 

 
PC*MILER Product Line End-User License Agreement  ix 

11. Acceptance:  You are deemed to have accepted the PC*MILER program materials upon 
receipt. 

  
12. Warranties:  ALK represents and warrants that:  

a)  For ninety (90) days from date of purchase, PC*MILER, when delivered and properly 
installed, will function substantially according to its specifications on a computer 
purchased independently by you. 

b)  For ninety (90) days from date of purchase, the software media on which ALK provides 
PC*MILER to you will function substantially free of errors and defects.  ALK will replace 
defective media during the warranty period at no charge to you unless the defect is the 
result of accident, abuse, or misapplication of the product. 

c) THE FOREGOING WARRANTIES ARE IN LIEU OF ALL OTHER WARRANTIES 
EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITING THE GENERALITY OF 
THE FOREGOING ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR 
A PARTICULAR USE.  THE PC*MILER PROGRAM, DATA AND 
DOCUMENTATION IS SOLD "AS IS". IN NO EVENT SHALL ALK OR ITS 
LICENSORS BE LIABLE FOR ANY INDIRECT, SPECIAL OR CONSEQUENTIAL 
DAMAGES SUCH AS, BUT NOT LIMITED TO, LOSS IN CONNECTION WITH OR 
ARISING OUT OF THE EXISTENCE OF THE FURNISHING, FUNCTIONING OR 
USE OF ANY ITEM OF SOFTWARE, DATA OR SERVICES PROVIDED FOR IN 
THIS AGREEMENT.  IN NO EVENT SHALL DAMAGES TO WHICH ALK MAY BE 
SUBJECT UNDER THIS AGREEMENT EXCEED THE CONTRACT PRICE.  THIS 
WARRANTY SHALL NOT ACCRUE TO THE BENEFIT OF THIRD PARTIES OR 
ASSIGNEES. 

  
13. Disclaimer:  The data may contain inaccurate, incomplete or untimely information due to the 

passage of time, changing circumstances, sources used and the nature of collecting 
comprehensive geographic data, any of which may lead to incorrect results.  PC*MILER's 
suggested routings, fuel and traffic data are provided without a warranty of any kind.  The user 
assumes full responsibility for any delay, expense, loss or damage that may occur as a result 
of their use. 

 
14. Termination:  This Agreement will terminate immediately upon any of the following events: 

a)  If you seek an order for relief under the bankruptcy laws of the United States or similar 
laws of any other jurisdiction, or a composition with or assignment for the benefit of 
creditors, or dissolution or liquidation, or if proceedings under any bankruptcy or 
insolvency law are commenced against you and are not discharged within thirty (30) 
calendar days. 

b) If you materially breach any terms, conditions, use limitations, payment obligations, or any 
other terms of this Agreement. 

c) Upon expiration of any written supplemental license agreement between you and ALK of 
which this license is a part. 
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15. Obligations on Termination:  Termination or expiration of this Agreement shall not be 
construed to release you from any obligations that existed prior to the date of such termination 
or expiration. 

 
16. Hold Harmless and Indemnity:  Except as otherwise provided in your agreement with ALK, 

the following article applies: To the maximum extent permitted by applicable law, you agree 
to hold harmless and indemnify ALK and its parent company, subsidiaries, affiliates, officers, 
agents, licensors, owners, co-branders,  other partners, and employees from and against any 
third party claim (other than a third party claim for Intellectual Property Rights) arising from 
or in any way related to your use of PC*MILER, including any liability or expense arising 
from all claims, losses, damages (actual and/or consequential), suits, judgments, litigation costs 
and attorney's fees, of every kind and nature. ALK shall use good faith efforts to provide you 
with written notice of such claim, suit or action. 

 
17. Disclosure for Products Containing Certain Data: 
 

a) Historical or Real-time Traffic data:  traffic data, including historical traffic data, is 
licensed as an optional subscription service which must be renewed annually for continued 
use.  ALK and its licensor(s) will use commercially reasonable efforts to make traffic data 
available at least 99.5% of the time each calendar month, excluding minor performance or 
technical issues as well as downtime attributable to necessary maintenance, and Force 
Majeure. 
 

b) This data is provided to you "as is," and you agree to use it at your own risk.  ALK and its 
licensors (and their licensors and suppliers) make no guarantees, representations or 
warranties of any kind, express or implied, arising by law or otherwise, including but not 
limited to, content, quality, accuracy, completeness, effectiveness, reliability, fitness for a 
particular purpose, usefulness, use or results to be obtained from this Data, or that the Data 
or server will be uninterrupted or error-free. 

 
18. Limitations on Export:  You hereby expressly agree not to export PC*MILER, in whole or in 

part, or any data derived therefrom, in violation of any export or other laws or regulations of 
the United States.  You acknowledge and agree that ALK commodities, technology or software 
that will be exported from the United States will be in accordance with U.S. Export 
Administration Regulations. Diversion contrary to U.S. law is prohibited.  Export or re-export 
of ALK goods may require an export license or may be prohibited as it pertains to commodities, 
technology or software of U.S. origin. 

 
19. Aggregated Data:  Except as otherwise provided in your agreement with ALK, the following 

article applies: ALK may, from time to time, share information about You with parent and 
sister or affiliated companies for business purposes and when necessary for it to perform work 
under this End User License Agreement.  In addition, ALK may, and is hereby authorized to, 
use, share and provide certain aggregated, non-identifiable information derived from Your use 
of PC*MILER to third parties. 

 
20. ALK Cloud Feature:  ALK Cloud feature, if used, will store in an anonymized way Your data 

in a cloud account in order to allow You to securely synchronize Your data with other users in 



 

 
PC*MILER Product Line End-User License Agreement  xi 

Your organization.  End-User data is deemed the confidential information of the End-User. For 
more information, you may refer to ALK's Privacy Policy. 

 
21. Internet-Based Services Components:  Certain features of PC*MILER require connection to 

the Internet directly or through a wireless connection in order to function. Such features may 
result in the transfer of certain data over such connection, which may or may not be encrypted. 
You are solely responsible for obtaining any necessary Internet, data or wireless subscription 
plans with the applicable service providers and you must comply with applicable third party 
terms of agreement when using PC*MILER. You further acknowledge that ALK is not 
responsible for the availability of the Internet or wireless connections or the security or 
integrity of data transmitted over such connections. 

 
22. Geographic Restrictions:  The Content and Services (as defined below) are provided for access 

for different areas in the world. You acknowledge and agree that you may not be able to access 
all or some of the same Content and Services depending as to where you are located in the 
world.  Access to PC*MILER may not be legal by certain persons or in certain countries. At 
all times, you are responsible for compliance with local laws. 

 
23. Content and Services:  PC*MILER may provide you with access to ALK's proprietary 

websites including without limitation at www.alk.com (the "Website") and products and 
services accessible thereon, and certain features, functionality, and content accessible on or 
through PC*MILER may be hosted on the Website (collectively, "Content and 
Services").  Your access to and use of such Content and Services are governed by this License 
and the Website's terms of use located at www.alk.com, which are incorporated herein by this 
reference.  Your access to and use of such Content and Services may require you to 
acknowledge your acceptance of such terms of use and/or to register with the Website, and 
your failure to do so may restrict you from accessing or using certain of PC*MILER's features 
and functionality. Any violation of such terms of use will also be deemed a violation of this 
License.  ALK DOES NOT PROVIDE ANY WARRANTY FOR, OR GUARANTEE THE 
AVAILABILITY OF, PRODUCTS AND SERVICES PURCHASED OR ADVERTISED 
THROUGH THE APPLICATION. 

  
24. Technical Support:  For one (1) year from date of purchase, ALK will provide you technical 

support on the PC*MILER product(s) purchased to those that are current on their payment. 
 

25. Disclosure for Optional Content Displayed in PC*MILER for Additional Purchase:  Traffic 
data, including historical traffic data, and any other optional content licensed as a subscription 
service must be renewed annually for continued use. You agree and acknowledge that ALK is 
not responsible for the content displayed which belongs to third parties, and advising you for 
the end of your subscription. 
 

26. Additional Use Terms, Conditions, Restrictions and Obligations:  This Agreement and your 
use of PC*MILER is expressly subject to the ALK Privacy Policy and the HERE and ALK 
End User License Agreement terms and conditions respectively  ("HERE EULA") and ("ALK 
EULA") set forth below.  YOU ACKNOWLEDGE AND AGREE THAT YOU MAY NOT 
USE PC*MILER IF YOU DO NOT ACCEPT THE TERMS AND CONDITIONS OF BOTH 
THE HERE AND ALK EULA AND YOU ACKNOWLEDGE THAT YOU HAVE 
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REVIEWED AND ACCEPT THE TERMS AND CONDITIONS OF BOTH THE HERE 
AND ALK EULA BY INSTALLING OR ACTUALLY USING PC*MILER. 

 
27. Copyright:  United States copyright law and international treaty provisions protect PC*MILER 

and the data transmitted by PC*MILER.  You agree that no title to the intellectual property in 
PC*MILER or the data is transferred to you.  You further acknowledge that title and ownership 
rights will remain the exclusive property of ALK or its licensors, and you will not acquire any 
rights to PC*MILER or the data except as expressly set out in this license. You agree that any 
copies of PC*MILER will contain the same proprietary notices that appear on and in 
PC*MILER.  The Copyright to PC*MILER is held by ALK Technologies, Inc., 1 
Independence Way, Princeton, NJ 08540 USA. Full contact details are available at 
www.alk.com. 
 

28. Miscellaneous:  This agreement shall be construed and applied in accordance with the laws of 
the State of New Jersey.  The Courts of the State of New Jersey shall be the exclusive forum 
for all actions or interpretation pertaining to this agreement.  Any amendments or addenda to 
this agreement shall be in writing executed by all parties hereto.  This is the entire agreement 
between the parties and supersedes any prior or contemporaneous agreements or 
understandings.  Should any provision of this agreement be found to be illegal or 
unenforceable, then only so much of this agreement as shall be illegal or unenforceable shall 
be stricken and the balance of this agreement shall remain in full force and effect. 
 

29. Date:  This EULA was last updated on August 9, 2017. Visit https://www.pcmiler.com/eula  
for regular updates. 

   
General Content Terms and Conditions 

 
The following terms shall apply to the use of map data  for the countries specified below to the 
extent that your product and/or services uses map data for each respective country: 
  

FOR HERE DATA 
 
This end user license agreement applies to HERE data included in your Software ("HERE 
EULA"), if any, as well as to HERE data you obtain separately that is formatted for use with your 
Software. 
  
The data ("Data") is provided for your personal, internal use only and not for resale.  It is protected 
by copyright, and is subject to the following terms and conditions which are agreed to by you, on 
the one hand, and ALK Technologies Inc. ("ALK") and its licensors (including their licensors and 
suppliers) on the other hand. 

  
© 2017 HERE.  All rights reserved. 
  
Personal Use Only:  You agree to use this Data together with PC*MILER for the solely personal, 
non-commercial purposes for which you were licensed, and not for service bureau, time-sharing 
or other similar purposes.  Accordingly, but subject to the restrictions set forth in the following 
paragraphs, you may copy this Data only as necessary for your personal use to (i) view it, and (ii) 

http://www.alk.com/
https://www.pcmiler.com/eula
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save it, provided that you do not remove any copyright notices that appear and do not modify the 
Data in any way.  You agree not to otherwise reproduce, copy, modify, decompile, disassemble or 
reverse engineer any portion of this Data, and may not transfer or distribute it in any form, for any 
purpose, except to the extent permitted by mandatory laws. Multi-disc sets may only be transferred 
or sold as a complete set as provided by ALK and not as a subset thereof. 
  
Restrictions:  Except where you have been specifically licensed to do so by ALK, and without 
limiting the preceding paragraph, you may not (a) use this Data with any products, systems, or 
applications installed or otherwise connected to or in communication with vehicles, capable of 
vehicle navigation, positioning, dispatch, real time route guidance, fleet management or similar 
applications; or (b) with or in communication with any positioning devices or any mobile or 
wireless-connected electronic or computer devices, including without limitation cellular phones, 
palmtop and handheld computers, pagers, and personal digital assistants or PDAs. 
  
Warning: The Data may contain inaccurate or incomplete information due to the passage of time, 
changing circumstances, sources used and the nature of collecting comprehensive geographic data, 
any of which may lead to incorrect results. 
  
No Warranty:  This Data is provided to you "as is," and you agree to use it at your own risk.  ALK 
and its licensors (and their licensors and suppliers) make no guarantees, representations or 
warranties of any kind, express or implied, arising by law or otherwise, including but not limited 
to, content, quality, accuracy, completeness, effectiveness, reliability, fitness for a particular 
purpose, usefulness, use or results to be obtained from this Data, or that the Data or server will be 
uninterrupted or error-free. 
  
Disclaimer of Warranty: ALK AND ITS LICENSORS (INCLUDING THEIR LICENSORS AND 
SUPPLIERS) DISCLAIM ANY WARRANTIES, EXPRESS OR IMPLIED, OF QUALITY, 
PERFORMANCE, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR 
NON-INFRINGEMENT.  Some States, Territories and Countries do not allow certain warranty 
exclusions, so to that extent the above exclusion may not apply to you. 
  
Disclaimer of Liability:  ALK AND ITS LICENSORS (INCLUDING THEIR LICENSORS AND 
SUPPLIERS) SHALL NOT BE LIABLE TO YOU: IN RESPECT OF ANY CLAIM, DEMAND 
OR ACTION, IRRESPECTIVE OF THE NATURE OF THE CAUSE OF THE CLAIM, 
DEMAND OR ACTION ALLEGING ANY LOSS, INJURY OR DAMAGES, DIRECT OR 
INDIRECT, WHICH MAY RESULT FROM THE USE OR POSSESSION OF THE 
INFORMATION; OR FOR ANY LOSS OF PROFIT, REVENUE, CONTRACTS OR SAVINGS, 
OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL 
DAMAGES ARISING OUT OF YOUR USE OF OR INABILITY TO USE THIS 
INFORMATION, ANY DEFECT IN THE INFORMATION, OR THE BREACH OF THESE 
TERMS OR CONDITIONS, WHETHER IN AN ACTION IN CONTRACT OR TORT OR 
BASED ON A WARRANTY, EVEN IF ALK OR ITS LICENSORS HAVE BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES.  Some States, Territories and Countries do not 
allow certain liability exclusions or damages limitations, so to that extent the above may not apply 
to you. 
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Export Control:  You agree not to export from anywhere any part of the Data provided to you or 
any direct product thereof except in compliance with, and with all licenses and approvals required 
under, applicable export laws, rules and regulations. 
  
Entire Agreement:  These terms and conditions constitute the entire agreement between ALK (and 
its licensors, including their licensors and suppliers) and you pertaining to the subject matter 
hereof, and supersedes in their entirety any and all written or oral agreements previously existing 
between us with respect to such subject matter. 
  
Governing Law:  The above terms and conditions shall be governed by the laws of Illinois, without 
giving effect to (i) its conflict of laws provisions, or (ii) the United Nations Convention for 
Contracts for the International Sale of Goods, which is explicitly excluded.  You agree to submit 
to the jurisdiction of the Illinois for any and all disputes, claims and actions arising from or in 
connection with the Data provided to you hereunder. 
  
Government End Users: If the Data is being acquired by or on behalf of the United States 
Government or any other entity seeking or applying rights similar to those customarily claimed by 
the United States government, the Data is a "commercial item" as that term is defined at 48 C.F.R 
("FAR") 2.101, is licensed in accordance with End-User Terms and each copy of Data delivered 
or otherwise furnished shall be marked and embedded as appropriate with the following "Notice 
of Use" and shall be treated in accordance with such Notice. 
  
Notice of Use 
Contractor (Manufacturer/Supplier) Name: HERE 
Contractor (Manufacturer/Supplier) Address: 425 W. Randolph Street, Chicago, Illinois 60606 
This Data is a commercial item as defined in FAR 2.101 and is subject to these End User Terms 
under which this Data was provided 
© 2017 HERE. All rights reserved 
  
If the Contracting Officer, federal government agency, or any federal official refuses to use the 
legend provided herein, the Contracting Officer, federal government agency, or any federal official 
must notify HERE prior to seeking additional or alternative rights in the Data. 
  

FOR ALK DATA  
 
This end user license agreement applies to ALK Data included in PC*MILER if any, as well as to 
ALK data you obtain separately that is formatted for use with your Software ("ALK EULA"). 
  
The data ("Data") is provided for your personal, internal use only and not for resale.  It is protected 
by copyright, and is subject to the following terms and conditions which are agreed to by you, on 
the one hand, and ALK Technologies, Inc. ("ALK") and its licensors (including their licensors and 
suppliers) on the other hand. 
  
© 2017 ALK.  All rights reserved. 
  
Personal Use Only:  "You" means you as an End-user or as a "Company" on behalf of its End-
Users which are subject to either a Non-Disclosure Agreement as employees or a License 
Agreement that contains the same restrictions as herein as a Value Added Reseller.  Also as used 
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in this EULA "personal use" can also be understood in more general terms as for a Company's use. 
You agree to use this Data together with PC*MILER for the solely personal, non-commercial 
purposes for which you were licensed, and not for service bureau, time-sharing or other similar 
purposes.  Accordingly, but subject to the restrictions set forth in the following paragraphs, you 
may copy this Data only as necessary for your personal use to (i) view it, and (ii) save it, provided 
that you do not remove any copyright notices that appear and do not modify the Data in any 
way.  You agree not to otherwise reproduce copy, modify, decompile, disassemble or reverse 
engineer any portion of this Data, and may not transfer or distribute it in any form, for any purpose, 
except to the extent permitted by mandatory laws. 

  
Restrictions:  Except where you have been specifically licensed to do so by ALK in the case of an 
integrated solution bundled or intended for use with specific smartphones, similar mobile 
communication device(s) or personal navigation device(s), and without limiting the preceding 
paragraph, you may not use this Data (a) with any products, systems, or applications installed or 
otherwise connected to or in communication with vehicles, capable of vehicle navigation, 
positioning, dispatch, real time route guidance, fleet management or similar applications; or (b) 
with or in communication with any positioning devices or any mobile or wireless-connected 
electronic or computer devices, including without limitation cellular phones, smartphones, 
palmtop and handheld computers, pagers, and personal digital assistants or PDAs. 

  
Warning:  The Data may contain inaccurate, untimely or incomplete information due to the 
passage of time, changing circumstances, sources used and the nature of collecting comprehensive 
geographic data, any of which may lead to incorrect results.  The Data is based on official highway 
maps, the Code of Federal Regulations, and information provided by state governments and other 
licensors.  It is provided without a warranty of any kind.  The user assumes full responsibility for 
any delay, expense, loss or damage that may occur as a result of use of the Data. 

  
No Warranty:  This Data is provided to you "as is," and you agree to use it at your own risk.  ALK 
and its licensors (and their licensors and suppliers) make no guarantees, representations or 
warranties of any kind, express or implied, arising by law or otherwise, including but not limited 
to, content, quality, accuracy, completeness, effectiveness, reliability, fitness for a particular 
purpose, usefulness, use or results to be obtained from this Data, or that the Data or server will be 
uninterrupted or error-free. 

  
Disclaimer of Warranty:  ALK AND ITS LICENSORS (INCLUDING THEIR LICENSORS 
AND SUPPLIERS) DISCLAIM ANY WARRANTIES, EXPRESS OR IMPLIED, OF 
QUALITY, PERFORMANCE, MERCHANTABILITY, AND/OR FITNESS FOR A 
PARTICULAR PURPOSE OR NON-INFRINGEMENT.  Some States, Territories and Countries 
do not allow certain warranty exclusions, so to that extent the above exclusion may not apply to 
you. 

  
Disclaimer of Liability:  ALK AND ITS LICENSORS (INCLUDING THEIR LICENSORS AND 
SUPPLIERS) SHALL NOT BE LIABLE TO YOU: IN RESPECT OF ANY CLAIM, DEMAND 
OR ACTION, IRRESPECTIVE OF THE NATURE OF THE CAUSE OF THE CLAIM, 
DEMAND OR ACTION ALLEGING ANY LOSS, INJURY OR DAMAGES, DIRECT OR 
INDIRECT, WHICH MAY RESULT FROM THE USE OR POSSESSION OF THE 
INFORMATION; OR FOR ANY LOSS OF PROFIT, REVENUE, CONTRACTS OR SAVINGS, 
OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL 
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DAMAGES ARISING OUT OF YOUR USE OF OR INABILITY TO USE THIS 
INFORMATION, ANY DEFECT IN THE INFORMATION, OR THE BREACH OF THESE 
TERMS OR CONDITIONS, WHETHER IN AN ACTION IN CONTRACT OR TORT OR 
BASED ON A WARRANTY, EVEN IF ALK OR ITS LICENSORS HAVE BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES.  Some States, Territories and Countries do not 
allow certain liability exclusions or damages limitations, so to that extent the above may not apply 
to you. 

  
Export Control:  You agree not to export from anywhere any part of the Data provided to you or 
any direct product thereof except in compliance with and with all licenses and approvals required 
under, applicable export laws, rules and regulations. 

  
Entire Agreement:  These terms and conditions constitute the entire agreement between ALK (and 
its licensors, including their licensors and suppliers) and you pertaining to the subject matter 
hereof, and supersedes in their entirety any and all written or oral agreements previously existing 
between us with respect to such subject matter. 

  
Governing Law:  The above terms and conditions shall be governed by the laws of the State of 
New Jersey.  The courts of the State of New Jersey shall have exclusive jurisdiction to settle any 
and all disputes, claims and actions arising from or in connection with the Data provided to you 
hereunder.  You agree to submit to such jurisdiction. 
  

FOR CANADA TERRITORY DATA 
 
The following provisions apply to data for Canada provided by Canada Post Corporation as the 
owner of the copyright, and Statistics Canada as the owner of all intellectual property rights, in the 
same data (collectively "Canada Post Data"). 
 
Neither Canada Post Data or Statistics Canada, shall be liable: (i) in respect of any claim, demand 
or action, irrespective of the nature or causes of the claim whatsoever, alleging any loss, injury or 
damages, direct or indirect, which may result from End User's use or possession of Canada Post 
Data; or (ii) in any way for loss of revenues or contracts, or any other consequential loss of any 
kind resulting from any defect in such Canada Post Data. 
  
End User agrees to indemnify and save harmless Canada Post and Statistics Canada and its officers, 
employees, agents from all claims alleging loss, costs, expenses, damages or injuries (including 
injuries resulting in death) arising out of End User's possession or use of Canada Data. 
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                 Introduction 
 

Welcome to ALK Technologies’ PC*MILER!  By purchasing a PC*MILER 
product, you have made a cost-effective investment in the transportation and 
logistics industry’s leading routing, mileage, and mapping software solution.  
Accuracy, reliability, and stability have positioned PC*MILER as the technology 
used by a majority of the top motor carriers and freight transportation firms in North 
America. The U.S. Department of Defense (DoD), the General Services 
Administration (GSA) and the Federal Motor Carrier Safety Administration 
(FMCSA) also rely on PC*MILER as their worldwide distance standard. If you're 
seeking to maximize revenues and minimize costs while utilizing the safest, most 
cost-effective routing for your vehicles and shipments, PC*MILER is the answer. 

 
PC*MILER is both easy to learn and easy to use.  You simply enter an origin, a 
destination, and any stops in between, and PC*MILER goes to work to calculate 
truck-specific routing that is displayed on a map.  Distances are returned along with 
time and cost estimates based on adjustable speed, time, and cost parameters.  
Detailed driving directions and a state mileage summary can quickly be generated 
with a click of the mouse.  Multiple routing options and additional features provide 
the tools you need to work effectively and productively.  
 
Before you go any further please read the License Agreement that starts on page i.  
It details the terms under which ALK Technologies, Inc. grants you a license, 
ALK's copyrights, and your rights as a licensee.   
 
THE SOFTWARE LICENSE CONTAINED IN THIS MANUAL LIMITS THE 
NUMBER AND TYPE OF COMPUTER ON WHICH YOU CAN LEGALLY 
USE PC*MILER.  BY INSTALLING PC*MILER, YOU HAVE ACCEPTED 
THE TERMS AND CONDITIONS OF THE LICENSE AGREEMENT.  ALK 
TECHNOLOGIES, INC. WILL TAKE PROPER LEGAL ACTION AGAINST 
ANY ILLEGAL USE OF THE PC*MILER SOFTWARE.  

 

1.1  What is PC*MILER? 
PC*MILER generates point-to-point mileage, routes, and driving instructions over 
the complete highway system in North America, including Greenland, Puerto Rico, 
St. Pierre and Miquelon, and the U.S. Virgin Islands. It can be supplemented with 
the PC*MILER|Worldwide global highway network as a separate purchase.* 
* All instructions for PC*MILER|Worldwide included in this User’s Guide pertain only when 
PC*MILER|Worldwide or DTOD Data has been purchased and installed with PC*MILER.    
PC*MILER|Worldwide data is updated and released yearly after the release of the North America 
version of PC*MILER. 
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PC*MILER will calculate an unlimited number of routes and mileage on a single 
personal computer or a network installation. 
 
PC*MILER calculates point-to-point mileage for an origin-destination pair of 
locations with intermediate stop-off points.  It provides leg and cumulative mileage, 
time and cost estimates, state/country distance summaries, driving directions, and  
much more.  PC*MILER provides Practical, Shortest, Fastest, and Least Cost 
routing, as well as additional options in North America for National Network plus 
53'/102'' trailer or twins, Toll Discouraged, and Hazardous Material routing and 
(optionally in the U.S. and Canada) local street networks. 
 
PC*MILER Version 31 includes the following major features: 
 
• Multiple Route Types and Options – PC*MILER route types and route 

options cover a wide range of routing and planning needs, with the ability to 
create and save custom route profiles for quick access to options you use the 
most. 

• ETA/ETD – Users can define a departure or arrival time for more precise 
calculation of ETA/ETD. 

• POI & Fuel Stop Search Along a Route – A POI search tool lets you search 
for POI, including fuel stops and prices, along a route or within a specified 
radius from within a route window. 

• Maps and Reports that can be exported via clipboard for use with 
spreadsheet, word processing and database software – including detailed route 
reports and driving instructions. 

• Toll Cost Calculation with the purchase of the PC*MILER|Tolls add-on. (U.S. 
and Canada only)  

• Optional Hours of Service (HOS) trip management, with HOS-compliant  
rest stops and breaks inserted along the route. 

• PC*MILER|Traffic – Provides an optional traffic data feed for more realistic 
transit times and real-time, historical or typical traffic displayed on the map (North 
America only, PC*MILER|Traffic license required) 

• PC*MILER|Weather – Provides weather reporting and weather alerts along the 
route, including road surface condition reports.  (PC*MILER|Weather license required) 

• PC*MILER|TripDirect® provides a direct link between PC*MILER in the 
back office and ALK’s CoPilot Truck GPS navigation software in the cab.  
(PC*MILER|TripDirect license purchase required)  

• Unlimited number of stop-off locations.  
• Multiple route generation with on-screen comparison reports to determine 

the best route. 
• County/province name designations for U.S. and international locations.  
• Comprehensive height and weight restrictions, including for 53'/102'' 

trailer or twins. 
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• Least Cost Routing – Least Cost routing generates several alternative routes 
based on multiple user-specified trip cost values.   

• Fastest Routing – In addition to standard PC*MILER Practical and Shortest 
route types, Fastest routing calculates the quickest feasible way to get to a 
destination.  (North America only, PC*MILER|Traffic required) 

• Route Optimization to resequence stops in the most efficient order on a route. 
• Custom Avoid/Favors to create and manage multiple sets of routing 

preferences. 
• Drag Route Feature and Via Points for customized routing. 
• User-specified vehicle dimensions for routing and toll calculation (includes 

an automobile routing option for vehicles classed less than 9,000 lbs./4,082 
kgs.). (PC*MILER|Tolls required for toll cost calculation) 

• Point of Interest (POI) database with customizable categories. 
• Location Radius – For rate determination and operations planning, this tool 

lets you search for cities, ZIP/postal codes and towns within a specified 
mileage radius around any location. 

• Elevation Discouraged routing lets users set a customized limit on the 
elevation of the roads a route will use. 

• Greenhouse Gas Estimator – For estimating greenhouse gas emissions by route. 
• Custom Place Names to conform to the name of your facilities and customer 

locations. 
• Import Custom Place feature, allowing seamless importing of custom address 

and pickup/delivery information to eliminate manual trip entry. 
• Geofence Tools – Create geofenced areas on the map and have PC*MILER 

avoid these areas or send a warning if routes travel in or out of them. 
• Ability to point and click on the map to select origin, stop-offs and destination, 

plus mouse-driven map customization. 
• Custom cost estimates for empty/loaded miles. 
• Custom average road speed estimates. 
• Hub mode that determines routing, total mileage and state mileage summaries 

from one origin point to unlimited destinations.  
• State/Country distance summaries including ferry miles. 
• Latitude/Longitude routing that generates point to point routes and mileage 

between lat/long coordinates. 
• Online Help – The PC*MILER User’s Guide is easily accessible from within 

the application. 
• U.S. Department of Defense compliance. 
• The complete North American highway network that includes the United 

States, Canada, and Mexico plus Greenland, Puerto Rico, St. Pierre and 
Miquelon, and the U.S. Virgin Islands. 
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• ALK Technologies’ complete Worldwide Highway Network, updated yearly 
to include the most current data available. (PC*MILER|Worldwide or DTOD Data 
required for global routing) 

• Optional add-on data modules for street-level addresses and map detail in 
the United States and Canada, Europe, India, and available countries in 
Africa, the Middle East, Oceania and South America. (PC*MILER|Worldwide 
required for address data outside North America) 

• Optional add-on data module for Hazardous Material routing. 
(PC*MILER|Hazmat add-on module required) 

• Optional add-on data module that provides an Integrated Energy-focused 
Map Data Set for the oil and gas industry.  (North America only, PC*MILER|Energy 
license required) 

 

1.2  What can PC*MILER be used for? 
PC*MILER can be used for:  

 

• Truck-specific routing and mileage calculations for Shortest, Practical, Fastest 
and Least Cost routes, with additional route options for Toll Discouraged and 
State + National (National Network and State extensions plus 53'/102'' trailer 
or twins) in North America 

• A direct link between PC*MILER in the back office and CoPilot Truck in the 
cab (PC*MILER|TripDirect license required) 

• Hazardous material routing for safety and compliance (with the 
PC*MILER|Hazmat add-on module) 

• Toll cost calculation (with the PC*MILER|Tolls add-on module, U.S. and Canada only) 
• Least Cost routing 
• Dispatch, including Hours of Service (HOS) trip management 
• Driver pay  
• Rate determination 
• Instant customer quotes  
• Fuel tax reporting 
• Trip time and/or cost estimation 
• Driver log audits 
• Load planning 
• Stop optimization 
• Carrier selection 
• Logistics analysis 
• Freight bill auditing 
• IFTA and IRP auditing, FHWA safety auditing 
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1.3  What’s New in PC*MILER Version 31? 

NOTE:  PC*MILER includes an easy way to check for updates from within the 
application.  Keeping current on updates is important to maintain the usability 
of your copy of PC*MILER.  See section 17.3, PC*MILER Updates. 
 

• ENHANCED! … Routing improvements are a major part of a PC*MILER 
release and each annual version release confirms our commitment to enhancing the 
quality of PC*MILER’s truck-specific routing database, mileage calculations and 
driving directions. 
 
In the North America region, this year’s focus was on: 
 

o Improving how a route’s path interacts with conditional road restrictions 
such as restrictions based on direction of travel, no through truck 
restrictions, and maneuvering restrictions (e.g. no left turn based on time 
of day). 

o Redefining routing logic so that the use of left turns, right turns, sharp turns, 
U-turns and K-turns in the route were specified for the vehicle dimensions 
entered in Route Profiles as well as based on road type of where the turns 
would occur. 

o Adding newly constructed roads and exit interchanges. 
o Improving city and ZIP/Postal Code placement and alignment. 
o Specifically for commercial vehicles, additional updates include but are not 

limited to: 
 

o Applying urban coding to appropriate city-centers to aid in generating 
better routes through congested areas. 

o Improving highway-level coverage and truck-specific through-travel 
routing within city limits (e.g. keeping drivers on roads designated by 
local and state authorities as preferred/designated for truck travel). 

o Updating vertical clearance data to accurately model posted limits at 
railroad crossings and overpasses, as well as other types of lower 
clearance bridges. 

o Verifying truck restrictions and allowances. Classifications include 
truck designated roads, truck discouraged roads, height/weight 
restrictions and allowances, commercial prohibited road classifications, 
hazardous materials restrictions/allowances, and others. 

o Fixed reported issue with ZIP code 32542 Eglin Air Force Base, FL. 
o New SPLC’s added (requires the PC*MILER SPLC data add-on): 

656972270 Fort Polk Alongside Coco SE5932, LA, Vernon 
844156301 Phillips 66 Ferndale Terminal, WA, Whatcom 
880219270 DFSP Twenty-Nine Palms, CA, San Bernardino 
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889513270 Camp Pendleton Super Station SE5P2M, CA, San Diego 
890510241 Hawaii ANG SE8F0G, HI, Honolulu 
890564304 Island Energy Services Kapolei Terminal, HI, Honolulu 
890564305 3D Global Solutions Kapolei Terminal, HI, Honolulu 
 

For PC*MILER|Worldwide and DTOD Data users, Worldwide region 
enhancements for Version 31 include: 

o Extensive data updates in over 200 countries, islands and territories. 
Includes the addition of over 104,000 miles of highway network, over 
83,000 new cities, and 112,000 postal codes since Version 30. 

o The following country codes have been updated in the database: 
 

Country Code Type Previous New 
Congo, Democratic Republic (Kinshasa) ISO2 CG CD 
Congo, Republic of the (Brazzaville) ISO2 CD CG 
Timor-Leste GENC3 TMP TLS 

 

o Algeria was upgraded to High level coverage (see Appendix I). 
o Added prefecture information to Japan cities to address the issue with 

duplicate entries being returned. 
o Three ferries were added between Hakodate, Aomori, Oma, and 

Wakinosawa in northern Japan per PC*MILER’s request. 
o Added Kuwait Naval Base, KU per PC*MILER request. 
 

• ENHANCED!... Improved reporting of conditional route and road restrictions 
in the Detailed Route and Driver’s Reports. 
PC*MILER 31 now provides a more complete description of conditional route 
restrictions in the Detailed Route and Driver’s reports, as well as in the Route 
window’s stop list.  “Conditional restrictions” refer to turn restrictions and/or 
allowances that are not applicable to all types of vehicles at all times. These 
restrictions include: 

 

o Road Closures – e.g. when a road is closed between 8:00 am and 4:00 pm 
o Truck Restrictions – e.g. when a road is restricted to one direction of travel 

based on weight 
o Turn Restrictions – e.g. when a road has a left turn restriction from 7:00 am 

and 11:00 pm 
 

• ENHANCED!... “Truck Restrictions” and “Commercially Prohibited” road 
attributes now displayed by default on the map. 
These attributes can be turned on or off in the Map > Map Features dialog. In 
previous versions, they were turned off by default when PC*MILER was installed. 
However, based on customer feedback, these features are now turned on upon 
installation.  
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• ENHANCED!... Live road closure data used in route calculation. 
When Arrival/Departure is set to Depart Now in the Routes window, 
PC*MILER|Traffic now takes live reports of road closures into account when 
calculating the route. (Requires a license for PC*MILER|Traffic.) 

 
• NEW!... Default average road speeds by jurisdiction have been updated to 

improve drive times and ETA calculations. 
Recalibrated default road speeds for trucks now yield more accurate drive times 
and ETA calculations. Users can continue to adjust default road speeds by accessing 
the Application Settings window, at File > Application Settings > General > 
Road Speeds.  
 

• NEW!... Cities can now be searched by full state name. 
Previously, only state/country abbreviations could be used when entering a place 
name as a stop. In Version 31, the full jurisdiction or country name can be entered.  
A comma is required after the city name when using a full state/country name.  For 
example, all of the following are now accepted: 

 

princeton, nj  princeton, new jersey 
princeton nj  paris, france (PC*MILER|Worldwide) 

 
• ENHANCED!... European map is now the default view for Worldwide users. 

The Europe region is now the default view in the map window if 
PC*MILER|Worldwide is installed.  (PC*MILER|Worldwide license required.) 

 
• NEW!... Now calculate distances in whole numbers. 

In addition to distance calculations rounded to tenths, hundredths, and thousandths, 
PC*MILER 31 can now report distances rounded to the nearest whole number. This 
setting is in File > Application Settings > Units > Distance Precision.  
 

• NEW!... Support for Mexico City’s status change from federal district to city.  
Recently, Mexico changed the name of the country’s capital from “Distro Federal” 
to “Ciudad de Mexico”. To accommodate this change, PC*MILER 31 now accepts 
only the following input for the city (users can no longer enter "Mexico City, 
Distrito Federal" or "Mexico City, DIF"): 
 

Mexico City, DF   
Mexico City, CMX 
Mexico City, Ciudad de Mexico 

 
• ENHANCED!... Some Route Option categories have been renamed. 

The following Route Option categories have been renamed as follows to better 
reflect how they are used when generating a route: 
 

Old Name New Name 
“Size and Weight Restrictions” “Restrictions” 
“Hazardous Materials” “HazMat” 
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• NEW! Current and forecasted road conditions are now displayed on the map. 
(Requires a license for PC*MILER|Weather.) The Road Conditions overlay is both 
predictive and real-time. It can display current road conditions, as well as road 
conditions up to 24 hours in advance to gauge potential impacts on the route plan. 
Road conditions are designated as dry, wet/slippery, water/snow and ice/snow.  
 

• NEW! New Weather Alert category for “Wind Alerts”. 
(Requires a license for PC*MILER|Weather.) A new Weather Alert group called 
“Wind Alerts” has been created. The group contains watches, warnings, and 
advisories for wind-related weather events that were contained in other categories, 
such as Storm Alerts, Winter/Snow Alerts, and Air Quality Alerts.  
 

• NEW! PC*MILER now runs on Windows Server 2016. 
Installation on Windows Server 2016 is supported with this release.  
 

• ENHANCED! Custom Place icon is now visible at higher zoom levels. 
Users can now view custom place icons on the map at zoom levels 11-20.  
 

• NEW! The Drag Map and Box Zoom tools can be selected in the Map window. 
The Drag Map and Box Zoom tools have been added to the Map window for ease 
of use. The tools are also available at their original location on the Map ribbon bar.  
 

• ENHANCED! Simplified layout of the settings in the Map Features dialog. 
To provide a better user experience, the Map Features settings have been optimized 
so that they are grouped by functional categories.  
 

• NEW! Visibility of turn restrictions can be controlled from the Map window. 
Now turn restriction icons (e.g. no-right or no-left) can be turned on or off within 
the map by right-clicking the map and selecting “Turn Restrictions” from the menu. 
 

• NEW! Save button in the Report window. 
For convenience, a button in the upper right corner of the Report window enables 
you to Save the report to a location on your computer. Clicking this button is the 
same as selecting Save Report to File from the File menu. 
 

• ENHANCED! Now click the “X” in a route window error message to clear it. 
In PC*MILER 31, error messages appearing in the route window can now be 
dismissed by selecting the “X” to the right of the message. 

 
• NEW! “Distribution Center” POI category has been added. 

The “Distribution Center” category was created to accommodate greater numbers 
of this type of Point of Interest (POI).  Now search for and route to locations of 
distribution centers frequented by carriers. Examples include Walmart, Target and 
Amazon distribution centers. 

 
• ENHANCED! Report titles added to previewed and printed reports. 

To help users identify the source and content of reports generated by PC*MILER, 
the formal title is now printed at the top.  



 

Chapter 1: Introduction   9 

• NEW! Insert new stops in the Route window by clicking the plus sign. 
Inserting stops in the Route window is simplified with this release. Just click the 
“plus” sign ( + ) in the left column at the point where you want to insert the stop to 
insert a new row and enter a stop. This functionally is the same as right-clicking a 
row and selecting Insert Stop Above from the menu. 

 
• ENHANCED! Expanded amenity icons in Place of Interest (POI) searches. 

PC*MILER 31 has expanded the range of amenity icons that appear in POI 
searches. The new icons enable better-informed choices when planning routes.  

 
• ENHANCED! “Distance” renamed “Geographical Distance” in results pick 

lists. 
In results pick lists showing the distance to locations or Places of Interest (POI), 
the “Distance” column has been renamed “Geographical Distance.” This clarifies 
that the distance shown is a straight-line air distance from the starting point, and 
not an over-the-road distance (which is always longer). 

 
• NEW! The Remote Support and License Tools are now accessible from the 

Help tab. 
From the Help tab, two existing support tools have new ways to access them: 

 

o The Remote Support Tool can be started by selecting it in the Technical 
Support group. 

o The License Tool can be started by selecting it in the Help group. The tool 
can also be started from a shortcut icon that was placed on the desktop when 
PC*MILER 31 was installed. 

 
• ENHANCED! The Comparison Report’s “Visibility” checkboxes are now 

synchronized with the Route window’s “Show/Hide” control. 
The Comparison Report’s “Visibility” checkboxes and the Route window’s 
“Show/Hide” controls are functionally identical; however, in previous releases, 
changing one did not change the other. With this release, the two controls are 
synchronized so that changing one changes the other to the same status. 
 

• NEW! Automatic verification of disk space before installation. 
The software installation program now verifies that there is enough space on the 
computer hard drive before attempting an installation. 
 

• ENHANCED! Reset to Default option now available in Application Settings > 
Route Costs. 
A “Reset To Default” button in the Route Costs settings enables the resetting of 
these values to the PC*MILER defaults. 

 
• NEW! Visibility of vehicle icons can be turned on or off. 

There is a new “Toggle Vehicles” button in the TripDirect section of the ALK 
Cloud ribbon bar to show or hide vehicle icons on the map. 
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1.4  The PC*MILER Highway Database 
PC*MILER products are based on ALK Technologies' proprietary computer 
representation of the North American and Worldwide highway systems.  The 
distances contained in PC*MILER are derived from official highway maps obtained 
from state, provincial, and national governments, state DOT maps, county maps, 
local maps, and information received from thousands of industry contacts.  U.S. 
Interstate, Federal and truck-specific State highways are included.   
 
PC*MILER Version 31 data features thousands of new and updated North 
American road miles and locations including: bridges and tunnels, border 
crossings, highway exits, truck stops, state weigh stations, CAT Scale weigh 
stations, five-digit U.S. ZIP codes, U.S. Department of Defense military 
installations, commercial truck restrictions in the United States, Canada, and 
Mexico, plus highway junctions and hundreds of thousands of cities, towns, and 
points of interest.  
  
With the purchase of separate add-on data modules, updated databases of 
Canadian Postal Codes, SPLC, and comprehensive U.S. federal, state, and 
local Hazardous Material restrictions and designations are available as well.   
In addition, ALK offers several other regularly updated add-on data modules for 
use with the base PC*MILER product: PC*MILER|Streets for address-to-address 
routing (see below); PC*MILER|Energy for oil and gas specific data and 
facilities; PC*MILER|Worldwide for global point-to-point routing; 
PC*MILER|Tolls for toll calculation.  
 
 

1.4.1  PC*MILER Local Street and International Database 
 

In North America, users have the ability to add street-level detail to generate dock-
to-dock routes and mileage.  PC*MILER's local street-level databases, included 
with the purchase of the PC*MILER|Streets data add-on, cover the United States 
and Canada* and include a comprehensive address database, along with related 
routing options and map detail.   
 

* Note that with the purchase of PC*MILER|Streets, street-level detail in the U.S. comes standard 
and a separate purchase of the Canadian Street-Level Add-On is necessary to access related data 
in Canada. 
 
Also available for purchase is the PC*MILER|Worldwide data add-on to generate 
point-to-point truck-specific mileage, driving directions and maps over the entire 
international highway network.  PC*MILER|Worldwide includes access to highway 
data in Africa, Asia, Europe, Middle East, North America, Oceania, and South 
America.  Worldwide data is updated after the base release is completed.  Optional 
street-level data in many countries and regions can be purchased along with a 
PC*MILER|Worldwide installation. 
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1.5  Distance Calculation 
Distances and routing directions are calculated by first determining which roads a 
vehicle will travel to get between two points and then adding up the distances over 
each section of road to arrive at a total mileage, similar to the manual task that one 
might follow if using an atlas. 
 
Routes will “clean up” to the nearest truck-usable road on the highway or local 
street network.  This local distance equals the short air distance between where the 
point is plotted on the map and the closest truck-usable road.  In the Detailed Route 
report, which lists every route segment and interchange on a route, this distance 
may appear as “Local”. 
 

1.6  PC*MILER Route Types 
PC*MILER offers three basic route types: Practical, Shortest and Fastest*.  For 
routing in North America, any of these may be combined with PC*MILER Toll 
Discouraged and/or State + National Network (includes 53'/102'' trailer or twins) 
routing.  Light Vehicle routing for vans, automobiles, pickup trucks, SUVs, etc. is 
also available, and Least Cost routing may be generated for the Practical, Shortest 
or Fastest route type.   * Note for PC*MILER|Worldwide users: Fastest routing is 
available only when North America is the selected region. 
 
The route type is set in the Route Options or Route Profiles dialog, with the 
exception of Least Cost routing.  See Chapter 10, Setting Route Types & Options, 
and Chapter 4, Least Cost Routing. 
 
 

PC*MILER Route Type Brief Descriptions  
(See sections 1.6.1 – 1.6.7 below for more detailed descriptions.)   

 

Route Type Description 

Practical 
Represents distances and driving routes that a driver 
would normally take to minimize time and cost.  Models 
the trade-off between taking the most direct path and 
staying on major, high quality highways. 

Shortest 
Represents distances and driving routes that a vehicle 
would take to minimize total distance traveled while still 
following a reasonable route.  A Shortest route may have 
a longer drive time than a Practical route. 
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Route Type Description 

Fastest 

(The North America region must be selected, and 
PC*MILER|Traffic must be installed.) 
Uses any day of the week or time of day information that 
has been set for a route (these are optional settings for 
Fastest routing) in conjunction with Inrix® real-time 
and/or historic traffic data to calculate the quickest route 
to the trip’s destination(s).  Actual mileage may be longer 
than a Practical route. 

Toll Discouraged 
Option 

(North America only) 
Avoids long stretches of toll roads but won’t take long, 
impractical detours to avoid toll bridges and tunnels. 
 

State + National 
Network Option 

(North America only) 
Favors using the US Federally designated National 
Network (primary Interstates with reasonable entry/egress 
points up to 1 mile off the Interstate), combined with a 
preference to favor using the state-designated extensions 
to the Federal National Network (additional highways and 
supporting roads that can be any distance off the 
Interstate, as determined by the individual states). 

Light Vehicle 
Routing (Override 
Restrictions Option)  

Overrides size and weight restrictions when calculating 
routes, but routes will still avoid truck-prohibited and 
truck-discouraged roads.  By default, PC*MILER uses 
size/weight restrictions.  (Note that to generate light 
vehicle or automobile routing that will use truck-
prohibited/discouraged roads, the user can specify small 
vehicle dimensions that take precedence over this setting 
– see section 10.5.) 

Least Cost Routing 

Considers user-specified values for miles per gallon, cost 
per gallon, fuel cost per mile, maintenance cost per mile, 
labor cost per hour, stop cost – and includes a parameter 
for a greenhouse gas emission estimate.  If PC*MILER| 
Tolls is installed, toll costs are factored in as well.   
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1.6.1  PC*MILER Practical Routes 
 

PC*MILER Practical Routes represent distances and driving routes that a driver 
would normally take to minimize time and cost.  Practical Routes consider distance, 
road quality, terrain, urban/rural classifications, truck-restricted roads, and 
designated principal and secondary through routes.   
 
Practical Routes model the trade-off between taking the most direct path and 
staying on major, high quality highways.  Interstate highways are given a higher 
priority than toll roads, which, in turn, are given a higher priority than secondary 
highways, and so on.  This typically means getting on, and staying on, major 
highways and using truck-designated routes as much as possible.  Practical routing 
avoids local and even secondary class roads where possible because they tend to be 
harder to navigate for large trucks due to stop lights, tighter and more frequent 
turns, etc. 
 
In the United States, PC*MILER Practical Route mileage and state-by-state 
mileage breakdowns can be used to supplement your regular fuel tax reporting 
documents for many jurisdictions.  Many state audit departments have purchased 
licenses to incorporate PC*MILER into their audit procedures. 
 
NOTE:  A PC*MILER user may still be assessed additional taxes even by those 
states using PC*MILER in their audit procedures.  However, your chances of 
being assessed additional taxes greatly diminishes by utilizing a computerized 
mileage system in conjunction with your driver logs, trip sheets, invoices, and bills 
of lading. 
 
In order to minimize the possibility of significant tax assessments, you must verify 
that the PC*MILER generated route is the same as that reported on your driver logs 
and/or trip sheets.  In addition, you must add the appropriate vicinity miles to the 
PC*MILER generated mileage so that the following equation is true: 
 
TOTAL ODOMETER MILES = PC*MILER Miles + Vicinity Miles 
 
NOTE:  PC*MILER accounts for some vicinity miles if non-Keypoints (generally 
postal code locations and/or place names not associated with the downtown 
metropolitan area) are used as stop-off locations. 
ALK Technologies continues to work closely with the member states of the 
International Fuel Tax Agreement (IFTA) and the International Registration Plan 
(IRP).  Currently many IFTA/IRP jurisdictions are using PC*MILER as an auditing 
tool in their fuel and mileage tax audit procedures. 
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1.6.2  PC*MILER Shortest Routes 
 

PC*MILER Shortest Routes represent distances and driving routes that a vehicle 
would take to minimize total distance traveled while still following a reasonable 
route.  Shortest Route mileage and routes will also avoid truck-restricted roads 
where possible and, in some cases, may favor a beltway rather than traveling 
directly through a city. 
 
However, because the goal of the Shortest route type is to minimize total distance, 
there is not much emphasis on taking major highways.  This could mean avoiding 
long loops of a major interstate by exiting the interstate to take a shorter more direct 
route.  For example, going from Baltimore, MD to Richmond, VA, a Practical 
Route will take I-495 around Washington, DC; but a Shortest Route may take US-
1 through Washington, DC in order to minimize the distance traveled. 
 
 

1.6.3  PC*MILER Fastest Routing (North America only) 
 
(PC*MILER|Traffic must be installed and activated, and North America must be 
the selected region.)  In addition to the standard Practical and Shortest routing 
types, PC*MILER now provides a Fastest routing type.  Fastest routing uses any 
day of the week or time of day information that has been set for a route (these are 
optional settings for Fastest routing) in conjunction with Inrix® real-time and/or 
historic traffic data to calculate the quickest route to the trip’s destination(s).  Users 
who ship time-sensitive freight can select a Fastest route that may be longer in 
distance but save time over the standard Practical route. 
 
Additionally, Least Cost routing (see section 1.6.7) now considers Fastest and 
Fastest with Toll Avoidance route types, increasing the number of routes 
considered to six.  Users can opt to utilize Least Cost routing to select the route that 
arrives on time but costs the least, using default or user-specified costs. 
 
NOTE: When using real-time traffic data, a Fastest route may actually calculate a 
longer drive time than the Practical route if there is significant traffic congestion. 
 
NOTE Also:  Setting a governor (maximum) road speed as a Route Option or in a 
route profile can alter the route calculated using the Fastest route type (see section 
10.3.2 and 10.4).  A lower governor speed could result in a shorter route distance 
and more lower class roads being used (see section 10.1.6 for road classifications). 
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1.6.4  PC*MILER State + National Network Routes (U.S. only) 
 
NOTE:  Also reference Appendix A and Appendix B. 
 
PC*MILER State + National Network routing favors using the US Federally 
designated National Network (primary Interstates with reasonable entry/egress 
points up to 1 mile off the Interstate), combined with a preference to favor using 
the state-designated extensions to the Federal National Network (additional 
highways and supporting roads that can be any distance off the Interstate, as 
determined by the individual states). 
 
Beginning in Version 30, the National Network and 53' Trailer or Twins route 
options from previous versions (described below) were combined into one State + 
National Network option.  In previous versions, the National Network option 
applied a preference within the routing algorithm to favor using the US Federally 
designated National Network (primary Interstates with reasonable entry/egress 
points up to 1 mile off the Interstate).  The 53' Trailer or Twins option applied a 
preference within the routing algorithm to favor using the state designated 
extensions to the Federal National Network (additional highways and supporting 
roads that can be any distance off the Interstate, as determined by the individual 
states).  In Version 30 and higher, the new State + National Network option applies 
both preferences. 
 
State + National Network routing can be selected using the Road Network route 
option, either as part of a route profile or in the Route Options dialog for an 
individual route – see sections 10.2-10.4. 
  
  
NATIONAL NETWORK ROUTING DESCRIPTION 
 

The National Network is a U.S. government-designated system of highways 
originally established by the Surface Transportation Assistance Act of 1982 
(STAA).  This routing option is based on the federally-designated National 
Network system updated in the April, 1992 Code of Federal Regulations, Part 658, 
Appendix A.  The National Network includes the Interstate System (several minor 
segments are not included), and many selected U.S. and state highways.  Highways 
continue to be added to the National Network by federal and state governments. 
 
PC*MILER National Network routing represents distances and driving routes 
which are most reasonable and legal for the larger trucks authorized by the Surface 
Transportation Assistance Act of 1982. 
 
National Network routing stays on the National Network to the maximum extent 
possible.  Given that many areas are not directly served by the National Network, 
the origin and stop-offs of your route may not be on the National Network.  In these 
cases PC*MILER will take the shortest reasonable path from the origin and stop-
offs to the Network.  Detailed Route Reports (driving directions) for PC*MILER 
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National Network routes provide a warning wherever the route is forced to use a 
non-conforming link.  These road segments should be checked before traveling. 
 
National Network mileage tends to be higher than Shortest or Practical mileage. 
 
These designated highways permit, at a minimum, 102" wide, single 48 ft. trailers 
and 28 ft. double trailers.  The Interstate system and most, but not all, remaining 
designated routes are open to 80,000 pound vehicles.  Certain states, notably 
Arkansas and Mississippi, have designated certain National Network segments with 
less than an 80,000 pound capacity. 
 
In addition to the National Network highways, access routes and access policies 
are components of routing STAA dimensioned trucks.  The Federal government 
has mandated that no state may prohibit travel from the National Network for a 
minimum of one road mile unless safety restrictions apply.  Also, no state may deny 
reasonable access to terminals and facilities for food, fuel, repairs and rest. 
 
Several states maintain more generous access policies and lists of specifically 
designated access routes to terminals and facilities.  Should you need to travel 
beyond the National Network and the access roads, you must acquire the proper 
permit.  See Appendix A for access rules by state. For detailed information about 
pre-approved access routes, contact the individual states. 

 
NOTES: PC*MILER’s suggested National Network routings are based on official 
highway maps, the Code of Federal Regulations, and information provided by state 
governments.  It is provided without a warranty of any kind.  The user assumes full 
responsibility for any delay, expense, loss, or damage which may occur as a result 
of its use. 
 
See Appendix A, Access Policies From National Network Routes, for the current 
status of National Network access policies.  For detailed information about pre-
approved access routes, contact the individual states. 
 
 
53' TRAILER OR TWINS ROUTING DESCRIPTION 
 

The regulations that govern the routing of trucks in North America are a function 
of weight, height, number of axles, distance between axles, number of trailers, and 
commodity.  These regulations take two principal forms: restrictions and 
designations.  In the case of designations, trucks may deviate from the designated 
road network, on any road that is not otherwise restricted, to access points of 
loading, unloading and services.   
 
Under the 1982 U.S. federal law known as the STAA, the most important 
distinction in truck designations is between 96'' wide, 48' long trailers on the one 
hand and 102'' wide, 53' long trailers (and twin 28' long trailers) on the other hand.  
When the State + National Network routing option is used in PC*MILER, or when 
a width of greater than 96'' or a length greater than 48' is entered into PC*MILER 
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as the vehicle size, PC*MILER’s routing algorithm switches to favoring roads 
designated by the states for “oversize” trucks (over 96'' wide or 48' long).  
  
In PC*MILER, the routing designations for the following equipment types are 
included in the State + National Network routing category:  

• double trailers no more than 28' long and 102'' wide; 
• semi-trailers longer than 48' or wider than 96'', but no longer than 53' and no 

wider than 102''. 
 
Detailed Route and Driver’s reports for State + National Network routes warn that 
a road is “Not Designated” if that road is necessary to reach an origin, destination 
or stop-off outside of the maximum access distance for that state.  In this case, a 
warning will appear in the Routes window and the Detailed Route Report.  
 
 

 
 
 

 
“Not Designated” Warning in a Route Window and Detailed Route Report 

 
 
See Appendix A for state-by-state access policies and an explanation of the criteria 
that will trigger a “Not Designated 53 Foot” warning. 
 
If such a warning appears, then a legal route for 53' equipment is either not possible 
under current state designations or would be so circuitous that you should either 
consider assigning smaller equipment or petitioning the state to designate a more 
direct access route.  Users should check the legal requirements on these roads 
because they vary; for example, delivery may be legal, but stopping for food or 
services may not be. 
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If the Designated Truck Routes layer in the Map Features dialog is turned on (see 
section 11.7), the PC*MILER map will display the 53-foot designated network with 
a light blue underlay when the map scale is approximately 1'' equals 8 miles or less. 
This underlay is hidden by default.  (Note: If you have the PC*MILER|Hazmat 
module installed and the Hazardous Material layer is turned on, you may want to 
turn it off for a better view of designated truck routes.) 
 
 

1.6.5  PC*MILER Toll Discouraged Routes 
 

For those who desire to avoid long stretches of toll roads, ALK provides a Toll 
Discouraged routing option.  Toll Discouraged routing will avoid long stretches of 
toll roads but will not take long, impractical detours to avoid toll bridges and 
tunnels.  For example, a route from Boston, MA to Albany, NY will avoid the 
Massachusetts Turnpike, but a route from Camden, NJ to Philadelphia, PA will 
include a toll bridge. 
 
If a Toll Discouraged route needs to travel on a toll road, toll miles will be shown 
in the Detailed Route and State/Country reports.  If PC*MILER|Tolls is installed,   
toll costs will also be shown, even if toll calculation is disabled for the route.  
 
Toll Discouraged routing is activated using the Toll Roads route option, see 
sections 10.2-10.5 on route profiles and options. 
 
NOTE:  PC*MILER chooses routes by minimizing a cost equation that combines 
distance, certain factors times distance, and certain fixed factors.  When Toll 
Discouraged is selected for a route, the factor that is multiplied times distance for 
toll roads is higher than when Toll Discouraged is not chosen.  This causes the 
route chosen to go a somewhat longer distance (all other factors being equal), but 
not an extremely longer distance, in order to avoid paying a toll. 
 
To see whether the Toll Discouraged option is cost-effective for you or your fleet, 
you may want to consider using ALK’s PC*MILER|Tolls add-on module and  
PC*MILER|Spreadsheets to analyze how much toll cost you will save versus how 
much additional mileage and time cost you will incur, for the particular  origin-
destination pairs that you run frequently.  See Chapter 7, Getting Toll Costs for 
more details about PC*MILER|Tolls.   
 
 

1.6.6  Routing For Different Vehicle Sizes and Restriction Overrides 
 

By default, PC*MILER generates routes and mileage for large, heavy trucks of a 
particular size and weight (in North America, 5-axle tractor-semitrailer 
combination, 96" wide, 48' long trailer, 13' 6" high, 80,000 lbs GVW).  Routing for 
102" wide 53' long trailers and 28' twin trailers is available using the “State + 
National Network” routing option.   You can route other sizes and weights of trucks 
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by setting vehicle dimensions, choosing among pre-defined route profiles or 
creating your own user-defined route profiles.   
 
Additionally, a setting that overrides size and weight restrictions is available as a 
route option or route profile option.  This setting relaxes truck restrictions for 
particular sizes and weights, but still avoids roads that are prohibited to or 
discouraged for trucks.  If a resulting route uses any roads that have restrictions for 
particular sizes and weights, the Detailed Route Report will list them.  This allows 
you to determine the largest or heaviest vehicle you can assign to drive that route.  
See Chapter 10, Setting Route Types & Options, specifically the Restrictions 
option in section 10.3.2. 
 
PC*MILER also includes a routing option specifically for automobiles and other 
light vehicles (vans, pickup trucks, SUVs, etc.) that relaxes all truck and 
commercial vehicle regulations (see section 10.5.3). 
 
By default PC*MILER does not override restrictions, so routing will avoid both 
truck-prohibited and truck-discouraged roads, as well as truck-restricted roads that 
pertain to the size and weight set in the current route profile.  In addition, 
nationwide 13' 6" height restrictions are taken into account.  
 
 

1.6.7  Least Cost Routing 
 

In response to the needs of our customers, ALK developed the “Least Cost” routing 
feature that considers user-specified values for miles per gallon, cost per gallon, 
fuel cost per mile, maintenance cost per mile, labor cost per hour, and stop cost – 
and includes a parameter for a greenhouse gas emission estimate. If 
PC*MILER|Tolls is installed, toll costs are factored in as well.  See Chapter 4 for 
a full description of this routing type and how to use it.
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             Getting Started 
 

 
Before installing PC*MILER, please make sure that you have the required 
hardware and software configuration.  All PC*MILER software, databases and 
auxiliary files are provided with the PC*MILER installation. 
 

2.1  System Requirements 

NOTE:  Please check for updates regularly to maintain the usability of your current 
copy of PC*MILER – select the Help tab > Check for Updates. 
 
 

2.1.1  Platforms 
 

• Windows 7, 8 and 10* running in 32-bit compatibility mode as well as support 
for 64-bit native applications on Windows 7 and 8 – please see section 2.4 if 
installing connectivity products on a 64-bit machine. 
* IMPORTANT: Windows 10 recommended.  Windows 7 requires the 
Convenience Rollup update.   

• AS/400 
• Citrix Metaframe and TCP/IP functionality for use with other platforms 
• Windows Server (Windows Server 2016, Windows Server 2012, Terminal 

Servers, and Server 2008* including Server 2008 R2 running in 32-bit 
compatibility mode for the PC*MILER user interface and on 64-bit processors 
for PC*MILER Connect, Mapping, BatchPro, and Spreadsheets) 
* IMPORTANT: Server 2008 requires Windows Server 2008 Service Pack 2. 

NOTE:  Platforms not supported include: Windows Vista, XP, Server 2000, and 
Server 2003. 
 
 

2.1.2  Windows Requirements  
 
NOTE:  If you are on an older version of the Windows operating system, it is 
strongly recommended that if possible you upgrade to Windows 10 for the desktop 
and/or Windows 2012 Server. 

 
NOTE Also:  ALK strongly encourages users to apply all available Windows 
Updates.  Without the most recent updates, PC*MILER could fail to launch. 

2 C
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https://support.microsoft.com/en-us/help/3125574/convenience-rollup-update-for-windows-7-sp1-and-windows-server-2008-r2-sp1
https://www.microsoft.com/en-us/download/details.aspx?id=16468
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Environment: 
• Stand-alone PC with a 1.5-2 GHz processor or networked personal computers 

(LANs and Server/Thin Client Networks)  
• 512 MB RAM minimum, 1 GB strongly recommended for standard desktop 

users.  For Citrix and Terminal Server, 200 MB RAM for each user running 
PC*MILER|Connect and PC*MILER|Spreadsheets. 

 
Other Requirements: 

• Windows 7 requires the Convenience Rollup update 
• Server 2008 requires Windows Server 2008 Service Pack 2 
• Minimum screen resolution 800X600 
• Color quality settings supported: 16-bit and 32-bit (8-bit & 24-bit not supported) 
• Internet connection for license activation (recommended) and access to select 

features such as Satellite imagery, real-time Traffic data, updated fuel prices, 
and PC*MILER|Weather. 

• Email address for license activation 
 

NOTE:  The hard disk requirements listed below are approximate.   
 

PC*MILER: 
• In Version 31, automatic installation of Microsoft® .NET Framework 4.6.1 

requires 4.5 GB, which reduces in size down to 39 MB once it is installed.  
See note in section 2.4 for exceptions. 

• PC*MILER – 3.1 GB hard disk space for full install (including all Add-Ons 
listed below except PC*MILER|Energy, and all Connectivity products) 
o PC*MILER|Tolls – 50 MB  
o PC*MILER|Hazmat – 50 MB  
o PC*MILER|Streets (U.S. Data) – 1.3 GB  
o PC*MILER|Streets (Canadian Data) – 60 MB  
o Canadian Postal Codes – 50 MB  
o Standard Point Location Codes (SPLC) – 2 MB  
o PC*MILER|Energy – Additional 2.6 GB hard disk space 

 
Connectivity Products: 

• PC*MILER|Connect – 13 MB  
• PC*MILER|Mapping –7.5MB  
• PC*MILER|Spreadsheets – 3 MB  
• PC*MILER|BatchPro –7.5MB  
• PC*MILER|TCP/IP – 6 MB  
 

NOTE:  PC*MILER|Connect and PC*MILER|Spreadsheets support x86-64 
architecture.  Our software was not ported to IA-64 architecture although it will 
still be supported through a hardware compatibility mode. 

 
 



 

 
Chapter 2: Getting Started   22 

PC*MILER|Worldwide: 
• Worldwide Highway Network Only – 5 GB hard disk space additional 
• PC*MILER|Streets Data hard disk space requirements: 

• United States – 1.3 GB 
• Canada – 60 MB 
• Africa – 263 MB 
• Europe – 3.38 GB 
• Asia – 616 MB 
• Middle East – 179 MB 
• Oceania – 189 MB 
• South America – 339 MB 
 

PC*MILER|TripDirect Requirements: 
 

NOTE:  TripDirect only works with appstore CoPilot Truck products.  It does not 
work with any PC*MILER or CoPilot integrated products. 
 
• CoPilot Truck running on one or more mobile devices and registered with 

CoPilot Live Messaging (only works with appstore downloads of CoPilot 
Truck) 

• CoPilot Truck Version 9 supported platforms are: iPhone, iPad, and Android 
• A PC*MILER|TripDirect license key code 
• TMS solution to dispatch the route to the device 
• PC*MILER 31 
• Street-level data in the US and/or Canada 
• Active remote connection on the device (no airplane mode) 

 
These additional components will also be installed: 

• Microsoft Visual C++ 2005 Redistributable Package (x86) – 6 MB disk space 
• WindowsInstaller-KB884016-v2-x86.exe (x86) – 2 MB disk space 
• .NET dotnetfx.exe (x86) – 280 MB disk space 
• Microsoft® .NET Framework 4.6.1 (automatically installed with PC*MILER) 

 
 

2.1.3  AS/400 Requirements 
 

PC to AS/400 Connectivity Options (Not Provided by ALK): 
• PC with a 2+ GHz processor 
• Client Access Express V4R4MO or higher, also known as iSeries Access 

(recommended) 
• Supports OS/400, i5/OS and IBMi operating systems; Version 4.2 (V4R2) and 

higher on IBM AS/400, System i and Power Systems™ hardware. 
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2.2  General Licensing Information 

Single-User License 
A single-user license can be installed to only one PC or workstation locally. 
 

Multi-User License 
A multi-user license can be installed to a server environment, on the computer that 
will be sharing the licenses to other computers.  It allows “x” number of concurrent 
workstation connections to PC*MILER at a time.  For example, a  
5-User License allows one installation on a central server or PC with as many 
workstation PCs as you want having access, but only 5 users can access PC*MILER 
at the same time. 

 

Enterprise License 
An Enterprise License allows users to install PC*MILER on any combination of 
end-user PCs or workstations without license limitations.  It’s a cost-effective 
installation and licensing solution for larger companies with several users.  It does 
not require license activation but requires signing an enterprise license 
supplemental agreement directly with ALK. 

 

Additional Copy License 
Users can install PC*MILER locally onto additional PCs by purchasing additional 
copy licenses.  If you purchase 5-copy licenses, you can install PC*MILER locally 
onto five additional PCs or workstations.  If you’re installing onto a desktop PC 
and a laptop, two licenses are needed. 
 

2.3  Installation Types 

Non-Network (Local) Installations 
A non-network installation allows you to install PC*MILER to a PC or workstation 
locally, not to be shared with other computers. 
 

Network Installations 
A networked installation allows you to install PC*MILER on network file servers 
where each end-user can save their own option settings or can share option settings 
that are stored on the server. 
 

NOTE:  PC*MILER 31 supports silent installations. 
 

Citrix/Terminal Services Installations 
PC*MILER can be installed onto a Citrix Server or Terminal Services environment, 
if you have purchased a license to do so.  Each end-user must have a license to gain 
access to PC*MILER. 
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Trial Installation 
A trial installation is a 15-day license to access PC*MILER’s features and data.  It 
includes an installation of PC*MILER that provides highway-level routing, 
mileage and mapping, with options to install street-level routing, truck-specific toll 
costs, PC*MILER|Energy data, worldwide highway-level mileage and mapping, 
Canadian postal codes, and SPLC.  (These additional features are paid upgrades 
when purchased.)  A trial installation cannot be upgraded, it must be uninstalled 
and reinstalled to add another product or feature.    
 

2.4  Important Installation Notes – PLEASE READ 

Microsoft® Windows® 10 Upgrade Recommendation:  If you are on an older 
version of the Windows operating system, it is strongly recommended that if 
possible you upgrade to Windows 10 for the desktop and/or Windows 2012 Server.  
For users who do not regularly install the available Windows updates, upgrading to 
Windows 10 may save many hours or even days of installing back-logged Windows 
updates to allow the current version of Microsoft® .NET Framework 4.6.1 to install 
properly.  When .NET 4.6.1 is not installed properly, PC*MILER won’t open.  For 
more on the .NET installation, please see the last note in this section. 

Who Should Run PC*MILER in Administration Mode:  If you’re on an 
operating system that is stricter about permissions, such as Windows Server, please 
consider running PC*MILER in Administration Mode to avoid possible problems 
when using the application.  Also, users of Microsoft® Windows® 7, 8, 10; 
Windows Server 2016 and Windows Server 2012 should refer to the note below.  

Microsoft Windows 7, 8, 10 and Windows Server 2012 and 2016 Users: Your 
license may need to be installed and activated using an Administrator Account.  
Once installed, you do not have to Run as Administrator provided you install to the 
recommended default directory or to another directory that doesn’t require users to 
Run as Administrator.  Additionally, the administrator should grant write 
permissions to the PC*MILER default directory since some of the newer operating 
systems require an administrator to grant these write permissions. 

Microsoft Windows 8 and Above:  It is strongly recommended that you avoid 
installing to the Program Files or Program Files (x86) folder. If you need to do so, 
you’ll have to Run as Administrator when you open PC*MILER. 

IMPORTANT for Microsoft Windows Server 2008 Users: You must install 
Windows Server 2008 Service Pack 2 to run PC*MILER Version 29 and higher. 

IMPORTANT for Microsoft Windows 7 Users: You must install the Microsoft 
Convenience Rollup update. 

COM DLL’s on a 64-Bit Computer: If you install PC*MILER|Connect or 
PC*MILER|Mapping Version 31 on a 64-bit computer, ALK’s 64-Bit COM objects 
will be automatically registered.  For 32-Bit calling applications you can switch to 

https://www.microsoft.com/en-us/download/details.aspx?id=16468
https://support.microsoft.com/en-us/help/3125574/convenience-rollup-update-for-windows-7-sp1-and-windows-server-2008-r2-sp1
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our 32-Bit COM objects by running the UseCom32.bat file found in the  
PCMILER31/Mapping/com and PCMILER31/Connect/com folders. 

PC*MILER Interfaces:  For those who interface any PC*MILER component to a 
transportation management, logistics management or other third party software 
system, please contact the vendor directly to make sure that the interface to this 
new version of PC*MILER is updated and complete before you install. 

Access to Updates and Patches: Check the PC*MILER Updater frequently for 
posted updates and patches applicable to your license type and components.  In 
PC*MILER, go the Help tab > Check for Updates.  

Automatic Installation of Microsoft® .NET Framework 4.6.1: The PC*MILER 
Version 31 installation will automatically install Microsoft .NET Framework 4.6.1 
if it is not already installed.  This upgrade resolves some feature display issues that 
occurred previously in PC*MILER for users of Windows 8.1, 10 and Server 2012 
operating systems.  Note that if PC*MILER is being installed from a network, the 
.NET installation may fail on some machines due to attributes of the installation 
that ALK cannot control.  If this occurs, you can copy the PC*MILER installation 
to the local machine and install from there.   
 
To ensure correct .NET functionality, ALK strongly encourages users to apply 
all available Windows Updates.  Without the most recent updates, PC*MILER 
could fail to launch. 
 
IMPORTANT: If the .NET Framework installation described above is 
performed, you must reboot when prompted to!  PC*MILER won’t open 
properly without a reboot first. 
 

2.5  Installing PC*MILER  
 

2.5.1  Single User Local (Non-Network) Installation 
 
NOTE:  Please look over the “Important Installation Notes” in section 2.4 above 
before beginning your installation. 
 
NOTE:  Have your Product Key Code(s) on hand before beginning the installation 
process.  It will be emailed to you from alkservices@alk.com in an email titled 
“PC*MILER Software Order…” (Enterprise License customers excluded).  You 
should see “Single” in this product key email. 
 
CONVERTING SAVED FILES:  To import saved custom settings and files from 
your previous version of PC*MILER, see section 2.8 before installing the new 
version. 
   

mailto:alkservices@alk.com
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PC*MILER|Traffic, PC*MILER|Weather, and PC*MILER|TripDirect: For 
each of these purchased products, a separate email will be sent with another Product 
Key Code and you will need to upgrade the PC*MILER license with this code at 
the end of the installation or at a later time.  See section 2.5.4. 
 
NOTE:  If you have a Multi-User Product Key Code and need to perform a Single 
User install, you will need to contact PC*MILER Technical Support for assistance, 
as a new Product Key Code is needed.  If you cannot get in touch with Technical 
Support at the time of installation, you can install a Single User License by typing 
“FREE” in the Product Key field.  After installing, please contact Technical 
Support to update your license status. 
 
UNINSTALLING an OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must do 
it before installing PC*MILER 31 (see section 2.9 to uninstall).  If you do not need 
to uninstall, you can have both versions of the desktop program installed on the 
same system.  Please note that PC*MILER|Connect, PC*MILER|Mapping and 
PC*MILER|Spreadsheets will be updated to the new version. 
 
BEFORE INSTALLING, please double-check that the emailed Product Key 
Code(s) lists all purchased components.  For example, the code shown below 
unlocks the following components: PC*MILER|BatchPro, TripDirect, 
PC*MILER|Tolls, PC*MILER|Streets (U.S. and Canada), and Worldwide highway 
data. 

 

Order #: SO-000000001 
Product Order #: PC*MILER 31 
Date: 7/1/2017 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER 31 (Single) BatchPro, Canadian Streets, TripDirect, Tolls, 

US Streets, Worldwide Data 
 
To install your single-user version of PC*MILER 31, follow these steps: 

 
1. If you are downloading the installation, click the provided link in the email 

that was sent from ALK Technologies and follow the instructions in the email. 
 

If you are installing using a DVD, place the PC*MILER Install DVD in the 
DVD or CD/DVD drive and the installation will start automatically.  If it does 
not start automatically, click the Windows Start menu. Then, depending on 
your operating system, either 1) type “d:\setup.exe” and click the search 
button (if the DVD drive is not the D drive, substitute the letter that designates 
the DVD drive); or 2) select Computer > [DVD drive letter] > setup.exe.  
See the note for Windows users in section 2.4 if applicable to your version. 
  

2. The InstallShield Wizard Welcome screen will open.  Click Next to review 
the End-User License Agreement.  NOTE:  Depending on the current status 
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of your Windows operating system, some Windows updates may install 
automatically before the PC*MILER installation begins.  

3. In the next screen, review the license agreement then choose “I accept…”  If 
this option isn’t selected, the setup won’t continue.  After selecting it, click 
Next to continue. 

 
4. When prompted, enter a User Name and Company Name and click Next. 

5. Enter the Product Key Code*,  or “FREE”** for a trial installation.  The 25-
character product key code will have been emailed from alkservices@alk.com 
with the subject line “PC*MILER Software Order…”.  It can be copied from 
the email and pasted in.  If entering the code manually, dashes are not required 
– dashes, spaces, or no spaces are all acceptable.  Click Next when finished.   
* NOTE: As a convenience to Enterprise License customers, the Product Key Code is hard-
coded into the installation and is valid for each install under the contracted terms. 
** NOTE: A trial installation cannot be upgraded, you must uninstall and reinstall to add 
another product or feature. 

6. In the next screen you will see a list of the Licensed Features that will be 
installed.  Check to make sure all the purchased features are in the list, then 
click Next to continue. 

 
NOTE for Enterprise Users:  If you need to disable product components that 
came packaged with your installation, see section 2.5.2 below. 

 
7. Now you will see the Destination Location where all components will be 

installed.  To install to the default directory* (recommended), do not make 
any changes and click Next.  By default, PC*MILER 31 installs directly to 
C:\ALK Technologies\PCMILER31. 
 
To install to a location other than the default, click Change to select a 
directory.  “PCMILER31” is required at the end of any custom path; for 
example, “C:\PCMILER\Version31\PCMILER31”.  If this folder is not 
detected, PC*MILER will add it automatically – see NOTE below.  Click OK 
then Next to continue. 
 
IMPORTANT:  DO NOT attempt to rename your PCMILER31 folder after 
installation.  The “PCMILER31” name is required and renaming it may cause 
product failure or unpredictable results. 
 
IMPORTANT – Microsoft® Windows® 8 and Above:  It is strongly 
recommended that you avoid installing to the Program Files or Program Files 
(x86) folder.  If you need to do so, you’ll have to Run as Administrator when 
you open PC*MILER. 
 

8. In the next screen, click Next to Start Copying Files.  To change any 
settings, select Back.   
 

mailto:alkservices@alk.com
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If you have a previous version of PC*MILER|Connect or PC*MILER| 
Mapping installed, this alert will appear: “The install found a previous version 
of Connect (Mapping).  These files will be renamed with a .bak extension”.  If 
both products were previously installed, you will receive two alerts.  Click 
OK in the dialog(s) to continue. 

9. Follow through with the rest of the installation.  This may take some time 
depending on the speed of the computer you are installing to.  Do not exit or 
reboot the computer during the installation.  If any error messages appear, 
please contact PC*MILER Technical Support – see Chapter 17, Technical 
Support and Contact Options.   

10. When the installation is complete, you will be prompted to view the 
ReadMe.txt and to activate your license.  If you need to use a Proxy Server 
to access the Internet, skip to section 2.5.3, Activating PC*MILER Using a 
Proxy Server.  Otherwise, leave these boxes checked and click Finish to 
proceed to the automatic activation (Step 11 below).  (NOTE: It may take 5-
15 seconds for the Product Activation window to open.)  When the ReadMe 
opens, review the information in it and then close the window. 

 
IMPORTANT NOTE:  ALK provides a 15-day temporary license prior to 
completing the activation process.  If you make a second attempt to install you 
will lose this license.  If you experience an activation error and need access to 
PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance – you’ll be able to use PC*MILER for 15 
days without completing the activation. 

 
 
AUTOMATIC LICENSE ACTIVATION 
 

11. The PC*MILER Product Activation window should be open.  (If it is not 
open, select the Windows Start menu > All Apps (or equivalent) > 
PCMILER 31 > License Status to open the License Tool window, then click 
Activate.)  
 
If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window then 
proceed to Step 15 to open PC*MILER and start using the application. 
 
If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, the 
license activation can be processed automatically.  Enter your Email Address 
then click Activate.  “Manual Activation” should be left unchecked. 
 

NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact PC*MILER 
Technical Support during business hours for assistance. 
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12. When the activation process is complete, you will receive a message in the 
Product Activation window saying, “License Activation Complete!”.  Close 
the window to continue.  If the activation failed, skip to Step 17 below for 
manual activation.   
 

13. To verify that PC*MILER is now licensed, go to the Windows Start menu > 
All Apps (or equivalent) > License Status.  In the PC*MILER License Tool 
window, verify that “Licensed” appears under Status.  PC*MILER is now 
activated.  If “Licensed” is NOT in the Status field, skip to Step 17 below for 
manual activation. 
 

If an additional license was purchased, you can install it now or it can be 
installed at a later time.  See section 2.5.4 for instructions on how to add the 
license to your base PC*MILER application. 
 

14. If the automatic activation was completed, close the License Tool window.  
An email titled “PC*MILER 31 Activation Code for Product XXXXX…” 
from alkservices@alk.com will be sent to the email you entered in Step 11.  
You only need to keep this email for your records.  

  
15. To start PC*MILER once the installation is complete, click the PC*MILER 

icon on the desktop, or click the Windows Start menu > All  (or equivalent) > 
PCMILER 31 > PCMILER 31. 

 
16. Before using PC*MILER, click the Help tab > Check for Updates and 

download and install available updates (see section 17.3). 
 
 
MANUAL ACTIVATION 

 
17. (You only need to follow these steps if the automatic license activation 

process failed.)  If the automatic activation (Steps 11-12 above) fails for any 
reason, try manually activating.  In the Product Activation window, enter your 
Email Address then check “Manual Activation”. 

  
18. Next, click the provided URL for the ALK activation site. 
 
19. You will be taken to the ALK Technical Support “Activate Product” web 

page, and your PC*MILER product key will automatically populate the 
Product Key fields.  Click Next to continue. 

 
20. In the next screen, enter your Email address and click Finish. 
 
21. An email titled “PC*MILER 31 Activation Code for Product XXXXX…” 

from alkservices@alk.com will immediately be sent to the email you entered. 
 

mailto:alkservices@alk.com
mailto:alkservices@alk.com
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22. Copy the activation code directly from the Activation web page or from the 
email sent to you, and paste it into the Activation Code field in the Product 
Activation window. 

 
23. Click Activate in the Product Activation window to complete the activation. 
 
24. You will see the message “License Activation Complete!”.  Close the Product 

Activation window.  PC*MILER is now activated. 

25. Start PC*MILER once the installation is complete: click the PC*MILER icon 
on the desktop, or click the Windows Start menu > All Apps (or equivalent) 
> PCMILER 31 > PCMILER 31. 

 
26. Before using PC*MILER, click the Help tab > Check for Updates and 

download and install available updates (see section 17.3). 
 
 

2.5.2  Disabling Licensed Features (Enterprise License Only) 
 

If you are an Enterprise Licensed User and need to disable one or more features 
that came packaged with your installation, follow the steps below before installing. 
 
1. Open a command prompt window (for Windows 7, click the Windows Start 

menu, type “cmd” and then press Enter). 

2. In the command prompt window, navigate to the folder containing 
PC*MILER’s setup.exe by typing cd “C:\your_install_location”. 
Example:  cd “C:\alk technologies\pcmiler31” 

3. To launch the install while turning a specific feature off, type the following: 
setup.exe “FeatureName1 off” “FeatureName2 off” “FeatureName3 off” 

 
For example, to turn off the Connect and Mapping features: 

setup.exe <space>“Connect<space>off”<space>“Mapping<space>off” 
 

Features that can be disabled this way are the following (not case sensitive): 
 

• CanPost • TripMatrix • TCPIP • Connect 
• MVSConnect • CanadaStreets* • Tolls • BatchPro 
• AS400 • U.S. Streets* • Traffic • Mapping 
• AS400 Tolls • SPLC • TripDirect • Spreadsheets 

 
 
 
 
 
 

*  To turn off North American Streets (includes U.S. and Canadian Streets), use the 
command:  setup.exe “CanadaStreets off” “Streets off”. 
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2.5.3  Activating PC*MILER Using a Proxy Server 
 

1. When the installation is complete (Steps 1-9 in section 2.5.1 above), uncheck the 
Activate check box and then click Finish. 

 
2. Next, start PC*MILER:  Either click the PC*MILER icon on the desktop, or 

click the Windows Start menu and then select All Apps (or equivalent) > 
PCMILER 31 > PCMILER 31. 

 
3. Select the Help tab > Proxy Setup. 
 
4. In the Proxy Setup dialog, check Use Proxy Server then enter a Host and Port. 
 
5. If needed, check Proxy Authentication then enter a Username and Password. 
 
6. Click OK to save your settings and close the dialog.  PC*MILER is now set up 

to use the indicated proxy server when connecting to the Internet. 
 
7. Close PC*MILER. 
 
8. In the Windows Start menu, select All Apps (or equivalent) > PCMILER 31 > 

License Status to open the PC*MILER License Tool window, then click 
Activate. 

 
9. Follow the steps in section 2.5.1 for automatic activation, beginning at Step 11. 
 
 

2.5.4  Installing Additional Licensed PC*MILER Products 
 

NOTE:  A trial installation cannot be upgraded, you must uninstall and reinstall 
to add another product or feature.  A multi-user license cannot be changed to a 
single-user installation of PC*MILER by simply adding the license – you must 
fully uninstall, deactivate your multi-user license, then reinstall using the new 
Product Key Code. 
 
NOTE Also:  To install data add-on modules, see section 2.5.5 below.   
 
These instructions apply to the products listed below.  For data add-ons such as 
PC*MILER|Worldwide, PC*MILER|Tolls, or PC*MILER|Streets, see section 
2.5.5. 
 
PC*MILER|Traffic  PC*MILER|Mapping 
PC*MILER|Weather  PC*MILER|Spreadsheets 
PC*MILER|TripDirect PC*MILER|TCP/IP 
PC*MILER|Connect  PC*MILER|RouteMatrix 
PC*MILER|BatchPro   
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SINGLE USER INSTALLATION 
 
If a license for any of the products listed above was purchased, a separate upgrade 
product key was sent in an email along with the base PC*MILER product key or at 
a later date when the license was purchased.  Follow the steps below to install the 
additional product after the base version of PC*MILER has been installed and 
activated.  
  
1.  If the PC*MILER License Tool window is not already open, select Windows 

Start menu > All Apps (or equivalent) > PCMILER 31 > License Status. 

2. Click Add License. 

3.  In the PC*MILER Product Activation window, enter the upgrade product 
key that was emailed to you and click Add License. 

4. When prompted, enter your Email Address then click Activate.   

5. When the activation process is complete, you will see the message “License 
Activated Successfully.”  The upgrade is now complete and the Product 
Activation window can be closed. 

6. You will immediately receive an email from ALK Technologies that contains 
the new activation code for this upgrade.  Keep this email for your records. 

7. To start PC*MILER, double-click the PC*MILER icon on the desktop, or select 
Windows Start menu > All Apps (or equivalent) > PCMILER 31 > 
PCMILER 31. 

 
 

MULTI-USER INSTALLATION, FROM A WORKSTATION 

1. Go to the workstation. 

2. Browse to the shared …\PCMILER31\network folder on the server. 

3. Run the setup.exe and choose “Modify”. 

4. Follow through with the rest of the installation. 
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2.5.5  Installing PC*MILER Data Add-ons  
 

NOTE:  A trial installation cannot be upgraded, you must uninstall and reinstall to 
add another product or feature.   
 
These instructions apply to the data add-ons listed below.  For licensed products 
such as PC*MILER|Connect, PC*MILER|Traffic, PC*MILER|Weather, etc. see 
section 2.5.4. 
 
PC*MILER|Worldwide* PC*MILER|Energy  
PC*MILER|Streets  DTOD Data 
PC*MILER|Hazmat  Canadian Postal Codes 
PC*MILER|Tolls  SPLC Data 
* including PC*MILER|Worldwide Streets data sets 
 
 

SINGLE USER INSTALLATION OF AN ADDITIONAL LICENSE 
 

If a license for any of the data products listed above was purchased, a separate 
upgrade product key was sent in an email along with the base PC*MILER product 
key.  Follow the steps below to install. 
 
IMPORTANT NOTE:  Please check that you have the latest updates before 
installing additional components. Open PC*MILER and select the Help tab > 
Check for Updates. Download and install any listed updates before installing 
additional data sets.  
 

1. Select the Windows Start menu > All Apps (or equivalent) > PCMILER 31 
> License Status. Or, if the PC*MILER application is open, you can start the 
License Tool by selecting the Help tab / License Tool. 

2. In the PC*MILER License Tool window, click Add License. 

3. Enter the product key code for the purchased data set. This key was included in 
the email sent to you at the time of purchase from alkservices@alk.com with 
subject line “PC*MILER Software Order…”.  The product key can be copied 
from the email and pasted. 

4. Click Add License. 

5. Enter your Email Address in the next screen, then click Activate. 

6. When the activation is finished you will see a “License Activation Complete!” 
message and an activation code will be emailed to you from ALK.  You only 
need to keep this code for your records.   

mailto:alkservices@alk.com
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7. Close the Product Activation and License Tool windows by clicking on the “X” 
in the upper right corner of each window.   

8. To download and install the data set: 

If you are using a DVD, insert the DVD and skip to Step 10. 

If you are not using a DVD, open PC*MILER and either click the PC*MILER 
Updater button or select the Help tab > Check for Updates. 

9. Select “Download & Install” to the right of the new data set you are adding.  
The download process will take several minutes. 

10. When the download is finished, the PC*MILER Data Add-On InstallShield 
Wizard will open.  Click Next to continue. 

11. Select “I accept the terms of the license agreement” then click Next. 

12. (AUP Customers Only)  At this point, you may see a prompt asking if you 
want to delete the data from the previous quarter.  Select Yes or No. 

13. The next screen will list the Licensed Features that will now be installed.  
Click Next.  (Note that the list may include components that are already 
installed.) 

14. In the next screen, click Next to Start Copying Files.  Click OK if any 
prompts pop up during this process. 

15. At the end of the copying process, a prompt will appear that says “Setup will 
now create a backup copy of your user.cfg file…”.  Click OK. 

16. Click Finish in the next screen.  Your data add-on is now ready to use. 

The title bar of the PC*MILER application window will include the installed data 
add-ons, and you will see the new data set in the Map tab > Change Data Set menu.  
All installed data sets are listed in this menu, and the data set you just installed will 
be activated by default.  See section 3.5.7 on changing the data set. 
 

MULTI-USER INSTALLATION OF A LICENSE FROM A WORKSTATION 

1. Go to the workstation. 

2. Browse to the shared …\PCMILER31\network folder on the server. 

3. Run the setup.exe and choose “Modify”. 

4. Follow through with the rest of the installation. 
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2.5.6  Multi-User Network Installation 
 
NOTE:  Please look over the “Important Installation Notes” in section 2.4 before 
beginning your installation. 
 
NOTE:  PC*MILER 31 supports silent installations. 

 
NOTE:  Have your Product Key Code(s) on hand before beginning the installation 
process.  It will have been emailed from alkservices@alk.com in an email titled 
“PC*MILER Software Order…” (Enterprise License customers excluded).  You 
should see “X-User” in this Product Key email. 

 
CONVERTING SAVED FILES:  To import saved custom settings and files from 
your previous version of PC*MILER, see section 2.8 before installing the new 
version. 

 
UNINSTALLING an OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must do 
it before installing the new version (see section 2.9 to uninstall).  If you do not need 
to uninstall, you can have both versions of the desktop program installed on the 
same system.  Please note that PC*MILER|Connect, PC*MILER|Mapping and 
PC*MILER| Spreadsheets will be updated to the new version. 
 
PC*MILER|Traffic, PC*MILER|Weather, and PC*MILER|TripDirect: For 
each of these purchased products, a separate email will be sent with another Product 
Key Code and you will need to upgrade the PC*MILER license with this code at 
the end of the installation or at a later time.  See section 2.5.4. 
 
NOTE FOR INSTALLING TO A MAPPED DRIVE:  For customers who install 
to a mapped drive (this is rare), do not enter the location by its mapped name.  For 
example, if you mapped C:\Apps to F:\, just use C:\Apps as the install directory 
when InstallShield asks you for the location.  Beginning in Version 28, the 
Windows program that PC*MILER uses to automate folder sharing cannot share 
mapped drives by using their mapped name (i.e. F:\ in the example above). 
 
 
BEFORE INSTALLING, double-check that the emailed Product Key Code(s) 
lists all purchased components.  For example, the code shown below unlocks the 
following components: PC*MILER|Connect, PC*MILER|Tolls, TripDirect,  
PC*MILER| Streets (U.S. and Canada), and Worldwide highway data. 
 
Order #: SO-000000001 
Product Order #: PC*MILER 31 
Date: 7/1/2017 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 

mailto:alkservices@alk.com
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== PC*MILER 31 (XX-User), Canadian Streets, Connect, Tolls, 
TripDirect, US Streets, Worldwide Data 
 
To install PC*MILER 31 on a network, follow these steps: 

1. Begin by installing PC*MILER to the server: follow steps 1-9 for a Single User 
Local Installation (section 2.5.1 above). 

2. You will be notified when the installation is complete.  Click OK. 

3. You will be prompted to view the ReadMe.txt and to activate your license.  
If you need to use a Proxy Server to access the Internet, skip to section 2.5.3.  
Otherwise, leave these boxes checked and click Finish to continue.  Review 
the ReadMe and then close the window. 

 
IMPORTANT NOTE:  ALK provides a 15-day temporary license prior to 
completing the activation process.  If you make a second attempt to install you 
will lose this license.  If you experience an activation error and need access to 
PC*MILER before Technical Support is available, please do not attempt a 
second installation without assistance – you’ll be able to use PC*MILER for 15 
days without completing the activation. 

 
4. After you click Finish, the PC*MILER Product Activation window will open.     

 
If you are an Enterprise License Customer: You can bypass the following 
license activation steps of the install because you are already activated and 
registered with ALK.  To continue, close the Product Activation window. 
PC*MILER is installed on the server and can be opened by double-clicking 
the PC*MILER icon on the desktop, or clicking the Windows Start menu and 
selecting All Apps (or equivalent) > PCMILER 31 > PCMILER 31. 
 
If you are not an Enterprise License Customer: If the computer you are 
installing to has an Internet connection and you have a valid email address, the 
license activation can be processed automatically.  Enter your Email Address 
then click Activate.  “Manual Activation” should be left unchecked. 
 
NOTE:  Internet license activation is available 24 hours a day.  If you don’t 
have an active Internet connection or email address, please contact Technical 
Support during business hours for assistance – see section 16.1. 

5. If the activation is successful, you will see a “License Activation Complete” 
message that directs you to open an email from ALK Technologies for further 
instructions.  If the activation was NOT successful, try activating manually 
(Steps 17-26 in section 2.5.1) before calling Technical Support.  To contact 
Technical Support, see section 17.1 in this User’s Guide. 

6. After activation, open the email you received, then follow the instructions for 
copying the “net.lic” file included with the email to the “App” folder in your 



 

 
Chapter 2: Getting Started   37 

PC*MILER installation.  Net.lic holds the license or user count for your 
installation.  Until you save this file to the designated folder, you will only 
have a single-user installation.  The PC*MILER application is now accessible 
on the server (see Step 2 below for access options). 

 

INSTALLING ON A WORKSTATION 

To install PC*MILER on each workstation, follow these steps: 
 
1. On the workstation, click the Windows Start menu and enter the network path 

to where the workstation setup program resides.  This path should match the 
network path sent to your email address as a result of running the server 
installation.  The only difference is that you will replace “App” with 
“Network”.  For example, if this path was sent via the email as "\\PRI-QA-
2K332-02\PCMILER31\App\" for the network license file, you will run the 
workstation installation program from \\PRI-QA-2K332-
02\PCMILER31\Network\setup.exe then press Enter. 

 
If you have lost the email that included the network path, you can determine the 
path as follows: navigate to the server’s “PCMILER31” folder, right click the 
folder, and go to Properties > Sharing.  The network path can be copied and 
pasted from there. 

2. Next, you will be asked to choose your workstation setup options.  Two screens 
will prompt you to select the type of settings you would like to use.   

The setup options in the first screen (Settings Location) are: 

• Use local setting – Allows the user at each workstation to customize default 
options and manage settings, including custom roads and places. 

• Share network settings – Provides each workstation the same default 
options and settings within the application. 

 
The setup options in the second screen (Settings Data) are: 

• Use local data – Installs data to the local workstation.  This option can 
decrease the time it takes PC*MILER to open and begin processing, and 
reduces network traffic.  In general, the performance is better.  However, 
there must be enough hard disk space to accommodate the data.  

• Share data on your network, default – This is the default choice.  
PC*MILER uses the shared data that was installed on the server.  

NOTE on Fuel Prices:  The feed that keeps fuel prices updated (section 3.13) 
will be turned off by default because the server will be getting the prices 
automatically.  Ensure that the PC*MILER user interface is running on the 
server so that fuel prices are regularly updated.  For PC*MILER|Connect use, 

file://PRI-QA-2K332-02/PCMILER28/App/
file://PRI-QA-2K332-02/PCMILER28/App/
file://PRI-QA-2K332-02/PCMILER29/Network/setup.exe
file://PRI-QA-2K332-02/PCMILER29/Network/setup.exe
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ensure that the PC*MILER user interface is running on the 
PC*MILER|Connect server. 

 
NOTE for PC*MILER|TripDirect Users:  Currently only one TripDirect 
account is allowed per installation.  To access TripDirect functionality from 
multiple workstations, one master TripDirect account must be shared. 
 
Tech Note on SWITCHING DATA SETS:   Each workstation will own the 
local user.cfg file stored in the PC*MILER App folder, and the server won’t 
have access to this file.  When the workstation user swaps the data set, the 
local config file will be updated with the current country/region data. 

3.  To start PC*MILER on a workstation once the installation is complete, 
double-click the desktop PC*MILER icon, or click the Windows Start menu 
and select All Apps (or equivalent) > PCMILER 31 > PCMILER 31. 

4. Before using PC*MILER, click the Help tab > Check for Updates and 
download and install any available updates (see section 17.3). 

 
 

 2.5.7  Citrix and Terminal Services Installations 
 
NOTE:  Please look over the “Important Installation Notes” in section 2.4 before 
beginning your installation. 

 
NOTE: Have your Product Key Code(s) on hand before beginning the installation 
process.  They will be emailed to you from alkservices@alk.com in an email with 
the subject line “PC*MILER Software Order…” (Enterprise License customers 
excluded).  You should see “Citrix/Terminal Services” in this Product Key email.  
 
UNINSTALLING AN OLDER VERSION: If you need to uninstall a previous 
version of PC*MILER on the computer that you are now installing to, you must do 
it before installing the new version.  If you do not need to uninstall, you can have 
both versions of the desktop program installed on the same system.  Please note 
that PC*MILER|Connect, PC*MILER|Mapping and PC*MILER| Spreadsheets 
will be updated to the new version. 

 
CONVERTING SAVED FILES:  To import saved custom settings and files from 
your previous version of PC*MILER, see section 2.8 before installing the new 
version. 

 
PC*MILER|Traffic, PC*MILER|Weather, and PC*MILER|TripDirect: For 
each of these purchased products, a separate email will be sent with another Product 
Key Code and you will need to upgrade the PC*MILER license with this code at 
the end of the installation or at a later time.  See section 2.5.4. 

mailto:alkservices@alk.com


 

 
Chapter 2: Getting Started   39 

 
BEFORE USING PC*MILER:  Citrix supports 16 bit and 24 bit color, while 
PC*MILER supports 16 bit and 32 bit color.  A Citrix end user must set the color 
resolution on their workstation to 16 bit before they log into a Citrix server to run 
PC*MILER.  If an end user has their color resolution set to 32 bit and logs in to 
Citrix, the Citrix software will adjust it downward to 24 bit prior to loading 
PC*MILER, and PC*MILER will fail to load. 

 
BEFORE INSTALLING, please double-check that the emailed Product Key Code 
lists all purchased components.  For example, the code shown below unlocks the 
following components: PC*MILER|BatchPro, PC*MILER|Tolls, TripDirect,  
PC*MILER|Streets (U.S. and Canada), and Worldwide highway data. 
   

Order #: SO-000000001 
Product Order #: PC*MILER 31 
Date: 7/1/2017 10:33 AM 
Product Key Code: 3QYKJ-V2KJ7-KJ2F5-82KJ2-KJ2F2 
== PC*MILER 31 (Citrix/Term Serv), BatchPro, Canadian Streets, Tolls, 
TripDirect, US Streets, Worldwide Data 

 
If you were using an existing version of PC*MILER with PC*MILER|Connect 
and/or PC*MILER|Mapping in your Citrix environment, there may be existing files 
that require deletion.  Citrix and Terminal Servers can have multiple copies 
underneath C:\Users\<username>\Windows, C:\Documents and Settings\ 
<username>\Windows or in %homedir%\windows like H:\Windows.  Copies of 
the following files should be deleted from any location outside of C:\WINDOWS: 
 

•  Pcmserve.ini •  Pmwssrv.ini 
•  Pcmserve.ctx •  Pmwssrv.ctx 

 
Only a qualified Citrix administrator should be installing PC*MILER on a 
Citrix system.  With Citrix in Install Mode, follow the steps in section 2.5.1, Single 
User Local (Non-Network) Installation. 
 
 

2.5.8  AS/400 Installations 
 

Installation instructions are included in the PC*MILER|AS400 User Guide. 
To download this document, go to ALK’s website Support Center at:  
http://www.pcmiler.com/support. 
 
 
 
 
 
 

http://www.pcmiler.com/support
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2.6  Starting and Closing PC*MILER 
To start the PC*MILER application, double-click the PC*MILER icon on the 
desktop, or click the Windows Start menu > All Apps (or equivalent) > 
PCMILER 31 > PCMILER 31. 
 
To close PC*MILER, choose Exit from the red File application menu, press 
Alt+F4, or simply close the application window.  
 

2.7  Proxy Setup For Internet Access 
The following PC*MILER features require a connection to the Internet: 
 

• License activation 
• Software update and patch downloads via the Updater tool 
• Real-time traffic data (license required) 
• Satellite imagery on the PC*MILER map 
• PC*MILER|TripDirect (license required) 
• PC*MILER|Weather map display (license required) 
• ALK’s MapSure in a browser (PC*MILER|Streets required) 

 
For those who need to bypass current security settings to access the Internet while 
using PC*MILER, the steps to complete the proxy setup are below.  The setup can 
be implemented after PC*MILER has been activated or before activation during 
the temporary grace period after installation. 
 
1. Open PC*MILER and select the File menu > Application Settings > Proxy. 

2. Check Use Proxy Server then enter a Host and Port. 

3. If needed, check Proxy Authentication then enter a Username and Password. 

4. Click OK to save your settings and close the dialog.  PC*MILER is now set up 
to use the indicated proxy server when connecting to the Internet. 

 

2.8  Importing Saved Files and Settings From a Previous Version 
Saved route files, custom road preferences, custom places, and geofence files can 
all be imported from the previous version of PC*MILER to the newly-installed 
version.  Saved route files will be automatically updated when they are opened in 
PC*MILER 31.  For custom place conversion, see section 3.15.7; custom road 
conversion, see section 12.1.7; geofence conversion, see section 12.4.6. 
 
Additionally, a Settings Importer utility is provided that lets you import customized 
route options and profiles, custom road speeds, map feature settings, and general 
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application settings from the previous version.  Here are a few things to note about 
this utility: 
 

• It will only import from the previous year’s release – i.e. from Version 30 
to Version 31. 

• The following settings won’t be imported and must be reset in Version 31: 
o Length and Distance unit of measure (English/Metric)  
o Fuel in (gallons/liters) 
o State/Country Report Order (alphabetical/route order) 
o Settings that change annually, such as currency conversion rate 

and route costs. 

• The current default values in PC*MILER will be overwritten.  For trip 
options and road speeds, only those values that have been customized in the 
previous version will be imported. 

• The import utility includes a license check and won’t run on workstations 
using shared data.  An error message will appear if an import request 
cannot be processed. 

 
To use the Settings Importer, follow these steps: 
 
1. Select the Windows Start menu > All Apps (or equivalent) > PCMILER 31 

> Settings Importer. 

2. In this dialog, uncheck any settings you do NOT want to import. 

3. Choose a version from the Import Settings from Version drop-down. 

4. Click Import to proceed with the import (click Close if you decide not to 
proceed).  Close the Settings Importer window when the process is complete. 
 

 
PC*MILER Settings Importer 
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2.9  Deactivating and Uninstalling a License 
You must fully deactivate the product’s license and uninstall all PC*MILER 
components, including local, network, enterprise, or server installations if you are: 

• Moving any PC*MILER installation to a new computer. 
• Reformatting a computer that PC*MILER is currently installed to. 
• Returning the product. 
• Reinstalling on the same PC. 

 
Here are the steps for deactivating and uninstalling: 

 
1. Go to Start > All Apps (or equivalent) > PCMILER 31 > License Status 

Alternatively, if the PC*MILER application is open, start the License Tool by 
selecting the Help tab / License Tool. Then, in the PC*MILER License Tool 
window click Deactivate. 

2. In the PC*MILER Product Deactivation window, click Deactivate. 

3. When the deactivation is complete, you will see a “Deactivation Complete” 
message, with the deactivated product keys listed below.   

4. Close the Product Deactivation and License Tool windows. 

5. To uninstall after deactivating, go to the Start menu and find Control Panel 
> Programs and Features (or the equivalent on your system). 

6. Highlight PC*MILER 31, right-mouse click and select Uninstall. 

7. Click Yes at the prompt to completely remove the application. 

8. Click Finish when the installation process is complete. 

NOTE:  If any messages appear during the uninstall process that say that a 
certain file cannot be removed, click OK to continue.   

 
9. !! IMPORTANT STEP !!  Once the uninstall process is finished, you will 

need to delete the …ALK Technologies\PCMILER31 folder manually to 
completely remove the PC*MILER application from your system.  The 
default location for this folder is C:\ALK Technologies\PCMILER31. 

 
NOTE:  If you deactivated/uninstalled an installation that included PC*MILER 
components that were licensed and added after the initial installation, you will 
need to add those components separately again when you reinstall. 
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2.10  Installation: Frequently Asked Questions 
For FAQs related to problems you may have with the installation of your 
PC*MILER products, please go to www.alk.com/support.   

 

2.11  User Guides, Online Help, and Technical Support 

NOTE: You must have Adobe Acrobat Reader on your computer to properly view 
the PC*MILER user’s guide and other documentation.  If you do not have this 
program installed already, a free copy can be downloaded from www.adobe.com.  
Using another reader may result in faulty pagination. 
 
To make Adobe Reader your default reader, from within the application select the 
Edit menu > Preferences > General and click Select Default PDF Handler.  Select 
Adobe Reader from the drop-down, and click Apply then OK to close the 
Preferences dialog. 
 
The PC*MILER User’s Guide can be accessed from within PC*MILER by 
selecting the Help tab > Help Index, by pressing the F1 key, or by clicking a Help 
button in any dialog.   
 

To view the user guide for any PC*MILER product without first opening an 
application, click the Windows Start button > All Apps (or the equivalent on your 
system) > PCMILER 31 and select one of the .pdf files from the sub-menu.  Or 
look on your PC’s desktop for the “PC*MILER 31 User’s Guide” icon that was 
installed with PC*MILER. 
 
To search for a keyword or phrase in a user guide, use Adobe Reader’s Find option 
in the Edit or View menu, or on the toolbar (depending on your version of the 
Reader).  Type a word or phrase into the Find box, and use the drop-down menu to 
refine your search if necessary. 
 

Technical Support 
 

ALK Technologies offers one year of free unlimited technical support to applicable 
registered users of PC*MILER.  See Chapter 17 for contact options. 

 

Version Release Notes 
 

To access Version Release Notes detailing what’s new in the current annual version 
release of PC*MILER and related products, go to the Windows Start menu > All 
Apps (or the equivalent option) > PCMILER 31 > Version Release Notes. 
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          Basic Routing 
 
 

3.1  The PC*MILER Application Window 
When you first open PC*MILER, you’ll see an active route window on the left, the 
PC*MILER map window on the right, and a Ribbon toolbar at the top.  The Ribbon 
contains layered toolbars organized in tabs like a set of file folders. When you click 
a tab, the attached toolbar becomes visible.   
 
The options in each toolbar on the Ribbon pertain to tasks that are related to each 
other.  For example, all tools in the Map tab perform tasks related to the map 
window.  In the screenshot below, the Routes toolbar is visible.  
 

 
PC*MILER Application Window 

 

1 - The File Application Menu.  Click the red File drop-down to open the 
PC*MILER application menu.  Use this menu to print and save maps and 
reports, change application settings, close all open routes or reports, and to 
exit PC*MILER. 
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2 - The Ribbon, with the Routes tab selected.  The Routes toolbar provides tools 
for entering and editing stops on a route, setting route options, and generating 
routes and reports.  

 
There are six tabs on the PC*MILER Ribbon: Routes, Map, Tools, Window, 
ALK Cloud, and Help.  The Ribbon can be minimized if needed: right click 
on it and select Minimize the Ribbon. 
 

 
 

3 - The Routes Window.  This is where all your trips are created and edited.  To 
float this window, click the down arrow in the upper right corner and choose 
Float.  Up to eight routes can be open simultaneously inside the Routes 
window.  Click the Routes tab > New Route to open a new route entry window 
in which you can enter stops and then generate costs, miles and time 
estimates.  When there’s not enough room to display all open routes, a scroll 
bar appears on the right edge of the Routes window that allows access to the 
hidden routes.    

 

4 - The PC*MILER Map Window.   The PC*MILER map window is a 
versatile, floatable window.  To float it, click the down arrow in the upper 
right corner and choose Float.   

 
Each route you run is automatically drawn on the map in the indicated color. 
(This color is shown on the left edge of each route window, in the Route 
legend on the map, and on the Ribbon.)  Use this window to compare routes, 
zoom into stops and specific locations, pick stops directly from the map, drag 
a generated route onto new roads, create avoid/favor preferences, and more.  
With PC*MILER|Weather and PC*MILER|Traffic installed, the map can 
display current weather patterns and traffic data as well.  (Applicable licenses 
required.) 
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3.2  Using the Quick Access Toolbar 
 
The PC*MILER application window includes a customizable Quick Access 
Toolbar that allows quick access to some of the features on the Ribbon that you use 
frequently, without clicking a tab first.  The toolbar is only displayed when at least 
one button has been added to it. 
 
To put a button on the toolbar, right click the button and select Add to Quick Access 
Toolbar.  The toolbar will appear in its default location below the Ribbon.   
 
 

 
 
 
To remove a button, right click it on the Quick Access Toolbar and select Remove 
from Quick Access Toolbar. 
 
 

 
 
 
To put the toolbar above the Ribbon, right click it and select Show Quick Access 
Toolbar above the Ribbon.  The Quick Access menu also gives you the option to 
minimize the Ribbon to increase the workspace in the application window. 
 
Not all buttons can be placed on the Quick Access Toolbar, only buttons that 
perform an action (e.g. New Route or Options).  Drop-downs (e.g. Save) and toggle 
buttons (e.g. Avoid Roads or Drag Route) can’t be added, but items in a drop-down 
that have an icon can be.  If the Quick Access Toolbar isn’t available for a button, 
the option to add it will be disabled in the right mouse menu: 
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3.3  Window and Layout Options 
The three panes in the PC*MILER application window – Routes, Map and Reports 
– can be arranged in several different layouts.  Select the Window tab > Layouts 
and choose your preferred layout. Use the Report Location menu to choose a 
position for the Reports window.  The Routes Window and Map Window buttons 
can be used to recover these windows when they have been hidden. 
  

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Default Layout 
 

Routes on the Left, Floating Reports Routes on the Right, Bottom Reports 

Routes and Reports, Hidden Map 
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Additionally, these panes can be individually resized, floated as a separate window, 
or hidden.  Click the down arrow in the window controls and select an option.   
 
 

Float Detaches the pane from the main PC*MILER application 
window, so that it can be moved around your screen and 
placed in a convenient position or resized. 

Dock Reverses the “Float” command – the pane will return to its 
previous position inside the PC*MILER application 
window. 

Hide Hides the pane.  Another way to do this is to simply click 
the “X” next to the drop-down arrow.  To reopen, use the 
options in the Window toolbar. 

 
 

3.4  PC*MILER Shortcut Keys 
 
For those who prefer using a keystroke rather than making a selection with the 
mouse, PC*MILER provides shortcut keys for commonly-used options.  These 
alternate keystrokes are listed below. 
 
KEY(S) FUNCTION  
F1 Open the PC*MILER User’s Guide for help with a feature. 
F2 Invoke the Custom Place Manager. 
Alt+F2 Invoke the Avoid/Favor Manager. 
F3 Open a list of state/country abbreviations. 
Alt+F3 Invoke the Route Options dialog for the active route. 
F4 Generate a Comparison Report. 
F5 Display the Detailed Route Report for the active window. 
F6 Display the State/Country Distance Report. 
F7 Insert a stop above the one highlighted on the stop list. 
F8 Delete the stop that is highlighted on the stop list. 
Alt+F8 Delete all stops in the route window. 
F10 Generate routes and distances (“Run” in the route window). 
Alt+F10 Optimize the stop order for an optimal route. 
Alt+Bkspace Undo typing in any entry field. 
Ctrl+S Save the active route with the existing filename. 
Ctrl+Shift+S Save the active route with a new filename. 
Ctrl+C Copy the open report to the clipboard for use with another 
 program. 
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Ctrl+N Open a new route. 
Shift+↑ Move the highlighted stop up one line on the stop list. 
Shift+↓ Move the highlighted stop down one line on the stop list. 

  
 
3.5  Building a Route    

 
To create a new route, you should be in the Routes tab of the Ribbon.  If a blank 
route window isn’t visible, select the Routes tab > New Route or Ctrl+N on your 
keyboard.  
 
 
 

 
New Route Window 

 
 
1 - More/Less Button.  Use this button to toggle between a fully expanded and a 

minimal view of the route window. 

2 - Route Name.  By default, each new route is named “Route 1”, “Route 2”, etc.  
A custom route name can be assigned in the Route Options dialog (see section 
10.4).  The route name appears in all reports and in the Route legend on the 
PC*MILER map. 

3 - Color Bar.  Each route displays in a different color on the PC*MILER map.  
A route’s color is shown in this color bar, on the Ribbon in the Routes toolbar, 
and in the Route legend on the map.   

4 - Currently Selected Route Options.  Current route options are displayed here, 
under the route name. The drop-downs below let you select a route profile, and 
set an arrival/departure time and travel speed option.   

5 - Stop Entry.  Stops are entered here in the City field.  If PC*MILER|Streets is 
installed, an address can also be entered in the Address field.  Click Add Stop 
or press Enter on your keyboard to validate the stop and add it to the stop list 
for this route.  The input must match the stop type shown to the left. 

{ 
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6 - Stop Type Drop-down.  The stop type defines the type of input that will be 
accepted in the City field. 

7 -  “Run” Button.  When at least two valid stops are entered for a route, this 
button turns green.  Click it to generate distance, cost, and time estimates. 

8 - Route Options (Gear) Button.  Click the gear to access the Route Options 
dialog or TripDirect (if installed), generate reports, and to float, dock or close 
the route window.     

9 - Frame Route and Show/Hide Route.  Use these buttons to frame the route 
on the map, and to toggle the map display of the route on/off.  

 
 

3.5.1  Stop Entry 
 

IMPORTANT NOTE For PC*MILER|Worldwide and DTOD Data Users:  
You must have the proper region selected when you enter stops. See section 3.5.5 
on region selection.  Also see section 3.5.7 on changing the data set, and section 
11.2 to frame the correct region on the map. 
 
NOTE:  Route options can be set to conform to your routing needs, see Chapter 
10.  Out-of-the-box PC*MILER default route options are: 

• Region: North America 
• Route Type: Practical 
• Vehicle Type: Truck (48') 
• Toll Roads: Allowed 
• Ferries: Allowed 
• Governor Speed Limiting: Disabled 
• Road Network: None 
• Roads: Highway Only, or Highway & Streets if PC*MILER|Streets, 

PC*MILER|Energy, or PC*MILER|TripDirect is installed 
• International Borders: Open 
• Custom Roads: Ignore Avoids/Favors 
• Restrictions: Use 
• Hub Routing: Disabled 
• Elevation: Any 
• Estimated Time of Arrival/Departure: None 
• Travel Speeds: PC*MILER default road speeds 
 
To generate distances and driving instructions for a route, you need to specify at 
least two stops – an origin and destination.  An unlimited number of stops may be 
entered.  PC*MILER will always treat the stop at the top of the stop list as the origin 
of the route and the last stop on the list as the destination, unless you are generating 
hub distances (see section 10.3.2).  As you add stops, each one will be placed below 
the previous stop on the list, creating the stop order from origin to destination. 
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To enter a stop, follow these steps: 
 
1. Select the Routes tab > New Route or the Ctrl+N keys. 
 
2. Make a selection in the stop type drop-down. 
 
3. In the City field of the new route window, type a location using any valid 

format (see the list of formats below); a street address can be included in the 
Address field if PC*MILER|Streets is installed. 

 
4. Click Add Stop or press the Enter key on your keyboard. 
 
5. If a pick list of locations appears, highlight your choice and click OK. 
 
If the location you entered is valid, the stop will appear above the City field in a 
stop list.  For a stop to be valid, there must be a match in the PC*MILER database.  
If an error is returned, see section 3.5.26.  To enter an arrival or departure time, see 
Chapter 5.  To set options for a route, see Chapter 10. 
   

 
You can input a city, town or location in any of these formats: 

 
• City name, followed by a comma or space and the state abbreviation  

(see section 3.5.2 below).  A street address may be included if PC*MILER|Streets 
data is installed (see section 3.5.4).  Spelling help is available (section 3.5.9). 

• The spelled-out name of a state as part of a place name. 
• 5-digit ZIP or postal code (section 3.5.10-11).  Postal code help is available. 
• 6-digit Canadian postal code (if the separate add-on data module is installed – 

see section 3.5.12).  Postal code help is available. 
• (North America only)  SPLC (only if the data add-on is installed – see section 

3.5.13 –14).  “SPLC” must be selected as the stop type in the stop type drop-down.  
SPLC help is available. 

• Point and click a point on the map (section 3.5.25) 
• Latitude/longitude point (sections 3.5.17-18 and 3.5.25) 
• Custom place (see section 3.12 and 3.15).  
• (U.S./North America only) Border crossing, highway junction, highway exit, 

truck stop, CAT scale or state weigh station (see sections 3.5.15-3.5.22). 
• (North America only)  Point of Interest (POI).  Search for POIs from within 

the route window, with a general search or targeting specific types of POI 
such as Fuel Stops or HOS Stops.  (See sections 3.12-14 and 11.14.) 

• (North America only) Energy land survey address (PC*MILER|Energy must be 
installed – see Chapter 14). 
 



 

 
Chapter 3: Basic Routing   52 

3.5.2  City Name and State/Country Abbreviation 
 

Here are the steps to enter a city or town using the city/state format: 
 
1.  Select Postal Code in the stop type drop-down.   
 
2. Type the city name and two-letter state/province/country abbreviation or fully 

spelled out state name in the City field, then click Add Stop or press the Enter 
key on your keyboard.   The city and state/country do not need to be capitalized, 
but do need to be separated by either a comma or a space.  The city name can 
be any length.  If the city name contains two or three words, each portion of the 
city name must be separated by spaces.  

 
Examples: chicago, il    

 chicago il    
 chicago, illinois 
 paris,fr (PC*MILER|Worldwide or DTOD Data users only) 
 los angeles, ca 
 salt lake city, ut 
 salt lake city, utah 
 belle croix,fr (PC*MILER|Worldwide or DTOD Data users only) 

 

 

Entering Trenton, NJ as a Stop  
 
3. PC*MILER will search through the database for a match to the location you 

entered.  If there are multiple listings in the database for the same location, a 
scrollable pick list will open.  Highlight your choice and click OK. 

 
4. If your entry was valid, a stop list will open above the City field and the stop 

you entered will be displayed as the trip origin along with a time zone:  
 

 
Stop List With An Origin Entered  

(PC*MILER|Streets required for addresses) 
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Turn Off the Pick List 
If you want PC*MILER to pick a default match rather than open a pick list of 
multiple postal codes, select the File application menu > Application Settings > 
Geocoding.  Uncheck Provide Pick List and click Save.  By default “Provide Pick 
List” is checked and if there is more than one location for a city name, the most 
densely populated city will appear at the top of the pick list with an alphabetical 
listing of other cities below.   
  
TIP on DATA MATCHING:  For a way to confirm that your location data 
matches the PC*MILER, see section 3.15.5, Importing Custom Places. 
 
Spelling Help 
Spelling help is available for city names – see section 3.5.9.  To look up 
state/province/country abbreviations, see Appendix D in this user’s guide.  
 
Country Code Format 
If PC*MILER|Worldwide or DTOD Data is installed, country abbreviations 
outside North America may be entered using FIPS 2-character, ISO 2-character, 
ISO 3-character, GENC 2-character or GENC 3-character codes.  FIPS codes are 
accepted by default.  To use another format for stop entry, select the File application 
menu > Application Settings > Worldwide.  Choose an option from the Country 
Abbreviation Format drop-down list.  
 
 

3.5.3  Entering Mexican and Canadian Locations 
 

Mexican Locations 
Mexican locations can be entered using a postal code, or a city name plus a two-
letter abbreviation.  See Appendix D in this user’s guide for a list of Mexican estado 
abbreviations.   
 

Examples: puerto vallarta, ja 
 99250 
 
Some Mexican and U.S. locations have the same postal code assigned to them.  The 
way PC*MILER handles Mexican versus U.S. postal codes in these cases can be 
set in the Application Settings dialog: 
 
1. Select the File menu > Application Settings > Geocoding. 
 
2. Select an option in the Postal Code Preference drop-down.  Options are 

described below, but note that if Provide Pick List is checked above the drop-
down, a pick list of Mexican and U.S. locations will always open when both are 
available for the entered location.   
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• Use Default US Zip Codes:  The default U.S. ZIP code will be returned. 
Mexican codes cannot be entered. 

• Use Default Mexican Zip Codes:  The default Mexican postal code will be 
returned.  U.S. codes cannot be entered. 

• Use Default US and Mexican Zip Codes:  The default U.S. ZIP code will 
be returned in cases where the postal code is assigned to both a U.S. and 
Mexican location.  Mexican codes can be entered with a state 
abbreviation, for example “50510 IA”; or with the abbreviation “EM” 
signifying a Mexican location, for example “50510, EM”. 

 
Canadian Locations 
Canadian postal codes can be entered only if the separate PC*MILER Canadian 
Postal Codes add-on data module is installed.  See section 3.5.12 on entering 
Canadian postal codes.  
 
If the Canadian Postal Codes module is not installed, Canadian place names can be 
entered using the city name and province abbreviation. See Appendix D in this 
user’s guide for a complete list of Canadian province abbreviations. 
 
Examples: montreal, qc 
 ottawa on   
 
If a Canadian place name has multiple postal codes, a pick list will open only if 
pick lists are enabled (File menu > Application Settings > Geocoding tab) and the 
Canadian Postal Code data module is installed.  Otherwise, the PC*MILER default 
choice will be entered.     
 
NOTE:  “NL” is recognized as Newfoundland and Labrador unless this setting has 
been changed to mean Nuevo Leon using the Application Settings dialog (File 
menu > Application Settings > Geocoding). 
 
NOTE Also:  To enter a location name that includes one or more accented letters 
(for example, Felipe Ángeles, CI), either 1) use the postal code, or 2) use the Insert 
> Symbol option in Microsoft® Word or Excel® to type the location name and then 
copy and paste into the route window in PC*MILER. 
 
 

3.5.4  Address Entry (PC*MILER|Streets required) 
 

(Applies only in countries for which PC*MILER|Streets address data has been 
purchased. The correct map data set must be selected – see section 3.5.7)   
 
If PC*MILER|Streets is purchased and installed with PC*MILER, you can – 
optionally – specify a street-level address for a stop.  Enter a street name by itself 
or with an address number in the Address field below the city entry. 
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Addresses can be added to a city/state or postal code entry.  An address can also be 
combined with a latitude/longitude point for more precise geocoding – see section 
3.6.18.   
 
To turn on local street routing, in the route window select the gear button  > Options 
> Routing Preferences > Roads > Highway & Streets. 
 
If you enter an address when the Highway Only mode is enabled, a warning will 
appear above the stop list.  To delete the warning, click the “X” on the far right.  
 
 

 
 

 
“Highway Only” Warning in a Route Window 

 
 
To look up synonyms for street type abbreviations that PC*MILER will accept (for 
example, “Blvd” for “Boulevard”), see Appendix E or the synonym.typ file located 
in the PC*MILER installation folder (usually in C:\ALK Technologies\ 
PCMILER31\Data\Info) and readable using a text editor. 
 
In North America, address data is available for the US and Canada. With 
PC*MILER|Worldwide installed, address data is also available in Europe, India, 
and available countries in Africa, the Middle East, Oceania and South America.  
The correct region and map data set must be selected – see sections 3.5.5-7 below. 
 
NOTE:  To see an address range on the map, place your cursor over any road 
segment – a tooltip with the segment’s street name and address range will pop up. 
  
For PC*MILER|Worldwide Users:  You may need to frame a different map region 
to see your routes on the map – see section 3.5.5 below. 
 
NOTE:  The pick list setting in the Application Settings dialog determines how 
PC*MILER handles incomplete or inaccurate street names that are entered in the 
route window.  Select the File menu > Application Settings > Geocoding to control 
this setting.  If Provide Pick List is unchecked, the first approximate match that is 
found in the database (if there is one) will be returned.  When Provide Pick List is 
checked (this is the default setting), a pick list will open and you can choose an 
address from it.  
 
TIP:  If you enter a ZIP/postal code and PC*MILER can’t find an address that you 
specify within that code, try expanding your search by entering the city name.  In 
general it is recommended that, when entering or importing addresses, you use the 
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corresponding city/state instead of the location’s postal code.  (For example, enter 
“457 North Harrison Street, Princeton, NJ” rather than “457 North Harrison Street, 
08540”.)  Using the city and state/province will increase the geocoding match 
success rate and provide a more accurate representation of the address when 
routing. 
 
 

3.5.5  Changing the Region (PC*MILER|Worldwide and DTOD Data only) 
 
The correct world region must be selected when entering stops.  The current 
region is displayed at the top of each route entry window.   
 
To set the default region for all trips:  
 
1. Select the File menu > Application Settings > General. 

2. Choose a region from the Default Region drop-down. 

3. Click Save. 
 

 
Changing the Default Region 

 
 
To change the region for the currently active route window only, select a region 
from the drop-down on the Routes toolbar.  

 

 
Changing the Region for the Current Trip Only 

 
If the wrong region is selected (i.e. it does not match the stop you are attempting to 
enter), normally either an error message will appear or your input will be matched 
with a city by the same name in the selected region; for example, if you enter “Paris, 
FR” when your region is North America, “Paris, AR” will be returned as a stop.   
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However, PC*MILER generates some trans-regional routing and in certain cases 
the above rule does not apply.  Because routing between Europe, Asia, Africa, and 
the Middle East is possible, locations may be entered that do not match the selected 
region when any of these regions are selected.  For example, entering “Paris, FR” 
will return the correct stop if Asia or Africa is the selected region. 
 
You may also need to change the map window to the desired region if you wish 
to see graphic displays of the routes you run: 
 
1.  Select the Map tab > Frame > Regions. 
 
2. Choose a region. 
 
 

3.5.6  Changing the Country Code Format (PC*MILER|Worldwide and DTOD  Data only) 
 
Worldwide country abbreviations may be entered using either FIPS 2-character, 
ISO 2-character, ISO 3-character, GENC 2-character or GENC 3-character codes.   
FIPS codes are accepted by default.  To use another format for stop entry: 
 
1. Click the File application menu > Application Settings > Worldwide. 
 
2. Choose an option from the Country Abbreviation Format drop-down.  For a 

complete list of worldwide country abbreviations, see Appendix D. 
 
 

3.5.7  Changing the Data Set 
 
 

 
Change Data Set Menu with PC*MILER|Worldwide Installed 

 
 
To change the version of the map data that PC*MILER uses to calculate routes: 
 
1. Select the Map tab > Change Data Set. 
 
2. Make a selection from the available options.  Options will vary depending on 

which data sets are installed. 
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3. The currently loaded data set will be displayed in the title bar of the map 
window, shown at the bottom of each page in any generated reports in Print 
View, and selected with a checkmark in the Change Data Set menu. 

 
For ALK’s Annual Update Program (AUP) Licensed Users:  For PC*MILER 
(North America only), the options in the drop-down will include the base version 
data set plus any mid-year versions that have been released since the base version, 
including PC*MILER|Streets U.S. and Canadian street-level data if installed. 
 
For PC*MILER|Worldwide Users: PC*MILER|Streets data modules are 
available for local street addresses in Canada, the United States, Europe, and some 
countries in Africa, Asia, Middle East, Oceania and South America.  Each module 
may be purchased separately or in combination with other data sets. The correct 
data set must be selected before you enter an address.  When you activate a data 
set, the correct region will automatically be active in Application Settings.   
 
Note that Streets data sets in world regions outside North America may not 
include coverage for every country in the region.  Therefore, when such a data 
set is selected, routes can’t be run within or across countries not included in 
the Streets data set.  The Worldwide Highway data set must be used to run routes 
to/from countries that are not covered in the Streets data set.  For more on 
worldwide data coverage, see Appendix I.   
 
For PC*MILER|Energy Users:  You will see the NA – Streets US/Canada Energy 
data set in the Change Data Set menu. 
 
 

3.5.8  About the Stop Entry Pick List 
 
By default,  when you enter a stop that has multiple listings in the database, a pick 
list of matching locations will open.  The order in which locations are listed in the 
pick list is based on such factors as population and geographic centrality. The most 
densely populated cities that match your entry will be at the top of the pick list.   
 
To have PC*MILER pick a default postal code or address rather than open a pick 
list of multiple database entries: 
 
1. Select the File menu > Application Settings > Geocoding. 
 
2. Uncheck Provide Pick List. 
 
3. Click Save.   
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3.5.9  Spelling Help 
 
If you're not sure how to spell a city name, or if you received an error message when 
entering a city and state abbreviation, try getting spelling help as follows: 
  
 1. In the City field of a route window, type the first letter or first few letters of 

the city name followed by a comma or space and the two-letter state/ 
province/estado abbreviation.  Note that typing more letters of the city name 
(i.e. two or three rather than just one) will decrease the processing time 
needed to create a list of matches. 

 
Examples: chi,il     los ang, ca     los a,ca     p fr  (PC*MILER|Worldwide only)        
 

2. Click Add Stop or press Enter.   
 
3. A pick list of possible matches will open unless this option is turned off in the 

Application Settings dialog (File menu > Application Settings > Geocoding).   
 
4. Scroll the list if necessary and highlight the city or ZIP/Postal code that you 

wish to select, then click OK. 
 

 
Matches to “pi nj” for Spelling Help 

 
 

3.5.10  Entering ZIP/Postal Codes 
 

To enter a postal code: 
 
1. Select Postal Code in the stop type drop-down. 
 
2, Enter a valid postal code in the City field. 
 
Entering any valid postal code creates a search for the corresponding city. The city 
name will be entered as a stop, along with the postal code, state/country 
abbreviation, and county/province if it exists in the database.  If you enter 08540 
(NA region), PC*MILER will return:  08540 Princeton, NJ, Mercer. 
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IMPORTANT for PC*MILER|Worldwide and DTOD Data Users:  When you 
enter postal codes outside North America, you need to enter a country abbreviation 
to avoid being routed to the wrong country in cases where the same postal code exists 
in more than one country.  Enter the postal code, a comma, and the correct two-letter 
country abbreviation. 
 
Example: 46001, sp  (Valencia, Spain)  
   
Remember that the correct region must be selected in Application Settings > 
General or on the ribbon tool bar > Routes tab.  Not all countries have postal codes 
in the database.  Users can import absent postal codes as custom places if needed (see 
section 3.15.5).  For the format of postal codes in PC*MILER|Worldwide regions 
and various countries in those regions, see Appendix H. 
 
NOTE:  If the +4 ZIP code designation is entered, PC*MILER will ignore it. 
 
 

3.5.11  ZIP/Postal Code Help 
 

If you’re unsure of a particular postal code or if you receive an error message when 
entering a postal code, do the following:  
 
1. Select Postal Code in the stop type drop-down. 
 
2. In the City field of a route window, type at least the first two digits of the 

postal code.  For postal codes outside North America, enter a country code as 
well.  Examples: 60 or 606 fr (France – PC*MILER|Worldwide required). 

 
2. Click Add Stop or press Enter to bring up a pick list of matches.  

 
Pick List of Matches for “60” – North America Region  

 

 
3. Scroll the list if necessary and highlight your selection. 

4. Click OK.  Note that the pick list won’t appear if this option is turned off (go 
to File menu > Application Settings > Geocoding).   
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3.5.12  Canadian Postal Codes 
 

(The PC*MILER Canadian Postal Code data add-on module is required.)   Six-digit 
Canadian postal codes can be entered as stops.  The codes are always alphanumeric 
in the format “ANA NAN” where “A” represents an alphabetic character and “N” 
represents a numeric character.  Entering any valid Canadian postal code will 
invoke a search for the corresponding city and province name, and these will be 
entered as a stop along with the postal code.  
 

Example: If you enter: K7L 4E7      
 PC*MILER will return: K7L 4E7 Kingston, ON 
 
For help with Canadian postal codes, you need to enter at least 3 digits. 
 
 

 
Canadian Postal Code Help 

 
 

3.5.13  SPLC Entry (North America only) 
 

(The PC*MILER SPLC data add-on module is required.)   A SPLC can be entered 
as a stop for any location in North America that has a SPLC assigned to it.  SPLCs 
may be six or nine digits in length.  SPLC data used in PC*MILER products is 
owned, maintained and copyrighted by the National Motor Freight Traffic 
Association, Inc. 
 
To enter a SPLC: 
 
1. Select SPLC from the stop type drop-down. 
 

 
 
2. Type your entry and click Add Stop or press Enter.   
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NOTE:  If you enter a SPLC when “SPLC” has not been selected in the stop type 
drop-down, you’ll get an error message.  When “SPLC” is selected, you won’t be 
able to enter other types of locations. 
 
 

3.5.14  SPLC Help 
 

If you need help finding the correct SPLC for a particular location, a pick list of 
SPLC can be invoked: 
 
1. First make sure that “SPLC” is selected in the drop-down to the left of the 

City field. 
 
2. Type at least the first two digits of the SPLC. 
 
3. Click Add Stop.   
 
A pick list will be generated unless this option is disabled in Application Settings 
(File menu > Application Settings > Geocoding). 
   
 

 
SPLC Help 

 
3.5.15  Border Crossings (U.S. only) 

 
U.S. state border crossings can be entered as stops on a route using the PC*MILER 
border crossing naming convention.  Border crossings have the following syntax: 

!XXYY  Name,  XX 
 
where XX is the two-letter abbreviation of the state that is first in alphabetical order, 
YY is the abbreviation of the state that is second in alphabetical order, and Name 
is the route name of the route that crosses the border. 
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In cases where the road name is different on either side of the border, the road name 
used is the one that lies within the state first in alphabetical order. 

 
Below is an example of how to quickly locate all border crossings between two 
states in the database.   

Example:  For Pennsylvania/New Jersey border crossings, enter:   !njpa, nj 

 

 
Pick List of NJ/PA Border Crossings 

 
 

NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this setting is turned on. 

 
 

3.5.16  Highway Junctions (North America only) 
 
PC*MILER allows you to access highway junctions between major road types in 
the United States, Canada, and Mexico.  (Note, however, that there are some 
highway junctions which are truck-inaccessible.  These junctions won’t be 
recognized as stops.)   
 
The format for junction names is: the first route name is the lower numbered one, 
the second route name is the higher numbered one, and the route names are 
followed by the abbreviation of the state in which the junction is located.   
 

Example:  +I 469 IN 37, IN 
 

In cases where two junctions by the same highway pair occur within the same state, 
the junctions are designated by a location direction (N, S, E, W) relative to the 
location of the other junction.   
 

Example:   +US231 IN 66W, IN is one mile west of  +US231 IN 66E, IN 
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The best way to enter a highway junction is to invoke a pick list of matches. Type 
a plus sign ( + ) followed by a comma and the state abbreviation.   
 

Example:   For highway junctions in Indiana, enter:   +, in 
 

 

 
Pick List of Highway Junctions in Indiana 

 
 

NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this setting is turned on. 

 
 

3.5.17  Latitude/Longitude Points 
 
There are several ways to enter latitude/longitude points as stops on a route in 
PC*MILER.   
 
Copy and Paste a Lat/Long From the Map: 
 
1. Pass your cursor over the map, you’ll see its lat/long position tracked in the 

status bar in the lower left corner of the map window. 
 

TIP:  It’s easier to copy lat/longs accurately at higher zoom levels.  
   
2. With the lat/long you want to enter displayed in the status 

bar, right click the map and choose Copy 
Latitude/Longitude from the menu. 

3. Click in a route window’s City field and paste (Ctrl-V or 
Paste in the right mouse menu).   
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   Pick a Lat/Long From the Map: 
 
1. Select the Routes tab > Pick Stop on Map button, OR right click the map and 

select Pick Stop. 
 
2.  Click on the point you want to enter. 
 

TIP:  It’s easier to pick a lat/long accurately at higher zoom levels.  
   
 
Enter a Lat/Long Directly in the Route Window: 
 
You can enter a lat/long directly in the City field in a route entry window, using a 
degrees minutes seconds direction format (e.g. 0401750N,0742131W) or 
decimal degrees (e.g. 40.123N,100.333W) as shown below. 
 
Degrees-Minutes-Seconds Format: 
In degrees-minutes-seconds format the latitude and longitude are each 8-character 
strings in the following format: 

 

Characters 1-3  specify the degrees (be sure to include  leading zero if required) 
Characters 4-5  specify the minutes 
Characters 6-7 specify the seconds 
Character   8  N, n, W, or w, with N’s for latitude and W’s for longitude  

Latitude and longitude must be separated by a comma, with or without a space.   
 

Example:   dddmmssN,dddmmssW 
 
Decimal Degrees Format: 
In decimal degrees format, latitude and longitude are strings of up to 8 characters 
representing a decimal number with up to 3 decimal places. No leading zeros are 
required. The decimal point counts as one of the characters. Latitude and longitude 
must be separated by a comma, with or without a space. 
 

Example:   dddd.dddN,dddd.dddW 
 
Converting Between Formats: 
To convert from degrees-minutes-seconds to decimal degrees use the following 
formula:   dddmmssN → ddd + mm/60 + ss/3600. 
 
 
Import Lists of Lat/Longs: 
 
See section 3.16.5. 
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3.5.18  Latitude/Longitude With Street Address 
 
(PC*MILER|Streets must be licensed and installed.)  For more precise geocoding 
and directions, latitude/longitude points can be combined with street addresses as 
in the image shown below. This functionality geocodes the lat/long to the nearest 
point on the particular street in the address, rather than simply to the nearest street, 
as would be the case for a lat/long by itself.  If the lat/long is more than .5 miles 
from the street in the address, an error message will be returned.  
 
The minimum input when using this combination should include the lat/long plus 
a street name.  Including an address will provide more precise geocoding. 
 
NOTE:  The Highway & Streets route option must be turned on in the Route 
Options dialog or the current route profile. This option is selected by default with 
PC*MILER|Streets, PC*MILER|Energy or PC*MILER|TripDirect installed. 
 
 

 
Stop Entry Using a Latitude/Longitude with an Address 

 
3.5.19  Truck Stops (U.S. and Canada only)  

 
Truck stops can be entered as stops on a route like other places in the PC*MILER 
database.  The syntax for a truck stop starts with an "at" symbol [@], then the truck 
stop name, and the state or province in which the truck stop is located.   

 
To generate a pick list of truck stops in a particular state, use the [@] symbol, a 
comma or space, and the state/province abbreviation.   
 

Example:  For truck stops in Georgia, enter:   @, ga 
 

To speed up a search for a known truck stop, use the first letter of the name.   
 

Example:  For truck stops in Georgia beginning with "C", enter:   @c, ga 
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Pick List of Truck Stops in Georgia 

 
 

NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this option is turned on. 
 
NOTE Also:  To search for fuel stops and prices, see section 3.13.  To search for 
truck stops within a radius or along a route using the POI search tool in a route 
window, see section 3.12. 

 
 

3.5.20  Highway Exits (U.S. only)   
 
Interstate-to-Interstate exit numbers can be entered as stops, including Interstate 
exits leading to non-Interstate highways.   
 
To generate a pick list of highway exits in a particular state, enter “^” (Shift-6) 
followed by a comma and state abbreviation.   
 

Example:  To list exits in New Jersey, enter:  ^, nj 
 

You can also enter an exit directly.  For example, you could type “^I 80 E x273, 
pa” to enter Exit 273 off Interstate 80 East in Pennsylvania.  No spaces are 
necessary, but the east/west designation must be included.   
 

Examples:   ^I-90 w x35, ny       ^I 90w x35, ny      ^I-90wx35, ny 
 

 
TIP:  You can search for highway exits within a radius or along a route using the 
POI search tool in a route window – see section 3.12. 

 
NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this setting is turned on. 



 

 
Chapter 3: Basic Routing   68 

 

 
Pick List of Highway Exits in New Jersey 

 
 

3.5.21  CAT Scale Weigh Stations (U.S. and Canada only)   
 
The PC*MILER database includes CAT Scale weigh station.  CAT Scale weigh 
stations are represented on the map by a cat icon.  To bring up a pick list of CAT 
weigh stations in a particular state, enter a pound sign followed by a comma and 
the state abbreviation or spelled-out state name.  
 

Example:  #, nj 
 

 
Pick List of CAT Weigh Stations in New Jersey 

 
 
To find CAT weigh stations within a specified radius of a location or along a route, 
use the POI search tool (see section 3.12).     
 
NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this setting is turned on.  
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3.5.22  State Weigh Stations (U.S. only)   
 
State weigh stations can be entered as stops on a route.  To bring up a pick list of 
weight stations in a particular state, enter a dollar sign ($) followed by a comma 
and the state abbreviation or spelled out state name.    
 

Example: $, id 
 
You can search for state weigh stations within a radius or along a route using the 
POI search tool in a route window – see section 3.12.    
 
NOTE:  A pick list will only be generated if Provide Pick List is enabled in the 
Application Settings dialog (File menu > Application Settings > Geocoding).  By 
default, this setting is turned on. 
 

 

 
Pick List of State Weigh Stations in Idaho 

 
 

3.5.23  Energy Land Survey Addresses 
 
Please see Chapter 14, Using PC*MILER|Energy. 
 
 

3.5.24  Custom Places 
 
Please see section 3.15. 
 
 

3.5.25  Entering An Arrival or Departure Time for ETA/ETD 
 
Please see Chapter 5, Using ETA/ETD and Traffic Data.    
 
 



 

 
Chapter 3: Basic Routing   70 

3.5.26  Loaded/Empty Stop Designation 
 
To designate a stop as arriving empty or loaded: 
 
1.  In the route window, right click a stop on the stop list. 
 
2. Uncheck Loaded.  Select this option again to toggle it back on.   
 

 

 
Right Mouse Menu Off a Stop 

 
 

3.5.27  Picking Stops From the Map 
 

TIP:  Pass your cursor over the map and notice how its lat/long position is 
automatically tracked in the status bar (lower left corner of the map window).  

 
Stops can be entered directly from the PC*MILER map window by pointing and 
clicking with the mouse.  Note that it’s easier to grab the location you want at closer 
zoom levels.  To pick a stop, follow these steps:   
 
1. Select the Routes tab > Pick Stop on Map button under Stops; or select Pick 

Stops from the right mouse menu off the map.   

2. In the map window, the cursor will now be in the shape of a hand.  Click on the 
target location to add it as a stop in the active route window.  The point will be 
entered as a place name or latitude/longitude point.   

3. Alternatively, in the map window’s right mouse menu select Copy 
Latitude/Longitude to copy the lat/long displayed in the status bar below, then 
paste into the City field of a route window (Ctrl-V or right click > Paste). 

 
 
NOTE:  There are some highway junctions which are truck-inaccessible.  These 
junctions won’t be recognized if you try to enter them as stops.  
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3.5.28  Input Errors 
 
One of several error messages might be returned when entering stops.  The most 
common one is “No matching city found”.  If you encounter an error message, click 
on the “X” in the message to close it and clear what you entered, then try the 
following:  

 

• Check that you separated the city name and state abbreviation with a 
comma or space, and check for typos and spelling errors. 

• Make sure that the stop type to the left of the City field matches your 
input.  For example, if entering a SPLC, make sure that SPLC is selected.  

• Get spelling help (see section 3.5.9). 

• Use the exact postal code or get ZIP/postal code help (see section 3.5.11). 

• See Appendix D for a list of valid state/country abbreviations. 
 
In all cases, the ZIP/postal code takes precedence over the city and state/country 
name.  Certain suburbs or small towns may not have their actual names in the 
database, but rather the name of the larger nearby city.  In these cases, the ZIP or 
postal code for the smaller community will have to be entered to achieve correct 
results.  
 
 

3.5.29  Duplicate City Names and County Designations 
 
In the PC*MILER database, there are several thousand instances of towns in the 
same jurisdiction that share the same name.  For example, in the U.S. state of 
Pennsylvania, there are two towns named Hamlin: one in Wayne County and one 
in Lebanon County.  Another example is the towns of Londonderry in the United 
Kingdom: one is in Londonderry and one is in North Yorkshire.  
 
In certain circumstances, duplicates can be separately identified by means of their 
differing postal codes.  However, some duplicate towns do not have postal codes 
assigned to them.  You can identify your desired stop by the county listing in the 
town name.  In the database, the county name follows the state abbreviation (e.g. 
Hamlin, PA, Wayne).  It appears in the route window after a stop has been entered, 
in small letters after the city name and state abbreviation. 
 
If you are not sure which city is the stop you want, first go to File menu > 
Application Settings > Geocoding and make sure that Provide Pick List is 
checked.  Then enter the city name and state/province/estado abbreviation.  When 
you click Add Stop, a pick list will provide the possible choices in the database 
along with county names.  The order in which locations are listed in the pick list is 
based on such factors as population and geographic centrality. The most densely 
populated cities that match your entry will be at the top of the pick list.  Select the 
correct city from the pick list and click OK to enter it as a stop. 
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If you know the county in which the duplicate city is located, you can enter that 
exact city in the stop entry field.  Do so by entering the city and state, followed by 
a comma and the county name as in any of these examples: 

hamlin, pa, wayne hamlin,pa, wayne 
hamlin, pa,wayne hamlin,pa,wayne 
 

TIP:  Another way to see the county name: zoom to the town on the map and place 
your cursor over it without clicking – the full name of the town, with its county, 
will appear in a tooltip. 
 
In Canada, duplicate city names are found in the same provinces.  PC*MILER 
identifies the town by assigning a county to it in the same way that the county name 
follows a U.S. city name.  For a list of Canadian counties in the PC*MILER 
database, see Appendix C. 
 
 

3.5.30  Editing the Stop List 
 
All options related to editing the stop list are found in the Routes tab under Stops.  
Several editing options are also available in a right mouse menu off any stop name 
on the stop list in a route window.   
 
Here are the editing options in the Routes tab, with the right mouse menu option 
noted where available: 
 
 

Editing Option Button/Shortcut Option Description 

Add Stop at End 
 

Type a location in the location entry fields 
and click this button to add the stop at the 
end of the stop list. 

Insert Stop Above    F7 

Click to insert a stop above the highlighted 
stop; or right mouse click on the 
highlighted stop and choose Insert Stop 
Above from the menu. You can also click 
the “plus” ( + ) symbol in the Routes 
window at the point of insertion. 

Edit Stop 
 

Click to edit the highlighted stop, or right 
mouse click on the highlighted stop name 
and choose Edit from the menu. When 
done editing, click Add Stop to add the 
edited stop back to the same position on 
the list. 
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Delete Stop    F8 

Click to delete the highlighted stop; or 
right mouse click the stop name and 
choose Remove from the menu. 

Delete All Stops    Alt+F8 
Click to delete all stops from the currently 
active route window. 

Frame Stop on Map 
 

Click to frame the highlighted stop on the 
map; or right mouse click on the stop 
name and choose Zoom to Stop from the 
menu. 

Pick Stop on Map 
 

Click to activate this option. Then pick a 
stop from the map: in the map window 
zoom in to the target location, point the 
cursor to a town, address, intersection, or 
lat/long on the map, then click to add this 
place as a stop. 

Move Stop Up    Shift+↑ 

Move the highlighted stop up on the list, or 
right mouse click on the stop name and 
choose Move Up. 

Move Stop Down    Shift+↓ 

Move the highlighted stop down on the list, 
or right mouse click on the stop name and 
choose Move Down. 

Reverse Stops 
 

Click to reverse the order of stops in the 
currently active route window. 

 
 

3.5.31  Moving and Copying Stops 
 
Stops on a stop list can be copied or moved from one route window to another, or 
moved to a different position in the same window.  Note that a waypoint can be 
copied or moved, but if it is moved to the Origin or Destination position on the stop 
list it will become a stop rather than a waypoint.      
 
 

To copy a stop to another route window: 
 
1. Left click the stop name while holding down the Ctrl key. 
2. Drag the stop onto the stop list in the target window. 
3. Let go when the stop is in the desired position on the list. 
 
or 
 
1. Right click the stop name. 
2. Select Copy To > and select a route window. 
3. The stop will be copied to the end of the stop list in the target window. 
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To move a stop to another route window: 
 
1. Left click the stop and drag it to a different route window. 
 
or 
 
1. Right click the stop name. 
2. Select Move To > and select a route window. 
3. The stop will be moved to the end of the stop list in the target window 
  
 

To move a stop to a new position in the same window: 
 
1. Left click the stop and drag it to a different position on the stop list. 
 
or 

1. Right click the stop name. 
2. Select Move Up or Move Down. 
 

 
Right Mouse Menu Off a Stop 

 
 

3.5.32  Zoom To a Stop On the Map     
 
There are three ways to zoom to a stop on the stop list in a route window: 
 
1. Double-click the stop name; 
2. Right mouse click on the stop name and select Zoom to Stop; or 
3. Click the stop name then click the Frame Stop on Map button in the Routes 

toolbar under Stops.  
 
 

NOTE:  If PC*MILER|Streets data is installed and you're trying to find an address, 
you can place your cursor, without clicking, on any road segment on the map to see 
a tooltip containing the street name and address range of that segment.  
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3.5.33  Reversing the Order of Stops   
 
To reverse the order of all stops on the stop list, select the Reverse Stops button in 
the Routes toolbar under Stops.   
 
This option can be useful in combination with the route optimization feature (see 
section 3.10).   
 
For example, you might need to make multiple pickups and you want to start at the 
farthest one on the route and end up at some other location for delivery.  Enter the 
delivery location first, then enter your pickup points.  Next, optimize your route 
keeping the first and last stops the same.  After optimizing, reverse the order of 
stops.  This will put your farthest pickup point first on the list, and your delivery 
point last, with an efficient route in between. 

 

3.6  Running a Route 

 

Mileage, Time and Cost Calculations for a Generated Route 
 
 
For a route to be generated, there must be a valid origin and at least one valid 
destination entered in the active route window.  To generate a route, you can:  
 

• click Run in the active route window;  
• press the F10 key; or 
• select the Routes tab > Run. 

 
Active routing options are listed at the top of the route window, under the route 
name.  See Chapter 10 to change routing options.  
 
PC*MILER off-the-shelf route option defaults are: 
  

• For North America: Practical, Borders Open, Highway Only*, Use Ferry 
Distances, Tolls Discount - US$** 

* Defaults to Streets if PC*MILER|Streets, PC*MILER|Energy and/or TripDirect is installed 
** With PC*MILER|Tolls installed 
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• For All Other Regions:  (PC*MILER|Worldwide and DTOD only) 
Practical, Borders Open, Highway Only*, Use Ferry Distances 
* Except if PC*MILER|Streets is installed for the active region 

 
 
When processing is finished, the route will be drawn and framed on the PC*MILER 
map, and mileage, cost, and time estimates by trip leg will appear to the right of 
each stop on the list.  If an arrival or departure time was entered, the ETA at each 
stop will also be shown.  From left to right, the columns are: 

 
• Time Zone – Displays the time zone for each stop. See section 5.1 on how 

time zones are set and reported.  

• Tolls – (PC*MILER|Tolls required) At each stop, shows toll costs for the 
trip leg from the previous stop, with the total toll cost for the trip at the 
bottom.   

• Cost – At each stop, shows the estimated cost of the trip leg from the 
previous stop, including tolls if PC*MILER|Tolls is installed.  Trip costs 
are calculated by multiplying PC*MILER’s default cost per mile by the 
number of miles. The cost per mile settings can be customized in the 
Application Settings – see section 10.1 and 10.1.7. 

• Stop Duration – (PC*MILER|Streets required) This column is populated 
if a stop duration was entered in the HOS Manager. 

• Drive Time – At each stop, shows the estimated driving time for the trip 
leg from the previous stop.  Cumulative driving time is shown in the bottom 
row. 

• Miles –  At each stop, shows the distance for the trip leg from the previous 
stop.  Cumulative distances for the trip are shown in the bottom row. 

• ETA/ETD – If an arrival or departure time was entered, this column shows 
the departure time at the origin (this time is an estimate if an arrival time 
was entered) and estimated arrival time(s) at each stop. 

 
 

3.6.1  Resizing a Route Window 
 
If the columns are crowded after running a route, try adjusting the column order or 
eliminating columns using the Column Chooser (see section 3.6.4).   
 
You can also float the window and then resize it.  Click the gear button and select 
Float.  Select Dock to return the window to its default position. 
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3.6.2  Warnings in Route Windows 
 
When PC*MILER generates any type of warning regarding a routing issue, a 
message with a red background will appear at the impacted segment of the route. 
Generate a Detailed or Driver’s Report to see more details. 
 
 

 
Warning Message in the Route Window 

 
 

3.6.3  Route Framing on the Map 
 
• To automatically frame each route after it is run, select the Map tab > Frame > 

Auto Frame Routes (this option is turned on by default). 
 
• To frame one route, select the Routes tab > Frame or the Map tab > Frame One 

Route > and select a route. 
   
• To frame all generated routes, select the Map tab > Frame > All Routes.  
 

 
3.6.4  Column Chooser 

 
The columns in any route window can be hidden using the Column Chooser.  Right 
click any stop on the stop list in a route window, then select Column Chooser… in 
the right mouse menu. 
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In the Column Chooser dialog, all available columns are listed and displayed 
columns are checked. (Note that the ETA/ETD column only displays if an arrival 
or departure time has been entered for a route.)  Uncheck any column to hide it.  
 
 
 
 
 
 
 
 
 

      
 
 
 
 
NOTE:  The Column Chooser is also available in reports – right click any column 
header to access it. 
 
 
 

3.6.5  Copy and Paste the Mileage Report 
 
After a route is generated, the results in the route window can be copied and pasted 
into a text editor such as Microsoft Word.  With your cursor inside the route 
window, press Ctrl + C.  Then open the text editor and press Ctrl + V.  The 
example below is in a WordPad file.  The widths of the data columns have been 
adjusted by changing the position of the tabs in those paragraphs. 
 
 

 
Mileage, Time and Cost Data Pasted Into WordPad 

 
 
 
 

Right Mouse Menu Off a Stop Column Chooser Dialog 
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3.7  Working with Multiple Routes and Windows 
You may want to route through different locations while keeping the routes you 
already generated open.  Up to eight route windows can be open simultaneously.   
The active route window will be highlighted. When there are hidden or partially 
hidden routes open, a scroll bar will appear on the right side of the Routes pane.   
  
Each open route will be drawn in a different color in the map window.  Routes are 
identified by name and color in the Route Legend, and their corresponding route 
color appears on the left side of each individual route window. (If the Route legend 
is not visible, select the Map tab > Legends > Route.) 
 
To adjust the layout of windows and reports, use the Windows toolbar on the 
Ribbon.  
 

3.8  Duplicating a Route for Easy Comparison  
To duplicate a route either before or after it is run, select the Routes tab > Duplicate.  
This option makes it easy to compare different route types for the same route. 
 

3.9  Saving and Retrieving Trips 
Routes generated in PC*MILER can be saved for later retrieval, either before or 
after they are generated.  To save a route:  
 
1. Select the Routes tab > Save > Save Route As. 
 
2. In the standard Windows® Save Route dialog, choose the folder where you 

want your route file to be placed, and assign a file name and type to the file.  
There is no limit to the length of a file name. 

 
3. Click Save.     
 
The route type “.r21” will be selected by default.   When you save a file with the 
.r21 extension, route options will be saved together with the route, but saved route 
files do not retain mileage, cost and time information. You will need to rerun 
the route to see this information. 
 
NOTE:  When saved route files from previous PC*MILER versions are opened as 
trips, they are automatically converted to the current version. 
 
IMPORTANT:  The file name you assign when saving a route is different from 
the route name.  To give the route a unique route name, click the gear button > 
Options or Routes tab > Options and make an entry in the Route Name field at the 
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top of the dialog, then click Save.  A route not named in this way will open with 
the default name (“Route 1”, “Route 2”, etc.), which will also be displayed in the 
Route legend on the map and in reports.  
 

 

 
Save Route Dialog 

 
 
To save sets of points in text format for batch processing using 
PC*MILER|BatchPro, select the route type “.in”.  Files saved with the extension 
“.in” do not include any route options.  
  
To open a previously saved .r21 route file: 
 
1. Select the Routes tab > Open. 
 
2. Select your saved file from the File Name drop-down. 
 
3. Click Open.  
  

3.10  Stop Optimization 

PC*MILER can optimize the order of stops in the active route window to minimize 
the total time (when using Practical routing), the total distance (when using Shortest 
routing), total toll distance (when using Toll Discouraged routing), and distance of 
the National Network (when using State + National Network routing).  Optimizing 
stops provides the optimal stop order, keeping the origin the same or, optionally, 
keeping both the origin and destination the same.    
 
TIP: The original stop order cannot be recovered after optimizing, so you may 
want to save or duplicate the original route before optimizing.  
  
To optimize stops on a route: 
 
1. Select the Routes tab > Optimize > Optimize Stops or press Alt+F10 on your 

keyboard to bring up the Optimize Stop Order dialog. 
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Optimize Stop Order Dialog 

 
2. Choose an option: 
 

• Route Through All: Stops will be optimized in any order, with only the 
origin remaining fixed.  The route must have at least three stops. 

• Destination Fixed:  Keeps the origin and destination the same.  The route 
must have at least four stops. 

• Run route after optimizing stops: Automatically generates the route 
when optimization is finished. 

 
3. Click OK. 
 

3.11  Location Radius 
PC*MILER includes a Location Radius search tool to assist with rate determination 
and trip planning.  This tool enables you to find cities and/or postal codes within a 
specified radius around any location.  To search for POIs, including custom places, 
see section 3.12 below on searching from within the route window.  
 
To use the Location Radius feature: 
 
1. Select the Routes tab > Location Radius then follow the steps below. 
 
2. Enter a location in the City field.  The location can be a city/state, postal code, 

latitude/longitude, or custom place.  If PC*MILER|Streets is installed, an 
address can also be entered.   

3. Use the check boxes to select which types of places to include in your search: 
Cities, Postal Codes, or both. 

4. Enter a Radius. 

5. Click Find to search.  The list below will be populated with the search results. 
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Postal Codes Within 10 Miles of Ames, IA 

 
 

Selecting, Saving and Plotting Locations 

Places on the search results list can be added to the active trip as stops, plotted on 
the map, or saved to a text file.  To select locations on the list: 
 
1. Click a location to highlight it. 
 
2. To select multiple places, hold down the Ctrl key then click on additional 

places; OR hold down the Shift key and click a second place on the list, 
everything between the two places will be highlighted.  (To select all places, 
highlight the first place on the list, then hold down the Shift key and highlight 
the last place, scrolling down if necessary.)  

 
3. With your places selected, you can:  
 
 Add them as stops in the active route window – click Add Stops.   

 
 Save them to a text file – click Save.   

 
 Plot them on the map – click Plot Points.  Plotted points will appear as 

small red squares. 
 

 Copy them to the Windows clipboard for pasting into another application 
– highlight your selection and press Ctrl+C on your keyboard. 
 

To clear the search from the picklist and map, click Clear.   
 
NOTE:  The maximum number of matching places that can be displayed after you 
execute the search is 15,000.  In some cases you may need to specify a smaller 
radius to get a complete list of matches.   
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3.12  POI/Custom Place Search (U.S. & Canada only) 
PC*MILER enables you to search for points of interest (POI) and custom places in 
the United States and Canada from a route window, either within a specified radius 
around a location or along a corridor on a route.   
 
Optionally, the search can target specific POI categories and can include a key word 
to look for.  Categories include custom places, truck stops and services, parking 
and rest areas, distribution centers, intermodal ramps, highway exits, airports, 
schools and facilities, hotels/motels, and emergency/medical.  (For more on custom 
places, see section 3.15.  For a complete list of POI icons, see section 11.14.) 
 
 

Searching Within a Radius Around a Location 
 
To search for POIs within a radius of a location, follow these steps: 

 
1. Either enter a location in the route window City field or select a stop on the 

stop list, then select Place of Interest from the stop type drop-down.  If one or 
more stops have been entered and you don’t specify a location for the search 
in the City field, PC*MILER will search around the previous stop 

 
 
 

 
 
 
 
 
 

 
 

 
2. (Optional)  To narrow your search, below the City field enter a word or name 

to search for in the Name field.   For example, you could enter “inn” and all 
POIs with a name that includes “inn” will be found. 

3. In the Search within field, specify a radius.  The default here is 5.0 miles. 

4. (Optional)   In the categories drop-down, uncheck the categories that you 
don’t want to include in the search.  If it’s easier, clear the list of check marks 
by unchecking Show All Categories and then check the ones you want. 
NOTE: “Custom” includes only places that were created using the default 
category; “Custom Place” includes all other custom place categories. 
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4. Click Search.  A pick list of POIs will be created and displayed on the map.*   
 

 
 
 
 
 
 
 
 
 
 
 
 
 
6. To zoom to any POI on the map, highlight it on the pick list.  Click OK or 

double-click to enter the selected POI as a stop.   
 

 
 
 

7. The POI you select will be entered as a stop.  It can be edited, deleted or 
moved on the list like any other stop on the trip.   

 

 
POI Added to the Stop List 

 
 

*  Fuel prices and amenities information is available with a PC*MILER|Streets 
license. 
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Searching for POIs Along a Route 

(PC*MILER|Streets must be installed and “Highway and Streets” must be enabled 
in the Route Options dialog or active route profile.)  To search for POIs along a 
trip leg between two stops, a route must be generated before the search. 

 
1. First enter and run a route. 

2. In the left column, click the plus icon at the place where you want to insert the 
POI. 

3. Select Place of Interest from the stop type drop-down. 

 
 
4. Select along the route from the Search drop-down.  The City, Name and 

Search within fields will be disabled when you select this option. 

 
 

 

5. (Optional)   In the categories drop-down, uncheck the POI categories that you 
don’t want to include in the search.  If it’s easier, clear the list of check marks 
by unchecking Show All Categories and then check the ones you want.  
NOTE: “Custom” includes only places that were created using the default 
category; “Custom Place” includes all other custom place categories. 

 
6. Click Search to create a pick list and see the POIs on the map. To zoom to a 

POI on the map, highlight it on the pick list.  To enter a POI from the pick list 
as a stop, either double-click it or select it and click OK.   
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7. The POI can be edited, deleted or moved on the stop list like any other stop on 
the trip.   

 
 

 
POI Found Along Route and Added to the Stop List 
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3.13  Searching for Fuel Stops and Fuel Prices (U.S. & Canada only) 
(PC*MILER|Streets must be installed and “Highway & Streets” must be enabled 
in the Route Options dialog or active route profile.  An Internet connection is 
required to access updated fuel prices.)   
 
PC*MILER lets you search for fuel stops along a route and provides live retail 
diesel prices where available.  To enable an automatic real-time fuel price feed, this 
option must be turned on in the File menu > Application Settings > Fuel Prices tab. 
By default this setting is enabled with a 60-minute interval, and it can be edited by 
the user. 
 
NOTE:  Fuel prices for stops in Canada are priced in Canadian dollars per liter.  A 
fuel price of $0.00 on the pick list means that current price data is not available.  

 
 

 
Fuel Prices Enabled in the Application Settings Dialog 

 
 
To search for fuel stops and prices, a route must be generated first and you must 
insert a stop above one of the stops on the route.  Follow the steps below:  

 
1. Make sure the Fuel Prices option is checked in the File menu > Application 

Settings > Fuel Prices tab. 

2.   Enter stops and generate a route.   

3. Press the F7 key or right click the stop and choose Insert Stop Above.   

4. Select Fuel Stop from the stop type drop-down. 

5. Enter a Distance from the previous stop.  PC*MILER will search along the 
route from this point until the next stop. 
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6. (Optional)  To narrow the search, in the categories drop-down uncheck any 
categories that you don’t want to include.  If it’s easier, clear the list of check 
marks by unchecking Show All Categories and then check the ones you want. 

 
7. Click Search to create a pick list of fuel stops with fuel prices where 

available.   Amenities at each stop are shown in the pick list where data is 
available, along with the distance from the origin of the trip segment.  Fuel 
stops will be plotted on the map as well.  To zoom to a stop, highlight it on the 
pick list.  To enter a location on the pick list as a stop, highlight it and double-
click or click OK. 

 
NOTE:  Fuel prices won’t be displayed if all the values in the results pick list 
are $0.00. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

Results of a Fuel Stop Search 
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3.14  Hours of Service (HOS) Trip Management (U.S. only) 

NOTE:  PC*MILER|Streets must be licensed and installed to use the HOS 
Manager, and the Highway & Streets option must be selected in the Route Options 
dialog or current route profile.  And though not required, a PC*MILER|Traffic 
license can significantly enhance reported travel times and the timing of applicable 
driver breaks and rest stops. 

 
NOTE Also:  When one or more HOS-enabled routes are open, Drag Route mode 
is not available for any route until the HOS route(s) are closed. 

 
PC*MILER’s HOS Manager provides the option to incorporate the requirements 
of the U.S. Federal Hours of Service (HOS) regulations into route calculations. 
Users can enter the driver’s available remaining hours of service and, optionally, 
expected stop times at each stop along a route.  When the route is generated, the 
HOS Manager will insert rest stops along the route at time intervals that meet the 
HOS requirements.   
 
Stop durations can also be set in the HOS Manager without enabling HOS breaks.  
 
The rest stops that PC*MILER selects can be customized as needed.  When you 
choose to edit a suggested rest stop, PC*MILER will search for alternate rest 
stops/fuel stops, backtracking along the route within a time window of about one 
hour.  This backtracking logic avoids a possible violation of HOS regulations due 
to traffic or other unforeseen conditions that would cause the driver to continue 
moving forward on the route past the time when a rest stop is due. 
 
 

 
Accessing the HOS Manager from the Routes Tab 

 

HOS Manager 
button 
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To generate a route that includes HOS stops, follow the steps below:  
 
1. First enter and run a route with all the route options set the way you want 

them.  (If a route is run using the HOS Manager and then a change is made to 
the route options or route profile, you will need to enter all your HOS options 
again and re-run the route.) 

2. Select the Routes tab > HOS Manager.  
 

 
HOS Manager Window  

 
 

3. In the HOS Manager, check Insert HOS Driver Breaks. 

4. In the HOS Rule Type drop-down, select your company’s schedule – US 
Federal 60/7 Long Haul or US Federal 70/8 Long Haul. 

5. Enter the driver’s driving hours remaining until he/she needs to take a 30-
minute rest break and 10-hour end-of-work-day break in the boxes under 
Available Driving Hours at Origin. 

6. Enter the driver’s duty hours remaining until he/she needs to take a 10-hour 
end-of-work-day break under Available Duty Hours at Origin. 

7. Under Available Cycle Time Duty Hours at Origin, enter the driver’s 
number of on-duty hours remaining until the next 34-hour break must be taken. 

8. (Optional)   Stop durations affect the time estimates used in route calculations.  
This option can be used with or without enabling HOS breaks.  Stop durations 
are reported and counted towards the total trip time in the Detailed and 
Driver’s reports.  In the route window, if an arrival or departure time was 
entered, the ETA/ETD column accounts for stop times but the estimated drive 
time column does not. 
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 Check Include Stop Duration to enable the settings below for each stop:  

 Stop Duration:  Enter a number of hours at each stop in hh.hh format 
(e.g. “1.25” would equal 1 hour and 15 minutes). 

 Status:  Unheck if the duration of the stop is not On Duty time. 

 Loaded/Empty:  Uncheck Loaded if vehicle arrives empty.  

 Type:  Select Pickup, Dropoff, RestStop or FuelStop.   

9. Click Save to generate a route with HOS-compliant breaks inserted. 

 
Stop List in a Route Window with HOS Rest Stops Inserted 

 

10. After processing is finished, the rest stops that PC*MILER inserted into the 
trip will appear on the stop list.  All stops will be numbered in order, with the 
rest stops numbered in light blue circles. 

 
11. Now you have the option to either Accept each inserted stop, or Change it to 

an alternate rest stop.  If you click Accept next to all the inserted stops, the 
route won’t need to be rerun. 

12. Click Change next to any inserted stop to initiate a search for an alternate rest 
stop.  You’ll be given the option to narrow down the search: in the drop-down 
on the left, you can optionally change the stop type from HOS Stop to Fuel 
Stop or Place of Interest; in the drop-down on the right, unchecking one or 
more stop type categories will narrow the search further.   
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13. Click Search to generate a pick list of alternate stops along this route segment.  
The pick list will include columns that show amenities where that data is 
available, the drive time and distance from the origin of the trip, and a fuel 
price where retail price data for diesel fuel is available.  (Fuel prices require an 
active Internet connection.  If a fuel price is listed as $0.00, it is because the 
current price data is not available.)  Note that the drive time to an HOS Stop on 
the pick list is an estimate that may vary slightly from the more accurate times 
that were calculated in the route window for the same stop.  

 
 

 
Pick List of Alternate Rest Stops 

 
NOTE:  To delete the HOS stops:  Open the HOS Manager and uncheck Insert 
HOS Driver Breaks, all HOS stops will be deleted from the trip without affecting 
the original stops. 

 
 

14. To zoom to any rest stop on the map, highlight it on the pick list.  When rest 
stops are displayed after a search, all other POIs will be temporarily hidden.    

 

 
Alternate Rest Stop 

 
15. To choose an alternate stop from the list, select it and click OK.  The new stop 

will be accepted and the trip will re-run automatically.  Click Cancel to either 
start another search or cancel this process and Accept the rest stop supplied by 
the HOS Manager. 
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Amenity Icons That Appear in Pick Lists 
 
The amenity icons that appear in pick lists enable a quick evaluation of the kind of 
services that are available at HOS stops. A description of each icon follows: 
 
 

 
10-hour parking 

 
24-hour parking 

 
ATM 

 
Diesel Exhaust Fluid 

 
Fuel 

 
Hotel 

 
Laundry 

 
Permit Services 

 
Picnic Area 

 
Restaurant 

 
Restrooms 

 
Roadside Assistance 

 
Scale 

 
Showers 

 
Tire Pass 

 
Tire Service 

 
Parking 

 
Repairs 

 
Truck Stop 

 
Showers 
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Summary of HOS Rules Implemented in PC*MILER 
 
The table below summarizes the U.S. government’s Hours of Service regulations 
that have been incorporated into PC*MILER’s HOS functionality: 
 
 

Hours of Service Rules (HOS) for 
Property Carrying Drivers in the U.S. – PC*MILER 31 

11-Hour  
Driving Limit 

May drive a maximum of 11 hours after 10 
consecutive hours off-duty. 

14-Hour  
Duty Limit 

May not drive beyond the 14th 
consecutive hour after coming on duty, 
following 10 consecutive hours off-duty.  
 
Off-duty time does not extend the 14-hour 
period. 

Rest Breaks 

May drive only if 8 hours or less have 
passed since end of driver’s last off-duty or 
sleeper berth period of at least 30 
minutes.  
 
Does not apply to drivers using either of 
the short-haul exceptions in 395.1(e). 
 
[49 CFR 397.5 mandatory “in attendance” 
time may be included in break if no other 
duties performed] 

60/70-Hour  
Duty Limit 
 

May not drive after 60/70 hours on duty in 
7/8 consecutive days. A driver may restart 
a 7/8 consecutive day period after taking 
34 or more consecutive hours off duty.  

 
For a complete summary of Federal HOS regulations go to: 

https://cms.fmcsa.dot.gov/regulations/hours-service/summary-hours- 
service-regulations 

 
For more detailed coverage of HOS rules for drivers, see: 

https://cms.fmcsa.dot.gov/regulations/title49/part/395 
 

  

https://cms.fmcsa.dot.gov/regulations/hours-service/summary-hours-service-regulations
https://cms.fmcsa.dot.gov/regulations/hours-service/summary-hours-service-regulations
https://cms.fmcsa.dot.gov/regulations/title49/part/395


 

 
Chapter 3: Basic Routing   95 

NOTES on Using the HOS Manager 
 
When using the HOS Manager, note the following: 

• PC*MILER may select and insert rest stops that occur along a route up to 
one hour before the HOS requirement would go into effect, to avoid 
violations due to traffic or another unforeseen event.  For example, if a 
driver is scheduled for a stop at 3:00, PC*MILER would in most cases 
favor a stop at 2:10 versus one estimated to occur at 2:50.   

• Remember, the hours that PC*MILER returns for a trip are estimates that 
may not reflect a variety of factors that can influence driving times.  When 
you are manually inserting an HOS stop (either editing a stop returned by 
the HOS Manager, or inserting a stop into a route without using the 
Manager), the drive time that appears on the pick list when “HOS Stop” is 
selected from the stop type list in the route window may vary slightly from 
the time calculated when the trip was run. 

• When changing an HOS rest stop, all POIs other than rest stops will be 
temporarily disabled – i.e. they won’t be visible on the map in the areas 
surrounding the route. 

• If all stops on a route are outside the United States, the HOS Manager will 
be disabled. 

• If you delete an HOS stop, PC*MILER will rerun the route and insert the 
original stop recommendations.  To delete all HOS stops, uncheck Insert 
HOS Driver Breaks in the HOS Manager.  

• When a route is saved that includes rest stops inserted by the HOS 
Manager, the rest stops will be saved but any custom settings in the 
Manager under Available Driving Hours and Available Duty Hours 
won’t be saved along with the route.  In other words, when the saved route 
is open, the HOS stops will be there but if you open the HOS Manager 
you’ll see the default available hours (8, 11 and 14 hours). 

• An arrival or departure time can be added to the trip after HOS rest stops 
have been inserted, the route will rerun automatically. 
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3.15  Custom Places 

3.15.1  Adding Custom Place Names to the Database 
 

PC*MILER gives you the capability to assign your own custom names to locations 
in the PC*MILER database, and optionally to assign them to custom categories.  
Follow the steps below.   
 
1. Select the Tools tab > Add Places; or to pick a location from the PC*MILER 

map, select the Tools tab > Pick Places on Map then click on the desired 
location. 

2. (Optional)  In the Add a Place dialog, click New to create a new category of 
custom places. 

3. (Optional)  Enter a unique Name for this category. 

4. (Optional)  From the drop-down Pin list, choose an icon to represent this category 
on the map.  (If none is chosen, the generic blue circle will be used.) 

 
 

5. (Optional)  Click Save to save the new category. 

6. (Optional)  In the Add a Place dialog, make a selection in the Category drop-
down.  If a category is not selected, the custom place you are creating will be 
in the generic “Custom” category. 

7. In the Add a Place dialog, enter your custom name in the Name field (the same 
name cannot be used more than once).   

8. Enter the PC*MILER location (real name) in the Location and (optionally) 
Address fields.  The location can be in any format that is valid for stop entry.  

9. Click Save to save the new custom place name to the PC*MILER database.   
 
NOTE on Duplicate Names:  Any custom name can only be assigned once.  If the 
name already exists as a custom place in the database, you will see a warning and 
the Save option won’t be available. 
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Saving a Custom Place 

 
 

Once a custom place is saved, you can enter it as a stop on a route: in the route 
window, type the custom name into the City field.   
 
NOTE:  Custom place names are sensitive to spacing – for example, the name 
“01586,GM” is not the same as “01586, GM” (PC*MILER|Worldwide required to enter 
stops in regions other than North America). 

 
 

 
Custom Place Entered as a Stop 

 
 
To view or edit custom places, press F2 or select the Tools tab > Manage (see 
section 3.15.2 below). 
 
To view or edit custom categories:  
 
1. Select the Tools tab > Categories.   
2. Click Edit. 
3. Make your edits to the Name or Pin. 
4. Click Save. 
 

 
 

Editing a Custom Place Category 
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3.15.2  Using the Custom Place Manager 
 

To view, edit or delete custom places, select the Tools tab > Manage.  All custom 
places in the database are listed in the Custom Place Manager.  To sort any column, 
click the column header. 
 

 

 
Custom Place Manager 

(Address data shown above can be entered only if PC*MILER|Streets data is installed) 
 
 
To edit a custom place, click the Edit button for that place in the last column. Make 
the desired changes and click Save to save your edits. 

 

 
Edit a Place Dialog 

 
 

To delete a place, click its Delete button.  To delete all places on the list, click 
Delete All.  A prompt will ask you to confirm if you mean to delete all places.  To 



 

 
Chapter 3: Basic Routing   99 

Export the list of places, see section 3.15.4 below.  To Import custom places, see 
section 3.15.5. 
 
Click the “X” in the upper right corner to close the Custom Place Manager and save 
your edits. 

 
IMPORTANT:  It is strongly suggested that you regularly back up important 
PC*MILER files such as custom places.  See section 12.5 for simple instructions.  
 
 

3.15.3  Creating Custom Latitude/Longitude Points  
 
A custom name can be assigned to a latitude/longitude point in the PC*MILER 
database by using the Add a Place dialog (section 3.15.1 above).  For example, you 
could type “Home Office” in the Name field, and “40n,100w” in the Location 
field.   
 
Note that PC*MILER tracks the latitude and longitude position of your cursor as it 
passes over the PC*MILER map (watch the status bar in the lower left corner of 
the map window). 
 
 

3.15.4  Exporting Custom Places 
 
 

 
Custom Places Exported to a Text File (Column Formatting Adjusted) 

 
 
All custom places listed in the Custom Place Manager can be exported into a tab-
delimited .txt text file.  This feature can be used to import custom places from an 
older version of PC*MILER, see section 3.15.5.   
 
To export custom places from the Custom Place Manager, follow these steps:  
 
1. Select the Tools tab > Manage. 

2. In the Custom Place Manager, click Export.   
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3. In the Export window, select a file type in the Save as type drop-down.  For a 
comma-delimited value file choose “.csv”, or choose “.txt” to save as a 
comma-delimited text file.   

4. Assign a file name. 

5. Select a target location where the export file will be saved.   

6. Click Save to create the export file. 
 
 

3.15.5  Importing Custom Places  
 
NOTE:  See section 3.5.17 for the correct way to format latitude/longitude points.  
See section 3.5.1 for all other stop entry formats that are accepted by the Import 
Custom Place Wizard.   
 
TIP:  Did you know that the Import Custom Place Wizard can be used as a batch 
geocoding tool to clean up the formatting of your data?  If you have a list of 
customer locations that include street addresses and/or other locational information, 
you can import those locations to confirm that they match locations in the 
PC*MILER map database.  (PC*MILER|Streets is required to process address 
data.)  The original input file does not need to include custom place names but does 
have to be correctly formatted – see Step 1 below. 

 
NOTE Also:  Importing a file containing more than 4,000 places may take a long 
time and is not recommended.  Consider dividing a large input file into smaller files 
for importing. 

 
Using the Import Custom Place Wizard, you can import sets of custom places which 
were created in an environment independent of PC*MILER.  During the import 
process, PC*MILER provides the option to 1) enter the whole set of imported 
places as stops on a route, or 2) save the imported places as custom places for future 
use.       
 
The Import Custom Place Wizard first tries to match each record in the input file to 
a place or address range in the database, converting the records to a format that 
PC*MILER can use.  The input file must be a text file with columns delimited by 
a tab or other character such as a comma.  Here are several lines from a sample text 
file of custom places that are suitable for importing: 
 
 

 
Sample Text File, Tab Delimited 
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The import process includes five basic steps, covered on the following pages: 
 
Step 1. Setting Up a Correctly Formatted Input File 
Step 2. Open the Input File in the Wizard 
Step 3. Select and Preview Input 
Step 4. Confirm Matches 
Step 5: Add Places to a Route Window or the Custom Place Manager 

 

STEP 1:  Set Up a Correctly Formatted Input File 
 

The first step is to ensure that your input file is correctly organized and formatted.  
Making the effort to properly organize the input file can make a big difference in 
how efficiently the locations in the file are processed.   
 
The input file must be a text file with columns delimited by a tab or other character 
such as a comma.  If the original file is a text file, try opening it in Excel, formatting 
as necessary, and then saving it again as a tab-delimited .txt file 
 
To successfully add places to the database, at minimum the input file must include 
a location column.   
 
The required location for each place must be either a latitude/longitude, postal code, 
or city and state/province/country abbreviation.  (PC*MILER|Worldwide or DTOD 
Data must be installed for countries outside North America.)  Other location 
information can be included in additional columns.  As you will see in Step 3, you 
can tell PC*MILER to ignore columns in the input file that contain data that can’t 
be imported. 
 
As an example, from left to right your input file might include: 
 

• Place Name – A custom place name (required).  If the file does not 
include place names and you are importing places for the purpose of data 
matching, you can insert a column with any appropriate custom name. 

• Address Line 1 – A location address including a street number and street 
name.  PO Box numbers are not valid input and should be removed.  
(PC*MILER|Streets is required for address data to be accepted.) 

• Address Line 2 – Secondary address information such as suites, floors, 
apartments, units, building names, etc.  These are not accepted by PC*MILER. 

• City – The city name. 

• State/Province – A two-letter state/province/estado abbreviation, the name 
should not be spelled out (e.g. “ON” is correct, “Ontario” won’t be accepted). 
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• ZIP/Postal Code –  
o U.S. addresses can be a ZIP or ZIP+4 Code (use a dash with 

ZIP+4, e.g. 12345-1155).  PC*MILER will only read in the first 
five digits and will ignore the last four. 

o Canadian postal codes should include spaces, do not use dashes 
(e.g. G1A 1B1, the format is ANA<space>NAN where “A” stands 
for “letter” and “N” stands for “number”). 

• Country – Not usually needed, but should be in its own column. 

• Region – (PC*MILER|Worldwide or DTOD Data must be installed)  A region 
is only needed if locations are outside North America.  Region names should 
be spelled out as they appear in the Application Settings dialog > General tab. 

 
Example File: 

 
 Place Name  Address Line 

1 
 Address Line 2  City  State/Province  ZIP/Postal Code  Country 

 Warehouse1  4 Moore Street  First Floor  Princeton  NJ  08540  US 
 
 
STEP 2:  Open the Input File in the Import Custom Place Wizard 

 
1. To begin, select the Tools tab > Import to open the Import Custom Place 

Wizard. 
 
 

 
Import Custom Place Wizard – Initial View 

 
2. In the Wizard, select Tab Delimited if the input file is tab-delimited text 

(recommended).  Otherwise, select Other Delimited and enter a delimiter in 
the box to the right.  This setting tells the Wizard where a new column should 
begin in the input file.  Most commonly, the delimiter is either a tab or a comma. 
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3. Click Browse and navigate to the drive and directory where your data file is 
located.  Be sure to select the correct file type in the drop-down, then select the 
file to be imported and click Open.   

 
 

 
Open Input File Dialog 

 
STEP 3:  Select and Preview Input 

 
Now you’ll see the data from the input file, organized into columns.  Initially, all 
column headers are labeled Skip, meaning PC*MILER will skip over that column 
without importing the data in it.   
 
For each column containing data you want to import, use the drop-down menu at 
the top to assign a new column header; or if the first row of the input file includes 
appropriate headers, check First row contains column headers.   
 
 

 
Import Custom Place Wizard – Select and Preview Input 

(Address data shown above can be imported only if PC*MILER|Streets data is installed) 
 

To successfully import places, there must be at least one location column.  The 
location must be a LatLong (latitude/longitude), PostCode (postal code), and/or 
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City and State (state/province/country abbreviation) with an optional Address.  
Other available headers are: Region (used only with PC*MILER|Worldwide or 
DTOD Data), Description and Category. 
 
TIP:  The “Category” header can be used to assign a map icon of your choosing 
to a set of custom places.  Simply create a custom category (Tools tab > Categories) 
and before importing make sure the category name in your input file exactly 
matches the custom category name. 
 
Each of the headers can be applied to only one column, with the exception of Skip.  
Label a column Skip if the data in it should not be read (e.g. memos or descriptions) 
or if it is blank. 
 
To adjust column widths in the table for better visibility, place your cursor between 
two column headers.  When the cursor changes to an arrow, hold down the left 
mouse button, drag the margin to the desired width, then let go. 
 
The options under Records to Process determine how many and which rows of 
data in the table will become custom places.  Select All to have all the data 
processed, or Selected to process only some of the records.  If you choose Selected, 
enter the range of records to be processed. 
 
With the columns and input selection set, click Next to continue. 

 
TIP:  If you want to import a file that has different types of locations (postal code, 
city and state, and/or latlong) on different rows, and/or different combinations of 
types (such as postal code and state), first use the =citytolatlong() function in 
PC*MILER|Spreadsheets to convert those types consistently to LatLong, then 
import that file specifying a Name column and a LatLong column as the only 
location.  See the PC*MILER|Spreadsheets User’s Guide for instructions on how 
to use the =citytolatlong() function. 
 
 
ADDITIONAL NOTES:  The more information you include, the more certain it 
is that a unique match will be found.  Import Custom Places will import a file that 
has city and state combined into a single column (label this column "City"), or zip 
code, city and state combined into a single column (label this column "Zipcode"). 
A county name may optionally be included at the end of either one. A space should 
separate the ZIP code from the city, a comma should separate the city from the 
state, and a comma should separate the state from the county. For example, any of 
the following are acceptable: 
 

City 
Princeton 
Princeton, NJ 
Princeton, NJ, Mercer 
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ZipCode 
08540 
08540, NJ 
08540 Princeton, NJ 
08540 Princeton, NJ, Mercer 

 
 
STEP 4:  Confirm Matches 

 
When all records have finished processing, the Confirm Matches screen will 
display the processed records along with results data and output options. 
 
 

 
Import Custom Place Wizard – Confirm Matches 

 
 
Results: 
 

• Total Processed: The total number of records processed. 

• Total Matches: The total number of records that were successfully matched 
with a location in the PC*MILER database.   

• Seconds/Records:  The average time spent on processing each record. 

• Time Elapsed: The time elapsed since the start of the record matching 
process. 
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Confidence Level: 
 

There are four possible levels of confidence in the accuracy of the data matching 
that can be returned for each record: 
 
1  Exact – An exact match was made.  For street addresses, trust is 95% or 
greater AND if address is outside the range listed in the database, the top 
match is within 100 address units of input address*; OR for any other match 
level if there are multiple matches they are all within .1 air miles of each 
other.  * For example, “100 Main Street” was input and the best match in the database is 
“150-250 Main Street”. 

2  Fair – Inexact match but unique result (i.e. there is only one match). For 
street addresses, trust is 85% or greater AND if address is outside the range 
listed in the database, the top match is within 500 address units of input 
address*; OR for any other match level if there are multiple matches they are 
all within .5 air miles of each other. 
* For example, “100 Main Street” was input and the best match in the database is “450-550 
Main Street”. 

3  Uncertain – Inexact match and there is more than one match in the 
database.  For street addresses, trust is 50% or greater. 

4  Failed – Match not found. Trust is below 50% for street addresses. 
 
# of Records: 
 

This column displays the total number of records which fall into each of the 
above categories. 

 
% of Records: 
 

This column shows the percentage of all records that fall into each category. 
 

In the Accept column, accepted records will be checked to indicate that they 
were successfully matched with a location in the PC*MILER database with 
either an Exact or Fair confidence level.  Locations that were not accepted will 
have an error message in the Error(s) column that briefly describes the reason 
for the error.  Check marks can be manually entered or deleted in the Accept 
column.   
 
The Conf (Confidence) column shows the confidence level of each record’s 
match (described above).  The Match column displays the record in the 
database that was matched to the input location. 
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STEP 5:  Add Places to a Route Window or the Custom Place Manager 
 
Once the validity of all the Accepted matches has been confirmed, you are ready to 
add the imported places to a route window or the Custom Place Manager.  You only 
need to make a few option selections, described below.  
  

Add Selected Places:  
Choose whether output should be added to the Custom Place Manager (i.e. the 
PC*MILER database) or a Route Entry Window.   Check Accepted to only add 
the accepted names, or All Matched to include all matches except those in the 
“Failed” category.  

Options:  
Here, if you selected to save the imported places to the Custom Place Manager, 
choose whether to automatically overwrite any duplicate custom place names or 
PC*MILER place names that already exist in the database.  If Do not override 
existing place or Prompt for each duplicate is selected, a prompt will pop up 
when a duplicate is detected and processing won’t proceed until there is an 
interaction.  If you are adding the output to a route window, under Add Places to 
Route Window choose whether to open a new route window or add them to the 
currently active window. 
 
When ready, click Add Selected Places to send the output to the target route 
window and/or the Custom Place Manager.  Click Export Results in the upper 
right corner to create a text file containing the confirmed matches.  
 
 

3.15.6  Editing Custom Place Records 
 
To edit or verify a record, highlight it in the Results window and click Edit Selected 
Custom Place in the upper right corner of the Confirm Matches screen.  In the Edit 
Match window, you’ll see all matches that were found in the PC*MILER database 
for that location listed and displayed on a map.  
 

 
Edit Match Window 
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The map in this window is set to “Box Zoom” mode.  To zoom to a match on the 
map, hold and drag a box around it with the left mouse button. 
   
Under the map, the fields on the left show the name and data included in the 
highlighted record.  These fields can be edited.  On the right, all matches are listed 
and the Selected Match field shows the complete record in the PC*MILER 
database for the match that is highlighted on the list. 
 
To search for a wide range of possible matches, you can enter the first few 
characters of a faulty postal code or city/state name and then click Find All 
Matches.  For example, type “085” in the LatLong, Postal Code, or City, State 
field to get a list of all postal codes that begin with “085”.  (Note that if there is an 
address in the Street Address field, you should delete it before performing the 
search for best results.) 
 
Click OK to exit the window and save your edits, or Cancel to cancel the edits. 
 
 

3.15.7  Exporting Results to a Text File 
 
After your custom places have been imported and Accepted matches confirmed 
(Step 5 above), you have the option to export the results to a text file: click Export 
Results in the upper right corner of the Wizard. 
 

 
Results Exported to a Text File (Format Edited) 

 
 

3.15.8  Converting Custom Place Files from a Previous Version 
 
Custom places that were saved in the previous version of PC*MILER can be 
transferred and converted to PC*MILER Version 31.  First you will need to export 
the custom places into a text (.txt) file using the Custom Place Manager in 
PC*MILER 30.  The .txt file you created can then be imported into Version 31 – 
see section 3.15.5 above. 
 
IMPORTANT NOTE:  Don’t try to simply copy your old custom places from the 
previous version to the new version.  PC*MILER won’t recognize the older custom 
places unless you go through the process described above. 
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Least Cost Routing 
 
 
Costing has always been an important use of PC*MILER.  Among ALK customers 
there has been a growing interest in using PC*MILER to help with the trade-off of 
toll costs, costs per mile, and costs per hour in determining a “least cost” route. 

 
In response to the needs of our customers, ALK began to research the relevant 
costing issues using several cost factors (typical miles per gallon, cost per gallon, 
fuel cost per mile, other cost per mile, and labor cost per hour for an 18-wheeler) 
and found that: 

 
• a slower (less “practical”) route is the least-cost route 58% of the time, 

regardless of diesel price, provided the truck can still make its delivery 
window and its pickup window for its next load; 

• if the least-cost route is chosen, there is the potential to save 0.6/% - 0.9% 
in costs, on average1; 

• when diesel prices are high, the least-cost route is more likely to be a 
“shorter” route compared to when diesel prices are low; and 

• the absolute amount of savings from choosing a least-cost route is 
insensitive to diesel price. 

 
Of the 90 origin/destination pairs used in ALK’s study2, the O/D with the largest 
difference in cost, regardless of diesel price, was Chicago, IL to Washington, DC.  
At a fuel price of $2.71/gallon, the savings if the “least cost” route was chosen 
would be $79, or 7.8% 3: 
 
 

Chicago, IL to Washington, DC 

Cost 
Total Tolls Fuel Time Maint 

Prac 697.1 11.60 $1,010 $147 $315 $465 $84 
Prac|Toll 776.8 12.90 $961 $0 $351 $517 $93 
Short 689.9 12.10 $994 $115 $312 $485 $83 
Short|Toll 700.1 13.23 $931 $0 $316 $531 $84 
Least-cost difference 3.0 1.63 -$79 -$147 $1 $66 $0 
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Would a customer in the above scenario actually save $79 in cost if they chose the 
“least cost” route?  That would depend on a lot of factors that are external to the 
route: 

• where the driver is in their hours of service cycle 
• the delivery time window for the truck and driver’s current load 
• the pickup time window for the truck and driver’s next load 
• alternative opportunities to match a different truck and driver to the next 

load (for a dispatcher of company drivers) or to choose a different next 
load (for an owner-operator) 

 
On the basis of all the above findings, ALK has developed a new Least Cost routing 
feature that considers user-specified values for miles per gallon, cost per gallon, 
fuel cost per mile, other costs per mile, labor cost per hour, and stop costs – and 
includes a parameter for a greenhouse gas emission estimate.   
 
Least Cost routing generates a series of alternative routes with distance, time and 
cost estimates, and lets the dispatcher or driver (or an external system, such as a 
truck dispatch optimization system) choose an optimal route, considering factors 
such as those cited above that are external to the route.  If PC*MILER|Tolls is 
installed, toll costs are factored in as well. 
 
______________________________ 
Reference Notes: 
1 - These results are for 48' equipment.  It is expected that the potential savings for 53' equipment will be 

lower, due to fewer opportunities for legal alternative routes. 
2 - The O/D pairs used for the study connect the centers of the 10 largest metro areas in the U.S. 
3 - Sources of “average” data used in the study were default values for drivers paid by the hour, along with 

values from a recent American Transportation Research Institute (ATRI) study (An Analysis of the 
Operational Costs of Trucking), the U.S. Energy Administration, and typical miles per gallon for an 18-
wheeler. 
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4.1  Using Least Cost Routing  
To calculate Least Cost routing, follow the steps below: 

 
1. In a new route window, enter an origin and at least one destination, then run the 

route – click Run or press F10.  If there are any time/cost settings that need to 
be specified, they can be entered in the Application Settings dialog – see section 
10.1.7. 

 
2. Select the Routes tab > Optimize > Least Cost Routing.  A separate window will 

open that displays the possible routes on a map and the calculated totals for each 
route below the map.  The most efficient calculated totals for distance, costs, 
hours and tolls will be highlighted in yellow below the map. 

 

 

 
Least Cost Options Window 

 
 

Internally, PC*MILER calculates six route types for Least Cost routing, but if the 
total cost is the same for two or more of these routes, not all routes will be displayed.  
Route types that PC*MILER calculates for every route are: Practical, Practical - 
Toll Discouraged, Shortest, Shortest - Toll Discouraged, Fastest, and Fastest - Toll 
Discouraged. 
 
Note that setting a governor (maximum) road speed as a Route Option or option in 
a route profile can alter the route calculated using the Fastest route type.  A lower 
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governor speed could result in a shorter route distance and more lower classed roads 
being used (see section 10.1.6 for road classifications). 
 
To hide a route on the map, uncheck it in the Visible column. 

 
To use one of the generated routes, highlight it and click Save Selected Options.  
The calculated totals will appear in the route window, replacing the original route. 
 
Click Print to print the Least Cost route calculations in a Comparison report. 

 
 

 

 
Least Cost Comparison Report 
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Using Time-Based Routing 
 
 
In recent years, ALK Technologies has become aware that a number of our 
customers are interested in considering time of day, day of the week, and time zones 
when calculating and reporting routes, distances, travel times, and toll costs.  Up to 
and including Version 31, PC*MILER default routes, distances, travel times and 
toll costs are calculated based on: 
 

• average road speeds by state/province, urban/rural, and class of road; 
• height, length, width, and weight restrictions that apply during the majority 

of the commonly traveled seasons of the year, days of the week, and times 
of day; 

• seasonal roads being open during shipping and receiving seasons, but not to 
through traffic; 

• and peak-period toll costs for the most recently updated quarter of the 
release year. 

 
These fundamental routing criteria work well for the many purposes of our users, 
and will always be foundational to ALK’s industry-leading PC*MILER products. 
 
The time-based feature enhancements described in this chapter offer more precise 
travel time estimates to those users who are interested.  PC*MILER capabilities 
related to time-based routing allow users to: 
 

• specify a departure or arrival date and time for more realistic transit times; 

• calculate truck-specific toll costs based on the time of day (PC*MILER|Tolls 
must be installed); 

• anticipate time-based road closures and calculate more accurate transit 
times based on industry-leading historical and real-time traffic data (a 
subscription to PC*MILER|Traffic and an Internet connection are required). 

 
Time-based routing can be run with or without the use of traffic data to increase the 
precision of travel time calculations.   
 
When time-based routing is used, ETA/ETD information appears in the route 
window, Detailed Route Report, and Driver’s Report.   
 
 
 
 

5 C
ha

pt
er

 



 

 
 Chapter 5:  Using ETA/ETD and Traffic Data 114 

5.1  Route Generation With ETA/ETD 

 
 
 
 

 
Time-Based Routing Options in the Route Window 

 
 
PC*MILER’s optional time and date settings enable you to generate routing that 
calculates estimated times of arrival (ETA) and departure (ETD) based on user-
specified departure or arrival input. An ETA is calculated for every stop and toll 
plaza on the route. (PC*MILER|Tolls must be installed to access toll information.) 
Follow the steps below to generate time-based routing. 
 
PC*MILER’s optional  time and date settings enable you to generate routing that 
calculates estimated times of arrival (ETA) and departure (ETD) based on user-
specified departure or arrival input.  An ETA is calculated for every stop and toll 
plaza on the route (PC*MILER|Tolls must be installed to access toll information).  Follow the 
steps below to generate time-based routing. 
 
1. (Optional) Select the File menu > Application Settings > Units to select a 

Time Zone and change the Time Format.  The time format is AM/PM by 
default, and the default time zone is Local time (conforms to the time at each 
stop).  The time zone setting affects ETA/ETD reporting but not how travel 
times are calculated.  Click Save to save changes.    

 
 
 
 
 
 
 
 
 
 
 

Optional Arrival/Departure 
and Travel Speed Settings 
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• Local: Reported ETA/ETD will conform to the time zone where each stop 
or toll plaza is located (applies in all world regions).  

• System: ETA/ETD at stops and toll plazas will be reported based on the 
time zone setting on the host computer. 

• Specific: (Available only for North America and Europe regions) Select a 
time zone by region.  Options will reflect the currently active world region.  
ETA/ETD at all stops and toll plazas will be reported using this time zone. 

2. In a route window, click the Arrival/Departure drop-down before or after 
entering stops and select your options:  

 
 

• Arrival/Departure   
Select Depart now for the trip’s time of departure at the origin to be the 
current time, Depart at… to set a departure day/time at the trip’s origin, or 
Arrive by… to set the target arrival time at the trip’s last stop.    

 
• Day/Date   

Select either Specific Date or Day of the Week.  To enter a date, either type 
it in the text box or click the calendar and select a date.  To specify a day of 
the week, click the drop-down list. 

         
 
 
 
 
 
 
 
• Time of Day 

This is the targeted local time at the arrival/departure location.  Type in a 
time (select the hour first, then the minutes, to overwrite) or use the arrows.  
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• Travel Speeds 
If PC*MILER|Traffic is licensed, use this drop-down to apply traffic speeds 
instead of PC*MILER’s average road speeds by road class.  See section 5.2 
below on the effect of Traffic data on route calculations.  See section 10.1.6 
to view or customize PC*MILER average road speeds. 
 

3. Click OK to close the Arrival/Departure drop-down. 
 
4. With two or more stops entered, click Run.  Estimated arrival and departure 

times at all stops on a route will be calculated.  If a target Arrival time was 
entered, the necessary ETD from the origin to meet that target will be shown. 

 
ETA/ETD calculations do not include break times or stop times.  To add stop 
times or Hours of Service rest/break stops to a route, see section 3.14. 

 
 

 
Generated Route with a Target ETA 

 
 

NOTE:  The Arrival/Departure options can also be set in the Route Options dialog 
(see section 10.4). 
 
NOTE Also:  By default, the Arrival/Departure option is set to None and time-
based road restrictions and other special restrictions are not factored into route 
calculations.  To avoid this, be sure to use an Arrival/Departure setting as described 
in the steps below.  See section 5.4 for more on special road restrictions. 
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5.2  Using Traffic Data (U.S. and Canada only) 

NOTE:  A subscription to PC*MILER|Traffic must be purchased to access traffic 
data in PC*MILER, and you must have an Internet connection to use these features. 
 
ETA/ETD estimates can be generated with or without using traffic data, and 
historical traffic data can be applied to time estimates without entering an 
ETA/ETD. Using traffic data will increase the precision of time estimates. 
 
If you choose not to activate traffic data, travel times and ETA’s will be calculated 
based on PC*MILER’s average road speeds by class of road in each state/province.  
(To view or customize these road speeds, select the File menu > Application 
Settings > Road Speeds.)  
 
To enable the use of Traffic data, select a traffic option in the Travel Speeds drop-
down:  Real-time Traffic if Depart Now is selected under Arrival/Departure, or 
Historical Traffic if one of the other Arrival/Departure options are selected 
(including None).  
 
Traffic data is collected by road segment.  With Traffic enabled, travel times and 
ETA’s will be calculated based on historical or real-time traffic data, depending 
on the arrive/depart setting.   
 
“Historical” data reflects how average traffic patterns affect road speeds on the road 
segments used by the generated route.  An “average” pattern is created using a 
historical time slice: 7 days in a week, with each day divided into 15-minute time 
slices.  “Real-time” data is just that: current traffic patterns that are fed into the 
system in real-time. 
 
If Depart now is selected, Real-time traffic data will be used for the first 15 miles 
and Historical data will be used for the remainder of the route.  This is because after 
15 miles of driving, conditions will have changed and they are more likely to 
resemble historical conditions than current conditions.  Other Arrival/Departure 
settings always use Historical data.    
 
The Traffic data feed can be displayed on the map – see Chapter 6. 
 
 

5.2.1  Use Traffic Data By Default 
 
To use traffic data by default, select the Routes tab > Options > Arrival/Departure 
and select the available traffic option under Travel Speeds.  Then save this setting 
to the Default route profile: select the gear button > Save Options as Default Profile.  
Or choose Save Options as New Profile to save a new route profile to use regularly.  
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Saving Route Options to a Route Profile 

 

5.3  ETA/ETD in Reports 
Estimated arrival and departure times at all stops on a route are shown in the 
mileage report in the route window after the route has been generated.  These times 
appear in the ETA/ETD column to the far right.  This column is inactive when an 
arrival or departure day/time has not been entered. 
 
ETA/ETD information also appears in the far right column of the Detailed Route 
Report if a day/time was entered for the route (the report may need to be scrolled 
to the right – see section 9.3 for a detailed description of this report).  This column 
will show the estimated times of arrival at every stop and toll plaza on the route.  If 
a target arrival time was entered, the estimated departure time from the origin will 
be shown.  If a departure time was entered, that time will be shown at the origin. 
 
In the Driver’s Report (see section 9.5), if a route was run using real-time traffic 
data, a Delay column will appear just to the right of the Time column.  The “delay” 
time identifies delays caused by the current traffic conditions on the first 15 miles 
of the trip.   
 

5.4  “Special Restrictions” in Routing and Reports 
Time-based routing integrates road restrictions that are active only during specific 
times.  These restrictions are enabled when you select an arrival or departure time 
for a trip – PC*MILER will route around roads that have time-based restrictions. 
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These special restrictions may include roads that are closed in one or more 
directions; have a temporary closure in one or more directions (construction/natural 
disaster); have a restriction on a particular truck configuration (weight, hazardous 
material) in one or both directions; have a special speed limit in effect;  or have a 
particular lane closed or allowed.  
 
For example, the CO-82 highway from Aspen, CO to Buena Vista, CO is closed in 
winter;  so if an arrival or departure time during the winter season is entered, 
PC*MILER will route around I-82. (Note that the roads the alternate route takes 
may vary depending on whether the Highway Only route option is active in the 
route’s options or profile.  Using local streets in routing generally provides a route 
that is closer to the original one – in this case the spring, summer and fall route.) 
 
Choosing to override Restrictions in the Route Options dialog or a route profile 
will override these time-based restrictions, along with all other restrictions.  Where 
a route travels on a restricted road, warnings will appear in the route window (a red 
circle, hovering over it provides a brief description), and in the Detailed and 
Driver’s reports. 
 
 
The information provided in warnings will be formatted as follows: 

Days of the Week:  SMTWTFS.  Any days during which the restrictions don’t 
apply appear as a dash, e.g. S-T-TFS. 

Hours:  XX:XX AM – XX:XX PM, or XX:XX – XX:XX  if 24 Hours (“military 
time”) is selected in the File menu > Application Settings > Units tab. 

Months: Includes the three-letter abbreviation of all valid months. 
Days:  Date range in every month from X-Y, e.g. 7-10. 
Weeks:  Week range in every month from X-Y, e.g. 1-2. 
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Special Restriction Override Warning in Route Window and Driving Directions – 

Highway CO-82 from Aspen to Buena Vista, Colorado 
 

5.5  Setting Road Speeds 
To change PC*MILER’s default road speeds to more closely conform to actual 
speed estimates for your vehicles, select the File menu > Application Settings > 
Road Speeds.  See section 10.1 on changing application settings. 
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5.6  Setting a Governor Speed 
Using a governor speed limit can help you more accurately calculate ETA’s in 
PC*MILER, publish ETA’s from PC*MILER to customers with more confidence, 
and calculate a more accurate HOS-planned route if desired.  
 
A governor speed limit can be set when you create a route profile, or as an option 
for an individual route (Routes tab > Options > Routing Preferences).  See section 
10.3.2 for a description of this option. 
 

5.7  Time-Based Toll Cost Reporting 
(PC*MILER|Tolls license required) Prior to Version 25, PC*MILER calculated toll 
costs based exclusively on peak hour rates while factoring in vehicle dimension 
settings that affect those rates.  Beginning in Version 25, when an arrival or 
departure time is entered for a route, truck-specific toll costs can be calculated even 
more precisely because time-of-day variations are factored into toll rates when and 
where they occur, including peak and non-peak tolls.   
 
See Chapter 7, Getting Toll Costs, for more on generating routes with toll costs.  
 
NOTE:  Toll costs are always calculated in the local time as the planned route 
crosses the toll booth.  By default, the date/time of the toll collection is also reported 
in that local time.  To change this setting, select the File application menu > 
Application Settings > Units and use the Time Zone option to choose either System 
(your computer’s time) or a specific time zone.  The date/time of the toll collection 
will then be reported in the time zone you specified.  Note that ETA/ETD displayed 
for each stop in a route window will also be affected by this setting change. 
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        Traffic Display 
 
 
A PC*MILER|Traffic license gives users the option to purchase access to real-time 
and historical traffic data for roads throughout the United States and Canada for 
more precise time-based routing, as described in Chapter 5.  This data can also be 
used to display historical, typical or real-time traffic patterns in the PC*MILER 
map window.  (See Chapter 11 for more on using the map window.)  
 
In addition, when Arrival/Departure is set to Depart now in the Routes window, 
PC*MILER|Traffic takes live reports of road closures into account when 
calculating the route. 
 
 

 
Real-Time Traffic Display Showing Level of Congestion –  

Lincoln Tunnel, New York, NY 
 
 
PC*MILER’s traffic display feature lets users instantly visualize traffic data on the 
map in any location throughout the continental United States to help with route 
planning, analysis, and diagnostics.  (A PC*MILER|Traffic license and an active Internet 
connection are required.) 
 
NOTE:  An active Internet connection is required for the display of real-time traffic 
patterns and subsequent updates to historical traffic data.  If you aren’t connected 
to the Internet and request a real-time traffic display, you won’t see any traffic flows 
on the map. 
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6.1  Traffic Display Options 
To display traffic on the map, select the Map tab > Show Traffic or Traffic… in the 
right mouse menu off the map window.  The Traffic Display window can be left 
open and moved around the screen.  
 
 

 
Traffic Display Window 

 
 
To turn on the display, select either Congestion or Speed at the top of the Traffic 
Display window.  Options in this window are: 
 
Show 

Congestion:  Show the amount of congestion relative to Typical (see Time 
options below). 

Speed:  Show absolute traffic speeds.   

Off:  Turn the traffic display off. 
 

Time 
Now:  Display real-time data (Internet connection required). 

Historical:  Display past traffic patterns.  The Historical option displays 
average traffic based on patterns created using a historical time slice: 7 days 
in a week, with each day divided into 15-minute time slices.  The Historical 
display depends on the day and time selected below. 

Typical: This option pertains only to road speeds (not congestion) and 
represents road speeds that are typical when there is no traffic congestion. 



 

 
 Chapter 6:  Traffic Display 124 

Historical Day & Time 
Using the radio buttons and slider bar or arrows, indicate a day of the week 
and time of day for the display of historical data.   

 

6.2  Traffic Display on the Map 
 

 
Historical Display for Tuesday 7:30 AM – Lincoln Tunnel, New York, NY  

 
 
With Traffic licensed and enabled (Map tab > Show Traffic), traffic patterns are 
drawn on the map at zoom levels 6-20.  Traffic does not appear at zoom levels less 
than 6.   
 
The Traffic legend shown on the map will correspond to the setting in the Traffic 
Display window.  In the example above, Historical Congestion patterns are drawn 
and the Traffic Congestion legend shows the colors used.   
 
Real-time traffic displays these legends:  
 
 

                         
Traffic Legends – Real-time Display  
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Historical traffic legends display the day of the week and time setting: 
 

          
Traffic Legends – Historical Display 

 
 

In the Road Speeds legend, speeds are in miles per hour by default.  This setting 
can be changed to kilometers – go to the File menu > Application Settings > Units 
tab. 
 
 
NOTE:  If you are working with a real-time display, it may take anywhere from a 
few seconds to a minute or so for the display to update, depending on the speed of 
your Internet connection and when updated traffic information becomes available. 
 
 



 

 
Chapter 7: Getting Toll Costs 126 

 
 

Getting Toll Costs 
 
 

If ALK’s PC*MILER|Tolls add-on module was purchased with PC*MILER, you 
can generate accurate, up-to-date toll costs for U.S. and Canadian lanes with these 
costs integrated directly into the routing database and reported turn-by-turn per trip.  
Toll costs appear in the Detailed Route Report, State/Country Distance Report, and 
Comparison Report, and tolls can be reported in the currency of choice – either U.S. 
or Canadian dollars – using the current conversion rate. 
 
Accurate toll cost calculations can optimize productivity in multiple departments 
of your organization by assisting in the routing, rating, and reconciliation processes. 
Now you can determine whether it’s more cost-effective to take a toll route, or a 
non-toll route with a few additional miles, before routing a vehicle.  
 
PC*MILER|Tolls generates truck-specific toll costs for toll roads, bridges, tunnels, 
and border crossings for U.S. and Canadian toll authorities.  The data that 
PC*MILER|Tolls provides includes: 
 
• Both cash and discount toll program transactions.  Rates for toll discount 

programs throughout the U.S. and Canada (states in which each program 
apply are listed below). 

• Toll rates for light, medium and heavy duty vehicles.   
• Range (ticket) and barrier (coin drop) data in addition to two-way tolls, one-

way tolls, and tolls that vary by direction.  
• Toll data updates to ensure accuracy when calculating toll costs throughout 

the year.  (PC*MILER|Tolls users receive notification by email when updates 
are available, or may use Check for Updates in the Help tab to ensure they 
have the most current data.) 

• Time-of-day variations factored into truck-specific toll rates when and where 
they occur, including peak and non-peak tolls, if time-based routing is active 
in the route window.  (See Chapter 5 for a detailed description of how to use 
time-based routing.) 

• Future expected changes to toll rates included as available. 
 
GENERAL NOTES on TOLL RATES: Unless vehicle dimension settings are 
customized in the Route Options dialog or using a route profile, PC*MILER|Tolls 
calculates toll costs for an 80,000 pound, 5-axle vehicle.  Reported toll amounts are 
accurate and up-to-date, but not always exact due to several factors: first, several – 
though not many – toll roads have rates that are based on weight (for example, the 
Detroit-Windsor Tunnel charges a set rate per 100 lbs. gross weight in both 
directions); second, some toll charges (in various states) are time-of-day driven, 
and in this case, tolls will be calculated using the highest (peak) rate unless 
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PC*MILER’s time-based routing is used; and third, future and proposed toll rates 
are incorporated into the database where appropriate and these rate changes may 
occasionally be cancelled at the last minute. 
 
Also note the following:  if the user does not specify a departure/arrival date, the 
computer’s system date is used as the date of departure to determine the effective 
toll rates for the trip (which include any rate changes that become effective during 
the trip).  However, this is not true for the time of day.  If the user does not specify 
a time of departure/arrival, the base rate for the date (i.e. highest rate) is used 
without reference to the system time. 

 

States/Provinces Where Each Discount Program Applies: 
 

SPECIAL NOTE:  The “EZPass-MA”, “EZPass-NJ”, or “EZPass-WV” options apply to 
those who purchased the EZPass service in Massachusetts, New Jersey, or West Virginia.  
The “EZPass” option must also be selected along with any or all of the above for the 
discount to be calculated.  Those who purchased the EZPass service outside 
Massachusetts, New Jersey, or West Virginia should choose the “EZPass” option when 
calculating toll costs. 
 

 
Discount Program Valid In  Discount Program Valid In 
407 ETR Transponder ON Canada  I-Pass IL 
A25 Transponder QC Canada  K-Tag KS 
A30 EXPRESS 
Transponder QC Canada  Laredo Trade Tag TX 

BreezeBy OR  LeeWay FL 
Cruise Card GA  MACPASS NS Canada 
Downbeach Express 
Pass NJ  NC Quick Pass NC 

E-Pass TX  NEXPRESS TOLL MI 
ON Canada 

E-Pass Canada NS Canada  Palmetto Pass 
(PAL PASS) SC 

ExpressPass NY, ON Canada  Peach Pass GA 
EXpressToll CO  PikePass OK 
EZ Tag TX  Quickpass BC Canada 

EZPass 
DE, IL, IN, ME, MD, 
MA, NH, NJ, NY, NC, 
OH, PA, RI, VA, WV 

 
RiverLink IN, KY 

EZPass-MA MA  StraitPASS PEI Canada 
EZPass-NJ NJ, MA  SunPass FL 
EZPass-WV WV  TollTag LA, TX 
FasTrak CA  TReO BC Canada 
GeauxPass LA  TxTag TX 
Good To Go WA  Wabash Pass IN 
GO-PASS CO    
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The following discount programs have been discontinued in the database: 
 

Discontinued 
Program State Versions 

Available 
Version 

Discontinued Reason 

C-Pass FL 24-28 29 Adopted SunPass 
FAST LANE MA  

and all 
EZPass 
facilities 

21-28 29 Only EZPass is used 
now 

Smart Tag VA 21-28 29 Only EZPass is used 
now 

NEXUS NY, ON 27 28 Discontinued 
I-Zoom IN 21-26 27 Replaced by EZPass 
B-Pass NB 17-25 26 Toll discontinued 
M-Tag MD 17-23 24 Replaced by EZPass 
NH Tokens NH 17-18 19 Replaced by EZPass 
O-Pass FL 21-23 24 Absorbed into SunPass 
Ready Toll OH 17-18 19 There is no discount 

associated with this 
program, it’s simply a 
“debit card” used to pay 
tolls 

Transpass ME 17-23 24 Replaced by EZPass 
 
 
SPECIAL NOTE:  Toll costs on the New York State Thruway for “5-axle 48' 
Trailer” and “5-axle 53' Trailer” vehicles are accurately reported.  The N.Y. 
Thruway lists separate toll rates for these vehicle types and PC*MILER|Tolls has 
been calibrated to report the correct rate depending on the routing option selected.  
If the Vehicle Dimension length is set to 53' in the active route profile or as a route 
option, the corresponding 5-axle 53' Trailer toll cost will be reported. 
 
NOTE Also:  Some toll exits in the U.S. and Canada have recently become 
“electronic only” (cashless). The way to pay for these tolls is either by electronic 
toll payment method or Pay By Mail.  Pay By Mail is for those who don’t have the 
electronic discount program – their license plates get photographed and a bill is 
mailed to the owner.  Commonly referred to as “video tolling” or “video billing”, 
the rates for this payment method are higher to cover processing costs. 
 
See Appendix G for a list of electronic-only toll roads. 
 
All Pay By Mail and video toll rates are considered as “Cash” in PC*MILER toll 
rate calculations. 
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7.1  Turning On Toll Cost Calculation (U.S. and Canada only)  
(PC*MILER|Tolls must be licensed and installed.)  Toll costs can be calculated 
along with mileage, cost and time estimates when you generate a PC*MILER route 
with at least an origin and a destination using any available route type or option, 
including Hub routing.   
 
To turn on toll cost reporting for the current route, select the Routes tab > Options 
> Reporting Preferences and make sure the Show Toll Costs in Reports option 
is checked; or for multiple routes, make sure this option is enabled in a route profile 
(see section 10.2).  This option is turned on by default when PC*MILER|Tolls is 
installed. 
 
To turn off the use of discount programs in toll calculations or to exclude reporting 
tolls related to individual discount programs, go to the File menu > Application 
Settings > Tolls. Click Deselect All to turn off discount programs, or uncheck the 
ones that you don’t want applied, then click Save. 
 
 

 
Application Settings Dialog, Tolls Tab 

 
   
To switch to Canadian dollars as the currency for toll calculations, use the 
Currency drop-down list.  The US Dollar/Canadian Dollar conversion rate can be 
customized by typing over the default rate.   
 
NOTE:  Settings in the Tolls tab not only affect PC*MILER, but also determine 
which discount programs will be in effect with the use of PC*MILER|Connect, 
PC*MILER|Spreadsheets, or PC*MILER|BatchPro to calculate tolls.  
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When toll calculations are enabled, you’ll see a Tolls column in the route window.  
Toll fees are listed for each leg (not cumulative).  For total cumulative toll costs, 
run a State Summary Report or Comparison Report (see sections 9.4 and 9.7). 
 
 
 
 
 

 
Toll Calculation by Trip Leg in the Route Window 

 
 
The default Tolls settings are: 
 

• Toll calculation is enabled. 
• Discount programs are applied. 
• All discount programs are selected. 
• Tolls are calculated in US Dollars. 
• The Version 31 default conversion rate is USD/CAD = $1.00/$1.334 
 
 
 
 
 
 

Tolls Column 

Discount Status and Currency 
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7.2  Customizing Toll Costs By Weight and Axle  
Jurisdictions in the U.S. and Canada that have toll roads class their toll rates either 
by vehicle weight or by a vehicle’s number of axles. Setting custom Vehicle 
Dimensions route options in PC*MILER enables toll cost reporting based on 
vehicle weight and number of axles.   
 
The available toll rates by axle are from 2 (two axle dual rear wheel vehicles only) 
up to 14 axles, including multi-trailer rates and automobile routing.  For toll rates 
categorized by weight, each toll road authority publishes its own definition of 
weight classes, and PC*MILER categorizes and reports these toll rates based on the 
published weight category and range provided. 
 
For those who are new to the arena of toll cost reporting, the jurisdictions that 
charge toll costs by weight and those that charge by axle are identified below.    This 
information is important to know if you intend to use PC*MILER to generate toll 
costs that are customized by weight and axle. 

• Jurisdictions Charging Tolls by Vehicle Weight:  MI, NJ, ON, PA 

• Jurisdictions Charging Tolls by Axle: AK, AL, BC, CA, CO, DE, FL, 
GA, IL, IN, KS, LA, MA, MD, ME, MI, MN, MO, NB, NC, NE, NH, 
NJ, NS, NY, OH, OK, OR, PA, PEI, QC, RI, SC, TX, UT,  VA, VT, WA, 
and WV 

 
To enter the weight and/or number of axles for a vehicle either before or after stops 
have been entered for a route, select the Routes tab > Options > Vehicle 
Dimensions tab. Alternatively, a route profile can be created or edited with the 
options described below – see section 10.2.  
 
 

 
Route Options Dialog, Vehicle Dimensions Tab 
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Only the weight, axle number and multiple trailer settings in this tab affect toll cost 
reporting.  Enter these parameters as follows: 
 
Weight   
For all regions and truck types, weights of 1500 – 156,748 lbs. or 681 – 71,099 kgs. 
may be entered.  See section 10.5.2 for more on vehicle weight.  The default weight 
setting for all regions is 80,000 lbs. 
 
Axles   
Select a number from the drop-down.  The default is 5 axles.  Note that 2 axle 
includes two axle dual rear wheel vehicles only. 
 
Multiple Trailer (MT) 
Check this option if the vehicle is a long combination vehicle with multiple trailers. 
(See Important Note below.) 

 
IMPORTANT NOTE:  Twin trailers with 7 or more axles are not allowed on the 
Massachusetts Turnpike east of Exit 14. If you enter 7 or more axles and check 
“Multiple Trailer (MT)”, PC*MILER will return a $0 toll rate for that section of 
roadway without a warning. 
 
When done, click Save to apply vehicle dimension edits and then generate your 
route.  PC*MILER will calculate the appropriate route and report the corresponding 
toll costs according to the vehicle dimensions you set.    
 
If custom information is not entered in the Vehicle Dimensions tab, the default 
values will be used.  The default values are based on a typical Class 8 vehicle with 
a weight of 80,000 lbs./36,287 kg. and 5 axles. 
 

7.3  Time-Based Toll Cost Reporting 
Prior to Version 25, PC*MILER calculated toll costs based exclusively on peak 
hour rates while factoring in vehicle dimension settings that affect those rates.  
Beginning in Version 25, when an arrival or departure time is entered for a route, 
truck-specific toll costs can be calculated even more precisely because time-of-day 
variations are factored into toll rates when and where they occur, including peak 
and non-peak tolls.   
 
See Chapter 5, Using ETA/ETD and Traffic Data, for more on generating time-
based routing.  
 
NOTE:  Toll costs are always calculated in the local time as the planned route 
crosses the toll booth.  By default, the date/time of the toll collection is also reported 
in that local time.  To change this setting, select the File application menu > 
Application Settings > Units and use the Time Zone option to choose either System 
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(your computer’s time) or a specific time zone.  The date/time of the toll collection 
will then be reported in the time zone you specified.  Note that ETA/ETD displayed 
for each stop in a route window will also be affected by this setting change. 

 
 

7.4  Tolls and Plaza Names in the Detailed Route Report 
Toll costs are shown by trip leg in the Detailed Route Report.  To generate this 
report, select the Routes tab > Reports > Detailed Report or press F5 on your 
keyboard.  For more on this report, see section 9.3. 

 
To assist users in toll cost reconciliation, toll plaza names have been added to the 
database.  Some plazas listed in this report have multiple sub-plazas at the same 
location, but PC*MILER assigns one name to all of them.   
 
Abbreviated plaza names appear in the Detailed Route Report in a “Toll Plaza” 
column.  If the Toll Plaza column is blank, either the agency does not have a 
transponder program or the agency has a transponder program but the toll plaza 
abbreviations used on that agency’s invoices could not be determined at this time. 
 
The format of the plaza names is as follows: the agency abbreviation, the entry 
plaza abbreviation, and the exit abbreviation.  In cases where the entry and exit 
plazas are the same (barrier toll), the plaza abbreviation will be shown only once. 
 
NOTE:  If a Toll Discouraged route is run with toll calculation disabled and the 
route needs to use a toll road, the Detailed Route Report will still report toll miles 
and the associated cost for that leg of the trip. 

 

 
 

 
Detailed Route Report 

 

Toll Costs by Trip Leg 
and Toll Plaza 
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7.5  Toll Information in the State/Country Distance Report 
The PC*MILER State/Country Report shows total toll costs at each stop, by state, 
and by trip if any tolls were calculated.  To generate this report, first run a trip, then 
press the F6 key or select the Routes tab > Reports > State/Country. 
 
To have this report include a breakdown of toll costs by the type of discount 
program applied, go to the File menu > Application Settings > Tolls and check 
Show Cash and Discount Program Breakdown, then click Save.  This can be 
done before or after the Report is generated. Discount program information will 
appear in the state/country summary section at the bottom of the report, in the Tolls 
column as shown below. 
 
 
 

 
 

State/Country Report – 
Display of Toll Costs and Discount Program Information 

 
 
 
 
 
 
 
 
 
 
 

State/Country Report Showing Toll Discount Breakdown (Print Preview) 
 
 
 

NOTE:  If a Toll Discouraged route is run with toll reporting disabled in the Route 
Options dialog or the active route profile and the route needs to use a toll road, the 
State/Country Report will still report toll miles and the associated cost for that leg 
of the trip. 
 
 
 

Leg Tolls and Toll 
Total at Each Stop 

Toll Amounts 
by State/Country 

Discount Information – 
Must be enabled in 

Application Settings > Tolls  

Toll Total 
for the Trip 
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7.6  Getting Toll Totals in the Comparison Report  
The PC*MILER Comparison Report calculates total toll amounts, along with 
mileage and estimated time and cost, for two or more trips.  To generate this report, 
click the Comparison button on the toolbar or press F4 on your keyboard.    
 
The two routes shown below in a sample report are identical except that the Toll 
Roads Discouraged route option was turned on for the bottom route (see section 
10.3.2 or 10.4). 
 
 
 
 
 
 

 

 
Comparing Toll Costs in the Comparison Report 

Toll Total for 
Each Trip 
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Weather Information & Alerts 
 
 
NOTE:  This feature requires a purchased license for PC*MILER|Weather and an 
Internet connection, and is only available in the PC*MILER user interface.  If 
PC*MILER is integrated with other systems, access to Weather features is 
available with an ALK Maps license. 
 
With an installation of PC*MILER|Weather, PC*MILER users can visualize 
predicted weather patterns across the U.S. and Canada on the map through the use 
of radar, precipitation, and general alert layers.  Additionally, a Weather Alerts 
Report is available that summarizes predicted weather alerts for a route.* This 
feature enables users to identify where a planned route is scheduled to pass through 
a predicted weather alert zone. What’s more, actual road surface conditions can be 
displayed as a map overlay. Weather data is provided by Environment Canada 
(EC), U.S. National Weather Services (NWS) with data from the U.S. National 
Oceanic and Atmospheric Administration (NOAA), and AerisWeather. 
 
* IMPORTANT:  The predicted weather information provided should not be 
construed to mean that significant and/or hazardous conditions will occur, it 
should only serve as a notice that the event described is possible. 
 
Weather alerts and weather patterns on the map reflect current conditions, which 
are updated every 30 minutes or less.  Therefore, conditions that trigger an alert at 
the time a planned route is generated may not trigger that alert if the route is run 
again at a later time. 
 
Weather reporting is enabled by default if PC*MILER|Weather is licensed and 
installed.  To enable/disable weather reporting, select the File menu > Application 
Settings > Weather and check/uncheck Enable Weather.    

 
 

 
PC*MILER|Weather Features Enabled 
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You will see the Current Status of the connection to the weather feed and the date 
and time when the data was Last Updated below the Enable Weather check box.   
Weather data is refreshed each time the PC*MILER application is started, and then 
at 30-minute intervals or less until the application is closed.  
 
If the Weather data feed is offline for any reason, the Current Status will show an 
error message. 
 
Under Select Weather Alerts Categories, any weather alert categories that you 
don’t want to receive alerts for or see on the map can be disabled.  Uncheck an alert 
category to disable it. 
 

8.1  Weather Display on the Map 
To display weather data on the map, select the Map tab > Weather > and check one 
or more options (Radar Layer, Cloud Layer, Road Conditions Layer, or 
Weather Alerts).  You will immediately see the type(s) of data you selected being 
drawn on the map. 

 
• Radar Layer: Displays current precipitation events using a gradation of 

colors that indicate rain and snow.  This data does not contribute to the 
generation of alerts, it is a visual aid only. 

• Cloud Layer: Displays current patterns of precipitation (cloud formations) as 
they are received from AerisWeather.  This data does not contribute to the 
generation of alerts, it is a visual aid only. 

• Road Conditions Layer: Displays current road conditions as well as road 
conditions up to 24 hours in advance. Road conditions are informational only 
and are not used in route calculation. 

• Weather Alerts: Displays colored polygons showing areas where a predicted 
weather alert has been issued by the U.S. National Weather Service or 
Environment Canada.   

 

 
Weather Menu, Map Toolbar 
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8.2  Alerts Legend & Tooltips on the Map 
To see an Alerts legend on the map, select the Map tab > Legends and check Weather 
Alerts.  To see a descriptive tooltip for an alert zone, place your cursor over a colored 
polygon on the map.   
 
For the types of conditions included in each alert category, see Appendix J. 

 
 
 
 
 
 
 

 
 
 
 
 

 
 
 

Turning on the Alerts Map Legend 

Tooltip for an Alert Area on the Map 

Radar Layer Enabled 
(Weather patterns provided by Aeris Weather) 

 

Cloud and Radar Layers Enabled 
(Precipitation patterns provided by Aeris Weather) 
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8.3  Weather Alerts on Planned Routes 
For weather alerts to be generated in the route window when you run a route, there 
are three requirements: 
 

• Your PC must have an active Internet connection; 

• The Enable Weather option must be turned on in the Application Settings 
dialog, or the Enable Weather Analysis option must be turned on in the 
Route Options dialog (see section 10.4); and 

• An Arrival/Departure time must be set for the trip (see section 5.1).  
 
When alerts are enabled as described above, a warning will appear on the stop list 
in the route window for any leg of the trip that travels through an active alert zone.  
Be aware that, because alerts are time sensitive and this feature requires you to set 
an arrival/departure time, an alert that appears on the map when a route is run may 
have expired by the time the destination is reached. 
 
 

 

 
Weather Warning on a Route Affected Area on the Map 

 

8.4  Weather Reports 
Three ways to generate a Weather Report: 
 

• Select the Routes tab > Reports > Weather. 
• Click “View Report” in the route window when an alert is displayed. 
• (Print only)  Select the File menu > Print Report > Weather.  

 
Weather reports provide detailed descriptions of all alerts generated along the route. 
For each alert, this report includes from left to right: the route leg, alert type, 
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calculated entry and exit time into/out of the affected area, effective time, expiration 
time, and the certainty, severity, and urgency ratings.  
 
Double-click an alert in a report to zoom to that area on the map.  Remember that 
the alerts in the report may not include all areas on the map where weather warnings 
(shaded polygons) are in effect along the route.  This is because the alert shown on 
the map may have expired by the time the planned route is due to travel through it.  
As shown in the report, each alert has a time window and expiration time. 
 

 
 
 
 

 
 
 

 
Accessing a Weather Report and Alert Zone on the Map 

 
 

Click “View Report” 

Double-click an Alert 
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8.5  Display of Road Surface Conditions 
(A license for PC*MILER|Weather is required.) The Road Conditions overlay can 
display current road conditions as well as road conditions up to 24 hours in advance, 
to gauge potential impacts on the route plan. It is both predictive and real-time. 
Road conditions are designated as dry, wet, water/snow and ice/snow. 
 
NOTE:  Road condition information is only available online, and requires an active 
internet connection. Road conditions are informational only and are not used in 
route calculation. 
 
 
 
 
 
 

 
 
 
 
 
 
 

Road Conditions layer 
can be accessed  

from here… 

…or from here 
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Generating Reports 
 

In addition to the mileage, time and cost information that is returned when a route 
is run, there are several additional route reports that PC*MILER can generate:  
Mileage, Detailed Route, State/Country, Driver’s, Road Type, and Comparison.  If 
PC*MILER|Weather is installed, a Weather Report is also available.   
 

9.1  Report Windows 
When a report is generated, it opens in a separate pane.  You can control the location 
of reports within the PC*MILER application window using the Report Location 
and Layouts buttons in the Window tab.  
 
  
 
 
 
To float an individual report in its own window, right click the report title in the tab 
at the top of the report, then select “Float”.  To dock it, right click the report title 
again and select “Dock”. 

 

 
Display Options for a Report Window 

 

9.2  Mileage Report 

When a route is run, mileage, time and cost information is returned in the route 
entry window.  A Mileage Report can be printed that summarizes this information 
and also includes cumulative miles by trip leg and greenhouse gas estimates.  Select 
the File menu > Print Report > Mileage.   
 
This report won’t appear on-screen, printing it is the only way to generate it.   
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9.3  Detailed Route Report 

Four ways to generate a Detailed Route Report after running a route are: 
 

• Select the route window gear button > Reports > Detailed. 
• Select the Routes tab > Reports > Detailed. 
• Press the F5 key. 
• (Print only) Select File menu > Print Report > Detailed. 

 
 

 
Detailed Route Report 

 
 
This report includes direction of travel, roads, interchanges, times and distances, 
stops, and toll costs (if PC*MILER|Tolls is installed and toll calculation is turned 
on).  The report displays additional information depending on the options selected 
when the route was run.    

TIP:  You can double-click a line in this report to zoom into that route segment on 
the map. 
 
The columns from left to right in the Detailed Route Report give you the following 
information for each route segment: state/country, toll or free road, direction of 
travel, route (with exit number where available), distance, driving time, interchange 
point, cumulative distance and time for the trip leg, and cumulative distance and 
time for the whole trip.  For each stop on the route, the on-duty status and duration 
is shown. (The default for these values is on-duty and 0 hours.  Stop times and on-
duty status can be set in the HOS Manager, see section 3.14.) 
  
If PC*MILER|Tolls is installed and toll calculations are enabled, leg toll costs and 
the corresponding toll plazas will be shown in two columns on the far right.  
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NOTE:  Due to the way PC*MILER identifies locations and calculates routes and 
distances, occasionally a toll barrier won’t be reported in the Detailed Route Report.  
When this happens anywhere on a route, an alert will appear at the very bottom of 
the report stating that this has occurred.  You can then check all route segments 
marked with a dollar sign to find the omission. 
 
If ETA/ETD information was entered, there will be an additional Stop Time 
column to the far right.  This column shows the estimated time of arrival at every 
stop and toll plaza on the route.  If a target arrival time was entered, the estimated 
departure time from the origin will be shown.  If a departure time was entered, that 
time will be shown at the origin.  The column header for the Stop Time column will 
reflect the currently selected time zone   (to set the time zone, go to the File 
application menu > Application Settings > Units).    
 
A dollar sign ( $ ) to the left of the directional column marks segments that are toll 
roads.  Alerts such as height, weight, 53-Foot restrictions, and geofence warnings 
are noted where they exist, appearing before the pertinent road segment in the 
report.  (See section 1.6.4 for more on 53-Foot restrictions in reports.)   
 
At the point where a route begins to use a road segment that travels through a 
geofenced area, a warning like this will appear that includes the name of the road, 
the name of the geofence set, and the name of the individual geofence: 
 
Warning * US-1 * : New Jersey : NewBrunswickNJ  

 
If one of the Hazardous Material route types was used (PC*MILER|Hazmat 
installation is required), the Detailed Route Report will include a Restriction 
column on the far right.  Any restricted road segments on the route will be labeled 
with the appropriate hazmat restriction type in this column.  PC*MILER uses these 
route segments in its calculations only if no other alternative is possible, or the 
alternative is extremely impractical.  Routes designated as preferred for hazardous 
materials will not be indicated in the report. 
 
 

 
Detailed Route Report With Hazmat Restriction Column 

  

Hazmat Restriction Column 
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In general, when warnings for restrictions are generated in reports, they appear in 
red lettering at the point where the restriction is encountered.  For example, the 
following Detailed Report shows restrictions relating to 53 foot trailers in this route 
from San Francisco to Sausalito: 
 

 
Detailed Route Report With Warnings 

 

9.4  State/Country Report 
Four ways to generate a State/Country Report after running a route are: 
 

• Route window gear button > Reports > State/Country 
• Routes tab > Reports > State/Country 
• Press the F6 key 
• (Print only) File menu > Print Report > State/Country 

 

 
State/Country Report with Toll Information (Print Preview) 

(PC*MILER|Tolls installation required for toll cost calculation) 

53' Not Designated Warnings 

Toll Costs & Applied Discounts 
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The State/Country Report generates a table that summarizes mileage by state, 
province, or country traveled.  It lists leg and total miles, cost, and time estimates 
in columns from left to right.  Leg and total toll costs will also be shown if 
PC*MILER|Tolls is installed and toll calculation is turned on.  The last two 
columns show leg and cumulative greenhouse gas estimates in pounds or kilograms 
of carbon dioxide equivalent per gallon/liter of fuel.  A breakdown of the route by 
state/country and category is at the bottom of the report.   
 
If PC*MILER|Tolls is installed and toll calculation is turned on, a breakdown of 
toll costs by the type of discount program applied is also available.  Go to the File 
menu > Application Settings > Tolls and check Show Cash and Discount 
Program Breakdown, then click Save.  You’ll see the discount breakdown in the 
Toll($) column in the summary section. 
 
 

9.4.1  Order of States in the State/Country Report 
 

In the State/Country Report, states and countries are displayed in alphabetical order 
by default.  To display them in the order they occur along the route as in a driver 
log, go to the File menu > Application Settings > Report and choose Route under 
State/Country Report Order.   
 

 
 

9.5  Driver’s Report (Driving Instructions)    
Three ways to generate a Driver’s Report after running a route are: 
 

• Route window gear button > Reports > Driver’s 
• Select the Routes tab > Reports > Driver’s 
• (Print only) File menu > Print Report > Driver’s 

 
The Driver’s Report provides easy-to-read detailed driving instructions with turn 
directions and distance between turns, and driving times that include the duration 
of each stop if durations were defined.  This report includes all alerts that appear in 
the Detailed Route Report. 
 
If the route was run using real-time traffic data and the departure time for the trip 
is within 15 minutes of the current time, the Delay column just to the right of the 
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Time column identifies delays caused by the current traffic conditions on the first 
15 miles of the trip.  
 

 
Driver’s Report (Print Preview) 

 
 
As with other reports, when warnings for restrictions are generated, they appear in 
red lettering at the point where the restriction is encountered.  For example, the 
following Driver’s Report shows restrictions relating to 53 foot trailers in New 
York City: 
 
 

 
Driver’s Report (Print Preview) 
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9.6  Road Type Report 

Three ways to generate a Road Type Report after running a route are: 
 

• Route window gear button > Reports > Road Type 
• Routes tab > Reports > Road Type 
• (Print only)  File menu > Print Report > Road Type 

 
The Road Type report provides a distance breakdown by PC*MILER road category 
for the active trip.  See section 10.1.6 for descriptions of road types.  This report 
does not include total mileage per route.  If PC*MILER|Energy is licensed and 
installed, the Energy Roads category will be included. 

 
 

 
Road Type Report (Print Preview)  

 

9.7  Comparison Report 

Three ways to generate a Comparison Report when two or more generated routes 
are active: 
 

• Routes tab > Comparison Report 
• F4 key 
• (Print only)  File menu > Print Report > Comparison  

 
The Comparison Report lists the total mileage, cost and time estimates for all open 
routes. To create this report, select the Routes tab > Comparison Report or press 
F4 on your keyboard when two or more generated routes are active.   
 
Columns from left to right show trip totals for miles, estimated cost, estimated 
hours, toll costs (if PC*MILER|Tolls is installed and toll calculation is turned on), 
estimated fuel cost, estimated cost of labor, estimated miscellaneous costs, and 
estimated greenhouse gas emission (these last four columns are not shown in the 
resized report window below).  Values that affect cost, time, toll and greenhouse 
gas estimates are set in the File menu > Application Settings dialog. 
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Comparison Report, Practical vs. Shortest Routing (Print Preview) 

 
NOTE:  The Comparison Report lists only the origin and destination of each route.  
If there are stop-off points in one route and no stop-offs in another, the mileage 
discrepancy between these routes could be large.  Check the stops in the route 
window if you see differences in mileage that are larger than expected. 

 

9.8  Weather Report 
(PC*MILER|Weather license and an Internet connection are required.)  Weather 
Reports are available if Weather features are enabled – see Chapter 8. 

 

9.9  Font Size and Page Layout 
To see a preview of how the report will look when it is printed, check Show Print 
Preview in the upper left corner of the report.  The Print Preview view will be 
displayed along with a toolbar for editing the page layout and font size.  Place your 
cursor over any button on the toolbar to see a tooltip that briefly describes what that 
button is for. 
 
To change the font size in the active report, use the Font Size drop-down on the 
toolbar.  For adjustments to the page layout, there are six buttons that control 
formatting (portrait vs. landscape) and magnification. 
 

 
 
To hide columns or change their position or width, right click on any column header 
in a report and click on “Column Chooser”.  See section 3.6.4 on how to use the 
Column Chooser.   
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9.10  Printing Reports 

All PC*MILER reports can be printed.  To print a report, first check Show Print 
Preview in the upper left corner.   
 
 
A toolbar for editing will display and you’ll be able to see what the printed copy 
will look like.  To print, do one of the following: 
 
1.  Click the Print button (upper right corner);   
2.  Click the Print icon on the toolbar; or 
3. Press Ctrl+P.   
 
To directly print a report without first generating it in its own window, select the 
File application menu > Print Report > and choose a report type.        

 

9.11  Saving and Copying Reports 
 

PC*MILER reports can be saved to disk. Do one of the following: 
 
• Choose Save Report to File from the File application menu. 

• Click the Save button (upper right corner).  
  
 
In addition, PC*MILER reports can be copied to the clipboard for use with other 
Windows® programs such as Microsoft® Word.  To copy and paste a report: 
 
1. Select the report in the Reports window. 
2. Check Show Print Preview in the upper left corner. 
3. In the toolbar that displays, click the Copy icon.   

 
4. In the application you are copying to, press Ctrl+V to paste. 
 
NOTE:  With some reports you may get better layout results if you save the report 
as a .CSV (comma separated value) file and then import that file into your target 
application.  This may be especially true for the Detailed Route report with its many 
columns.  To save the active report, select the File application menu > Save Report 
to File and select “.csv” as the file type. 
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Setting Route Types & Options  
 
 
PC*MILER chooses routes by minimizing a cost equation that combines distance, 
certain factors times distance, and certain fixed factors.  A PC*MILER user can 
choose between versions of the equation and numerical values by setting different 
route options.  
 
General options such as route type, vehicle dimensions, and hazmat* designations 
affect which route is chosen.  Cost/time, road speed and tolls* route options affect 
time/cost and toll data that is returned when a route is generated, but do not affect 
which route is chosen.  (* These options are available only if the related data modules have 
been purchased and installed.) 
 
Route types and options can be changed using the Application Settings, Route 
Profiles, and Route Options dialogs. 
 
 

10.1  Application Settings    
 
The application settings described in the following sections 10.1.1 – 10.1.11 affect 
all PC*MILER route calculations and determine the behavior of some features in 
the application.  Application settings have a global effect on routes, maps and/or 
reports, and are likely to be changed infrequently.  
 
Choose File menu > Application Settings to open the Application Settings dialog.  
Select a category on the left to see its options on the right.  Click Apply to save 
your edits and keep the dialog open, or Save to save changes and close the dialog. 

 

  
Application Settings Dialog 
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10.1.1  General 
 
Default Region 
North America is the only available region with the base version of PC*MILER.   
 
If PC*MILER|Worldwide or DTOD Data is installed, North America is the default 
region and other regions can be selected: click the down arrow and select a region 
from the drop-down.  Available worldwide regions are: Africa, Asia, Europe, 
Middle East, Oceania and South America.  The active region is displayed at the 
top of each new route window.  
 
Avoids/Favors 
Uncheck Show Comment Box to disable the comment box that pops up each time 
an avoid/favor designation is created on the map. This option is on by default. 
 
Data Installation Reminder 
 After the main software is downloaded and installed, if a user is licensed for a 
particular data add-on (e.g. Energy, Worldwide Highway or a Worldwide Streets 
Region), the applicable data set must also be downloaded and installed. If the Show 
Reminder on Startup box is checked and the data has not been installed, a pop-up 
reminder to install the data is displayed on startup. This option is off by default. 
 
 

10.1.2  Fuel Prices 
 

 
 
(An installation of PC*MILER|Streets and an Internet connection is required.)  
This option enables a real-time fuel price feed that pulls in current diesel fuel prices 
at the entered Polling Interval.  The fuel feed is enabled by default with a refresh 
every 60 minutes.  Users can enter a different polling interval or uncheck the option 
to disable it.  Fuel prices are shown in a pick list of matches when the user searches 
for Fuel Stops in a route window – see section 3.13. 
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10.1.3  Geocoding (Stop Entry Processing) 
 

 
 

Multiple Geocoding Results 
The Provide Pick List option is checked by default.   A During stop entry, this 
option provides a pick list of postal codes if there is more than one instance of a 
location in the database.  The order in which locations are listed in the pick list is 
based on such factors as population and geographic centrality, putting the most 
densely populated cities at the top. When this option is not checked, PC*MILER 
will select the first match that is found in the database.   
 
Postal Code Preference 
Use the drop-down to select how PC*MILER handles Mexican and U.S. locations 
that have the same postal code:   

• Use Default US Zip Codes:   
This option is selected by default.  The default U.S. ZIP code will be 
returned. Mexican codes cannot be entered. 

• Use Default Mexican Zip Codes:  The default Mexican postal code will be 
returned.  U.S. codes cannot be entered. 

• Use Default US and Mexican Zip Codes:  The default U.S. ZIP code will be 
returned.  However, Mexican codes can be entered with “EM” as the state 
abbreviation; for example, “50510, EM”. 

 
NL Abbreviation 
Choose whether to Use NL For Newfoundland and Labrador in Canada (this option 
is selected by default) or Use NL For Nuevo Leon in Mexico. 
 
 

10.1.4  Proxy 
 
 
 
 
 
 
 
 
See section 2.7, Proxy Setup for Internet Access. 

  



 

 
 Chapter 10:  Route Options & Settings 154 

10.1.5  Report 
 

 
 
State/Country Report Order 
Choose whether State/Country reports will have states/countries listed in Route 
order as in a driver log, or Alphabetical order by state/country.  Alphabetical is the 
default setting. 
 
Ferry Distances 
The Show in Reports option includes ferry distances in mileage and cost 
calculations.  The setting does not affect the actual route on the map and travel time 
is not affected.  Note that the “Total” column of the State/Country report always 
includes ferry distances, even if this option is turned off.  By default, Show in 
Reports is selected.   

 
  

10.1.6  Road Speeds 
 

 
 

NOTE for PC*MILER|Energy Users:  If PC*MILER|Energy is installed, an 
“Energy” road class will be listed in the Road Speeds tab.  Energy roads can be 
customized by state. 

 
 

Vehicle Type 
Truck is the default vehicle type.  Choose Automobile to view or change the road 
speeds used in van/automobile route calculations. 
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NOTE:  When PC*MILER|Traffic data is used for a route, it will override these 
road speeds.  Also note that setting a governor (maximum) speed in the Route 
Options dialog or current route profile will override any speeds set here that are 
above the governor speed. 

 
PC*MILER time estimates for a route are computed by summing up the estimated 
time traveled on each road segment on the route, plus an added stop-off time for 
each stop along the route if stop durations were set in the HOS Manager.  
 
Each PC*MILER road class has two average road speed parameters assigned to it, 
one for Rural and one for Urban.  Spreading the estimated average speed over the 
various road classes gets a more accurate estimate of the total time traveled based 
on the quality of the road used.  See descriptions of road classes below.   
 
To enter your own custom road speeds, first select a jurisdiction from the pick list 
of jurisdictions, then enter your new road speed(s) for each road class.  To apply 
your edits for one jurisdiction to all jurisdictions, click Update All Road Speeds.  
Click Apply to apply your edits to the currently open route, or Save to save them 
for future use.   
 
Road speed changes will affect time and cost estimates in route calculations.  To 
restore all road speeds to the PC*MILER default settings, click Reset All to 
Default. 
 

               
PC*MILER ROAD CLASSIFICATIONS 
 

Interstate 
Highways 

• The primary function of these roads is to move high volumes of 
vehicular traffic over medium to long distances at high speeds  

• Can be accessed only via access ramps  

Major Highways • Major arteries that move heavy volumes of traffic at moderate speeds 
• Can be limited access in some areas but may also offer access from 

local roads 
• Usually have a barrier or median that prevents movement between lanes 

of opposing traffic 
• Medians may have crossovers that are part of the normal traffic pattern 
• Left turns are often restricted, both off of the highway and onto the 

highway 
• Usually multi-lane 
• Many but not all U.S. highways are in this class 

Primary Highways  • Move significant volumes of traffic at moderate speeds 
• Most state roads fall into this class 
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Secondary Roads • These roads move moderate volumes of traffic over short to moderate 
distances 

• Carry vehicles from local roads to higher class roads 

Local Roads • Function is to provide access to homes and properties 

Ramp • A connecting road leading on or off of a main road or highway 

Ferry • Ferry routes (boarding/exit time not included) 

Energy • Roads that lead in or out of well sites and other facilities  
(requires a PC*MILER|Energy license and installation) 

 
 

10.1.7  Route Costs 
 

 
 
PC*MILER calculates a total cost for each generated route.  This cost estimate is 
determined by multiplying a dollar amount per mile by the number of miles.  In the 
Route Costs tab, the trip costs that go into the dollar amount per mile have been 
broken out into fuel costs, labor costs, and “other” maintenance or miscellaneous 
costs.  For information purposes only, a greenhouse gas emissions value is also 
included.   
 
You will see these values reflected in the columns of the Comparison report.  The 
greenhouse gas estimate also appears in the State/Country Distance report. 
 
Editing the Route Costs options will affect the trip costs shown in the route window 
and in reports when a trip is generated. 
 
Route cost changes will affect cost estimates in route calculations.  To restore all 
route cost changes to the PC*MILER default settings, click Reset To Default. 
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Greenhouse Gases 
Enter the pounds per gallon or liter emissions as CO2 equivalent, or use the default 
values.  Leg and total greenhouse gas (GHG) emission estimates appear in the 
State/Country Report, and a total GHG estimate appears in the Comparison Report.  
The default settings* for all world regions are: 
 

• Per Gallon: 22.20 lbs. 
• Per Liter: 5.86 lbs. 
 

*  These default settings are based on values for North America that were provided 
by the U.S. Environmental Protection Agency (EPA).  For more information, see 
http://www.epa.gov/otaq/climate. 

 
Fuel Cost Per Gallon (or Liter) 
(To switch between gallons and liters, use the Application Settings Units tab, see 
section 10.1.9.)  All world regions have the same default value for fuel cost, 
depending on the unit of measure, as follows: 
 

• Per Gallon:  $2.564 
• Per Liter:  $0.677 

 
Miles (or Kilometers) Per Gallon (or Liter) 
(To switch between miles and kilometers, use the Application Settings Units tab, 
see section 10.1.9.)  Default values are: 
 

• Miles Per Gallon (Loaded or Empty):  6.48 
• Kilometers Per Gallon (Loaded or Empty):  10.43 
• Miles Per Liter (Loaded or Empty):  1.71 
• Kilometers Per Liter (Loaded or Empty):  2.75 

 
Fuel Cost Per Mile (or Kilometer) 
These fields are for reference only and not editable.  Values are based on the Fuel 
Cost Per Gallon/Liter and MPG/MPL, and are used to calculate the fuel cost total 
that appears in the Comparison Report. 

 
 

IMPORTANT:  The PC*MILER fuel costs that are calculated when you run a 
route may vary slightly from what you would get by simply multiplying the fuel 
cost per mile/kilometer times the number of miles.  This is normal and expected, 
because PC*MILER calculations use internal values that have greater precision 
than the values you see on your screen.  For example, a trip between two street 
addresses in Boynton Beach and Doral in Florida is 67.1 miles, with a fuel cost of 
$.43/mile.  PC*MILER will calculate a total fuel cost of $28.81 for the trip rather 
than $28.85 (67.1 times .43). 
 

  

http://www.epa.gov/otaq/climate
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Other Cost Per Mile (or Kilometer) 
Default values for miscellaneous costs are: 
 

• Other Cost Per Mile (Loaded or Empty):  $.20 
• Other Cost Per Kilometer (Loaded or Empty): $.12 

 
Labor Cost Per Hour 
The default value is: 
 

• (Loaded or Empty):  $38.87 
 
 

10.1.8  Tolls 
 

 
 
(PC*MILER|Tolls must be licensed and installed.) 
 
Currency 
Sets the US Dollar/Canadian Dollar currency conversion rate.  This option can be 
edited.  The Version 31 default conversion rate is USD/CAD = $1.00/$1.334. 
 
Discount Programs 
All available toll discount programs are listed and enabled by default.  To disable 
all discount programs, click Deselect All, or uncheck the programs to exclude.  (To 
completely disable toll cost calculations, turn off Show Toll Costs in Reports in the 
Route Options or Profile Options dialog > Reporting Preferences tab.) 
 
State/Country Distance Report 
This option generates a breakdown of toll costs by discount program in the 
State/Country Distance Report and is unchecked by default.   
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10.1.9  Units 
 

 
 
Length and Distance in 
Select the units of measure to use for route calculations and reports – US Customary 
(miles, feet, inches) or Metric (kilometers, miles).  Affects trip costs, average road 
speeds, and distance calculations shown in reports and route windows.  The default 
value is US Customary. 
 
Distance Precision 
Choose how many decimal points will be calculated and displayed for distances – 
Whole Number, Tenths, Hundredths, or Thousandths. Affects distance calculations 
in route windows and all reports that include mileage.  The default value is Tenths. 
 
Time Format 
Choose whether times of day should be displayed in AM/PM or 24 Hours 
(“military”) format; e.g. 3:20 PM or 15:20.  This setting affects reported ETA/ETD.  
The default value is AM/PM. 
 
Time Zone 
Options are Local, System, or a specific time zone.  This setting affects reported 
ETA/ETD.  It does not affect how dates/times are calculated.  See section 5.1, Route 
Generation With ETA/ETD.  The default value is Local. 
 
Fuel in 
Select Gallons or Liters for fuel reporting.  Affects trip costs and distances shown 
in reports and route windows.  The default value is Gallons.   
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10.1.10  Weather 
 

 
 
(PC*MILER|Weather must be licensed and installed, and an Internet connection is 
required for weather reporting.) 
 
Weather 
The Enable Weather setting enables/disables all weather reporting. The current 
online/offline status and time of the last weather update is displayed under the check 
box.  When enabled, weather conditions are updated at least every 30 minutes.  To 
see weather conditions on the map, select the Map tab > Weather in the PC*MILER 
application window. 
 
Select Weather Alerts Categories 
Select which categories of weather alerts will be received.  Affects warnings in 
route windows, map displays, and weather reports.  See Appendix J for the alert 
types included in each category. 
 
See Chapter 8, Weather Information and Alerts for descriptions of all the Weather 
features available with a subscription to PC*MILER|Weather.   
 
 

10.1.11  Worldwide 
 

 
 
Country Abbreviation Format 
(PC*MILER|Worldwide or DTOD Data must be licensed and installed.)  When 
entering stops on a route in a region other than North America, worldwide country 
abbreviations can be entered using either FIPS 2-character, ISO 2-character, ISO 
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3-character, GENC 2-character or GENC 3-character codes.  Select a format that 
will be used from the drop-down.  FIPS codes are accepted by default.  For a list of 
worldwide country abbreviations in different formats, see Appendix D. 
 

10.2  Using Route Profiles 

VERY IMPORTANT! Please Be Aware.  When using a route profile, the profile 
must be selected for a route before all other options.  A route profile overrides any 
other option set for the route, including an ETA/ETD. 
 
PC*MILER’s route profiles enable you to create and save comprehensive sets of 
custom routing options and quickly apply them to a route.  Using profiles can help 
ensure that your frequently used options are correctly and consistently used when 
generating routes.  A profile can be applied to individual routes, or globally to all 
new routes using a Default profile.  Route profiles can be created, edited, deleted, 
and designated as favorites, with the exception of the Default profile which can be 
edited but not deleted. 
 
To begin working with route profiles, select the Routes tab > Profiles to open the 
Manage Profiles dialog:  

 

 
Manage Profiles Dialog 

 
Off the shelf, PC*MILER applies a Default profile to each new route that includes 
options suitable for 48 foot semi-trailer trucks in North America and provides 
several other sample profiles suitable for different vehicle types.  The default 48 
foot options are the same standard default settings that were historically applied to 
PC*MILER routes. These default values can be edited by the user to be more 
reflective of the equipment used in the field, e.g. light, medium-duty and/or heavy 
vehicles; but as stated above, the Default route profile can be edited but not deleted.  
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10.2.1  The PC*MILER Default Route Profile 
 
PC*MILER is shipped with a default route profile suitable for 48 foot semi-trailer 
trucks in North America that applies the options listed below to each new route.  
The PC*MILER Default_NA route profile can be edited but not deleted.  
 
 

• Route Type: Practical 
• Vehicle Type: Truck (48 ft.)  80,000 lbs.  5-axle 
• Dimensions:  L = 48 ft.   H= 96 ft. or less   W= 13 ft. 6 in.   
• Toll Roads: Allowed 
• Ferries: Allowed 
• Governor (Maximum) Speed Limit: Disabled 
• HazMat: None 
• Road Network: None 
• International Borders: Open 
• Custom Roads: Ignore Avoid/Favors 
• Elevation: Any 
• Roads:  Highway only*  
• Size and Weight Restrictions: Use 
• Hub Routing: Disabled 
• Tolls: Calculate tolls and use discount programs (PC*MILER|Tolls required) 
• Weather Alerts: Disabled (PC*MILER|Weather required for alerts) 
 
* The default for this option is Highway & Streets if PC*MILER|Streets, 

PC*MILER|Energy or PC*MILER|TripDirect is installed. 
 
 
10.2.2  Creating a New Profile 

 
To create a new profile: 
 
1. Open the Manage Profiles dialog (Routes tab > Profiles). 
2. Click New.   
3. Enter a Profile Name at the top of the Profile Options dialog. 
4. Set your options (see 10.3, Route Profile Options). 
5. Click Save. 
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10.2.3  Editing an Existing Profile 
 
Initially the Manage Profiles dialog will include six sample profiles and the Default 
profile at the top of the list.  To edit an existing profile: 
 
1. Open the Manage Profiles dialog (Routes tab > Profiles). 
2. In the list of profiles, click the one you want to edit. 
3. Click the pencil icon. 

4. Set your options (see section 10.3, Route Profile Options). 
5. Click Save.  
 

 
10.2.4  Managing Route Profiles 

 
In the Manage Profiles dialog, users can create and edit a virtually unlimited 
number of profiles.  The list of profiles becomes scrollable when it outgrows the 
area of visibility. 
 
To designate a favorite, select it on the profile list and click the star to the left of 
the profile name.  The star will turn yellow, and the favorite will be moved to the 
top of the list under the Default profile.   
 
 
 
To remove a profile’s favorite status, click the yellow star.   
 
Favorites profiles can be quickly accessed using the New From Profile  
drop-down in the Routes tab.  The order of profiles on this menu will  
be as follows: 
 

• The Default profile is always at the top. 
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• Favorites are listed under the Default profile in alphabetical order. 
• All other profiles are listed under the favorites in alphabetical order. 

 
To delete a profile, select it on the list and click the trash can to the right.   

 
 

10.2.5  Selecting a Profile To Use For a Route 
 
REMEMBER!  When using a route profile, the profile must be selected for a route 
before all other options.  A route profile overrides any other option set for the 
route, including an ETA/ETD. 
 
There are two ways to select a route profile for a route: 
 
1. Select a profile from the drop-down in the route window before selecting any 

other option for the route.  Menu options will include the Default profile and 
all profiles that are designated as favorites in the Manage Profiles dialog. 

 

 
 
 

2. Select the Routes tab > New From Profile and choose a profile (all profiles 
designated as Favorites will be listed).  A new route window will open with 
that profile selected. 

 
 
 
 
 
 
 
 
 
 

  “New From Profile” Menu 

Route Profile 
drop-down 
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10.3  Route Profile Options 
The Profile Options dialog opens when you choose to edit or create a route profile 
from the Manage Profiles dialog.  The tabs in this dialog are accordion style – click 
on each tab to see its options.   
 
NOTE for Users on a Workstation:  Some options in the Profile Options dialog 
may not be accessible if you don’t have permission to edit them. 
 
 

10.3.1  Vehicle Dimensions 
 
See section 10.5, Using Custom Vehicle Dimensions. 
 
 

10.3.2  Routing Preferences 
 

 
 
Route Type 
See section 1.6, PC*MILER Route Types, for descriptions. Defaults to Practical. 
 
Toll Roads 
Select Allowed to use toll roads on routes, or Discouraged to only use a toll road 
where necessary to avoid long, impractical detours.  See section 1.6.5 for a 
description of Toll Discouraged routing.  Default value is Allowed. 
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Ferries 
Select Allowed to use ferries on routes, or Discouraged to only route on a ferry 
where necessary to avoid long, impractical detours.  Default value is Allowed. 
 
Governor Speed Limiting 
Select Enabled to use a maximum road speed in route calculations, then enter a 
custom value or use the 55 mph default.  This speed overrides all other speed values 
for a trip when those speeds are higher than the governor setting. 
 
For example, PC*MILER’s default average road speed on Interstates is set to 65 
mph, which directly affects a trip's travel time and ETA calculation. However, 
XYZ Trucking has a governor speed of 55 mph on any type of road.  XYZ 
Trucking wants their governor speed factored into PC*MILER when it computes 
an ETA and sets the governor speed to 55 mph.  In this scenario: 

• for link A, the existing speed is 35 mph and PC*MILER’s ETA 
calculations use 35 mph for that link; 

• for link B, the existing speed is 60 mph and PC*MILER’s ETA 
calculations use 55 mph for that link. 

 
The use of a governor speed limit can help you more accurately calculate drive 
times and ETA’s in PC*MILER, publish ETA’s from PC*MILER to customers 
with more confidence, and calculate a more accurate HOS-planned route if desired.  
By default, governor speed limiting is Disabled. 
 
NOTE:  Setting a governor (maximum) road speed as a Route Option or in a route 
profile can alter the route calculated using the Fastest route type.  A lower 
governor speed could result in a shorter route distance and more lower classed roads 
being used (see section 10.1.6 for road classifications). 
 
Hazmat 
(Visible only if PC*MILER|Hazmat is licensed and installed.) See Chapter 13, 
Hazardous Material Routing, for more details on PC*MILER hazmat route types 
and road categories.  The default route type is None. 
 
Road Network 
(U.S. only) Select State + National Network to favor the US Federally designated 
National Network (primary Interstates with reasonable entry/egress points up to 1 
mile off the Interstate) and state-designated extensions to the National Network 
(additional highways and supporting roads any distance off the Interstate, as 
determined by individual states).   
 
The National Network is a U.S. government-designated system of highways 
originally established by the Surface Transportation Assistance Act of 1982 
(STAA).  The State + National Network option also incorporates roads that permit 
53' trailers or twins.  This option will calculate routes that stay on the National 
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Network to the maximum extent possible.  Given that many areas are not directly 
served by the National Network, the origin and stop-offs on a route may not be on 
the Network.  See section 1.6.4 for a more detailed description of State + National 
Network routing.  The default value here is None. 
 
International Borders 
Select Closed to minimize the number of international border crossings.  For 
example, if all your stops are in the “lower 48” United States, the resulting route 
will stay in the United States even though the most practical or shortest route would 
normally involve some Canadian mileage.  The Open option ignores international 
boundaries in generating the best route.  Borders are open by default. 
 
Custom Roads 
Select Use Avoid/Favors to apply all user-designated avoid/favor road preferences 
to route calculations, including geofences, truck restriction overrides, and hazmat 
permit overrides.  User-designated road preferences won’t be used unless this 
option is selected.  Does not affect via points or routes that have been dragged onto 
another road on the map.  See section 12.1, Picking Roads to Avoid or Favor, to 
create custom avoid/favor preferences.   
 
Elevation 
Select Discourage Above then enter an elevation in feet to set a customized limit 
on the elevation of the roads a route will use.  Elevations at or above this height 
will be avoided on a route unless 1) it is extremely impractical to do so; or 2) a stop 
or destination on the route is located at the higher elevation.  No warnings are issued 
when a road that exceeds the elevation limit must be used.  Elevations are from the 
National Elevation Data produced by the U.S. Geological Survey. 
 
Roads 
(PC*MILER|Streets is required for street-level routing.)  The Highway Only option 
is selected by default except when PC*MILER|Streets, PC*MILER|Energy and/or 
PC*MILER|TripDirect is licensed and installed.  The Highway Only option 
calculates routes using an air distance from the midpoint of the truck-usable 
highway segment that is nearest to the destination postal code or city/state.  Routes 
to stops that include a street-level address are calculated to the truck-usable 
highway-level road that is closest to the entered address.  This functionality matches 
the base PC*MILER highway product.   
 
When Highways & Streets is selected, PC*MILER calculates the route and driving 
distance using local streets between the nearest truck-usable highway segment and 
the stop.  All stops, whether they contain a street-level address or not, clean up via 
the shortest air distance to the nearest road (highway or street level).  This distance 
may appear as “Local” in the Detailed Route report. 
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Restrictions 
Select Override to generate routes that waive truck restrictions pertaining to 
specific sizes and weights, but that continue to avoid truck-prohibited and truck-
discouraged roads.  When this option is active, height, length, width and weight 
restrictions will be overridden.  If a route uses roads that have any of these types of 
restrictions, the Detailed Route Report will list them.  This allows you to determine 
the largest or heaviest vehicle you can assign to drive that route. 

When Use is selected, PC*MILER routing will avoid truck-prohibited and truck-
discouraged roads, as well as truck-restricted roads that pertain to the size and 
weight set in the current vehicle dimensions or profile. 

NOTE for PC*MILER|Streets Users: An error message will appear if you 
attempt to enter an address that is on a truck-prohibited road. 
 
Below is a table showing the North American states/provinces that have a 
jurisdiction-wide weight limit, with exceptions listed. 
 
 

State/ 
Province 

Weight 
Limit* Exceptions Ref. 

SK 76,038 lb 
(34,500 kg) 

- 87,058 lbs (39,500 kg) on designated primary highways year-
round and other designated primary highways for 9 
months/year, and a maximum distance of 15 kilometers on any 
secondary provincial [not including municipal] highway or 
provincial road 
- 91,466 lbs (41,500 kg) on most roads in winter, i.e. Nov16-
Mar14 (except for certain restricted exceptions) 
- special restrictions on certain listed highways 

(1) 
(2) 

MB 76,038 lb 
(34,500 kg) 

- 82,650 lbs (37,500 kg) on designated “A1” highways 
- 87,058 lbs (39,500 kg) on designated “RTAC” highways 
- Winter weights higher in some cases 
- “If a delivery needs to be made off of a designated truck route 
the vehicle is allowed to stray from the truck route via the 
shortest distance to its destination.  Once the delivery has been 
completed the vehicle must return to the truck route the same 
way” 

(3) 
(4) 

*  For the PC*MILER default vehicle configuration:  5-axle tractor/48' long semitrailer combination.  
Higher limits > 80,000 lbs apply in SK & MB for 6+ axles. 

Ref: 
1. http://www.highways.gov.sk.ca/trucking/ 
2. Saskatchewan Vehicle Weight and Dimension Regulations, 1999, page 17, Sec 12(1)(KK) 
3. http://www.gov.mb.ca/mit/mcd/mcpd/pdf/normalloading.pdf & http://www.gov.mb.ca/mit/mcd/mcpd/twlm.html 
4. Email from Dwight Solon, Director, Motor Carrier Enforcement Programs, Province of Manitoba, 11/03/08 

 
SAFETY NOTE:  For winter roads in Manitoba and North West Territories, 
Canada, road safety information for heavy vehicles using these roads can be found 
at: http://www.gov.mb.ca/  

http://www.highways.gov.sk.ca/trucking/
http://www.gov.mb.ca/mit/mcd/mcpd/pdf/normalloading.pdf
http://www.gov.mb.ca/mit/mcd/mcpd/twlm.html
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Hub Routing 
Select Enabled to generate mileage from one origin defined as the "hub" to an 
unlimited number of destinations in the same route window.  This type of route 
calculation gets its name from the image of a wheel with spokes and a hub at the 
center.  The Detailed Route Report and State/Country Report are both available for 
hub routing. Note that timestamps won’t be shown along a hub route on the map.  
By default, hub routing is Disabled. 
 
 

10.3.3  Reporting Preferences 
 

 
 
Tolls 
Check Show Toll Costs in Reports to have toll costs appear in reports.  Check Use 
Toll Discount Programs to have toll calculations use the discount programs 
selected in the Application Settings dialog > Tolls tab.  Both options are checked 
by default. 
 

10.4  Route Options for an Individual Route   
In addition to the use of route profiles, route options can also be set and saved for 
individual routes.  The Route Options dialog lets you customize and apply settings 
to the currently open route, with the option to save those settings to a new route 
profile or to the Default route profile.   
 
The Route Options dialog can be accessed in one of the following ways: 
 

• In a route window, select the gear button > Options. 

• Select the Routes tab > Options. 

• Use the Alt+F3 shortcut.  
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Route Options Dialog, Reporting Preferences 

 
 
Besides the Vehicle Dimensions and Routing Preferences settings included in route 
profile options (described above in section 10.3), the Route Options dialog has a 
Route Name option in the upper left corner, an Arrival/Departure tab, and two 
additional Reporting Preferences settings.   
 
Route Name 
Enter a Route Name at the top of the dialog to assign a unique name to the current 
route.  This name will appear in the title bar of the route window, in the Route 
legend in the map window, and in reports. 
 
Arrival/Departure 
(Arrival/Departure tab)  Set a time/day of arrival or departure for a trip, and select 
which road speeds to use in ETA/ETD calculations – see sections 5.1 and 5.2 for 
details.  These same settings can be found in each route window.  The default is 
None. 
 
Report Memo 
(Reporting Preferences tab) This field allows you to create custom report headers.  
Text that is entered in this field will appear at the top of all printed reports (check 
Show Print Preview in the Reports window to see how the header looks).  By 
default the Report Memo field is left blank. 
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Alerts 
(Reporting Preferences tab) If PC*MILER|Weather is licensed and installed, the 
Enable Weather Analysis check box turns weather reporting and alerts on/off.  In 
the Application Settings dialog Weather tab, the “Enable Weather” check box has 
the same function and controls whether this option is enabled in Route Options, but 
not vice versa.   This allows the setting to be turned on/off for a single route in 
Route Options without affecting the application setting that affects all new routes. 
 
 
Your edits in the Route Options dialog can be saved and applied in three ways: 
 

• Click Save to apply the custom settings you entered to the currently open 
route.  These settings won’t be applied to the route profile displayed in the 
upper right corner.  

• Click the gear button (upper right corner) and select Save Options as New 
Profile, enter a name for the new route profile, then click Save.  You’ll see 
the new profile listed the next time you open the Manage Profiles dialog. 

 

 
 
 

 
 
 

• Click the gear button (upper right corner) and select Save Options as 
Default Profile to save your custom settings to the PC*MILER Default 
route profile.   
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10.5  Using Custom Vehicle Dimensions   
 

 
Route Options Dialog, Vehicle Dimensions Tab 

 
 

PC*MILER’s Vehicle Dimension options in the Route Options and Profile Options 
dialog (sections 10.3 and 10.4) enable you to generate routes based on custom 
vehicle dimensions.  With these options, users can generate routing that conforms 
to the requirements of a vehicle’s height, length, width and weight for light, 
medium duty and heavy vehicles. 
 
If a vehicle weight and/or height is entered, PC*MILER route calculations will take 
into account restrictions on roads and bridges to ensure that the vehicle’s 
weight/height is below the restriction(s).  Vehicle weight, length and width 
information is checked against the threshold at which a truck becomes “oversized” 
and appropriate routing is generated. 
 
Additionally, PC*MILER supports calculation of routes and toll costs for smaller 
vehicles (vans, pickup trucks, SUVs, automobiles, etc. that are classed less than 
9,000 lbs./4,082 kgs.) with a “Full-size van” profile option or your own custom 
route profile that includes dimensions that meet the required criteria.  
 

 
10.5.1  Vehicle Type, Route Profile and Vehicle Dimensions Defined 

 
The Vehicle Type in the upper left corner of the Route Options or Profile Options 
dialog > Vehicle Dimensions tab conforms to the vehicle dimensions in the Vehicle 
Dimensions tab.  The vehicle type updates automatically when dimensions are 
changed by the user.  It is informational only and cannot be edited.  Possible 
categories are Auto, Truck (Medium-Duty), or Truck (heavy truck).  
 
A Route Profile (full-size van, 48 ft. semitrailer, etc.) is a template containing a 
particular combination of vehicle dimensions and other route options that can be 
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conveniently reapplied as needed.  Out of the box, PC*MILER ships with an active 
Default route profile configured for 48 foot semi-trailers and a selection of other 
typical profiles to choose from.  Route profiles can be created and edited by end 
users – see section 10.2.   
 
Vehicle Dimensions (weight, length, height, width, axles, trailers) are specific 
values that will affect the selection or avoidance of road segments that restrict 
vehicles to below those dimensions.  In other words, the roads that a route takes 
will depend on the specified vehicle dimensions.  Vehicle dimensions are included 
in every route profile and may be customized.  They can trigger warning messages 
if a restriction is violated because an alternate road segment was either unavailable 
or too impractical.  Additionally, the weight, number of axles and trailer settings 
are used in calculating tolls.  Vehicle dimensions determine the vehicle type 
(mentioned above) as shown in Table 1 below. 
  
 

Table 1.  PC*MILER Rules for Inferring Vehicle Type from Vehicle Dimensions 

 

Dimension Automobile 
if ALL values 
are less than  
or equal to 

Medium Truck  
if ALL values  
are less than or  
equal to 

Heavy Truck 
All other 
values are 
regular 
heavy truck, 
unless… 

In USA, Nat’l 
Network and 
State Oversize 
if ANY values 
are greater 
than 

In Canada* in 
SK and MB, 
State Oversize 
if greater than 
*see note below 

In Canada* in MB, 
National Network if 
greater than 
*see note below 

Weight 8,500 lbs. 26,000 lbs.    76,038 lbs. 
(34,500 kg.) 

82,650 lbs. 
(37,500 kg.) 

Length 20 ft. 26 ft.   48 ft.   
Height 7 ft. 13 ft. 6 in.      
Width 96 in. 96 in.   96 in.   
Axles 2 (4 tires) 2 (6 tires)      
Trailers None None      

 

* The rules for Canada in the table above are for truck tractors with a single 5 or 6 axle semi-trailer.  Customers 
who run heavy straight trucks (this would be unusual) or doubles (more common) in SK or MB are advised to 
consult the Weights and Dimensions Compliance Guides published by those provinces, and to select the 
PC*MILER State + National Network route type as appropriate. 

 
 
REMEMBER: An alternative to entering vehicle dimensions manually is, where 
appropriate, to select a pre-defined or user-created route profile. 

NOTE:  If the user enters a vehicle height over 13 ft. 6 in., PC*MILER will avoid 
jurisdictions with lower overall limits in its calculations wherever possible and 
practical.  You will receive a warning message in the Detailed and Driver’s reports 
if any of these jurisdictions cannot be avoided on a route. 
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10.5.2  Customizing Vehicle Dimensions 
 
NOTE:  Oversize permits will allow for “normal” truck routing if you have 
purchased the appropriate permits for your oversize vehicle for routing on assumed 
80,000 lb./36,287 kg. roadways.  Nonetheless, if the route includes a road segment 
for which the truck as configured will require a permit, the destination will be 
represented by a solid red circle in the route window (position the cursor over it to 
see the warning) and a warning will appear in the Detailed and Driver’s reports. 
 
Below are the vehicle dimension options that can be edited in the Route Options or 
Profile Options dialog > Vehicle Dimensions tab. See section 10.5.3 for default 
values. 
 
Height   
For all regions and truck types, enter a length of 5 ft. – 13 ft. 6 in. or 1.52 – 4.11 m.  
The minimum height is > 0.  
 
Length   
For all regions and truck types, enter a length of 8 ft. – 82 ft. or 2.44 – 25 m.  The 
minimum length is > 0.   
 
NOTE:  If the State + National Network routing option is selected in the General 
tab and a custom length is entered, both attributes are weighed in the overall 
calculation but the routing option takes precedence. 

 
Width 
For US Customary units, select 96 or less, 98, or 102 or more inches.  For Metric 
units select 2.44 or less, 2.48, or 2.59 or more meters.  Note that entering the larger 
vehicle width category will use State + National Network routing in the U.S. and 
Canada except where necessary for local deliveries.   
 
Weight   
For all regions and truck types, weights of 1,500 – 156,748 lbs. or 681 – 71,099 
kgs. may be entered.  See section 10.5.1 above for more on vehicle weight.   
 
Axles  
(For PC*MILER|Tolls users only)  The number of axles entered here is used only 
for the calculation of toll costs using the PC*MILER|Tolls add-on module.  If 
PC*MILER|Tolls is not installed, this option will be disabled.  See Chapter 7 for 
toll cost calculation information.  The default number of axles is 5. 
 
Permit  
If you try to enter a weight greater than 80,000 lbs/36,287 kg and this option is not 
checked, a warning will display in the Route Options dialog: “Trucks weighing 
over 80,000 lbs (36,287 kgs) require a permit in most U.S. states.”  Check Permit 
to continue.  This option does not affect routing, it only serves as a reminder that a 
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permit is usually required for the vehicle dimensions entered. By default, it is 
unchecked. 
 

 
 
Multiple Trailer (MT)   
Check if the vehicle is a long combination vehicle with multiple trailers. (See 
section 7.2 for toll calculation considerations.)  By default, it is unchecked. 
 
 

10.5.3  Vehicle Dimension Defaults 
 
The table below shows PC*MILER’s default vehicle dimensions for all regions. 
 

 
 Length Height Width Weight 

US Cust Metric US Cust Metric US Cust Metric US Cust Metric 
54' 1" 16.48m 12' 5" 3.78m 98" or 

less 
2.48m 80000lbs 36287kg 

US Cust Metric US Cust Metric US Cust Metric US Cust Metric 
48 feet 14.63m 13' 6" 4.11m 96" or 

less 
2.44m 
or less 

80000lbs 36287kg 

 
 
 

10.5.4  Vehicle Dimensions for Automobile Routing 
 
To generate a route that ignores commercial truck restrictions (Truck Restricted, 
Truck Prohibited and Truck Discouraged), you can either 1) use the PC*MILER 
“Full-size van” route profile intended for use with vans, pickup trucks, SUVs, 
automobiles, etc. that are classed less than 9,000 lbs./4,082 kgs., or 2) enter your 
own vehicle dimensions that conform to the criteria for automobile routing in 
PC*MILER.  Those criteria are as follows (all criteria must be met): 

• 2 axles; 
• less than or equal to 9,000 pounds/4,082 kilograms in weight; 
• less than or equal to 7 feet/2.133 meters in height; 
• less than or equal to 20 feet/6.096 meters in length; 
• less than or equal to 96 inches/2.438 meters in width. 

 
Automobile routing will relax all regulations that pertain to trucks, allowing the 
route to take advantage of parkways and other roads that larger and/or heavier 
and/or commercial vehicles are prohibited from using.  PC*MILER will also use 
toll rates that apply to 4-tire vehicles with 2-axles, which often differ from rates 
that apply to 6-tire 2-axle vehicles.  (PC*MILER|Tolls must be installed.) 
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   Using the  
PC*MILER Map Window 

 
 

The PC*MILER map window is like an electronic road atlas.  All routes generated 
by PC*MILER are automatically displayed in the map window.  This enables you 
to examine routes in detail, visually evaluate routing alternatives, and perform a 
variety of "what-if" analyses.   
 
 

 
The PC*MILER Map Window 

 

11.1  Routes on the Map 

Up to eight routes can be generated and displayed simultaneously in the map 
window.  Each route will be drawn in a different color.  The Route Legend on the 
map and a color bar in the route window show the color used for each route. 
 
To maximize the size of the map so that it fills the whole PC*MILER application 
window, close the Routes and Reports panes.  To toggle the map window between 
hide and display, select the Window tab > Map Window.  To restore the default 
layout, select the Window tab > Layouts > Default Layout. 
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11.2  Frame Options 
To frame a country or area within the region set in the Application Settings dialog, 
select the Map tab > Frame > Areas > and choose an area. 
 
 (PC*MILER|Worldwide only)  To frame a world region, select the Map tab > 
Frame > Regions and choose a region.   
 
To frame the active route on the map, do one of the following: 

• select the Routes tab > Frame;   

• click the Frame Route button in the route window;   

• select the Map tab > Frame > Frame One Route >; or  
> Auto Frame Routes to automatically frame each generated route (this is 
selected by default). 

 
To frame all currently open routes, select the Map tab > Frame > All Routes. 
 
There are several ways to frame a stop – see section 11.3, Zoom Options, below. 

 
 

 
Framed Routes on the Map 
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11.3  Zoom Options 

The PC*MILER map window features 20 possible zoom levels.  You’ll see the 
current zoom level in the window’s title bar (e.g. “Zoom Level 14 of 20”).     
 
To zoom into a specific area, select the Box Zoom control in 
the upper left corner of the Map window. Then drag a box 
around the area: press and hold the left mouse button down 
and drag the cursor on the map.  Repeat to zoom in closer. 
 
 
To zoom directly to a stop you entered in the route window, highlight it on the 
stop list, then do one of the following:  

• double-click the highlighted stop; 
• right click the stop name and select Zoom to Stop from the menu; 
• select the Routes tab > Frame; 
• or choose Zoom to Stop from the right mouse menu off the map. 

Other ways to zoom your view of the map are:  

• double-click a point on the map; 
• use your mouse’s scroll wheel: rotate the mouse wheel up to zoom in and 

down to zoom out; 
• or choose Zoom In or Zoom Out from the right mouse menu off the map. 
 

11.4  Drag Map or Pan To Shift the View 

Drag the Map: 
To drag the map, select the Drag control in the upper left corner 
of the Map window.  With your cursor (now in the shape of a 
hand) in the map window, hold the left mouse button down and 
drag in the desired direction.  The map will redraw the new view. 
 
The Drag control stays on until you select the Box Zoom control 
(section 11.3 above). 
 
Pan: 
Select Pan in the right mouse menu off the map, then select a direction.  The map 
view will shift incrementally in the chosen direction.  You can also pan using the 
scroll bar (section 11.5 below). 
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11.5  Scroll Bars in the Map Window 

The PC*MILER map window includes scroll bars that are hidden from view until 
activated.  To activate, touch any edge of the map window with your cursor and a 
translucent scroll bar will appear.  Click on it to move the map incrementally in the 
direction indicated by the arrow, or click and hold to pan your view. 

 
 

 
 
 
 

 
Scroll Bar for Map Panning 

11.6  Legends  
To hide or display legends on the map, select the Map tab > Legends.  Each legend 
can be toggled on/off.   
 
A legend can be moved to any position on the map – click and drag it to the desired 
location.  Available legends are: 
 
• Road Legend: Shows how PC*MILER road 

classes appear on the map.  This legend is 
displayed by default.  Road colors will depend on 
which map style is chosen. Some road types are 
listed only if they are turned on for display in the 
Map Features dialog (see section 11.7). 

 
  

Scroll Bar with 
Directional Arrow 



  

 
 Chapter 11:  Using the PC*MILER Map Window 180 

Road types included in each road class are: 
 

Interstate Multi-lane toll free and urban highways 
Major Highway Major highways, urban access roads 
Toll Toll roads and urban highways  
Primary Non-divided highways 
Secondary Non-divided highways, urban access roads, ferries 
Ramp Exit and entrance ramps 
Local Truck-discouraged roads (as defined by PC*MILER) 
Ferry Ferries 
Closed Temporary road closure. 
Discouraged* Not compatible for trucks, as determined by 

PC*MILER 
Restricted* Most kinds of trucks prohibited, as determined by the 

controlling governmental authority.  Appears if “Truck 
Restrictions” is checked in the Map Features dialog.    
* For more on truck-discouraged vs. truck-restricted roads, see 
sections 1.6.7 and 10.3.2. 

Designated Designated 53' road network (these roads have either 
“State Oversized”, “Oversized Access”, or “National 
Network” designations on them).  Appears if 
“Designated Truck Routes” is checked in Map Features. 

Comm 
Prohibited 

Roads that are prohibited for commercial truck traffic.  
Appears if “Commercially Prohibited” is checked in 
Map Features. 
 

• Route Legend:  Appears if at least one route window is open; provides a key 
to the color(s) used to draw each generated route on the map.  Routes are listed 
in the order they were generated. 

 
 

• Scale of Miles:  A standard component of most maps, providing the scale of 
miles/kilometers.  Appears by default.  To change from miles to kilometers, go 
to File menu > Application Settings > Units > Length and Distance in. 
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• Hazmat Legend:  If the PC*MILER|Hazmat add-on data module is installed, 
a legend showing hazmat restrictions will be available. 

 
 
 

• Traffic Legend:  For PC*MILER|Traffic subscribers only, this legend shows 
the significance of the colors used for traffic flows on the map. 

 

 
 

 
 
 
 
• Road Conditions Legend: For PC*MILER|Weather subscribers, the legend 

shows the colors associated with current road conditions as well as road 
conditions up to 24 hours in advance. (Road conditions are informational only 
and are not used in route calculation.) 
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• Weather Alerts Legend:  For PC*MILER|Weather subscribers, this legend 
shows the colors of the different areas of the map that are under various kinds 
of weather alerts. 

 

 
 

11.7  Hiding, Displaying and Layering Map Features 

To choose which map features are drawn on the map and in what order, select the 
Map tab > Map Features, or choose Features... from the right mouse menu off the 
map to bring up the Map Features dialog. 
 
 

 
Map Features Dialog 
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Checked features will be displayed – click any check box to toggle between hiding 
and displaying an individual feature.  Click Show All or Hide All to check or 
uncheck all listed features.  Click on the Reset button to return to the default 
settings. 
 
Click OK to close the Map Features dialog and redraw the map. 
 
 
TIPS:  Truck Restrictions and Commercially Prohibited:  Note that by default 
“Truck Restrictions” and “Commercially Prohibited” are turned on in the map 
display; and truck-restricted roads are highlighted on the map. Refer to the Road 
Legend to see the color of the highlight that is used in the active map style for these 
roads. 
 
Points of Interest: If your map is too cluttered with points of interest, uncheck 
“Places” to hide them. 
 

11.8  Map Styles 
The PC*MILER map window can be drawn in one of nine available map styles.  
Each style features a different color scheme and overall appearance.  Available 
styles are Classic, Contemporary, Default, Lightness, Black and White, Night, 
Road Atlas, Satellite, and Smooth.  
 
To change the map style, select the Map tab > Map Style > and click on one of the 
style options. 

 

11.9  Satellite Image Layer on the Map 
(Requires Internet connectivity)  To display a photographic satellite image 
superimposed onto the PC*MILER map, select the Map tab > Map Style > Satellite; 
or turn the “Satellite Imagery” feature on in the Map Features dialog (Map tab > 
Map Features).   
 
Satellite imagery in PC*MILER is provided by Digital Globe, Inc. 
 
For best visibility, the map should be zoomed in to at least Zoom Level 10.  (The 
zoom level is displayed in the title bar of the map window – see section 11.3 on the 
many ways to zoom your map view.) 
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Satellite Map Image (Zoom Level 16) – Chicago, IL 

(Satellite imagery provided by Digital Globe, Inc.) 
 
 

If the Satellite map style is selected and satellite images are temporarily 
unavailable, the map will display a white background with gridlines across it similar 
to the image below. 
 
 

 
Satellite Images Temporarily Unavailable 
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11.10  Route Distances and Drive Times on the Map 
Select the Map tab > Tooltips > Route Distance to have a tooltip appear when you 
place your cursor over a generated route on the map.  The tooltip will show the 
distance between the selected point and the route’s origin, and between the selected 
point and the route’s final destination. 
 
 

 
Tooltip on Route Near Bowling Green, KY 

 
 

The estimated number of on-duty hours from the origin of a route is automatically 
shown on the map when a route is generated: 
 

 
Hours:Minutes from the Origin of a Route 

 

11.11  Right Mouse Map Menu 

A right mouse menu off the map window is available to give you quicker access to 
frequently-used map options.  To use it, place your cursor in the map window and 
click the right mouse button, then highlight the option you want.   
 
The features in this menu are described in other sections of 
this User Guide.  Refer to the Index or Table of Contents, or 
search for a keyword in the document. 
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11.12  Stops and Turn Restrictions 
 

11.12.1  Stops 
 
Stops are represented on the map by circle icons with borders of different colors: 
green for the origin of a trip and red for the destination, deep blue for a stop, light 
blue for an HOS rest stop, and gray for a waypoint. 
 
 

 
Origin, Stops, HOS Rest Stops, and Destination on the Map 

 
 
By default, each stop is labeled with the name, address (if entered) and ZIP code of 
the location, or its latitude/longitude position.  Stop labels can be toggled on/off by 
selecting the Map tab > Stop Labels, or by selecting Stop Labels in the right mouse 
menu. 
 
 

11.12.2  Turn Restrictions 

On the map, turn restriction icons (such as no-right or no-left) are displayed as 
black arrows inside red circles. To show or hide them, right-click the map and 
select Turn Restrictions from the menu. 
 
 

              
 

  
Restrictions Turned Off Restrictions Turned On 
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11.13  Using the Mouse To Pick Stops   
PC*MILER gives you the ability to enter stops in the route window directly from 
the map window without typing.  You can use the mouse to select any point on a 
highway, labeled city, unlabeled location, intersection, truck stop, or 
latitude/longitude point.  See section 3.5.25 for a description of this feature.   

 
TIP:  When your cursor hovers over the map, its latitude/longitude position is 
automatically tracked and appears in the status bar in the lower left corner of the 
program window. 
 
Here’s an easy way to enter a latitude longitude point: right mouse click on the map 
and choose Copy Latitude/Longitude, then click in a route window’s city field and 
paste (Ctrl-V or Paste in the right mouse menu).   
 

11.14  Points of Interest on the Map (U.S. only) 

PC*MILER offers as a standard feature the ability to search, display and route to 
millions of points of interest (POIs) from ALK Technologies’ proprietary location 
database and Infogroup’s U.S. business database.  Truck stops, weigh stations, 
business locations, rest areas, intermodal ramps, and many other landmarks are 
visible on the map.  POI categories that you might see on the map are listed below.  
Use the POI search tool in any route window to search for POIs (see section 3.12). 
 

TIP:  If the map is too cluttered with points of interest at a particular location, select the 
Map tab > Map Features and uncheck “Places” to hide them.  

 

   

 Address 

 Airport 

 ATM 

 Attraction 

 
Auto 
Dealership 

 Auto Rental 

 Auto Repair 

 Bank 

 Border Crossing 

 
Bridges and 
Tunnels 

 Bus Stop 

 Cat Scale 

 Commuter Rail 

 
Distribution 
Center 

 Entertainment 

 Favorite 

 Ferry 

 Fuel Stop 

 Games 

 
Geographic 
Feature 

 
Government 
/Municipal 

 Grocery 

 Home 

 Hotel 
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Industrial 
Estate 

 
Intermodal 

 Live Search 

 LiveLink Kiosk 

 Marina 

 
Marker 
(generic)* 

 Medical 

 
Motorcycle 
Dealer 

 Park 

 Parking 

 
Place of 
Worship 

 Public Venue 

 Recent 

 Recreation 

 
Recreation 
Vehicle 

 Rest Area 

 Restaurant 

 Retail 

 Safety Camera 

 School 

 
Tandem Trailer 
(LCV) Lot 

 Toll Booth 

 Train Station 

 Truck 

 Truck Stop 

 
Vehicle 
Charging 

 Web Result 

 Weigh Station 

 Wikipedia 

 Work 

 
Blank 
(white square) 

 

 
* This generic marker category includes Custom Places and highway exits. 
 

11.15  Printing or Copying a Map 
The map in the PC*MILER map window can be printed or copied.  
 
To print the map, either select the File menu > Print Map or select the Map tab > 
Print Map.  A standard Windows® setup dialog for printing will open. 

 
To copy a map to the clipboard for pasting into another Windows program, select 
the Map tab > Copy Map. 
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Custom Routing 
 
 
PC*MILER provides a number of ways to customize routing, described in this 
chapter, including via point creation, dragging a route on the map, avoid and favor 
preference designations, truck and hazardous material restriction overrides, and 
geofence options. 
 
IMPORTANT NOTE:  To back up your customized data, see section 12.5 in this 
chapter.  
 
  

12.1  Picking Roads to Avoid or Favor  

IMPORTANT:  Your avoid/favor preferences will affect routing only when 
Routing Preferences > Custom Roads > Use Avoid/Favors is selected in the 
Route Options dialog or current route profile.  This option is turned off by default.    
 
You may wish to indicate road segments that PC*MILER should avoid or favor 
when generating a route.  An avoided road segment is effectively treated as if it 
were closed unless no other road can be used for the route, or if the total trip 
distance would be increased to the point of unacceptable inefficiency.  Favored 
road segments will be used unless it is not practical to do so.  Preferences are 
saved in a file called “avoidfavors.db” in the Data\Base\Save or Data\WW\Save 
folder of your installation. 
 
Road segments to avoid or favor can be picked from the PC*MILER map window.  
Alternatively, you can use the map provided in the Avoid/Favor Manager dialog – 
see section 12.1.1 below for a description of this Manager.  Here are the steps to 
create a road preference using either map: 
 
1. First select the Tools tab > Avoid Roads or Favor Roads.   

2. On the map, the cursor will now appear with a minus or plus sign. Click on 
the road segment to be avoided/favored (zoom in for a closer view if 
necessary).   

 

3. An Add Comments prompt will appear on the map.  Adding a comment is 
optional.  Any comment you type in will be saved along with the avoid/favor 
when you click OK.  If you do nothing, the dialog will close on its own as 
soon as another action is initiated.  (A comment can also be added at a later 
time in the Avoid/Favor Manager – see section 12.1.1 below.)  If you don’t 
want the Add Comments box to keep popping up, uncheck “Show this 

C
ha

pt
er

 
12 
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window whenever adding Custom Roads”.  To activate this feature again, 
go to the File menu > Application Settings > General tab, check Show 
Comment Box, and save your edit. 

 
 

 
Add Comments Dialog 

 
 
4. The selected road segment will be highlighted red if it’s to be avoided or 

green if it’s to be favored. You may need to click on several adjoining 
segments to cover the entire area you wish to designate.   

 
 

 
Avoid and Favor Designations on the Map – Dallas, TX 

 

5. If you want to cancel an existing avoid/favor on the map, click on it with the 
Avoid Roads or Favor Roads tool selected.  

 
NOTE on Favored Roads:  The PC*MILER long-distance “backbone” contains 
the roads that PC*MILER uses for its default Practical and Shortest routes over 
long distances.  If a favored road is not in the PC*MILER long-distance backbone, 
it will not be used for long-distance routes even if it is favored, unless an 
intermediate stop on that road is inserted into the route. 
 
 
 
 

Avoid 

Favor 
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12.1.1  Using the Avoid/Favor Manager 
 
All avoid/favor road preferences are saved in the Avoid/Favor Manager.  To open 
this dialog, select the Tools tab > Manager or press Alt+F2 on your keyboard. 
 
In this Manager you can create, delete, edit or export existing avoid/favor 
preferences using the tabs, buttons and map provided.   
 
 

 
Avoid/Favor Manager 

 
 

The Avoid/Favor Manager map includes most but not all of the functionality that 
exists in the PC*MILER map window.  It can be used just like the PC*MILER map 
to designate or delete road preferences – click one of the avoid/favor buttons at the 
top, then click a road segment on the map to add it to the list in the corresponding 
tab above.  To zoom your map view to a road segment listed in any tab of the 
Manager, first highlight it in the applicable tab and then double-click. 
 
See section 12.1.2 below on overriding truck restricted roads, and section 12.1.3 on 
overriding hazardous material restrictions to accommodate hazmat permits. 
 
To delete an individual custom road segment from any tab in the Manager, 
highlight it and click the “X” on the far right.  Click Delete All to delete the entire 
contents of the list in any tab.  
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To add or edit a comment, highlight an avoid/favor on the list then, in the 
highlighted row, double-click in the Comments column. 
 
To save your edits, click the “X” in the upper right corner to close the Manager 
window. 
 
 

12.1.2  Overriding Truck-Restricted Roads 
   
NOTE:  A road that is flagged as “truck-discouraged” (versus “truck-restricted”) 
in the PC*MILER database cannot be overridden only by using the method 
described below.  In addition to overriding the road, you must designate all the road 
segments on it as favored to make it fully truck-accessible (see section 12.1 above).  
To determine if a road is truck-discouraged, refer to the Road legend on the map 
for the color of the highlighting used to indicate a truck-discouraged road. (Truck 
Restrictions must be checked in the Map Features dialog to see truck-discouraged 
roads on the map. This feature is turned on by default.) 
 
A truck-restricted road, as determined by the controlling governmental authority, 
prohibits trucks larger than a certain size and weight.  The visibility of  these roads 
on the map can be selected  in the Map tab > Map Features dialog with the Truck 
Restrictions checkbox.  In accordance with these regulations, PC*MILER does not 
use truck-restricted roads when routing vehicles larger or heavier than the restricted 
size or weight.  However, you can override these restrictions using the Restriction 
Override feature described in this section, to determine the largest and heaviest 
vehicle that can be assigned to a route. 
 
A truck-discouraged road is one that is open for local deliveries, but unsuitable for 
through trucks, as determined either by the controlling authority or by PC*MILER.  
The road may be discouraged because it is narrow, winding, not well paved, or for 
a variety of other reasons.  PC*MILER avoids routing over truck-discouraged roads 
whenever possible, with the following exceptions: if the destination is located on 
such a road; if avoiding the truck-discouraged road will add a very significant 
amount of time and distance to a route; or if you have marked the road to be favored. 
 
If you have questions about truck restrictions, please contact each jurisdiction 
directly.  
 
TIP:  To set PC*MILER to override truck restrictions by default, click the Routes 
tab > Profiles and edit the Default route profile (or whichever profile you use 
regularly): select the Routing Preferences tab and set Restrictions to Override, 
then save your edit. 

 
IMPORTANT:  Your avoid/favor preferences will affect routing only when 
Routing Preferences > Custom Roads > Use Avoid/Favors is selected in the 
Route Options dialog or current route profile.  This option is turned off by default.    
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PC*MILER normally routes around all truck-restricted roads.  However, some of 
these restrictions may be overridden by the user, making the roads accessible. (This 
assumes that you have been granted permission to use these roads from the 
controlling authority, or that you are going to be using special equipment.) 
 
To see truck-restricted roads highlighted on the map, turn on the Truck 
Restrictions layer in the Map Features dialog.  A “Restricted” category will appear 
in the Road legend, showing the color of the highlighting on these roads. 
 
Overriding restrictions on a road is similar to designating road segments to be 
avoided or favored – you can pick overrides from the PC*MILER map window or 
from the map in the Restriction Overrides tab of the Avoid/Favor Manager.  
Remember though, that a “truck-discouraged” road must be favored as well (see 
NOTE above).   Overrides are indicated by a solid dark blue highlight.  Comments 
can be added if needed.  Be sure to override all segments included on the route; 
otherwise the entire road will continue to be treated as inaccessible. 
 
To undo an override, click on it on the map with the Toggle Overrides tool activated 
or delete it from the Restriction Overrides tab of the Avoid/Favor Manager. The 
road will be restored to its original truck-restricted status.  
 
 

 
Restriction Override on the Map – Kingston, NJ 

 
 

12.1.3  Hazmat Permit Overrides 
 
To change the status of roads that are restricted for hazardous materials, see section 
13.3.  To transport hazardous materials on these roads, the applicable permits must 
have been obtained. 

\ 
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12.1.4  Creating Sets of Custom Road Preferences 
 
The Avoid/Favor Manager enables you to manage multiple sets of custom road 
preferences by allowing you to create and save sets of these preferences.  You may 
find that custom sets are a useful tool for working with special equipment you 
operate, or for seasonal routing requirements.  Sets can include road segment 
avoids/favors, and hazmat and truck restriction overrides.  
 
IMPORTANT:  The Avoid and Favor tools won’t be available if there is no set 
selected in the Avoid/Favor Manager, or if more than one set is selected. 
 
NOTE:  Many states and provinces in the north central part of the North American 
continent have seasonal weight limits that apply either to all commodities or to 
particular commodities (such as grain) at certain times of year (harvest season, 
winter, spring thaw, etc.). 
 
In these areas, the carrier typically works with the shipper to adjust how much 
material is loaded into the truck in order to max out the limit for the season in 
question, rather than adjust the route traveled.    So (for example) more grain would 
be loaded into the truck during harvest season or winter than during spring thaw, in 
order to have a legal load when an origin or destination is on a road with a seasonal 
limit.    In addition to legal considerations there are also practical physical 
considerations since many loading and unloading points in that part of the country 
are on unpaved surfaces, and to overload a truck during spring thaw risks the truck 
getting stuck during pickup or delivery. 
 
PC*MILER has the weight limit coded that applies to general commodities during 
most seasons of the year.   For situations where the low-limit road is used as a 
through route rather than for pickup or delivery, the Sets feature described below 
can be used to create avoid/favor/restriction override “sets” for each season of the 
year for each commodity. Custom routing must be turned on in the Route Options 
dialog or the active route profile; then use the set that applies for a specific 
commodity at the appropriate season of the year. 
 
REMEMBER:  Your avoid/favor preferences will affect routing only when 
Routing Preferences > Custom Roads > Use Avoid/Favors is selected in the 
Route Options dialog or current route profile.  This option is turned off by default.    
 
To create a set, do the following: 
 
1. Select the Tools tab > Manager to open the Avoid/Favor Manager. 

2. Click Create Set in the lower left corner. 

3. At the prompt, enter a Name for the new set. 
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4. Click Save. 

5. You will see the new set under Available Sets on the left.  Uncheck the 
DefaultNA set and any other existing sets that are checked in this list. 

NOTE: If more than one set is enabled in the Avoid/Favor Manager, the 
avoid/favor buttons in the Tools tab will be disabled. 
 

6. Now you can begin to add road segments in any tab of the Manager.  These 
avoid/favors will be specific to this set.  The set you are adding them to must 
be the only set selected in the Available Sets list. 

Note the following guidelines for creating new sets: 
 

• Set names cannot be longer than 50 characters, and must be comprised of 
letters and/or numbers. 

• Spaces are not allowed in the set name, but underscores (“_”) are 
permitted.   

 
To delete an individual set, place the cursor over the set name and click the “X” 
that appears on the right: 
 

 
Deleting a Set 

 
 

To delete all sets, click the Delete All Sets button in the lower left corner.  The 
Default NA set cannot be deleted. 
 
When more than one set is checked, all preferences included in the active sets will 
be visible on the map and listed in the corresponding tabs.  However, only one set 
must be active when you want to add or delete preferences to a set.  When multiple 
sets are active, the Favor Roads, Avoid Roads, Toggle Overrides, and Adjust 
for Permit buttons will be grayed out on the toolbar and in the right mouse map 
menu. 
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12.1.5  Exporting Custom Roads Data To a Report 
 
To create a report in a text file (.txt) or Excel file (.csv) that contains all the 
preferences in the open tab of the Avoid/Favor Manager, click Export All.  In the 
dialog that opens, name the file and choose a file format from the Save as type 
drop-down.  Here are examples of the two types of file formats (the formatting in 
these files has been edited): 
 

 
Exported File of Avoided Roads in .TXT Format 

 
 

 
Exported File of Avoided Roads in .CVS Format  
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12.1.6  Avoiding or Favoring Whole Roads or States/Countries 
 

REMEMBER:  Your avoid/favor preferences will affect routing only when 
Routing Preferences > Custom Roads > Use Avoid/Favors is selected in the 
Route Options dialog or current route profile.  This option is turned off by default.    
 
In addition to the road preferences described above, whole roads and whole states 
can be selected to be avoided/favored for a route using the States/Roads Manager.     
 

Avoid or Favor a Whole Road 
 
NOTE for PC*MILER|Streets Users:  You cannot designate a local street by 
name to be avoided or favored in the Roads Restrictions tab; a local road can only 
be avoided/favored by designating it as such on the map.  

 
To select whole roads to be avoided/favored: 

 
1. Select the Tools tab > States/Roads > Roads Restrictions tab. 

 

 
States/Roads Manager, Road Restrictions Tab 

 

2. Select a state (or country) from the State drop-down. 

3. Type the road name* in the Road Name field (e.g. I 95) without a state 
abbreviation. 

4. Click Avoid or Favor under the road name.   
 
 
To delete a road from one of the lists, place the cursor over it and click the “X” that 
appears to the right.  To clear either list, click Clear All. 
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 *  To see how the name of a particular road appears in the PC*MILER database, 
you can zoom to that road on the map and place your cursor over the road 
without clicking.  Some highway labels may include a common name along 
with the road number; for example, “Pennsylvania Turnpike (I 276)”.  In these 
cases, use the road number from within the parentheses (“I 276” in this 
example). 

 
NOTE:  You won’t see any indication on the map that a whole road or whole 
state/country has been designated to be avoided or favored.  To see the difference 
a designation makes on a route, first run the route with Use Avoid/Favors turned 
off and run the same route with this option enabled (Route Options or Profile 
Options dialog > Routing Preferences > Custom Roads > Use Avoid/Favors.   
 
 

Avoid or Favor Whole States/Countries  
 

Whole states can be avoided or favored on a route.  If PC*MILER|Worldwide or 
DTOD Data is installed and a region other than North America is selected, whole 
countries can be avoided/favored as well.   
 
1. Select the Tools tab > States/Roads to open the States/Roads Manager.  
 
2. VERY IMPORTANT:  Make sure “Enable” is checked in the upper left 

corner of the State Restrictions tab. 
 
3. Select a state (or country) from the States pick list. 
 
4. Click either Avoid or Favor to add to the desired list. 
 
To delete a state (or country) from one of the lists, place the cursor over it and click 
the “X” that appears to the right.  To clear either list, click Clear All at the bottom 
of the list. 
 

 
States/Roads Manager, State Restrictions Tab 
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12.1.7  Converting Custom Road Files from a Previous Version  
 
Saved custom road preferences from the previous version of PC*MILER can be 
imported using PC*MILER’s file conversion utility as in the steps below.  
  
1. Select the Tools tab > Convert.   

2. Click Import and navigate to your existing custom road file(s) that are located 
in the Data\Base\Save folder in your PC*MILER 30 installation folder – 
select the file avoidfavors.db. 

3. After you select the file(s), click Open to start the import.   

4. Once the import process is complete, check to make sure all the avoid/favors 
were imported successfully.  Due to changes in the highway and street-level 
network database over time, some avoid/favors may not be successfully 
imported.  Double-clicking on any listed road segment in the Conversion 
Utility dialog will zoom to that segment on the map where you can edit your 
preferences further if necessary.   

 
IMPORTANT NOTE:  Because of enhancements to the PC*MILER database that 
incorporate express, local, north/south and east/west lanes, etc., some of your 
avoid/favor/override designations from a previous version may need to be edited 
link-by-link to be sure the designated preference will operate in both directions.  
 
In the Avoid/Favor Manager, open the Avoid, Favor, Restriction Overrides or 
Haz Permits tab to see a list of your preferences. Then zoom in to the maximum 
level (20) on each listed link on the map (you can double-click each link to do this) 
and make sure that lanes in both directions are marked with the desired designation.    

 

12.2  Using Via Points For Route Customization 
PC*MILER gives users the ability to enter and save up to 12 via points between an 
origin and destination to guide a route along user-preferred roads.   
 
The via points you create can be designated as stops or waypoints.  The “waypoint” 
designation means that these locations were added only to guide the route along 
desired roads.   Waypoints are treated like stops on the map (routes travel through 
the centroid of a waypoint town or city), but they don’t appear in the driving 
instructions in the Driver’s Report and are marked as a “Via” in the Detailed route 
Report.  Waypoints appear on the stop list as circles with a gray border.  When 
using PC*MILER|TripDirect and CoPilot, the navigation system will tell drivers to 
stop at a stop or to drive through a waypoint. 
  
Via points are saved in a set and the option to enter them will be offered whenever 
the route segment for which they were created is included on a trip.  For example, 
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vias for a trip leg between Baltimore and Chicago can be entered with a click of the 
mouse whenever Baltimore followed by Chicago is entered for a route.   
 
To create a via point set, follow these steps either before or after running a route: 
 
1. In a new route window, enter at least two stops. 

2. Highlight the stop that you wish to designate as the origin.  This need not 
be the origin of the route if multiple stops are entered.  You will be creating via 
points between this highlighted stop and the next destination on the stop list. 

3. Select the Routes tab > Create Via Point Set to open the Via Point Set 
Manager. 

 

 
Via Point Set Manager 

 
4. Under Via Point Location, type a PC*MILER location (city/state, postal 

code, etc.) in the top field and, optionally, a street address underneath. 

5. Under Via Point Type, select whether the point you entered will be a Stop or 
a Waypoint.     

6. Press Enter or click Find Point.  PC*MILER will confirm that the location 
exists in the database – if a pick list appears, make a selection and click OK.  

7. Click Add Point to add this location to the Via Points in Set list.  

8. Under Via Point Set Application, select whether the new set will be applied 
only when the route travels from Origin to Destination, from Destination to 
Origin, or in Both Directions. 

9. Also under Via Point Set Application, the radius around the origin and/or 
destination can be edited (default is 10 miles).  This is the radius within which 
an origin and a destination point must be located to trigger the via points 
option for this route segment.  The radius is defined from the city center or 
postal code center.  
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10. Steps 4-9 can be repeated to add up to 11 additional via points to the set. 

11. When finished adding points, click Save Set to save the new set then click 
Close to close the dialog. 

12. In the route window, you’ll see a line inserted into the stop list under the 
specified origin for the via point set.  Click the Add Via Set button on this 
line to add the point(s) to the stop list.  If you decide not to use the via point(s) 
for this route, ignore this button and they won’t be used. 

 

 
“Add Via Set” Button in the Route Window 

 

 
13. Click Run to run the route.  If you activated the via point set as described in 

Step 12, the route will travel on the preferred roads through the via point(s).   
  

To Edit a Set: 
To edit a set at any time, select the Routes tab > Manage Via Point Sets.  Then 
select the set you want to edit from the drop-down of sets, make your changes, and 
click Save Set. 
 
Editing options include: 

• Rename the set – click Edit Set Name, enter a new name, then click 
Rename. 

• Delete the set – click Delete Set in the upper right corner of the dialog.  
This action cannot be undone. 

• Change the direction to which the set will be applied. 

• Add more stops or waypoints as described above. 

• Change the via point type – select a point on the list then click Stop or 
Waypoint. 

• Delete one or more via points – select a point on the list and click Delete 
Point. 

• Change the order of points in the set – select a point on the list and click 
Move Up or Move Down. 
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12.3  Dragging a Route on the Map 
Once a trip has been generated, any point along the generated route on the map can 
be dragged onto another road in order to re-route the trip. 
 
NOTE: When Hub Routing is enabled, Drag Routing is disabled. 
 
To drag a route, do the following: 
 
1. Select the Routes tab > Drag Route.   
 
2. In the PC*MILER map window, click on the route and hold down the cursor, 

then drag to the desired location and let go.   
 
3. This action will create a waypoint at the location to which the route was 

dragged, indicated by a gray circle icon. The trip will be re-routed to 
accommodate the new waypoint.   

 
 
 
 
 
 
 
 
 
 
 
 

 

12.4  Geofence Options 
PC*MILER provides tools that enable you to create, modify and manage geofences.  
A geofence defines a geographic area that will either generate an alert when a route 
enters it, or will be avoided by the route.  Its use has many different applications, 
such as: 

 
• Drawing zones around a warehouse to identify delivery/billing zones 
• Alerting dispatchers when a vehicle enters an area that it wasn’t 

authorized to enter –  for example, leaving the country 
• Avoiding or warning about steep grades, mountain passes susceptible to 

snow closures, tunnels requiring escorts, etc. 

Original Route New Route Created by Dragging 
 

New Via Point 
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• Avoiding or warning if an asset has crossed into a high crime or high 
accident area 

• Avoiding or warning about areas where bad weather is expected or has 
occurred: heavy snowfalls, floods, hurricane evacuation areas, etc. (also 
see the PC*MILER|Weather Alerts feature, see Chapter 8). 

 
The geofence tools in PC*MILER allow users to: 

 

• Create and modify the characteristics of a geofence: 
- Define its size and shape as a circle, rectangle, or a user-defined polygon 
- Give the geofence a unique name (with  the exact text that will appear 

in report warnings) 
- Delete the geofence 

• Identify points and roads that fall within the boundaries of a geofence 
• Group geofences into sets and assign and modify the characteristics of a set: 

- Create and uniquely name a set with the name that will appear in report 
warnings 

- Define the border color, border width and fill color of the geofences in 
the set 

- Define the set properties: off (not active), warning only, or avoid and warn 
- Delete the set 

 
 
12.4.1  Creating a Geofence 

 
NOTE:  There is no limit to the number of individual geofences that can be created 
and added to a geofence set, or to the number of sets that can be created.   
 
TIP:  A geofence that covers a very large area (for example, a whole state) will 
draw very slowly on the map and will affect other map functions that involve a map 
redraw.  Whole states and whole roads can be avoided or favored using the 
States/Roads Manager – see section 12.1.6. 
 
NOTE:  To see geofences on the PC*MILER map or on the map in the Geofence 
Manager, “Geofences” must be checked in the Map Features dialog (Map tab > 
Map Features).  This map feature is enabled by default. 
 
Follow the steps below to create an individual geofence:   

1. Select Tools tab > Geofence Options > Manage to open the Geofence 
Manager. 

2. In this window, use the zoom tools and Drag Map button to zoom into the 
target area on the map. 
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3. Click the Avoid Roads, Favor Roads, Toggle Overrides 

4. Click the Rectangular, Circular, or Polygonal button at the top of the map.  
Depending on which shape you chose, the cursor will change to one of the 
following: 

 

• When drawing a rectangle:  
• When drawing a circle:  
• (Recommended)  When drawing a user-defined polygon:    

If using the circle or rectangle shape, drag the cursor over the desired area.   If 
using the polygon tool, click all the points of the desired perimeter and finish 
by clicking on the first point again to close the polygon.  If you are not 
satisfied with the area that is covered, delete the geofence in the Available 
Geofences list to the right and start over. 
 
NOTE:  Note that alternatively you could use the map and geofence tools in 
the PC*MILER application window to initially create a geofence – open the 
Tools tab > Create Geofence and create a geofence on the map as in Steps 2-
3.  Then open the Manager to rename. 

 
NOTE Also:  See sections 12.4.5 on identifying points and roads that are 
included within the boundary of a geofence. 

 
 

 
Geofence Manager 

 
 

5. In the Available Geofences list, you will see a generic name assigned 
(“Geofence_#”) to the geofence you just created on the map.  (If more than 
one geofence is on the list, they will be listed alphabetically, e.g. Geofence_1, 
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Geofence_10, Geofence_2, etc.)  To assign a unique name to this geofence 
(for example, a geographic location): 

a. Click on the default name. 
b. Click Rename below the list. 
c. In the prompt that pops up, type a new name. 
 

 
 
 
 
 
 
 

d. Click Save. 
 

6. A geofence must belong to a set before a warning status and display properties 
can be assigned to it: 
a. Click Create under Geofence Sets. 
b. Type a name for the new set. 

 
 
 
 
 
 
 
 

c. Click Create.  The set name will appear as the selected set in the 
Geofence Sets list.   

d. Go back to the Available Geofences list, highlight the geofence(s) you 
want to add and click Add To Set.   

 
7. Click OK to close the Geofence Manager.  The geofence(s) you created will 

be saved in the PC*MILER installation folder. 
 

TIP:  To zoom to an existing geofence or set on the map in the Manager, double-
click the geofence name under Available Geofences or the set name under 
Geofence Sets. 
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12.4.2  Customizing Geofence Sets 

 
The properties of each geofence set can be customized in the Geofence Manager.  
All geofences in the set will have the same appearance and activity status.  
Individual geofences cannot be customized. 
  
 
Customizing the Appearance of Geofences in a Set: 
 

 
 
1. Under Customization, select a set from the Applied To drop-down. 
2. To edit the Fill Color or Border Color, choose a new color from the drop-down. 
3. Use the Border Weight drop-down to select a new width for the border. 
4. Click Apply Changes to see these atributes appear on the map. 

 
 

Designating the Behavior of Geofences in a Set: 
 
 1. Under Customization, select one of these Behavior options: 

Off:  Geofences are not active. They do not affect the Detailed Route Report 
and are not visible on the map. 

Warning Only:  Geofences are visible on the map, and a warning will appear 
in the Detailed Route Report at the points where the route begins to travel 
on a road segment that is part of a geofenced area.  The warning will 
include the road name, geofence set name, and geofence name, for 
example: 
Warning * US 69 *: Montana Geofences: ButteMT 

Avoid + Warning:  Geofences are visible on the map.  The route will avoid 
road segments within the geofenced area if the Use Avoid/Favors is 
selected in the Route Options dialog or the current route profile. A 
warning will appear in the Detailed Route Report in cases where the route 
has to enter the geofence (for example, if the destination is within the 
geofenced area). 

 
2. Click Apply Changes to save your selection. 
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Renaming and Deleting Geofences and Sets: 
 
To delete a geofence: 
 

To permanently delete a geofence, highlight it in either the Geofences In This Set 
list or the Available Geofences list and click Delete below the list. 

 

To delete an individual geofence directly from the map: 
 

1. On the map, zoom to the location of the geofence you want to delete. 
2. Click the Delete button at the top of the map.  In Delete mode, your cursor will 

change to look like this:        To exit from delete mode, select Delete again. 
3. Click the geofence(s) you want to delete. 
4. To exit from Delete mode, select Delete again. 
 
To delete a set: 

Under Geofence Sets, select the set you want to delete from the drop-down, then 
click Delete to the right. 
 

To rename a set: 

Under Geofence Sets, select the set you want to rename from the drop-down, click 
Rename to the right, type a new name in the prompt that appears, and click Save. 
 

To edit a set: 
 

To remove a geofence from a set and reassign it to the Available Geofences list, 
highlight it in the Geofences In This Set list and click Remove From Set. 
 
 

Detailed Route Report with Geofence Warning 
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12.4.3  Generating a Geofence Report 

 
To create a report that shows all road segments included within the perimeter of a 
geofence, do the following: 
 
1. Select the Tools tab > Convert > Export Geofences.   

2. In the Save dialog, select a file type (*.txt or *.csv), enter a file name, and 
select a target location where the report will be saved.    

 
To open the report, navigate to the folder where it was saved.  If the report was 
saved as a *.txt file, it will open in Notepad.  If it was saved as a *.csv file, it will 
open in Excel.   
 
This report includes the following data: the name of the geofence, the set that the 
geofence belongs to, the corresponding road segments included in the geofence, 
and the date the geofence was added.  A sample *.txt report for two geofences is 
shown below.   

 
 

 

Geofence Location, Set 
Name, Date Created, Shape, 

and Defining Lat/Longs List of road 
segments in both 
geofences begins 

here. 

Each listed road segment 
includes Segment, Length, 
Nearest Town, Date and 

Set Name 
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Geofence Report in *.txt Format 
12.4.4  Geofence Behavior on the Map 

 
By default, geofences that are created will initially appear on the map with light 
gray fill and a thin red border.  Fill color and border width can be edited as described 
in section 12.4.2. 
 
When a geofence is inactive (not assigned to a set, but still listed under “Availabe 
Geofences”), it will no longer be visible on the map though it is still saved. 
 
There are also two settings in the Map Features dialog that affect the geofence 
display on the map: if Avoids & Favors is unchecked, the blue highlighting that 
designates road segments inside each geofence will be hidden; and if Geofences is 
unchecked, the geofence shapes will be hidden but the blue highlighting on affected 
road segments will still be visible.  All geofences are affected by these settings. 
 
 

12.4.5  Identify Points Within a Geofence Boundary 
 
To determine if particular points lie within a geofence boundary, follow the steps 
below. 
 
1. Select the Tools tab > Geofence Options > Identify. 

2. Enter a location in the City field, with or without an Address.  Any 
PC*MILER location is acceptable, including lat/long points and custom place 
names.  If you enter a city name without an address, PC*MILER will use the 
city center of that town. 

 

 
Geofence Identifier 
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3. Under Search Within, select to search All geofence sets for the location, or 
within A specific geofence set.  Choose a set from the drop-down menu if you 
want to search within a specific set. 

4. Click Search.  All geofences that include the location will be listed under 
Matching Geofences.  If the point is not within the boundary of any 
geofence, a “No matches found” message will appear. 

5. Click Reset to clear the search before entering another location. 

 
12.4.6  Using the Geofences Conversion Utility 

 
If you created and saved geofences in the previous version of PC*MILER, you can 
easily import those files into Version 31 using the Geofences Conversion Utility.  
To do this, follow the steps below.   
 
1. Select the Tools tab > Convert > Import Geofences.  

2. In the window that opens, navigate to the saved geofences in the PC*MILER 
30 installation folder (usually C:\ALK Technologies\PCMILER30\Data\ 
Base\save\geofences).   

3. Select the files in the “geofences” folder and click Open to copy. 

4. When the process is complete, close the dialog.  The geofences should now be 
accessible in Version 31.  

 

12.5  Backing Up Your Custom Files (Strongly Suggested) 
It’s always strongly suggested to back up important files frequently to a different location 
in case the unexpected occurs.  The following customized data in PC*MILER can be 
backed up: 
 

• Custom places 
• Custom roads 
• Geofences 
• Default routing options 
• Default road speeds 
• Routing Profiles 

To  create a backup, copy your files into a separate folder, preferably one that is located on 
a second computer or device.  Your custom data files can be found in a “Save” folder in 
the PC*MILER installation.  The location of the Save folder in different types of 
PC*MILER installations is shown below: 
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• PC*MILER 31 - NA - US/Canada Base 
- C:\ALK Technologies\PCMILER31\Data\Base\save 

 

• PC*MILER 31 - NA - US/Canada Energy 
- C:\ALK Technologies\PCMILER31\Data\NA_Energy\save 

 

• PC*MILER 31 - Highway WorldWide 
- C:\ALK Technologies\PCMILER31\Data\WW\save 

 

• PC*MILER 31 - Streets Africa/Asia/Middle East/Oceania/South America 
- C:\ALK Technologies\PCMILER31\Data\'xx'\save 
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Hazardous Material Routing 
 
 
If the separate PC*MILER|HazMat data add-on module is installed, routing can be 
generated in North America, Europe and Oceania for various types of hazardous 
materials and dangerous goods using any PC*MILER route type.   

To generate a route for hazardous materials, select a Hazardous Materials route type 
in the Route Options dialog > Routing Preferences tab for the open route or 
create/edit a route profile to use for hazmat routing (see sections 10.2 and 10.4). 
 
 

 
Hazmat Route Type Set in Profile Options > Routing Preferences Tab 

 
 

Hazardous material routing options for North America include:  Other, Corrosive, 
Explosives, Flammable, Inhalants, and Radioactive.  When Europe or Oceania 
is the selected region, the options are: Other, Explosives, Flammable, and 
Harmful to Water. (with additional tunnel restrictions categories in Europe – see 
Table 2 below).   
 
Tables 1 and 2 below show how each PC*MILER hazmat route type handles each 
hazmat road category.  Table 3 shows U.S. DOT Hazmat classes and the 
corresponding PC*MILER route type.   
 
NOTE:  The “Other” option should be used for any hazardous material that 
presents a danger during transportation and is not corrosive, explosive, flammable, 
inhalant, or radioactive.  Common examples include: oxidizers (such as compressed 
oxygen tanks), combustible liquids (such as diesel fuel), and poisons (such as 
pesticides). 
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TABLE 1:  PC*MILER Hazardous Material Route Types and Road Categories 

 

favor = routing will prefer these segments 
no change = routing will not be altered in any way 
avoid = routing will go around these segments whenever possible 
discourage = a lesser degree of avoidance, used when a state or road authority allows hazmat only at certain times of day, with 

prior notification, by permit, or in limited quantities, and for tunnels not otherwise classified 
 
 

 
(continued on next page) 
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NOTE: U.S. hazardous material routing restriction/designation information taken from The National Hazardous Materials Route 
Registry provided by the Federal Motor Carrier Safety Administration (FMCSA); and various other state and federal sources.  
Canadian hazmat/dangerous goods routing data derived from government and municipal sources in each Province and Territory, 
and includes restrictions for major Canadian bridges and tunnels. 
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TABLE 2:  PC*MILER Hazardous Materials Route Types and Road Categories – 

EU Harmful to Water and EU Tunnels 
 

(PC*MILER|Worldwide or DTOD Data must be installed)  For PC*MILER|Worldwide and 
DTOD users, the hazmat categories below are used in the Europe and Oceania regions. 
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TABLE 3:  U.S. DOT Hazmat Classes and Corresponding PC*MILER Hazmat Route Types 
 

The table below shows how the wording used for PC*MILER hazmat routing 
options, which is derived from industry-standard placarded descriptions of 
hazardous materials, corresponds to the U.S. Department of Transportation Hazmat 
classifications.  See sections 13.1 - 13.2 below on how to use this table. 
 

U.S. DOT Hazmat Classes (corresponding PC*MILER routing options are bolded): 

Class 1: Explosives – Explosive  
Class 2: Compressed Gases 
              2.1: Flammable Gas – Flammable 
              2.2: Non-Flammable Compressed Gas – Other  
              2.3: Poisonous Gas – Inhalant  
Class 3: Flammable and Combustible Liquid – Flammable  
Class 4: Flammable Solids 
              4.1: Flammable Solid – Flammable 
              4.2: Spontaneously Combustible Material – Flammable  
              4.3: Dangerous When Wet Material – Other  
Class 5: Oxidizers – Other  
Class 6: Poisons 
              6.1: (part) Inhalation Hazard – Inhalant  
              6.1: (balance) – Other  
              6.2: Infectious Substance (Etiologic agent) [“Biohazard”] – Other  
Class 7: Radioactive Materials – Radioactive  
Class 8: Corrosive Liquids – Corrosive (“Caustic” in PC*MILER 22 and earlier) 
Class 9: Miscellaneous – Other  

 

13.1  Determining Which Route Type to Use 

NOTE:  Hazmat regulations for a particular tunnel on a route should be checked if 
there is any doubt about which materials are permitted, as regulations may change 
over time and might not be included in the version of the PC*MILER database that 
you are currently using. 
 
The shipper of hazardous materials is legally responsible for determining the U.S. 
DOT Hazmat Class for their shipment and communicating that class to the carrier 
in their shipping papers. 
 
To determine the U.S. DOT Hazmat Class, go to the online 49 CFR 172.101 at 
www.ecfr.gov.  Once the Class is identified for a shipment, use Table 2 above to 
determine which route type should be used when generating a PC*MILER route 
for that shipment. 

http://www.ecfr.gov/
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For example, on the government web site, hydrogen is classified as a Flammable 
Gas (DOT class 2.1), while oxygen, nitrogen, carbon dioxide, and argon are Non-
Flammable Compressed Gases (DOT class 2.2). 
 
Using Table 2 above, DOT class 2.1 corresponds to the PC*MILER Hazmat route 
type “Flammable”, while DOT class 2.2 corresponds to the PC*MILER Hazmat 
route type “Other”.  
  

13.2  Routing Multiple Hazmat Classes 
For routing a single shipment containing multiple hazmat classes, the following 
procedures are suggested: 
 
1. First, determine the weight of each commodity and check the U.S. DOT 

(PHMSA) rule to see if that combination is permissible and if so, which 
placard(s) are to be used. 

2. Then, for each placard, look up the PC*MILER|Hazmat routing options in the 
table above. 

 a. If all the placards correspond to one routing option, use that option. 
 b. If the placards correspond to multiple routing options, then run the route 

 for each option, and: 
  i.  If all the routes are the same, that common route is the route to be used. 
  ii. If the routes are different, then there may or may not exist a legal route  

     for that combination of commodities for the specified origin/destination  
     (this will occur only rarely). 

 

13.3  Changing the Status of Hazmat-Prohibited Roads 
Customers who have obtained permits can change the status of hazmat-prohibited 
roads as follows: 
 

1. First make sure “Hazmat” is checked in the Map Features dialog (Map tab 
> Map Features).   

2. Select the Tools tab > Adjust for Permits. 

3. In the map window click on the prohibited road(s) that you wish to make 
accessible for routing.  The adjusted route segments will change color (the 
color will depend on which map style is currently active).  

 
All user-created road preferences are saved and managed in the Haz Permits tab 
of the Avoid/Favor Manager (Tools tab > Manage – see section 12.1.1).  A 
comment may be added to each record, either by typing a comment in the Add 
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Comment dialog that appears when a road segment is clicked or by entering it 
directly in the Avoid/Favor Manager.   
 
 

 
Hazmat Restriction Override Shown on the PC*MILER Map 

 
 
The custom road settings you create can be removed by clicking again on the same 
roads with the Adjust for Permits tool active, or by using the Avoid/Favor 
Manager. 
 

13.4  Hazardous Material Routing on the PC*MILER Map 
 

 
Map Showing Hazmat Restricted Roads & Restrictions Legend 

Restriction Override 
near Greenville, RI 
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With the PC*MILER|Hazmat add-on data module installed, hazmat-prohibited and 
-designated roads will be highlighted in the PC*MILER map window provided this 
feature is checked in the Map Features dialog (see TIP below). The Restrictions 
legend shows the highlight color for various designations (to show/hide this legend, 
select the Map tab > Customize > Legends). 

 
 

TIP:  If you don’t want hazmat routing to show up on maps, the highlighting can 
be hidden from view by turning off the Hazardous Material feature in the Map 
Features dialog.  Select the Map tab > Map Features and uncheck “Hazardous 
Material”, then click OK to save. 
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Using PC*MILER|Energy 
 
 
PC*MILER now offers users an integrated energy-focused map data set for the oil 
and gas industry.  Through partnership with GEOTrac Systems Inc. of Calgary, 
ALK has created the PC*MILER|Energy data set that includes access roads and 
infrastructure coverage across states and provinces in North America where oil and 
gas wells are actively developed and known reserves are found.   
 
PC*MILER|Energy is available as a separate add-on data module for PC*MILER 
(your PC*MILER installation must also include the PC*MILER|Streets).  With 
these three modules installed, PC*MILER|Energy gives users the ability to: 
 

• plot the latitude/longitude of a wellhead, facility or land survey address 
and route directly to it, then view that route on the PC*MILER map; 

• generate turn-by-turn directions on leased or bonded roads in and out of 
well sites and other facilities; 

• assign a custom average road speed to all roads classified as “Energy 
Road” in the PC*MILER|Energy dataset for ETA accuracy; 

• switch between the base PC*MILER map data set, accessible to general 
users of PC*MILER, and the PC*MILER|Energy oil- and gas-specific 
data set; 

• use the PC*MILER Import Custom Place Wizard to customize the 
PC*MILER database with specific wellhead, facility and land survey 
addresses, and group those locations into one or more POI (point of 
interest) category (see section 3.15.5). 

 

 
Satellite View of a PC*MILER|Energy Route To a Wellhead 
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PC*MILER also gives users access to land survey addresses from the Public Land 
Survey System (PLSS) and the Dominion Land Survey (DLS) including Land 
Survey Grids (LSDs)*.  Land survey POIs give users the ability to route to locations 
on roads that were created too recently to be included in the most current update of 
PC*MILER’s energy road database. 
 

*  Oil and Gas field content provided by GEOTrac Systems Inc.  
 

14.1  Accessing the PC*MILER|Energy Data Set 
With PC*MILER|Energy data purchased and installed, select the Map tab > 
Change Data Set and select NA Energy.  (If PC*MILER|Energy data has not been 
installed yet, see section 2.5.5.)  The currently loaded data set will be displayed in 
the title bar of the PC*MILER map window, shown at the bottom of each page in 
any reports that are generated, and checked in the Change Data Set menu.  To 
switch to another data set, simply select it in the menu. 
 
To route with the Energy data set, the Highway & Streets option must be selected 
as a route option or profile option (see sections 10.2-10.4) and the region must be 
North America in Application Settings (see section 10.1.1).  Options listed at the 
top of the route entry window should include “Streets”, indicating that local streets 
will be included in routing calculations, and “North America” as the region. 
 
 

 
Change Data Set Menu 

 
 

14.1.1  Searching for Land Survey Addresses 
 
If PC*MILER|Energy and PC*MILER|Streets are licensed and installed, 
PC*MILER|Energy users now have access to land survey addresses from the Public 
Land Survey System (PLSS) and the Dominion Land Survey (DLS) including Land 
Survey Grids (LSDs).  Users can search for a land survey name using an exact 
character match.  These locations can be added as stops on a route, saved as custom 
places, and displayed on the map.  
 
To search for a survey address, follow the steps below. 
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1. In a route window, click the stop format drop-down and select Survey Address. 
 
2. Enter a full survey address. 
 

Example: SW NW S27 T010N R020W 
 
3. Make a selection in the pick list that opens and click OK. 
 

 

 
 
 

 
 
 

 
Generated Trip To a Survey Address 
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14.2  PC*MILER|Energy Routing and Mapping 
With the NA Energy data set selected and local street routing activated, you are 
ready to generate PC*MILER routes directly to the latitude/longitude points where 
wellheads or other oil and gas facilities are located, using leased or bonded access 
roads to get there.  For lat/long formats that PC*MILER accepts as stops, see 
section 3.5.17.  Use the 6-digit decimal format for precision and best results. 
Locations can also be picked off the map using the mouse – see section 3.5.25.   To 
change the map to a satellite view, select the Map tab > Map Style.  An Internet 
connection is required to display satellite images. 
    
The two routes shown below illustrate the difference between a route calculated 
using the PC*MILER|Energy data set and one that does not use the Energy data.  
The route run without Energy data uses the air distance between wellheads. 

 
 
 

 
Routing at a Well Site Near Odessa, TX – Using Energy Data 

 
 
 

 
Routing at a Well Site Near Odessa, TX – Without Energy Data 

(Route Uses Air Distances) 
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14.3  Energy Roads in Reports 
Roads that provide access into and out of well sites and other energy-related 
facilities are classified as “Energy Roads” on the PC*MILER map and in 
PC*MILER reports.  Examples of how Energy Roads are identified in three report 
types are below. 
 
 

 
Driver’s Report (Driving Directions) 

 
 

 
 
 
 
 
 
 

Detailed Route Report 
 

 
State/Country Distance Report 

Energy Column in 
the State Mileage 

Summary 

Detailed turn-by-turn driving 
directions on Energy Roads  
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ALK on the Cloud 
 
 

Beginning in PC*MILER Version 29, ALK Cloud Services is available for users 
who are interested in storing and sharing data.  (An active Internet connection is 
required to use ALK Cloud Services.)   
 
The benefits of using ALK Cloud Services include: 
 

• Allows users to seamlessly and securely create, modify, and share user-
generated data. 

• Provides reliable backup and restoration of user-generated data. 

• Provides a common company account and user login. 
 
Currently, ALK Cloud Services enables sharing of custom place data generated by 
users of the PC*MILER user interface.  It also enables PC*MILER|TripDirect users 
to dispatch routes and trip options to drivers equipped with ALK’s CoPilot Truck 
navigation software on mobile devices in the cab.  (See Chapter 16 for a description 
of the TripDirect feature.)  
 

15.1  Creating an ALK Cloud Account 
1.  Select the ALK Cloud tab > User Login.   
 
4. In the ALK Cloud Login dialog, click the secure link to the right: 

 

 
 

 
3.  On the web page that opens, click or Sign Up: 
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4.  In the ALK Cloud Signup screen, enter a unique valid email and click Continue. 
 

 
 

5.  In the next screen, enter a first and last name, a password (8 characters or 
more), and a name for this new account, then click Submit. 

 

 
 

6.  After a few seconds of processing, you should see a login screen that displays 
the message “You have successfully signed up” and you will receive an 
email confirming that you created an account.  You can Login immediately 
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from this screen or close the web page and login later from the ALK Cloud 
ribbon in PC*MILER. 

 

 
 

15.2  Login, Settings and Options    
To login to your new account from PC*MILER, select the ALK Cloud tab > User 
Login and enter the user name (email) and password that you used to create the 
account.  If there is more than one account associated with the email you enter, you 
will also need to pick an account from the drop-down list that appears under your 
password: 
 

 
 
 
If the login was successful, you’ll see the icon on the ALK Cloud tab turn green: 

   
 
After login, select the ALK Cloud tab > Manage Account to bring up the Manage 
ALK Cloud Account web page.  You’ll be asked to login again first.   
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When you set up a new Cloud account, you are automatically given administrator 
status for that account.  As an administrator you can add or disable users on the 
account, permanently cancel the account, and change your own password. 
 
Users on an account may be given administrative rights by the original 
administrator, and one user can join multiple accounts. 
 
NOTE: ALK Cloud account activity is logged in a “log.db” file found in the 
App\log folder of the PC*MILER installation folder (usually C:\ALK 
Technologies\PCMILER31\App\log).  
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15.2.1  Administrators vs. Non-Admin Users 
 
Users who do not have administrator rights won’t see the Account Users list, the 
Cancel Account button, or the Regenerate button for the account Alias.  They can 
change their password, and view subscription information and the account Alias. 
Here is what the non-admin user’s account management page looks like: 
 
 

 
 

 
15.2.2  Adding/Deleting Users 

 
To add a user to the account, click Add User to Account, enter a first and last name 
and email address, then click Add.  The user will be added to the account and will 
receive a Welcome email from ALK Cloud Services that includes a link to create a 
password. 
 
When the new user has been added to the Account Users list, check the Account 
Administrator column if you want to give this user administrative rights.  By 
default, each new user you add will be Enabled.  An administrator can disable a 
user temporarily by unchecking this option, or by clicking the garbage can icon in 
the Remove column. The deleted user’s ID will remain on the list but the user will 
no longer have access to the account.  
 
 

15.2.3  How Is the Account Alias Used? 
 
The Account Alias is a system-generated string of six letters that uniquely identifies 
your account on the cloud.  It is displayed on the ALK Cloud ribbon in PC*MILER 
when a PC*MILER user logs into the account.  The Alias can be given to remote 
users to allow them to join the account and receive PC*MILER|TripDirect routes 
on their mobile devices while using CoPilot (see Chapter 16 for more on 
PC*MILER|TripDirect).   
 
To disable an Alias and create a new one for the account, an administrator can click 
Regenerate.   
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15.3  Sync Data   

NOTE:  To sync data on the Cloud, you must login to the same ALK Cloud account 
on both the server and the workstation.  Even if you login to the ALK Cloud account 
on your workstation, but you are not logged into the same account on the server, 
syncing won’t work. 
 
Syncing your custom place data makes it available to all other users on the ALK 
Cloud account that you are logged into. The goal is to provide built-in sharing and 
backup of this data so that users need not manage their custom places manually and 
can share files over a network.  Here are a few things to keep in mind regarding 
data syncs: 
 

• Only one user at a time may edit the data set on the ALK Cloud (by 
syncing), simultaneous editing is not currently supported.  

• Data syncs always apply in both directions (to and from the cloud) and 
data from the ALK cloud is synced back to users as a complete set.  Data 
will never be partially synced.  Syncing your data will overwrite any 
local unsynced data sets. 

• The most recent set of synced custom places will be available locally in 
the Custom Place Manager when there is no current internet connection, 
provided the user remains logged into their ALK Cloud account.  
When logged out of ALK Cloud, custom places won’t appear in the 
Manager until the user logs in again. 

• All users on the Cloud should sync up immediately after login to avoid 
the possibility of data loss.  As an illustration, consider the following 
scenario: User 1 creates 50 custom places and then syncs her data.  A few 
minutes after User 1’s sync, User 2 creates 50 custom places without 
syncing first, and then syncs his data.  In this scenario, User 1’s data 
would overwrite User 2’s data and User 2 would lose his custom places 
because he did not sync before starting his local edits. 

• Cloud data is not available when the user is not logged in.  Only data 
that was created locally when the user was offline will be available. 

• A user should not choose to use the Cloud sometimes and not other 
times.  Participation in ALK Cloud Services is optional.  Users may 
choose to continue storing data locally.  However, intermittent use of ALK 
Cloud Services would create a non-optimal situation in which the most up-
to-date or desired data might not be available to other Cloud users. 

 
To sync your data, select Sync Data on the ALK Cloud ribbon in the PC*MILER 
application window.  
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Using PC*MILER|TripDirect® 
 
 
PC*MILER|TripDirect by ALK Technologies is an add-on to the PC*MILER user 
interface that provides a direct link between two of ALK’s existing industry-
standard products: PC*MILER routing, mileage and mapping software in the back 
office and CoPilot® Truck™ – ALK’s truck-specific GPS navigation system for 
mobile devices – in the vehicle.  
 
NOTE:  PC*MILER|Streets and PC*MILER|TripDirect must be licensed and 
installed, and you must have an active Internet connection to use TripDirect.  
ALK’s CoPilot Truck navigation software is downloaded from an app store and 
used in the cab.  
 
For hardware and software requirements, see section 2.1.2.  TripDirect is for the 
PC*MILER user interface only, it cannot be used with PC*MILER|Connect or 
integrated with third-party software.  If integration features are needed, 
PC*MILER|Connect can be purchased to provide this functionality via RouteSync 
API’s – see the product description at www.pcmiler.com/Integration. 
 
PC*MILER, synced with CoPilot Truck in the cab via PC*MILER|TripDirect, now 
offers the transportation and logistics industry a unique tracking and route 
management capability.  PC*MILER route compliance ensures that CoPilot Truck 
will follow user-defined routing (Practical, Hazmat, Toll Discouraged, etc.) that 
includes vehicle dimensions and custom avoid/favor routing preferences. 
 
TripDirect is an ideal fit for motor carriers, private fleets and owner operators who 
need to maintain operational consistency between PC*MILER operations and 
accounting functions in the back office and their vehicles.  It offers a flexible 
approach to minimizing the mileage variance between actual and planned routes. 
 
From the back office, TripDirect in the PC*MILER user interface can be used for: 
 
• sending routes including  trip options* and stops from the PC*MILER user 

interface to CoPilot Truck in the cab; 
• sending a PC*MILER route’s lat/long sequence to CoPilot Truck;  
• telling CoPilot Truck how strictly its in-cab directions should follow the exact 

route calculated by PC*MILER for a trip; 
• providing Out-of-Route warnings to drivers via CoPilot when they depart from 

the prescribed route, exceeding a specified distance from the route. 
 

* Avoid/favor options are the exception, they cannot be sent directly via 
TripDirect. Avoid/favor road preferences must be set in PC*MILER for the 
calculation of a route before it is sent to CoPilot. 
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16.1  Getting Started With TripDirect 
To use TripDirect, you must first log in to an ALK Cloud Services account.  To set 
up an account, see section 15.1. 
 
After setting up a Cloud account, follow these steps to get started:  
 
1.  Open PC*MILER and select the ALK Cloud tab > User Login. 
 
 

 
 

2. Enter the email address and password that were used to create an ALK Cloud 
Services account, and click Login.   

 
5. If the login attempt was successful, you’ll see the icon on the ALK Cloud tab 

turn green.  You’ll also see an Account Alias code, which can be used to add 
drivers to your ALK Cloud account (see below). 
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16.2  Adding Drivers 
To invite CoPilot-equipped drivers to join your ALK Cloud account: 
 
1. After login, select the ALK Cloud tab > Manage Account and enter the 

required email and password.  If you belong to more than one account, you 
will need to select an account from a drop-down list. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. When the Manage ALK Cloud Account web page opens, you have two options:  
 

1) Provide drivers with the Account Alias shown on the page, which they then 
use to login and join the account from within CoPilot (see Driver Setup below); 
OR  

2) Add drivers to the account as new users directly from the Manage Account 
page by entering the email address the driver used as an ID when activating 

Option 1: 
Send the Account 

Alias to drivers 

Option 2: 
Add drivers directly 
from the Manage 

Account page 
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CoPilot on a mobile device. Using the Manage Account page generates a 
“Welcome to ALK Cloud” email that enables the driver to sign up.  For this 
second option, continue with the steps below. 

 
3. To add a driver as a new user, click Add User to Account. 

4. Enter a first and last name and a valid email address at the prompts that appear 
below, then click Add.  The email you enter must match the email that the 
driver used as an ID when installing CoPilot. 

 
5. You’ll see the new user added to the list of Account Users, enabled by 

default.  Each user you add will receive an email for signing up.  To 
temporarily disable a user, uncheck the Enabled column, or click the garbage 
can icon (the user will remain on the list but access to the account will be 
denied in both cases). 

 

16.3  Driver Setup 
Drivers can download CoPilot Truck for iPhone or Android from GooglePlay, then 
follow the steps below to get set up with CoPilot and TripDirect: 
 
 

1. If necessary, download CoPilot Truck from the appstore and create an account 
as described in Step 2 below.  (You could also use an existing account if 
CoPilot is already installed.) 

 
2. Create a CoPilot Account and go through the first-run setup: 
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3. Login to the company that will be sending routes via TripDirect:  

In CoPilot, go to Main Menu  MyCoPilot icon (bottom of screen)                               
 My Account  Join New Company. 

 
 

 
 
 
4.  Enter the 6-digit Company Alias that was shared, then click “Join”. 
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16.4  Sending Routes and Options from PC*MILER to CoPilot 
The usernames (emails) of all CoPilot-equipped drivers who join your ALK Cloud 
account will appear in the TripDirect Vehicle Manager, along with their 
online/offline status.  Select Vehicle Manager on the ALK Cloud ribbon to see all 
users who have joined your account.  It may take a couple of minutes for vehicle 
sign-up information to synchronize and be visible. 
 
 

 
TripDirect Vehicle Manager 

 
 
PC*MILER routes can be sent to any CoPilot-equipped driver listed in the Vehicle 
Manager.  By sending a route to CoPilot, the sender requires the driver to adhere 
precisely to that route.  To send a route, follow the steps below. 
 
1. Run a PC*MILER Route.  (PC*MILER|Streets must be installed.) 

 
2. Open the Send Route dialog.  In the route window, click the gear button and 

select TripDirect. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 TripDirect Send Route Dialog  
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3. Select a Vehicle.  In the Send Route dialog, select one or more vehicles from 
the Select Vehicle drop-down.  Click View Vehicle List to view the 
online/offline status of all users on your ALK Cloud account. 

 
4. Select the Route Compliance Level. 
 

 
 
Under Route Compliance, select how strictly CoPilot should try to return to 
the original route once the driver is out-of-route: 

Strict:  This is the default compliance level.  CoPilot will try to navigate back 
to the original route at all costs, even if it means the driver needs to turn around 
and drive back to rejoin the prescribed route. 

Moderate:  CoPilot will try to navigate back to the original route but will take 
into account the driver’s current position in relation to the destination; i.e. 
CoPilot will try to rejoin the prescribed route as it navigates towards the 
destination, but along a route that is more reasonable than what the Strict 
compliance level would follow. 

Minimal:  At this level, the original prescribed route is not taken into 
consideration.  The route taken may still rejoin the original route, but its first 
objective is to navigate to the destination from the driver’s current position. 

 
5. Set a Distance That Triggers an OoR Alert. 
 

 
Whenever the CoPilot-equipped vehicle goes off route, CoPilot generates an 
alert for the driver that is also sent to the PC*MILER-side dispatcher. By 
default, an out-of-route alert is generated when the vehicle reaches a point .2 
miles away from the planned route.  To adjust this distance, type in a new 
distance under Alert. 

 
6. Send the Route. 
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Click the active Send to CoPilot button.  At the bottom of the Send Route 
dialog you will see a confirming “Route Sent on…” message that includes the 
date and time the route was sent. 
 

 
 

TripDirect new route alerts will appear in CoPilot only when the CoPilot map 
display is on the screen (in navigation view). The CoPilot user will receive an 
onscreen alert that a route has been sent and may choose to click OK to accept 
the route, or Details to see driving instructions.    
 
 

    
 
 

NOTE:  It sometimes takes 1-2 minutes for a route to be sent down to the device. 
 
NOTE Also: ALK Cloud and TripDirect activity is logged in a “log.db” file found 
in the App\log folder of the PC*MILER installation folder (usually C:\ALK 
Technologies\PCMILER31\App\log).  

 
 

  

“Route Sent” Confirmation 
with Timestamp 
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16.5  Managing and Tracking Vehicles 
 

 
TripDirect Vehicle Manager 

 
 

To Track Vehicles: 
To see all vehicles that have accepted to join your account, click View Vehicle List 
in the Send Route dialog or Vehicle Manager on the ALK Cloud ribbon.   

 
Vehicles in the Vehicle Manager are listed by their associated CoPilot ID under 
TruckName.  For each vehicle, PC*MILER displays an online/offline Status and 
Last Known Position.  For trucks that are offline, the date/time when the truck 
went offline is shown.  The last column in the Vehicle List records the last message 
that the dispatcher received from a truck, including a timestamp and message 
description. 
 
When you select a vehicle on the list, its Last Known Position will be displayed if 
it is available.  If a vehicle is offline, the route that you send will be received when 
CoPilot comes back online in the vehicle.   
 
To Delete Vehicles: 
Use the Manage ALK Cloud Account web page.  See section 15.2.2. 
 
To Update the Vehicle List: 
To refresh the information in the Vehicle Manager, click Update Vehicles.   
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16.6  Vehicle Display on the Map 
To zoom to a vehicle’s current or last known position on the PC*MILER map, in 
the Send Route dialog click Show Vehicle On Map (see section 16.4 above).   The 
vehicle’s position on the map is updated automatically every 60 seconds. 
 

 
 
 

 
 

 
 
 
 
 
 

 
 
 
 
 
 
 
To stop display of vehicle positions on the map, click the 
Toggle Vehicles icon on the ALK Cloud ribbon bar. 
 

16.7  Data Updates 
Map data and software updates for PC*MILER and CoPilot are available 
periodically between version releases.  Users of TripDirect should wait for the 
next PC*MILER data update to be installed before considering updating their 
CoPilot devices, in order to ensure data matching between the two products. 
 
PC*MILER Updates: 
Go to the Help tab > Check for Updates.  All available updates will be listed in the 
PC*MILER Updater window.  See section 17.3 for more information. 
 
CoPilot Updates: 
On the mobile device: 
1. In the Main Menu tap My CoPilot                            at the bottom of the screen. 

Send Route Dialog 

Two Online Vehicles on the Map 
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2. Tap My Maps.  If a map update is available, a popup will be displayed to 
download the map update. 

3. Tap on an update to download and install it directly to the device.   



  
   

 
 Chapter 17: Technical Support & Contact Options 242 

Technical Support & 
Contact Options 

 
 

17.1  Technical Support Options 

If you have unresolved questions about PC*MILER or problems with the software, 
visit us at www.pcmiler.com/support for online support, product training resources, 
and much more.  You can also contact us in the following ways:  
 
Phone: 1.800.377.6453, ext 2 or 609.683.0220, ext. 2.  When calling, ask for 

PC*MILER Technical Support.  Please be sure to have your PC*MILER 
Product Key Code, version number, Windows® version number, and 
hardware configuration information (manufacturer, speed, and monitor 
type) available before your call.  Please include this information in your 
message if you are contacting us by email. 

Email: pcmsupport@alk.com, or from within PC*MILER select the Help tab > 
Email Technical Support and follow the instructions provided.  If you 
have any supporting material, click Attach File and browse for the file(s) 
to attach. Attachments of supporting documentation can be up to 10 MB.  
When ready, click Send.  ALK's technical support team will send a 
confirmation email to the email entered in the "Enter your email here" 
field when it is received. 

Web Site: www.pcmiler.com 
Hours: 8:00am – 5:00pm EST, Mon-Fri 

 
To print any part of this User’s Guide, click the Windows Start button, then go to 
All Apps (or equivalent) > PCMILER 31 and select User’s Guide  from the sub-
menu.   
 

17.2  PC*MILER Sales Contact Information 

Phone: 800.377.6453, ext 1  
  609.683.0220 (outside the U.S.) 
Fax:  609.683.0290 
Email: sales@alk.com 
Web Site: www.pcmiler.com 
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17.3  PC*MILER Updates 
Between version releases of PC*MILER, updates and patches are periodically 
made available as the need arises.  These may include corrections to any reported 
errors in the software or data, or access to updated data releases (for applicable 
products and license types*).  Note that these patches and updates are now 
cumulative, meaning they include items from previously released patches/updates 
of the same type.   
 
ALK strongly recommends checking for the most current updates regularly.  
This is recommended for all users, but particularly important for 
PC*MILER|Tolls users. 
 
* NOTE:  If a PC*MILER product was purchased along with signing up for the 
ALK Annual Support & Update Program (AUP license purchase), customers are 
entitled to use PC*MILER during the term of their agreement and also to receive 
data updates when and if available. AUP licensed users will have access to the base 
version data set as well as to more recently released data sets as they are available.   
 
For those who do not sign up for the AUP, PC*MILER is purchased as a Perpetual 
license which entitles the licensed user to available software patches released for 
the purchased version.  For more information on upgrading a Perpetual license to 
an AUP license, please contact an Enterprise Solutions account executive at 800-
377-6453 ext. 1 or email sales@alk.com.  
 
 

17.3.1  Using the Updater Tool 
 
Provided you have an Internet connection, follow the steps below to check if an 
update is available for your license type and install the available updates: 
 
1. Close all open instances of PC*MILER and its connectivity products.  If a 

third-party program that accesses any PC*MILER component is running, 
(for example, PC*MILER|Connect or PC*MILER|Mapping) it must be 
closed before updating. 

2. Open PC*MILER and select the Help tab > Check for Updates.  The 
PC*MILER Updater dialog will open.  The Updater first checks for valid 
license information and then begins checking for available updates. 

3. When the search for updates is complete you will see all available updates 
listed.  In the Download & Install drop-down menu next to each available 
update, click the arrow to select either Download & Install to download and 
install right away or Download to download now and install at a later time. 
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4. Note the version number of the updates you will be downloading so you can 
check if the update installed properly (see Step 7 below).   

5. Selecting either option will begin the download process.  You will see the 
progress of the download reflected in a progress bar.  If any PC*MILER-
related application is open, you will be prompted to close it.  After closing 
the application(s), click OK to continue with the download. 

 
 

 
 

6. If you chose Download and Install, the InstallShield Wizard will open when 
the download is finished.  Follow the instructions to complete the installation.  
After installing, you will see the update or patch listed under “Installed 
Updates” in the Updater window. 

 
NOTE for Patch Installations:  Depending on which patch you are installing, 
the Updater window may close when you begin running the InstallShield 
Wizard update. 

 
If you chose Download, when the download is finished the button to the 
right will now say “Install”.  You can complete the installation as described 
above at any time in the future: open the Updater window and click Install. 

PC*MILER Updater – Checking for Updates Download & Install Options 
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IMPORTANT:  You must close the Updater after downloading without 
installing.  The next time you open the Updater, the files you downloaded will 
be shown in the “Downloaded Updates” section of the dialog. 
 

 
7. As a last step, check to make sure the update(s) installed properly.  Select the 

Help tab > About and look for the Software Version number under “This 
Product is Licensed To”.  It should match what you downloaded. 

 
 

 
PC*MILER “About” Window 

 
 

17.3.2  Updating Workstation Installations 
 
For workstation installations, first follow the steps in section 17.3.1 above to 
install any available updates and patches on the Server. 
   
Next, to keep all workstations in sync with what is running on the Server, run the 
Updater on each workstation to install the same updates and/or patches.    
 
 
 
 
 
 
 
 
 

Software Version 
Number 
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17.4  Reporting Data Errors 

ALK Technologies is dedicated to maintaining a highway and street-level network 
of the highest quality and welcomes user input.  PC*MILER users are encouraged 
to submit map data enhancements to ALK’s map data experts using ALK’s 
MapSure from within PC*MILER or by contacting PC*MILER Technical Support. 
Reported issues will be researched and if a requested change is accepted, it will be 
incorporated in a future map data update. 
 
 

17.4.1  Using ALK’s MapSure  
 
PC*MILER|Streets users with an ALK Cloud account (see Chapter 15) now have 
access to ALK’s MapSure website to submit map data enhancement requests. If 
you encounter any problems on the map related to missing or incorrect streets and 
addresses, street or highway names, turn restrictions, one-way designations, truck 
restrictions and allowances, toll road designations, or ZIP/Postal Codes, from 
within PC*MILER select the Help tab > Open MapSure in Browser or right click 
the map and select Report a Map Problem….* On the MapSure web page, follow 
the on-screen instructions to report an error or a needed enhancement. 
* The MapSure feature is only available if PC*MILER|Streets is licensed and installed, and won’t 

appear in Highway-Only versions of PC*MILER. 
 
NOTE:  If you have PC*MILER installed behind a Proxy and have trouble 
accessing the MapSure feature, go to Help > Proxy Setup to enter your proxy 
information.  If the problem still persists, in a web browser go directly to 
http://mapsure.alk.com and login using your ALK Cloud account information. 

 

 

 
Accessing ALK’s MapSure from Within PC*MILER 

“Open MapSure in Browser” 
button in the Help tab 

“Report a Map Problem…” option in 
the right mouse map menu 

http://mapsure.alk.com/
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17.4.2  Reporting Data Errors to PC*MILER Technical Support 
 
To report other types of map data issues such as mileage calculation errors or 
routing errors, or for users without an ALK Cloud account, email PC*MILER 
Technical Support at pcmsupport@alk.com and include any relevant route 
information along with a description of the problem you encountered. 

 

17.5  The Remote Support Tool and License Tool 
Two of the tools available when calling PC*MILER Technical Support are the 
Remote Support Tool and License Tool. These tools enable the Technical Support 
staff at ALK Technologies to assist you with troubleshooting and licensing. 
 

• The Remote Support Tool is started by clicking Help > Remote Support 
Tool. If you call Technical Support for support of your PC*MILER 
installation, you may be advised to start this tool, if necessary. 

 
• The License Tool enables adding, viewing, or deactivating licensed 

components of PC*MILER.  It is started by clicking Help > License Tool. 
Starting the tool will close PC*MILER and start a separate License Tool 
application. 

 
 

 
Accessing the Remote Support Tool and License Tool from Within PC*MILER 
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        About ALK Technologies 
 
 
 

 
 
ALK Technologies is a transportation technology company dedicated to defining 
the optimal route to success through innovative routing, mileage, mapping and 
mobile navigation solutions. From trusted industry standard data to seamless 
integration, ALK solutions are developed for a broad range of industries, 
workforces, and everyday drivers on the road. For over 35 years, its suite of 
powerful solutions, including PC*MILER®, CoPilot®, and ALK® Maps™, have 
set the foundation for safe and efficient journeys worldwide – one mile, one driver, 
one vehicle at a time. ALK is a Trimble (NASDAQ: TRMB) Company and part of 
its international Transportation and Logistics Division. 
 

Visit us at 
 www.alk.com 
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Appendix A: 
 Access Policies from National Network Routes 

to Terminals & Services (U.S. Only) 
 
 
 

Reasonable Access Defined 
 
Reasonable access is the deviation allowed between the specified truck network and any 
allowable stops.  A stop is typically defined as a place of loading or unloading, or facilities 
for food, fuel, repairsand rest.  In all cases, local signs and warnings prohibiting truck 
access or providing an applicable restriction take precedence over reasonable access rules.  
In some states the deviation allowed from the National Network or 53 Foot Designated 
Truck Network may vary depending on the roads used to get to the stop.  If this is the case, 
we have differentiated between reasonable access from the truck route and on a state 
highway versus local roads. 
 
For detailed information about pre-approved routes, contact the individual states. 
 
 

PC*MILER Designated Road Categories 
 
In the PC*MILER database, roads designated for 102" wide, 53' long trailers or twin 28' 
long trailers are coded in three ways: 

 
 National Network – These are the original roads designated by the states and 

approved by FHWA circa 1990, or (rarely) changes submitted by the states to 
FHWA post-1990.  FHWA requires that the states allow at least 1 mile access 
distance to/from these roads, but the states are free to specify a longer access 
distance if they wish.  Many states (especially in the west) have size limits for their 
entire state that equal or exceed this size of equipment in both width and length. In 
PC*MILER, these roads are considered to have “unlimited” access distance.  Some 
states in the east restrict this equipment to designated roads, but allow unlimited 
access “by the shortest and/or most direct route” (or similar language), and roads 
in these states also have “unlimited” access distance. 
 

 State Oversize – This category includes additional roads designated by the states 
since 1990, or which they have not submitted to FHWA for approval since 1990, 
to which the same access distance applies as to the National network in that state. 
 

 Oversize Access – This category includes additional roads designated by the states 
to which a different (shorter, often zero) access distance applies.    Usually these 
are county highways or local streets that lead all the way from the National Network 
and/or State Oversize network to the entrance to an industrial park, truck terminal, 
distribution center, factory, warehouse, etc. 
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Users will receive a “Not Designated” warning in the route window and the Detailed and 
Driver’s reports if State + National Network is selected as the route type, and: 
 

a. the route uses a road that is not designated National Network, State Oversize, 
or Oversize Access to go between roads that are designated National Network, 
State Oversize, or Oversize Access, OR 

b. the route uses a road that is not designated National Network, State Oversize, 
or Oversize Access to access an origin, destination, or stop further  than the 
distances specified in the regulations. 

 
 

Allowable Distance by Jurisdiction 
 
The table below shows the allowable distance (in miles) on truck access roads in North 
American jurisdictions, by PC*MILER road category as described above.  Columns in the 
table are: 
 
Column 1 - Jurisdiction abbreviation 
Column 2 - Jurisdiction FIPS code 
Column 3 - Access miles from National Network on US and State numbered highways 
Column 4 - Access miles from National Network on all other roads 
Column 5 - Access miles from State Oversize on US and State numbered highways 
Column 6 - Access miles from State Oversize on all other roads 
Column 7 - Access miles from Oversize Access 

 
NOTE:  “Unlimited access” in this table is as defined in the description of PC*MILER 
designated road categories above. 
 

Jurisdiction 
Abbrev. FIPS 

3 - From Nat’l 
Netw on US & 
State Highways 

4 - From Nat’l 
Netw on other 
roads 

5 - From State 
Oversize on 
US & State 
Highways 

6 – From State 
Oversize on 
other roads 

7 – From 
Oversize 
Access 

AL 1 1 1 1 1 0 
AK 2 Unlimited access Unlimited access Unlimited access Unlimited access 0 
AZ 4 1 1 1 1 0 
AR 5 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CA 6 1 1 1 1 0 
CO 8 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CT 9 1 1 1 1 0 
DE 10 1 1 1 1 0 
DC 11 1 1 1 1 0 
FL 12 Unlimited access Unlimited access Unlimited access Unlimited access 0 
GA 13 Unlimited access Unlimited access Unlimited access Unlimited access 0 
HI 15 Unlimited access Unlimited access Unlimited access Unlimited access 0 
ID 16 1 1 1 1 0 
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Jurisdiction 
Abbrev. FIPS 

3 - From Nat’l 
Netw on US & 
State Highways 

4 - From Nat’l 
Netw on other 
roads 

5 - From State 
Oversize on 
US & State 
Highways 

6 – From State 
Oversize on 
other roads 

7 – From 
Oversize 
Access 

IL 17 5 1 5 1 0 
IN 18 Unlimited access Unlimited access Unlimited access Unlimited access 0 
IA 19 Unlimited access Unlimited access Unlimited access Unlimited access 0 
KS 20 Unlimited access Unlimited access Unlimited access Unlimited access 0 
KY 21 5 1 5 1 0 
LA 22 10 10 10 10 0 
ME 23 1 1 1 1 0 
MD 24 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MA 25 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MI 26 5 1 5 1 0 
MN 27 1 1 1 1 0 
MS 28 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MO 29 10 10 10 10 0 
MT 30 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NE 31 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NV 32 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NH 33 1 1 1 1 0 
NJ 34 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NM 35 20 20 20 20 0 
NY 36 1 1 1 1 0 
NC 37 3 3 3 3 0 
ND 38 Unlimited access Unlimited access Unlimited access Unlimited access 0 
OH 39 Unlimited access Unlimited access Unlimited access Unlimited access 0 
OK 40 Unlimited access Unlimited access Unlimited access Unlimited access 0 
OR 41 1 1 1 1 0 
PA 42 1 1 1 1 0 
RI 44 1 1 1 1 0 
SC 45 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SD 46 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TN 47 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TX 48 Unlimited access Unlimited access Unlimited access Unlimited access 0 
UT 49 Unlimited access Unlimited access Unlimited access Unlimited access 0 
VT 50 1 1 1 1 0 
VA 51 1 1 1 1 0 
WA 53 Unlimited access Unlimited access Unlimited access Unlimited access 0 
WV 54 Unlimited access Unlimited access Unlimited access Unlimited access 0 
WI 55 15 15 15 15 0 
WY 56 Unlimited access Unlimited access Unlimited access Unlimited access 0 
PR 72 Unlimited access Unlimited access Unlimited access Unlimited access 0 
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Jurisdiction 
Abbrev. FIPS 

3 - From Nat’l 
Netw on US & 
State Highways 

4 - From Nat’l 
Netw on other 
roads 

5 - From State 
Oversize on 
US & State 
Highways 

6 – From State 
Oversize on 
other roads 

7 – From 
Oversize 
Access 

NU 80 Unlimited access Unlimited access Unlimited access Unlimited access 0 
YT 81 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NT 82 Unlimited access Unlimited access Unlimited access Unlimited access 0 
BC 83 Unlimited access Unlimited access Unlimited access Unlimited access 0 
AB 84 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SK 85 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MB 86 Unlimited access Unlimited access Unlimited access Unlimited access 0 
ON 87 Unlimited access Unlimited access Unlimited access Unlimited access 0 
QC 88 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NB 89 Unlimited access Unlimited access Unlimited access Unlimited access 0 
PE 90 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NS 91 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NL 92 Unlimited access Unlimited access Unlimited access Unlimited access 0 
EM 93 Unlimited access Unlimited access Unlimited access Unlimited access 0 
BD 130 Unlimited access Unlimited access Unlimited access Unlimited access 0 
GL 131 Unlimited access Unlimited access Unlimited access Unlimited access 0 
BH 132 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CS 133 Unlimited access Unlimited access Unlimited access Unlimited access 0 
ES 134 Unlimited access Unlimited access Unlimited access Unlimited access 0 
GT 135 Unlimited access Unlimited access Unlimited access Unlimited access 0 
HO 136 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NU 137 Unlimited access Unlimited access Unlimited access Unlimited access 0 
PM 138 Unlimited access Unlimited access Unlimited access Unlimited access 0 
AG 139 Unlimited access Unlimited access Unlimited access Unlimited access 0 
BJ 140 Unlimited access Unlimited access Unlimited access Unlimited access 0 
BS 141 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CP 142 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CH 143 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CI 144 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CU 145 Unlimited access Unlimited access Unlimited access Unlimited access 0 
CL 146 Unlimited access Unlimited access Unlimited access Unlimited access 0 
DF 147 Unlimited access Unlimited access Unlimited access Unlimited access 0 
DG 148 Unlimited access Unlimited access Unlimited access Unlimited access 0 
GR 149 Unlimited access Unlimited access Unlimited access Unlimited access 0 
GJ 150 Unlimited access Unlimited access Unlimited access Unlimited access 0 
HG 151 Unlimited access Unlimited access Unlimited access Unlimited access 0 
JA 152 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MH 154 Unlimited access Unlimited access Unlimited access Unlimited access 0 
MR 155 Unlimited access Unlimited access Unlimited access Unlimited access 0 
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Jurisdiction 
Abbrev. FIPS 

3 - From Nat’l 
Netw on US & 
State Highways 

4 - From Nat’l 
Netw on other 
roads 

5 - From State 
Oversize on 
US & State 
Highways 

6 – From State 
Oversize on 
other roads 

7 – From 
Oversize 
Access 

NA 156 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NX 157 Unlimited access Unlimited access Unlimited access Unlimited access 0 
OA 158 Unlimited access Unlimited access Unlimited access Unlimited access 0 
PU 159 Unlimited access Unlimited access Unlimited access Unlimited access 0 
QA 160 Unlimited access Unlimited access Unlimited access Unlimited access 0 
QR 161 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SI 162 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SL 163 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SO 164 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TA 165 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TM 166 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TL 167 Unlimited access Unlimited access Unlimited access Unlimited access 0 
VZ 168 Unlimited access Unlimited access Unlimited access Unlimited access 0 
YC 169 Unlimited access Unlimited access Unlimited access Unlimited access 0 
ZT 170 Unlimited access Unlimited access Unlimited access Unlimited access 0 
ACT 200 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NSW 201 Unlimited access Unlimited access Unlimited access Unlimited access 0 
NT 202 Unlimited access Unlimited access Unlimited access Unlimited access 0 
QLD 203 Unlimited access Unlimited access Unlimited access Unlimited access 0 
SA 204 Unlimited access Unlimited access Unlimited access Unlimited access 0 
TAS 205 Unlimited access Unlimited access Unlimited access Unlimited access 0 
VIC 206 Unlimited access Unlimited access Unlimited access Unlimited access 0 
WA 207 Unlimited access Unlimited access Unlimited access Unlimited access 0 
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Appendix B: 
 National Network Policies by State and Truck Configuration (U.S. Only) 

 
 
Table 1 below shows, for each U.S. state as of February 2016, which truck configurations are required by law to use State + 
National Network routing.  PC*MILER currently turns this option on when a vehicle’s dimensions, as included in a route 
profile or set as route options for an individual route, exceed 48 ft. long and/or 96 inches wide.  In general this is a 
conservative setting.  If a route is entirely within states that have more liberal rules for their particular truck configuration, 
users can turn off the State + National Network option and potentially calculate a somewhat shorter route. 
 
Table 2 below provides a source for exception information by state. 
 

Table 1.  State + National Network Requirements by State & Truck Configuration 
 
TRUE = must use State + National Network routing 
FALSE = not required 

 

U.S. State 

Straigh
t 

Truck 

Straight 
Truck 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regula
r 

Tractor 

Regular 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

No 
trailer
, 102" 
wide 

Straigh
t truck 
with 
trailer 
("maxi-
cube"), 
102" 
wide 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer 
53' 
long x 
102" 
wide 

Twin 
trailers 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer  
53' 
long  
x 102" 
 wide 

Twin 
trailers 

Alabama AL TRUE TRUE TRUE FALSE TRUE FALSE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Alaska AK FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Arizona AZ TRUE TRUE TRUE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Arkansas AR FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
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U.S. State 

Straigh
t 

Truck 

Straight 
Truck 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regula
r 

Tractor 

Regular 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

No 
trailer
, 102" 
wide 

Straigh
t truck 
with 
trailer 
("maxi-
cube"), 
102" 
wide 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer 
53' 
long x 
102" 
wide 

Twin 
trailers 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer  
53' 
long  
x 102" 
 wide 

Twin 
trailers 

California CA FALSE FALSE FALSE FALSE FALSE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Colorado CO FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Connecticut CT FALSE FALSE FALSE FALSE FALSE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Delaware DE FALSE FALSE FALSE FALSE FALSE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Dist. of Columbia DC TRUE TRUE TRUE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Florida FL TRUE TRUE TRUE FALSE TRUE FALSE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Georgia GA FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Hawaii HI FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Idaho ID FALSE FALSE FALSE FALSE FALSE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Illinois IL FALSE TRUE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Indiana IN FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Iowa IA FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Kansas KS FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Kentucky KY TRUE TRUE TRUE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Louisiana LA FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE TRUE 
Maine ME FALSE FALSE FALSE FALSE FALSE FALSE FALSE TRUE FALSE FALSE FALSE FALSE FALSE TRUE 
Maryland MD FALSE TRUE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
Massachusetts MA FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
Michigan MI TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE 
Minnesota MN FALSE FALSE FALSE FALSE FALSE FALSE FALSE TRUE FALSE FALSE FALSE FALSE FALSE TRUE 
Mississippi MS FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
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U.S. State 

Straigh
t 

Truck 

Straight 
Truck 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regula
r 

Tractor 

Regular 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

No 
trailer
, 102" 
wide 

Straigh
t truck 
with 
trailer 
("maxi-
cube"), 
102" 
wide 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer 
53' 
long x 
102" 
wide 

Twin 
trailers 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer  
53' 
long  
x 102" 
 wide 

Twin 
trailers 

Missouri MO FALSE TRUE FALSE FALSE TRUE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
Montana MT FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Nebraska NE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Nevada NV FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
New Hampshire NH FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
New Jersey NJ TRUE TRUE TRUE FALSE TRUE FALSE TRUE TRUE TRUE FALSE TRUE FALSE TRUE TRUE 
New Mexico NM FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE FALSE FALSE TRUE 
New York NY TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE 
North Carolina NC FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
North Dakota ND FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Ohio OH FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Oklahoma OK FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Oregon OR FALSE TRUE FALSE FALSE TRUE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
Pennsylvania PA FALSE TRUE FALSE FALSE TRUE FALSE TRUE TRUE FALSE FALSE TRUE FALSE TRUE TRUE 
Rhode Island RI FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
South Carolina SC FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
South Dakota SD FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Tennessee TN TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE 
Texas TX FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Utah UT FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
Vermont VT FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
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U.S. State 

Straigh
t 

Truck 

Straight 
Truck 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regular 
Tractor 

Regula
r 

Tractor 

Regular 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

Short 
Tractor 

No 
trailer
, 102" 
wide 

Straigh
t truck 
with 
trailer 
("maxi-
cube"), 
102" 
wide 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer 
53' 
long x 
102" 
wide 

Twin 
trailers 

Single 
trailer 
28' 
long x 
102" 
wide 

Single 
trailer 
48' 
long x 
96" 
wide 

Single 
trailer 
48' 
long x 
102" 
wide 

Single 
trailer 
53' 
long x 
96" 
wide 

Single 
trailer  
53' 
long  
x 102" 
 wide 

Twin 
trailers 

Virginia VA FALSE FALSE FALSE FALSE FALSE FALSE FALSE TRUE FALSE FALSE FALSE FALSE FALSE TRUE 
Washington WA FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 
West Virginia WV TRUE TRUE TRUE TRUE TRUE TRUE TRUE TRUE TRUE FALSE TRUE TRUE TRUE TRUE 
Wisconsin WI FALSE FALSE FALSE FALSE FALSE TRUE TRUE TRUE FALSE FALSE FALSE TRUE TRUE TRUE 
Wyoming WY FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE FALSE 

 
 

Table 2.  Sources for Exception Information by State 
 
U.S. State For exceptions to rules in Table 1, see: 
Alabama AL http://codes.lp.findlaw.com/alcode/32/9/2/32-9-20 
Alaska AK Alaska Chapter 25 Commercial Vehicle Size, Weight and Permit Regulations April 12 2013 
Arizona AZ Arizona statutes 28-1092, 28-1093, 28-1095 
Arkansas AR Arkansas permit rules for movement of oversize and overweight vehicles 2014 
California CA http://www.dot.ca.gov/hq/traffops/trucks/ 
Colorado CO Colorado DOT FYIs legal vehicle dimensions 2015 
Connecticut CT Connecticut commercial vehicle limits 
Delaware DE Delaware Oversize Overweight Hauling Permit Policy and Procedures Manual October 2015 
Dist. of Columbia DC District of Columbia Truck and Motor Carrier FAQ 
Florida FL Florida Highway Patrol Commercial Motor Vehicle Manual, April 2013 
Georgia GA http://www.dot.ga.gov/PartnerSmart/permits/Documents/Rules/Title32.pdf 

http://codes.lp.findlaw.com/alcode/32/9/2/32-9-20
http://www.dot.ca.gov/hq/traffops/trucks/
http://www.dot.ga.gov/PartnerSmart/permits/Documents/Rules/Title32.pdf
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U.S. State For exceptions to rules in Table 1, see: 
Hawaii HI Hawaii Statutes 291-34 Size of vehicles.pdf 
Idaho ID http://itd.idaho.gov/dmv/poe/LegalWidthHeightLength.html 
Illinois IL Illinois Maximum Legal Dimensions and Weights on State Federal and Local Routes March 2014 
Indiana IN Indiana summary of size and weight laws under title 9 article 20 
Iowa IA Iowa truck information guide July 2015-July 2016 edition 
Kansas KS http://www.kscoplaw.com/vehcode/art19.html 
Kentucky KY http://www.lrc.ky.gov/kar/603/005/070.htm 
Louisiana LA Louisiana Regulations for Trucks Vehicles and Loads 2013 
Maine ME Maine Commercial Vehicle Laws effective June 6 2012.pdf 
Maryland MD Maryland Motor Carrier Handbook Dec 2014 
Massachusetts MA Massachusetts Commercial Motor Vehicle Information 
Michigan MI Michigan Maximum Legal Truck Loadings and Dimensions March 2007 
Minnesota MN Minnesota maximum vehicle dimensions 
Mississippi MS Mississippi Sub-Part 6601 Over-Dimensional Permits 
Missouri MO Missouri Commercial Vehicle Regulations Jul 2009 
Montana MT Montana permitting reference and FAQs 
Nebraska NE Nebraska Truck Information Guide 2013-14 
Nevada NV Nevada Traffic Laws for Size, Weight & Load Jul 2012 
New Hampshire NH https://www.nh.gov/safety/divisions/nhsp/fob/troopg/motorcarrier/faqmc.html 
New Jersey NJ New Jersey Title 16 Chapter 32 Truck Access expires 2022 
New Mexico NM New Mexico Statutes Title 18 Chapter 19 Part 8.pd 
New York NY Official Description of Designated Qualifying and Access Highways in New York State, April 2015 
North Carolina NC https://connect.ncdot.gov/business/trucking/Pages/Truck-Access-Designation.aspx 
North Dakota ND North Dakota vehicle legal size and weight guide Dec 2011 
Ohio OH Ohio legal dimension and weight limits for highway vehicles 
Oklahoma OK Oklahoma chapter14 size, weight and load 
Oregon OR Oregon Group Map 1 and Route Map 7 
Pennsylvania PA Pennsylvania STAA Truck Routes for 102" Wide Trailers, December 2015 
Rhode Island RI Rhode Island Manual for Overweight and Oversize Vehicle Permits third edition 

http://itd.idaho.gov/dmv/poe/LegalWidthHeightLength.html
http://www.kscoplaw.com/vehcode/art19.html
http://www.lrc.ky.gov/kar/603/005/070.htm
https://www.nh.gov/safety/divisions/nhsp/fob/troopg/motorcarrier/faqmc.html
https://connect.ncdot.gov/business/trucking/Pages/Truck-Access-Designation.aspx
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U.S. State For exceptions to rules in Table 1, see: 
South Carolina SC South Carolina Size, Weight and Load 
South Dakota SD South Dakota motor carrier handbook chapter 4 size and weight regulations 
Tennessee TN http://law.justia.com/codes/tennessee/2015/title-55/chapter-7/part-2/ 
Texas TX http://www.txdmv.gov/motor-carriers/oversize-overweight-permits/texas-size-weight-limits 
Utah UT Utah Chapter 19 Legal Size Vehicle Dimensions 
Vermont VT Vermont guide to motor carrier safety regulations, and http://dmv.vermont.gov/commercial_trucking/permitting_rules 
Virginia VA Virginia Size Weight and Equipment Requirements, July 2015 
Washington WA Washington State Commercial Vehicle Guide 
West Virginia WV West Virginia Vehicle Size Map Oct 2008 
Wisconsin WI Wisconsin statutes Chapter 348 Vehicles - Size, Weight and Load dated 20Feb2016.pdf 
Wyoming WY No exceptions.  Ref: http://www.whp.dot.state.wy.us/home/size_and_weight/size_limits.html 

 
 
 

 
 

http://law.justia.com/codes/tennessee/2015/title-55/chapter-7/part-2/
http://www.txdmv.gov/motor-carriers/oversize-overweight-permits/texas-size-weight-limits
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Appendix C:  Canadian Counties 
 
 
 
Canadian Counties that are included in the PC*MILER database are listed below.  
Regional districts and other types of sub-divisions that exist within Canadian 
provinces and territories are not included in the database and therefore not listed. 
 
 

Province Counties 
  
Alberta (No Counties) 
  
British Columbia (Contains a County) 

 CARIBOO 
  
Manitoba (No Counties) 
  
New Brunswick (Contains Counties) 

 ALBERT 
 CARLETON 
 CHARLOTTE 

 GLOUCESTER 
 KENT 
 KINGS 
 MADAWASKA 
 NORTHUMBERLAND 
 QUEENS 
 RESTIGOUCHE 
 ST. JOHN 
 SUNBURY 
 VICTORIA 
 WESTMORLAND 
 YORK 
  

Newfoundland and 
Labrador 

(No Counties) 

 
Northwest 
Territories 

(No Counties) 
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Nova Scotia (Contains Counties) 

 ANNAPOLIS 
 ANTIGONISH 
 CAPE BRETON 
 COLCHESTER 
 CUMBERLAND 
 DIGBY 
 GUYSBOROUGH 
 HALIFAX 
 HANTS 
 INVERNESS 
 KINGS 
 LUNENBURG 
 PICTOU 
 QUEENS 
 RICHMOND 
 SHELBURNE 
 VICTORIA 
 YARMOUTH 
  
Nunavut 
 
Ontario 
 

(No Counties) 
 
(Contains Counties) 
 

 ALGOMA 
 BRANT 
 BRUCE 
 COCHRANE 
 DUFFERIN 
 DURHAM 
 ELGIN 

 ESSEX 
 FRONTENAC 
 GREY 
 HALDIMAND 
 HALIBURTON 
 HASTINGS 
 HURON 
 KENORA 
 KENT 

 LAMBTON 
 LANARK 
 MANITOULIN 
 MIDDLESEX 
 NIPISSING 

NORFOLK 
 NORTHUMBERLAND 
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 OTTAWA - CARLETON 
 OXFORD 
 PARRY SOUND 
 PERTH 
 PETERBOROUGH 
 PRINCE EDWARD 
 RAINY RIVER 
 RENFREW 
 SIMCOE 
 SUDBURY RM 
 THUNDER BAY 
 TIMISKAMING 
 TORONTO 
 VICTORIA 
 WELLINGTON 
  
Prince Edward 
Island 

(Contains Counties) 

 KINGS 
 PRINCE 
 QUEENS 
  

Quebec (Contains Counties) 
 

 ABITIBI-TEMISCAMINGUE 
 BAS-SAINT-LAURENT 
 CENTRE-DU-QUEBEC 
 CHAUDIERE-APPALACHES 

 COMMUNAUTE-URBAINE-DE-MONTREAL 
 COTE-NORD 
 ESTRIE 
 GASPESIE - ILES-DE-LA-MADELEINE 
 LA CÔTE-DE-BEAUPRÉ 
 LANAUDIERE 
 LAURENTIDES 
 LES JARDINS-DE-NAPIERVILLE 
 MAURICIE 
 MONTEREGIE 
 MONTREAL 
 OUTAOUAIS 
 QUEBEC 
 ROUVILLE 
 SAGUENAY - LAC-SAINT-JEAN 

 
Saskatchewan (No Counties) 
 
Yukon (No Counties) 
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Appendix D: 

 State/Province/Country Abbreviations 
 
 

States/Provinces in the U.S., Canada, and Mexico 
(For countries and country abbreviations included in the North America region, see “North America” 
below under Country Codes for Worldwide Regions) 
 
States/Provinces in the United States & Canada 
 

AL Alabama 
AK Alaska 
AB Alberta 
AZ Arizona 
AR Arkansas 
BC British Columbia 
CA California 
CO Colorado 
CT Connecticut 
DE Delaware 
DC Dist. of Columbia 
FL Florida 
GA Georgia 
ID Idaho 
IL Illinois 
IN Indiana  
IA Iowa 
KS Kansas 
KY Kentucky 
LA Louisiana 
ME Maine 
MB Manitoba 
MD Maryland 
MA Massachusetts 
MI Michigan 
MN Minnesota 
MS Mississippi 
MO Missouri 
MT Montana 
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NE Nebraska 
NV Nevada 
NB New Brunswick 
NH New Hampshire 
NJ New Jersey 
NM New Mexico 
NY New York 
NL Newfoundland & Labrador 
NC North Carolina 
ND North Dakota 
NT Northwest Territory 
NS Nova Scotia 
NU* Nunavut 
OH Ohio 
OK Oklahoma 
ON Ontario 
OR Oregon 
PA Pennsylvania 
PE Prince Edward Island 
QC Quebec 
RI Rhode Island  
SK Saskatchewan 
SC South Carolina 
SD South Dakota 
TN Tennessee 
TX Texas 
UT Utah 
VT Vermont 
VA Virginia 
WA Washington 
WV West Virginia 
WI Wisconsin 
WY Wyoming 
YT Yukon Territory 

 
 

* The same FIPS code, NU, is used for Nicaragua and the province of Nunavut, Canada in the 
PC*MILER database. 
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Mexican Estados 
AG Aguascalientes 
BJ Baja California 
BS Baja California Sur 
CP Campeche 
CH Chiapas 
CI Chihuahua 
CU Coahuila de Zaragoza 
CL Colima 
DF Ciudad de Mexico (previously “Distrito Federal”) 
DG Durango 
GJ Guanajuato 
GR Guerrero 
HG Hidalgo 
JA Jalisco 
EM Mexico (Estado) 
MH Michoacan de Ocampo 
MR Morelos 
NA Nayarit 
NX * Nuevo Leon 
OA Oaxaca 
PU Puebla 
QA Queretaro Arteaga 
QR Quintana Roo 
SL San Luis Potosi 
SI Sinaloa 
SO Sonora 
TA Tabasco 
TM Tamaulipas 
TL Tlaxcala 
VZ Veracruz 
YC Yucatan 
ZT Zacatecas 

 
*  Please note that by default, “NX” is used for Nuevo Leon because the province of 

Newfoundland and Labrador in Canada already utilizes “NL” in the database.  However, there 
is an option that sets “NL” as the abbreviation for Nuevo Leon: in the red File menu, select 
Application Settings > Geocoding.  In the NL Abbreviation drop-down, select Use NL for 
Nuevo Leon and click Save. 
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Country Codes for Worldwide Regions 
 
Africa 

 

COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Algeria AG DZ DZA DZ DZA 
Angola AO AO AGO AO AGO 
Benin BN BJ BEN BJ BEN 
Botswana BC BW BWA BW BWA 
Burkina Faso UV BF BFA BF BFA 
Burundi BY BI BDI BI BDI 
Cameroon CM CM CMR CM CMR 
Cape Verde CV CV CPV CV CPV 
Central African Republic CT CF CAF CF CAF 
Chad CD TD TCD TD TCD 
Comoros CN KM COM KM COM 
Congo Democratic Republic (Kinshasa) CG CD COD CD COD 
Congo, Republic of the (Brazzaville) CF CG COG CG COG 
Djibouti DJ DJ DJI DJ DJI 
Egypt EG EG EGY EG EGY 
Equatorial Guinea EK GQ GNQ GQ GNQ 
Eritrea ER ER ERI ER ERI 
Ethiopia ET ET ETH ET ETH 
Gabon GB GA GAB GA GAB 
Gambia GA GM GMB GM GMB 
Ghana GH GH GHA GH GHA 
Guinea GV GN GIN GN GIN 
Guinea-Bissau PU GW GNB GW GNB 
Ivory Coast (Côte d’Ivoire) IV CI CIV CI CIV 
Kenya KE KE KEN KE KEN 
Lesotho LT LS LSO LS LSO 
Liberia LI LR LBR LR LBR 
Libya LY LY LBY LY LBY 
Madagascar MA MG MDG MG MDG 
Malawi MI MW MWI MW MWI 
Mali ML ML MLI ML MLI 
Mauritania MR MR MRT MR MRT 
Mauritius MP MU MUS MU MUS 
Mayotte MF YT MYT YT MYT 
Morocco MO MA MAR MA MAR 
Mozambique MZ MZ MOZ MZ MOZ 
Namibia WA NA NAM NA NAM 
Niger NG NE NER NE NER 
Nigeria NI NG NGA NG NGA 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Reunion RE RE REU RE REU 
Rwanda RW RW RWA RW RWA 
Saint Helena SH SH SHN SH SHN 
Sao Tome and Principe TP ST STP ST STP 
Senegal SG SN SEN SN SEN 
Seychelles SE SC SYC SC SYC 
Sierra Leone SL SL SLE SL SLE 
Somalia SO SO SOM SO SOM 
South Africa SF ZA ZAF ZA ZAF 
South Sudan OD SD SDW SS SSD 
Sudan SU SD SDN SD SDN 
Swaziland WZ SZ SWZ SZ SWZ 
Tanzania TZ TZ TZA TZ TZA 
Togo TO TG TGO TG TGO 
Tunisia TS TN TUN TN TUN 
Uganda UG UG UGA UG UGA 
Western Sahara WI EH ESH EH ESH 
Zambia ZA ZM ZMB ZM ZMB 
Zimbabwe ZI ZW ZWE ZW ZWE 
 

      
Asia 
      
Bangladesh BG BD BGD BD BGD 
Bhutan BT BT BTN BT BTN 
British Indian Ocean Territory IO -- -- -- -- 
Brunei  BX BN BRN BN BRN 
Burma (Myanmar) BM MM MMR MM MMR 
Cambodia CB KH KHM KH KHM 
China CH CN CHN CN CHN 
Guam GQ GU GUM GU GUM 
Hong Kong HK HK HKG HK HKG 
India IN IN IND IN IND 
Indonesia ID ID IDN ID IDN 
Japan JA JP JPN JP JPN 
Korea, North KN KP PRK KP PRK 
Korea, South KS KR KOR KR KOR 
Laos LA LA LAO LA LAO 
Macao MC MO MAC MO MAC 
Malaysia MY MY MYS MY MYS 
Maldives MV MV MDV MV MDV 
Mongolia MG MN MNG MN MNG 
Nepal NP NP NPL NP NPL 
Northern Mariana Islands CQ MP MNP MP MNP 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Pakistan PK PK PAK PK PAK 
Palau PS PW PLW PW PLW 
Papua New Guinea PP PG PNG PG PNG 
Philippines RP PH PHL PH PHL 
Singapore SN SG SGP SG SGP 
Solomon Islands BP SB SLB SB SLB 
Sri Lanka CE LK LKA LK LKA 
Taiwan TW TW TWN TW TWN 
Thailand TH TH THA TH THA 
Timor-Leste TT TL TLS TL TLS 
Vietnam VM VN VNM VN VNM 
 
      
Europe 
      
Akrotiri AX -- -- QZ XQZ 
Albania AL AL ALB AL ALB 
Armenia AM AM ARM AM ARM 
Andorra AN AD AND AD AND 
Austria AU AT AUT AT AUT 
Azerbaijan AJ AZ AZE AZ AZE 
Belarus BO BY BLR BY BLR 
Belgium BE BE BEL BE BEL 
Bosnia and Herzegovina BK BA BIH BA BIH 
Bulgaria BU BG BGR BG BGR 
Croatia HR HR HRV HR HRV 
Cyprus CY CY CYP CY CYP 
Czech Republic EZ CZ CZE CZ CZE 
Denmark DA DK DNK DK DNK 
Dhekelia DX -- -- XD XXD 
Estonia EN EE EST EE EST 
Faroe Islands FO FO FRO FO FRO 
Finland FI FI FIN FI FIN 
France FR FR FRA FR FRA 
Georgia GG GE GEO GE GEO 
Germany GM DE DEU DE DEU 
Gibraltar GI GI GIB GI GIB 
Greece GR GR GRC GR GRC 
Guernsey GK -- -- GG GGY 
Hungary HU HU HUN HU HUN 
Iceland IC IS ISL IS ISL 
Ireland EI IE IRL IE IRL 
Isle of Man IM IM IMN IM IMN 
Italy IT IT ITA IT ITA 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Jersey JE -- -- JE JEY 
Kazakhstan KZ KZ KAZ KZ KAZ 
Kyrgyzstan KG KG KGZ KG KGZ 
Latvia LG LV LVA LV LVA 
Liechtenstein LS LI LIE LI LIE 
Lithuania LH LT LTU LT LTU 
Luxembourg LU LU LUX LU LUX 
Macedonia MK MK MKD MK MKD 
Malta MT MT MLT MT MLT 
Moldova MD MD MDA MD MDA 
Monaco MN MC MCO MC MCO 
Montenegro MJ ME MNE ME MNE 
Netherlands NL NL NLD NL NLD 
Norway NO NO NOR NO NOR 
Poland PL PL POL PL POL 
Portugal PO PT PRT PT PRT 
Romania RO RO ROU RO ROU 
Russia RS RU RUS RU RUS 
San Marino SM SM SMR SM SMR 
Serbia RI SRB SRB RS SRB 
Slovakia LO SK SVK SK SVK 
Slovenia SI SI SVN SI SVN 
Spain SP ES ESP ES ESP 
Svalbard and Jan Mayen Islands SV SJ SJM XR XSV 
Sweden SW SE SWE SE SWE 
Switzerland SZ CH CHE CH CHE 
Tajikistan TI TJ TJK TJ TJK 
Turkey TU TR TUR TR TUR 
Turkmenistan TX TM TKM TM TKM 
Ukraine UP UA UKR UA UKR 
United Kingdom UK GB GBR GB GBR 
Uzbekistan UZ UZ UZB UZ UZB 
Vatican City VT VA VAT VA VAT 
      
      

Middle East 
Afghanistan AF AF AFG AF AFG 
Bahrain BA BH BHR BH BHR 
Gaza Strip GZ -- XGZ XG XGZ 
Iran IR IR IRN IR IRN 
Iraq IZ IQ IRQ IQ IRQ 
Israel IS IL ISR IL ISR 
Jordan JO JO JOR JO JOR 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Kuwait KU KW KWT KW KWT 
Lebanon LE LB LBN LB LBN 
Oman MU OM OMN OM OMN 
Palestinian Territory -- PS PSE PS PSE 
Qatar QA QA QAT QA QAT 
Saudi Arabia SA SA SAU SA SAU 
Syria SY SY SYR SY SYR 
United Arab Emirates AE AE ARE AE ARE 
West Bank WE -- XWB XW XWB 
Yemen YM YE YEM YE YEM 

    

North America 
 

Canada CA CA CAN CA CAN 
Greenland GL GL GRL GL GRL 
Mexico MX MX MEX MX MEX 
Puerto Rico* PR* PR PRI PR PRI 
Saint Pierre and Miquelon SB PM SPM PM SPM 
United States US US USA US USA 
Virgin Islands, U.S. VI VI VIR VI VIR 

* Note: “PR” for Puerto Rico is a USPS code, not a FIPS code. 
 

 

Oceania 
      
American Samoa AQ AS ASM AS ASM 
Australia AS AU AUS AU AUS 
Cook Islands CW CK COK CK COK 
Fiji FJ FJ FJI FJ FJI 
French Polynesia FP PF PYF PJ PYF 
French Southern and Antarctic Islands FS TF ATF TF ATF 
Kiribati KR KI KIR KI KIR 
Marshall Islands RM MH MHL MH MHL 
Micronesia, Federated States of FM FM FSM FM FSM 
Midway Island MQ UM -- QM XMW 
Nauru NR NR NRU NR NRU 
New Caledonia NC NC NCL NC NCL 
New Zealand NZ NZ NZL NZ NZL 
Niue NE NU NIU NU NIU 
Norfolk Island NF NF NFK NF NFK 
Pitcairn Islands PC PN PCN PN PCN 
Samoa (Western Samoa) WS WS WSM WS WSM 
Tokelau TL TK TKL TK TKL 
Tonga TN TO TON TO TON 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Tuvalu TV TV TUV TV TUV 
Vanuatu NH VU VUT VU VUT 
Wake Island WQ WQ XWK QW XWK 
Wallis and Futuna WF WF WLF WF WLF 

         
South America 
      
Anguilla AV AI AIA AI AIA 
Antigua and Barbuda AC AG ATG AG ATG 
Argentina AR AR ARG AR ARG 
Aruba AA AW ABW AW ABW 
Bahamas BF BS BHS BS BHS 
Barbados BB BB BRB BB BRB 
Belize BH BZ BLZ BZ BLZ 
Bermuda BD BM BMU BM BMU 
Bolivia BL BO BOL BO BOL 
Bonaire, Sint Eustatius, Saba -- -- -- BQ BES 
Brazil BR BR BRA BR BRA 
Caribbean Netherlands NT AN BES BQ BES 
Cayman Islands CJ KY CYM KY CYM 
Chile CI CL CHL CL CHL 
Colombia CO CO COL CO COL 
Costa Rica CS CR CRI CR CRI 
Cuba CU CU CUB CU CUB 
Curacao UC -- -- CUW CUW 
Dominica DO DM DMA DM DMA 
Dominican Republic DR DO DOM DO DOM 
Ecuador EC EC ECU EC ECU 
El Salvador ES SV SLV SV SLV 
Falkland Islands (Islas Malvinas) FK FK FLK FK FLK 
French Guiana FG GF GUF GF GUF 
Grenada GJ GD GRD GD GRD 
Guadeloupe GP GP GLP GP GLP 
Guantanamo Bay -- -- -- A2 AX2 
Guatemala GT GT GTM GT GTM 
Guyana GY GY GUY GY GUY 
Haiti HA HT HTI HT HTI 
Honduras HO HN HND HN HND 
Jamaica JM JM JAM JM JAM 
Martinique MB MQ MTQ MQ MTQ 
Montserrat MH MS MSR MS MSR 
Nicaragua* NU* NI NIC NI NIC 
Panama PM PA PAN PA PAN 
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COUNTRY NAME FIPS ISO2 ISO3 GENC2 GENC3 
Paraguay PA PY PRY PY PRY 
Peru PE PE PER PE PER 
Saint Barthalemy TB -- BLM BL BLM 
Saint Kitts and Nevis Islands SC KN KNA KN KNA 
Saint Lucia ST LC LCA LC LCA 
Saint Martin RN -- MAF MF MAF 
Saint Vincent and the Grenadines VC VC VCT VC VCT 
Sint Maarten NN -- SXM SX SXM 
Suriname NS SR SUR SR SUR 
Trinidad and Tobago TD TT TTO TT TTO 
Turks and Caicos Islands TK TC TCA TC TCA 
Uruguay UY UY URY UY URY 
Venezuela VE VE VEN VE VEN 
Virgin Islands, British VG VG VGB VG VGB 

 * The same FIPS code, NU, is used for Nicaragua and the province of Nunavut, Canada in the PC*MILER 
database. 

 
 
Official Sources 
 
FIPS Country Codes: 
FIPS PUB 10-4: http://geonames.nga.mil/gns/html/countrycodes.html (“Download Country Files” link) 
 
ISO2 and ISO3 Country Codes: 
ISO Online Browsing Platform: https://www.iso.org/obp/ui/#search/code/ 
 
GENC2 and GENC3 Country Codes (Geopolitical Entities, Names and Codes): 
GENC Registry: https://nsgreg.nga.mil/genc/discovery 
 

http://geonames.nga.mil/gns/html/countrycodes.html
https://www.iso.org/obp/ui/#search/code/
https://nsgreg.nga.mil/genc/discovery
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Appendix E:  
Valid Entries for Street Addresses 

 
 
 

For PC*MILER|Streets users, valid directional and street type abbreviations for street address 
entry in North America are listed below.  Spelling out the whole word is also acceptable.  
Capitalization is not necessary. 
 

Directional Synonyms for Address Entry – Prefix or Suffix 

Full Spelling Valid in PC*MILER 
EAST E 
EAST E. 
NORTH N 
NORTH N. 
NORTH NO 
NORTH NO. 
NORTHEAST N-E 
NORTHEAST N.E 
NORTHEAST N.E. 
NORTHEAST NE 
NORTHEAST NE. 
NORTHEAST NORTH-EAST 
NORTHWEST N-W 
NORTHWEST N.W 
NORTHWEST. N.W. 
NORTHWEST NORTH-WEST 
NORTHWEST NW 
NORTHWEST NW. 
SOUTH S 
SOUTH S. 
SOUTH SO 
SOUTH SO. 
SOUTHEAST S-E 
SOUTHEAST S.E 
SOUTHEAST S.E. 
SOUTHEAST SE 
SOUTHEAST SE. 
SOUTHEAST SOUTH-EAST 
SOUTHWEST S-W 
SOUTHWEST S.W 
SOUTHWEST S.W. 
SOUTHWEST SOUTH-WEST 
SOUTHWEST SW 
SOUTHWEST SW. 
WEST W 
WEST W. 
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Synonyms for Street Types 
 
 Valid in 
Full Spelling PC*MILER 
 
ALLEY AL 
ALLEY AL. 
ALLEY                    ALL 
ALLEY                    ALL. 
ALLEY                    ALY 
ALLEY                    ALY. 
ARCADE                   ARC 
ARCADE                   ARC. 
AVENUE                   AV 
AVENUE                   AV. 
AVENUE                  AVDA 
AVENUE                   AVDA. 
AVENUE                  AVE 
AVENUE                  AVE. 
AVENUE                   AVEN 
AVENUE                   AVEN. 
AVENUE                   AVENIDA 
AVENUE                   AVENIDA. 
AVENUE DES             AV DES 
AVENUE DES               AV DES. 
BASSIN                   BAS 
BASSIN                   BAS. 
BASSINS                 BAS 
BASSINS                  BAS. 
BEACH                    BCH 
BEACH                    BCH. 
BEND                     BND 
BEND                     BND. 
BERGE                    BER 
BERGE                    BER. 
BLUFFS                   BLFS 
BLUFFS                   BLFS. 
BOUCLE                   BCLE 
BOUCLE                   BCLE. 
BOULEVARD                BD 
BOULEVARD                BD. 
BOULEVARD                BL 
BOULEVARD                BL. 
BOULEVARD                BLVD 
BOULEVARD               BLVD. 
BOULEVARD                BOUL 
BOULEVARD                BOUL. 
BRIDGE                   BRDG 
BRIDGE                   BRDG. 
BRIDGE                   BRG 
BRIDGE                   BRG. 
BROOK                    BRK 

BROOK                    BRK. 
BROOKS                   BRKS 
BROOKS                   BRKS. 
BUTTE                    BUT 
BUTTE                    BUT. 
BYPASS                  BYP 
BYPASS                   BYP. 
CALE                     CAL 
CALE                     CAL. 
CAPE                     CPE 
CAPE                     CPE. 
CARREFOUR                CAR 
CARREFOUR                CAR. 
CARRIERE                 CARE 
CARRIERE                 CARE. 
CAUSEWAY                 CAUSE 
CAUSEWAY                 CAUSE. 
CAUSEWAY                 CSWY 
CAUSEWAY                 CSWY. 
CAVEE                    CAV 
CAVEE                    CAV. 
CENTER                   CNTR 
CENTER                   CNTR. 
CENTER                   CTR 
CENTER                   CTR. 
CHATEAU                  CHA 
CHATEAU                  CHA. 
CHEMIN                   CH 
CHEMIN                   CH. 
CHEMIN                   CHE 
CHEMIN                   CHE. 
CHEMINEMENT             CHEM 
CHEMINEMENT             CHEM. 
CIRCLE                   CIR 
CIRCLE                   CIR. 
CIRCLE                   CIRC 
CIRCLE                   CIRC. 
CIRCLES                  CIRS 
CIRCLES                  CIRS. 
CLIFFS                   CLFS 
CLIFFS                   CLFS. 
CITE                     CIT 
CITE                     CIT. 
CLOS                     CL 
CLOS                     CL. 
COLONEL                  COL 
COLONEL                  COL. 
COMMON                   CMN 
COMMON                   CMN. 
COMMONS                  CMN 
COMMONS                  CMN. 
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COMMONS                  CMNS 
COMMONS                  CMNS. 
CORNER                   COR 
CORNER                   COR. 
CORNERS                  CORS 
CORNERS                  CORS. 
CONTOUR                  CTR 
CORNICHE                 CORN 
COTE                     COT 
COUR                     C 
COUR                     CR 
COURS                    CRS 
COURT                    CRT 
COURT                    CRT. 
COURT                    CT 
COURT                    CT. 
COURTS                   CTS 
COURTS                   CTS. 
COVE                     CV 
COVE                     CV. 
COVES                    CVS 
COVES                    CVS. 
CREEK                    CRK 
CREEK                    CRK. 
CRESCENT                 CRES 
CRESCENT                 CRES. 
CRESCENT                 CRESC 
CRESCENT                 CRESC. 
CRESCENT                 CRESNT 
CREST                    CRST 
CREST                    CRST. 
CROSSING                 CRSG 
CROSSING                 CRSG. 
CROSSING                 XING 
CROSSING                 XING. 
CROSSROADS               XRDS 
CROSSROADS               XRDS. 
DESCENTE                 DESC 
DRIVE                    DR 
DRIVE                    DR. 
DRIVE                    DRV 
DRIVE                   DRV. 
DRIVES                   DRS 
DRIVES                   DRS. 
ENCLAVE                  ENC 
ENCLOS                   ENC 
ESPACE                   ESP 
ESPLANADE                ESP 
ESTATE                   EST 
ESTATE                   EST. 
ESTATES                  ESTS 
ESTATES                  ESTS. 

EXPRESSWAY               EXPR 
EXPRESSWAY               EXPR. 
EXPRESSWAY               EXPY 
EXPRESSWAY               EXPY. 
EXPRESSWAY               EXWY 
EXPRESSWAY               EXWY. 
EXTENSION                EXT 
EXTENSION                EXT. 
EXTENSIONS               EXTS 
EXTENSIONS               EXTS. 
FALLS                    FLS 
FALLS                    FLS. 
FARM-TO-MARKET    F-M 
FARM-TO-MARKET     FM 
FARM-TO-MARKET      FM. 
FAUBOURG                 FAUB 
FAUBOURG                 FAUB. 
FIELD                    FLD 
FIELD                    FLD. 
FIELDS                   FLDS 
FIELDS                   FLDS. 
FLATS                    FLTS 
FLATS                    FLTS. 
FORKS                    FRKS 
FORKS                    FRKS. 
FORUM                    FORM 
FREEWAY                  FRWY 
FREEWAY                 FRWY. 
FREEWAY                  FWY 
FREEWAY                  FWY. 
GLEN                     GLN 
GLEN                     GLN. 
GRAND BOULEVARD GBD 
GRAND BOULEVARD GBLVD 
GREEN                    GRN 
GREEN                    GRN. 
GREENS                   GRNS 
GREENS                   GRNS. 
GROVE                    GRV 
GROVE                    GRV. 
GROVES                   GRVS 
GROVES                   GRVS. 
GRANDE RUE               GR 
GRIMPETTE                GRP 
GRIMPETTE                GRP. 
HARBOR                   HBR 
HAVEN                    HVN 
HAVEN                    HVN. 
HEIGHTS                  HTS 
HIGHWAY                  HWY 
HIGHWAY                  HWY. 
HIGHWAY                  HY 
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HIGHWAY                  HY. 
HIGHWAY                  HIWAY 
HIGHWAY                  HIWAY. 
HILL                     HL 
HILLS                    HLS 
HILLS                    HLS. 
HOLLOW                   HOLW 
HOLLOW                   HOLW. 
IMMEUBLE                 IMM 
IMMEUBLE                 IMM. 
IMPASSE                  IMP 
IMPASSE                  IMP. 
ISLAND                   IS 
ISLAND                   IS. 
JARDIN                   J 
KEY                      KY 
KEY                      KY. 
KEYS                     KYS 
KEYS                     KYS. 
KNOLL                    KNL 
KNOLL                    KNL. 
KNOLLS                   KNLS 
KNOLLS                   KNLS. 
LAKES                    LKS 
LAKES                    LKS. 
LAND                     LAND 
LAND                     LAND. 
LANDING                  LNDG 
LANDING                  LNDG. 
LANE                     LA 
LANE                     LA. 
LANE                     LN 
LANE                     LN. 
LEVEE                    LEV 
LIEU DIT                 L-D 
LIEU DIT                 LD 
LIEU DIT                LIEU 
LIEU-DIT                 L-D 
LIEU-DIT                 LD 
LIEU-DIT                 LIEU 
LIGHTS                   LGTS 
LIGHTS                   LGTS. 
LOCKS                    LCKS 
LOCKS                    LCKS. 
LOOP                     LP 
LOOP                     LP. 
LOTISSEMENT              LOT 
LOTISSEMENT              LOT. 
MALL                     ML 
MALL                     ML. 
MANOR                    MNR 
MANOR                    MNR. 

MANORS                   MNRS 
MANORS                   MNRS. 
MEADOW                   MDW 
MEADOW                   MDW. 
MEADOWS                  MDWS 
MEADOWS                  MDWS. 
MILLS                    MLS 
MILLS                    MLS. 
MOTORWAY                 MRWY 
MOTORWAY                 MRWY. 
MOTORWAY                 MTRWY 
MOTORWAY                 MTRWY. 
MOTORWAY                 MTWY 
MOTORWAY                 MTWY. 
MOUNT                    MT 
MOUNT                    MT. 
OVERPASS                 OPAS 
OVERPASS                 OPAS. 
OVERPASS                 OVER 
OVERPASS                 OVER. 
OVERPASS                 OVPS 
OVERPASS                 OVPS. 
OVERPASS                 OVRPS 
OVERPASS                 OVRPS. 
PARK                     PK 
PARK                     PK. 
PARK                     PRK 
PARK                     PRK. 
PARKWAY                  PKY 
PARKWAY                  PKY. 
PARKWAY                  PKW 
PARKWAY                  PKW. 
PARKWAY                  PKWY 
PARKWAY                  PKWY. 
PARKWAY                  PKWAY 
PARKWAY                  PKWAY. 
PARKWAY                  PRKWY 
PARKWAY                  PRKWY. 
PARVIS                   PAR 
PASEO                    PSO 
PASS                     PS 
PASS                     PS. 
PASSAGE                  PASS 
PATH                     PTH 
PATH                     PTH. 
PETITE AVENUE           PTA 
PETITE IMPASSE           PTI 
PETITE ROUTE             PRT 
PETITE RUE               PTR 
PIKE                     PKE 
PIKE                     PKE. 
PINE                     PNE 
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PINE                     PNE. 
PINES                    PNES 
PINES                    PNES. 
PLACE                    PL 
PLACE                    PL. 
PLACE                    PLA 
PLACE                    PLA. 
PLACE                    PLAC 
PLACE                    PLAC. 
PLACE                    PLC 
PLACE                    PLC. 
PLAINS                   PLNS 
PLAINS                   PLNS. 
PLAZA                    PLZ 
PLAZA                    PLZ. 
POINT                    PNT 
POINT                    PNT. 
POINT                    PT 
POINT                    PT. 
POINTS                   PTS 
POINTS                   PTS. 
PORTE                    PTE 
POURTOUR                 POUR 
POURTOUR                 POUR. 
PRAIRIE                  PR 
PRAIRIE                  PR. 
PROMENADE                PROM 
QUAI                     Q 
QUAI                     Q. 
QUARTIER                 QUA 
RACCOURCI                RAC 
RACCOURCI                RAC. 
RAMP                     RMP 
RAMP                     RMP. 
RAMPE                    RPE 
RAPIDS                   RPDS 
RAPIDS                   RPDS. 
REMPART                 REM 
RESIDENCE                RES 
RESIDENCE                RES. 
RIDGE                    RDG 
RIDGE                    RDG. 
RIDGES                   RDGS 
RIDGES                   RDGS. 
ROAD                     RD 
ROAD                     RD. 
ROADS                    RDS 
ROADS                    RDS. 
ROCADE                   ROC 
ROCADE                   ROC. 
ROND POINT               ROND 
ROND POINT               RP 

ROND POINT               RP. 
ROND-POINT               ROND 
ROND-POINT               RP 
ROND-POINT               RP. 
ROTONDE                  ROT 
ROTONDE                  RTD 
ROUTE                    RTE 
RUE                      R 
RUE                      R. 
RUE DE                   RUE 
SENTIER                  SENT 
SENTIER                  SENT. 
SHOALS                   SHLS 
SHOALS                   SHLS. 
SHORES                   SHRS 
SHORES                   SHRS. 
SKYWAY                   SKWY 
SKYWAY                   SKWY. 
SPRINGS                 SPGS 
SPRINGS                 SPGS. 
SQUARE                   SQ 
SQUARE                   SQ. 
SQUARE                   SQR 
SQUARE                   SQR. 
SQUARES                  SQS 
SQUARES                  SQS. 
STRASSE                  STR 
STRASSE                  STR. 
STREET                   ST 
STREET                   ST. 
STREET                   STR 
STREET                   STR. 
STREETS                  STS 
STREETS                  STS. 
TERRACE                  TER 
TERRACE                  TER. 
TERRACE                  TERR 
TERRACE                  TERR. 
TERRACE                  TRC 
TERRACE                  TRC. 
TERRASSE                 TER 
TERTRE                   TRT 
THROUGHWAY             THRUWAY 
THROUGHWAY             THWY 
THROUGHWAY             THWY. 
TOUR                     TR 
TOUR                     TR. 
TRACK                    TRAK 
TRACK                    TRAK. 
TRAFFICWAY               TFCWY 
TRAFFICWAY               TFCWY. 
TRAFFICWAY               TFWY 
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TRAFFICWAY               TFWY. 
TRAFFICWAY               TRFY 
TRAFFICWAY               TRFY. 
TRAFFICWAY              TRWY 
TRAFFICWAY               TRWY. 
TRAIL                    TRL 
TRAIL                    TRL. 
TRAILER                  TRLR 
TRAILER                  TRLR. 
TRAVERSE                 TRA 
TUNNEL                   TUN 
TUNNEL                   TUN. 
TUNNEL                   TUNL 
TUNNEL                   TUNL. 
TUNNEL                   TUNN 
TUNNEL                   TUNN. 
TURNPIKE                 TPK 
TURNPIKE                 TPK. 
TURNPIKE                 TPKE 
TURNPIKE                 TPKE. 
UNDERPASS                UNP 
UNDERPASS                UNP. 
UNDERPASS                UNPS 
UNDERPASS               UNPS. 
UNDERPASS                UNRPS 
UNDERPASS                UNRPS. 
UNDERPASS                UPAS 
UNDERPASS                UPAS. 
VENELLE                  VEN 
VIEILLE ROUTE            VRTE 
VIEUX CHEMIN             VCHE 
VIEW                     VW 
VIEW                     VW. 
VIEWS                    VWS 
VIEWS                    VWS. 
VILLAGE                  VGE 
VILLAGE                  VLG 
VILLAGE                  VLG. 
VILLAGES                 VLGS 
VILLAGES                 VLGS. 
VOIE                     V 
WAY                      WY 
WAY                      WY. 
WAYS                     WAYS 
WAYS                     WAYS. 
WELLS                    WLS 
WELLS                    WLS. 
ZONE ARTISANALE    ZA 
ZONE D'ACTIVITE      Z.A. 
ZONE D'ACTIVITE      ZA. 
ZONE INDUSTRIELLE Z.I 

ZONE INDUSTRIELLE Z.I.ZONE 
INDUSTRIELLE ZI 
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Appendix F:  
Toll Plaza Names in Reports 

 
 
The chart below identifies the toll authorities that have assigned multiple names to the same toll plaza location.  When generating a route 
using PC*MILER|Tolls, only one name for each toll plaza location is provided in the Detailed Route Report.  Because a vehicle can travel 
through any of the sub-plazas at one of these locations, this chart may help you match up agency names to the names that appear along a 
route in the Detailed Route Report. 
 
Currently there is only one toll plaza location in the database that has multiple names assigned to it: 
 
 

Agency Toll Road Toll Plaza Name in 
PC*MILER|Connect 

Toll Plaza 
Abbreviation in 
Detailed Route 
Report 

Other Plaza 
Abbreviations Used 
By Agency at the 
Same Location 

Other Plaza Names 
Used by Agency at 
the Same Location 

VDOT Chesapeake Expressway Chesapeake Expressway 16, 17 18*  
 
* 18 is the abbreviation used for Discount Program Members. 
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Appendix G:  
Toll Roads Requiring Electronic Payment 

 
 
Table 1 below lists roads that only accept toll discount programs.  No cash or other payment option is offered, and driving on one of these 
roads without a transponder and discount program membership will cause an invoice to be sent with a surcharge added to the toll rate. 
 
Table 2 lists all electronic toll roads (Open Road Tolling).  Like the roads in Table 1, drivers without a transponder on these roads will 
receive an invoice with a video toll rate amount. 
 
What differentiates these two types of roads is the amount of the surcharge on the roads in Table 1: these roads carry a relatively expensive 
surcharge, and the transportation authorities strongly advise against driving on these roads without a transponder. 

 
 
TABLE 1.  Roads Accepting Only Toll Discount Programs – Additional Surcharge on Violations 
 

State Toll Road/Exits Discount Program Video Toll/Cash Comments 

Florida’s Turnpike SunPass None For the Florida Turnpike, the five 
exits listed are SunPass Only. 
Drivers without SunPass are 
required to exit before or after 
these exits.  If used by mistake 
then an invoice is sent home with 
a surcharge. 

Becker Road exit 138 SunPass None  
Jog Road exit 98 SunPass None  
SR 710 exit 107 SunPass None  
Consulate Drive exit 255 SunPass None  
Kissimmee Park Rd exit 240 SunPass None  
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State Toll Road/Exits Discount Program Video Toll/Cash Comments 

Florida Polk Parkway - 
Pace Road exit 23 

SunPass None This exit on the Polk Parkway is 
SunPass only.  If used by mistake 
an invoice is sent to the user with 
a surcharge. 

I-595 Express Lane SunPass None Express Lanes tolling violators 
shall be charged $25 per trip plus 
the applicable toll amount. 

Pennsylvania Turnpike E-ZPass None For the four exits listed here a 
video toll plus a surcharge is sent 
in an invoice to the user. 

Virginia Drive exit 340 E-ZPass None  
Street Road exit 352    
SR 29 exit 320 E-ZPass None  

 SR 903 exit 87 E-ZPass None  
Camino Colombia Toll Road EZ Tag, TxTag, TollTag None You must have a TxTag account or 

other accepted prepaid account to 
pay tolls on Camino Colombia. 
Under Texas law, non-payment of 
tolls is a misdemeanor offense, 
and you may be subject to 
Administrative fees and fines of 
up to $350 per violation. 

Fort Bend Westpark Tollway EZ Tag, TxTag None A toll violation event can result in 
a Toll Violation Invoice being sent 
to the registered owner/renter for 
the past-due toll amount plus 
fees. Independent of a Toll 
Violation Invoice, any toll violation 
event may also result in a traffic 
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State Toll Road/Exits Discount Program Video Toll/Cash Comments 

 
 
Texas 

stop and the issuance of a traffic 
citation, which carries a significant 
fine plus court costs. 

Fort Bend Parkway Toll 
Road (Fort Bend Section) 

EZ Tag, TxTag, TollTag None A fee is added to the toll rate and 
an invoice it sent to drivers 
without EZ Tag. 

Westpark Tollway EZ Tag, TxTag, TollTag  None Driving without an EZ TAG results 
in a violation event. A toll 
violation event can result in a Toll 
Violation Invoice being sent to the 
registered owner/renter for the 
past-due toll amount plus fees. 
Independent of a Toll Violation 
Invoice, any toll violation event 
may also result in a traffic stop 
and the issuance of a traffic 
citation, which carries a significant 
fine plus court costs. 

Grand Parkway (Fort Bend 
section) 

EZ Tag, TxTag, TollTag None A fee is added to the toll rate and 
an invoice it sent to drivers 
without EZ Tag. 

Texas State Highway 99 EZ Tag, TxTag, TollTag None A Notice of Toll Violation with a 
$5.00 fee for each toll charge is 
issued. Drivers who fail to pay 
violation notices on time are 
subject to collection fees and 
court fines that can add up to 
$350 per violation. 
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State Toll Road/Exits Discount Program Video Toll/Cash Comments 

 
 
 

Texas SH 242 Direct 
Connectors 

EZ Tag, TxTag, TollTag None A toll violation event can result in 
a Toll Violation Invoice being sent 
to the registered owner/renter for 
the past-due toll amount plus 
fees. Independent of a Toll 
Violation Invoice, any toll violation 
event may also result in a traffic 
stop and the issuance of a traffic 
citation, which carries a significant 
fine plus court costs. 

Sam Houston Tollway EZ Tag, TxTag, TollTag    None There are nineteen plazas that 
require an EZ TAG. A toll violation 
event can result in a Toll Violation 
Invoice being sent to the 
registered owner/renter for the 
past-due toll amount plus fees. 
Independent of a Toll Violation 
Invoice, any toll violation event 
may also result in a traffic stop 
and the issuance of a traffic 
citation, which carries a significant 
fine plus court costs. 

 North Gessner EZ Tag, TxTag, TollTag    None  
 West Road Entrance Ramp EZ Tag, TxTag, TollTag    None  
 Hammerly Blvd Entrance 

Ramp 
EZ Tag, TxTag, TollTag    None  

 Bellaire Blvd Entrance Ramp EZ Tag, TxTag, TollTag    None  
 Tidwell Road EZ Tag, TxTag, TollTag    None  
 Garrett Road EZ Tag, TxTag, TollTag    None  
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State Toll Road/Exits Discount Program Video Toll/Cash Comments 

 Generation Parkway EZ Tag, TxTag, TollTag    None  
 Northeast Mainline Toll 

Plaza 
EZ Tag, TxTag, TollTag    None  

 W Lake Houston Parkway EZ Tag, TxTag, TollTag    None  
 John Ralston Road EZ Tag, TxTag, TollTag    None  
 Wilson Road EZ Tag, TxTag, TollTag    None  
Texas Tanner Road Exit Ramp EZ Tag, TxTag, TollTag    None  
 Clay Road Exit Ramp EZ Tag, TxTag, TollTag    None  
 South Main Entrance Ramp EZ Tag, TxTag, TollTag    None  
 Almeda Road Entrance 

Ramp 
EZ Tag, TxTag, TollTag    None  

 Cullen Exit Ramp EZ TAG, TxTag, TollTag None  
 Wayside Entrance Ramp EZ TAG, TxTag, TollTag None  
 Red Bluff/ San Augustine 

Entrance Ramp 
EZ TAG, TxTag, TollTag None  

 Monroe Exit Ramp EZ TAG, TxTag, TollTag None  
 South Main EZ TAG, TxTag, TollTag None  
 Sam Houston Ship Channel 

Bridge 
EZ TAG, TxTag, TollTag None A toll violation event can result in 

a Toll Violation Invoice being sent 
to the registered owner/renter for 
the past-due toll amount plus 
fees. Independent of a Toll 
Violation Invoice, any toll violation 
event may also result in a traffic 
stop and the issuance of a traffic 
citation, which carries a significant 
fine plus court costs. 
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State Toll Road/Exits Discount Program Video Toll/Cash Comments 

 Hardy Toll Road EZ Tag, TxTag, TollTag    None A toll violation event can result in 
a Toll Violation Invoice being sent 
to the registered owner/renter for 
the past-due toll amount plus fees. 
Independent of a Toll Violation 
Invoice, any toll violation event 
may also result in a traffic stop and 
the issuance of a traffic citation, 
which carries a significant fine plus 
court costs. 

Rankin Road EZ Tag, TxTag, TollTag    None  
 Central Green Blvd EZ Tag, TxTag, TollTag    None  
 Richey Road  EZ Tag, TxTag, TollTag    None  
 Aldine Mail Route EZ Tag, TxTag, TollTag    None  
 Little York EZ Tag, TxTag, TollTag    None  
 Tidwell Road  EZ Tag, TxTag, TollTag    None  

 
 
 
TABLE 2.  Electronic Toll Roads (Open Road Tolling) 

 

State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

Golden Ears Bridge Quickpass Pay As You Go If the driver is not a registered 
customer, the license plate 
information is forwarded electronically 
to ICBC when the bridge is crossed. 
TransLink uses the information 
received from ICBC to send a bill for 
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State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

the toll amount to the registered 
owner of the vehicle. 

Port Mann Bridge TReO Pay By Mail  
Golden Gate Bridge FasTrak Pay-by-Plate  
Foothills-Eastern Toll Road FasTrak ExpressAccount 

Invoice 
 

San Joaquin Hills Corridor FasTrak ExpressAccount 
Invoice 

 

Colorado E-470 EXpressToll, GO-
PASS 

License Plate 
Toll 

 

 Northwest Parkway EXpressToll, GO-
PASS 

License Plate 
Toll 

 

 I-25 HOV Express Lanes EXpressToll, GO-
PASS 

License Plate 
Toll 

 

Snapper Creek Expressway SR 
878 

SunPass Toll-By-Plate  

Don Shula Expressway SR 874 SunPass Toll-By-Plate  
Gratigny Parkway SR 924 SunPass Toll-By-Plate  
Homestead Extension Of Florida's 
Turnpike - Exit 1 to Exit 47 
including Miramar Plaza 

SunPass Toll-By-Plate  

Sawgrass Expressway SunPass Toll-By-Plate  
Veterans Expressway SunPass Toll-By-Plate  
Airport Expressway SunPass Toll-By-Plate  
Broad Causeway SunPass Toll-By-Plate  
I-4/Selmon Expressway 
Interchange (Connector) 

SunPass Toll-By-Plate  

Orchard Pond Parkway SunPass Toll-By-Plate  
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State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

Poinciana Parkway E-Pass Pay by Plate  
Dolphin Expressway SR 836 SunPass Toll-By-Plate  
Rickenbacker Causeway SunPass Toll-By-Plate  
Venetian Causeway SunPass Toll-By-Plate  
Mid-Bay Bridge Connector SunPass Toll-By-Plate  
Florida’s Turnpike –  SunPass Toll-By-Plate  
Griffin Road SunPass Toll-By-Plate  
Hollywood Boulevard SunPass Toll-By-Plate  
NW 27th Avenue SunPass Toll-By-Plate  
Miramar Plaza SunPass Toll-By-Plate  
County Line Road SunPass Toll-By-Plate  
SR 417 X251 SunPass Toll-By-Plate  
Golden Glades Toll Plaza SunPass Toll-By-Plate  

 Central Florida Greeneway E-Pass Pay by Plate  
 East West Expressway E-Pass Pay by Plate  
 SR414 John Land Apopka E-Pass Pay by Plate  
 Western Expressway FL 429 E-Pass Pay by Plate  
 Beachline Expressway E-Pass Pay by Plate  
 Wekiva Parkway SunPass Toll-By-Plate  

Tri-State Tollway I-Pass, E-ZPass Video Toll Rate For the highlighted exit which is an all 
electronic tolling ramps, no cash 
accepted. Cash customers will incur an 
unpaid toll and are responsible for 
paying the cash fare indicated within 7 
days of the event. 

147th Street I-57/1294 I-Pass, E-ZPass Video Toll Rate  
Balmoral Northbound I-Pass, E-ZPass Video Toll Rate  
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State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

Ronald Reagan Tollway I-Pass, E-ZPass Video Toll Rate For the highlighted exit which is an all 
electronic tolling ramps, no cash 
accepted. Cash customers will incur an 
unpaid toll and are responsible for 
paying the cash fare indicated within 7 
days of the event. 

Eola Road I-Pass, E-ZPass Video Toll Rate  
Jane Addams Tollway I-Pass, E-ZPass Video Toll Rate  
Irene Road I-Pass, E-ZPass Video Toll Rate  
IL 47 EB ent WB exit I-Pass, E-ZPass Video Toll Rate  
IL 47 EB ent WB exit I-Pass, E-ZPass Video Toll Rate  

Maryland Intercounty Connector MD E-ZPass Video Toll Rate Toll facility customers who do not have 
an E-ZPass and travel the ICC will be 
sent a bill in the mail and charged the 
Video Toll Rate (VRT).  VRTs at all 
Maryland toll facilities are 150% of the 
base toll rates with a minimum of $1 
and a maximum of $15 above the base 
toll rate.      

Massachusetts Tobin Memorial Bridge E-ZPass Pay-By-Plate A photo of the license plate is taken 
and the registered owner of the 
vehicle receives a PAY BY PLATE MA 
invoice in the mail. Commercial 
customers will also see a 50 cent 
surcharge per toll. A convenience fee 
of $2.95 per PAY BY PLATE MA invoice 
payment will be charged for cash 
payments. 
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State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

New York Henry Hudson Bridge E-ZPass Tolls By Mail A photograph is taken of the license 
plate and the registered owner of the 
vehicle will receive a bill in the mail. 

 Tappan Zee Bridge E-ZPass Tolls By Mail Starting April 1, 2016 
North Carolina Triangle Expressway NC Quick Pass Bill By Mail  
Ontario 407 ETR 407 ETR 

Transponder 
Video Toll 
Charge 

 

Quebec A 25 Bridge A25 Transponder Video Toll 
Charge 

 

183A EZ Tag, TxTag, 
TollTag 

Pay By Mail  

Central Texas Tollways Loop 1 EZ Tag, TxTag, 
TollTag 

Pay By Mail  

Central Texas Tollways SH 130 EZ Tag, TxTag, 
TollTag 

Pay By Mail  

Central Texas Tollways SH 45 EZ Tag, TxTag, 
TollTag 

Pay By Mail  

Loop 49 TxTag, TollTag, EZ 
TAG 

Pay By Mail  

Manor Expressway EZ Tag, TxTag, 
TollTag 

Pay By Mail  

Addison Airport Tunnel TollTag, TxTag ZipCash  
Dallas North Tollway TollTag, TxTag ZipCash  
Lewisville Lake Toll Bridge TollTag, TxTag ZipCash  
Mountain Creek Lake Toll Bridge TollTag, TxTag ZipCash  
Sam Rayburn Tollway TollTag, TxTag ZipCash  
President George Bush Turnpike TollTag, TxTag ZipCash  
PGBT Western Extension SH 161 TollTag, TxTag ZipCash  
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State Toll Road/Exits Discount Program Video 
Toll/Cash Comments 

Chisholm Trail Parkway TollTag, TxTag ZipCash  
Tomball Tollway EZ Tag, TxTag, 

TollTag 
Video Toll A photo of the license plate is taken and 

the registered owner of the vehicle 
receives a violation notice with a $11.00 
fee added to the amount of the toll rate.  
This is a new toll road that opened on April 
12, 2015. 

Texas SH 550 EZ Tag, TxTag, 
TollTag 

Pay By Mail 
Rate 

 

Texas State Highway 99 EZ Tag, TxTag, 
TollTag 

Notice By Mail  

 Sam Houston Tollway    
 SH 249 Direct Connector EZ Tag, TxTag, 

TollTag 
Video Toll  

Pocahontas Parkway E-ZPass  E-ZPass, Visa or 
Mastercard 

The two listed exits are no cash exits, 
The Mainline Plaza is also cashless 
overnight from 11 p.m to 5 a.m. 
Payment options are Visa/Mastercard 
Debit/Credit cards 

Laburnum Avenue E-ZPass E-ZPass, Visa or 
Mastercard 

 

Airport Connector E-ZPass E-ZPass, Visa or 
Mastercard 

 

South Norfolk Jordan Bridge E-ZPass Pay by Plate  
Midtown Tunnel E-ZPass Pay by Plate  
Downtown Tunnel E-ZPass Pay by Plate  

Washington SR 520 Bridge Good To Go Pay By Mail  
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Appendix H:   

Worldwide Postal Code Formats 
 
 

 

Legend: A = alphabetic (A,B,C,…Z) 
N = numeric (0,1,2,...9) 

 

NOTE:  The version of PC*MILER in which postal code coverage was started is 
noted for each country listed below.  This refers to postal code coverage only, the 
country may have been available for routing without postal code access in previous 
versions. 

North America 
Canada  
ANA NAN or ANANAN 

Mexico, starting in Version 25.1 
NNNNN 

Puerto Rico, starting in Version 27.1 
NNNNN 

United States 
NNNNN 

South America 
Brazil, starting in Version 24.1 
NNNNN 

Europe 
United Kingdom 
AANA N or AAN N or AANN N 
or, starting in PCM24, AANAN or AANN or AANNN 
or, starting in Version 25.1, AANA NAA or AANANAA or AAN NAA or 
AANNAA or AANN NAA or AANNNAA 

France, Germany, Italy, Vatican City, Spain, and Finland 
NNNNN 

Russian Federation, starting in Version 22.1 
NNNNNN 

Romania, starting in Version 23.1 
NNNNNN 
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Estonia and Croatia, starting in Version 22.1 
NNNNN 

Lithuania, starting in Version 23.1 
NNNNN 
 
Andorra, starting in Version 26.1 
AANNN 
 
Monaco, starting in Version 26.1 
NNNNN 

Ukraine and Turkey, starting in Version 24.1 
NNNNN 

Netherlands, Belgium, Luxemburg, Austria, Switzerland, Liechtenstein, 
Denmark, Norway and Hungary 
NNNN 

Latvia and Slovenia, starting in Version 22.1 
NNNN 

Bulgaria, starting in Version 23.1 
NNNN 

Iceland 
NNN 

Ireland (Dublin only) 
NN (single digit postcodes N are not supported for input in PC*MILER) 

Poland 
NN-NNN 
or, starting in Version 24.1: NNNNN 

Portugal 
NNNN 
or, starting in Version 24.1: NNNN-NNN or NNNNNNN 
 
San Marino, starting in Version 26.1 
NNNNN 

Sweden 
NNN 
or, starting in Version 22.1: NNN NN or NNNNN 

Czech Republic and Slovakia 
NNN NN or NNNNN 
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Greece, starting in Version 22.1 
NNN NN or NNNNN 

Africa 
Lesotho, starting in Version 27.1 
NNNN 
 
South Africa, starting in Version 24.1 
NNNN 
 
Swaziland, starting in Version 27.1 
ANNN 

Asia 
Japan, starting in Version 24.1 
NNN-NNNN or NNNNNNN  

India, starting in Version 24.1 
NNNNNN 
 
Indonesia, starting in Version 27.1 
NNNNN 
 
Malaysia, starting in Version 27.1 
NNNNN 
 
Taiwan, starting in Version 27.1 
NNN 
 
Thailand, starting in Version 27.1 
NNNNN 

Oceania 
Australia, starting in Version 24.1 
NNNN 
 
New Zealand, starting in Version 27.1 
NNNN 
 
Federated States of Micronesia, Guam, Marshall Islands, Northern Mariana Islands, 
and Palau, starting in Version 27.1 
NNNNN 
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Appendix I:  Worldwide Data Coverage & Postal 

Code Access 
 
 
PC*MILER Version 31* data highlights include extensive updates in over 200 countries and 
territories; the addition of over 104,000 miles of highway network, 83,000 new cities, and 112,000 
additional postal codes since Version 30. *Worldwide data is updated several months after the base version 
release each year. 
 
Highway and Street-Level Data Coverage by Region 

 

Region Number of 
Countries 

Highway 
Distance 
 (Miles) 

Streets  
 Distance1  

(Miles) 
Number of 

Cities 
Number of 

Postal Codes 
Africa  58 4 67,739 4,934,585 193,358 9,010 
Asia  32 1,057,348 5,691,830 988,825 1,014,694 
Europe  58 1,902,288 11,304,005 784,508 1,180,106 
Middle East 16 227,411 680,626 148,901 58,875 
North 
America  7 1,090,775 8,026,006 267,751 1,047,5962 
Oceania 23 160,051 852,445 22,013 24,925 
South 
America  48 517,760 2,668,728 140,831 125,776 
TOTAL 242 5,423,372 34,158,225 2,546,187 3,460,982 

1  Available with purchase of the PC*MILER|Streets add-on.  Street-level coverage for each region is available only 
for select countries with coverage level Comprehensive and High.  Street-level mileage includes highway miles. 

2  Includes Canadian Postal Codes available with purchase of data add-on. 
 
 
 

Countries With Significant Street-Level Coverage* – Version 31 
 
Region Countries 

Africa 
Algeria, Botswana, Egypt, Kenya, Lesotho, Mayotte, Morocco, Mozambique, 
Namibia, Reunion, South Africa, Swaziland, Tunisia, Western Sahara, 
Zambia, Zimbabwe 

Asia  Brunei, Hong Kong, India, Indonesia, Macau, Malaysia, Philippines, 
Singapore, Taiwan, Thailand, Vietnam 

Europe  All countries except Armenia, Azerbaijan, Faroe Islands, Georgia, 
Kyrgyzstan, Svalbard, Tajikistan, Turkmenistan, and Uzbekistan 

Middle East Bahrain, Israel, Jordan, Kuwait, Lebanon, Oman, Qatar, Saudi Arabia, United 
Arab Emirtes, West Bank 

North America Canada, Puerto Rico, United States 
Oceania Australia, New Zealand, Norfolk Island  

South America  
Argentina, Bahamas, Brazil, Cayman Islands, Chile, Colombia, Costa Rica, 
Falkland Islands, French Guiana, Guadeloupe, Martinique, Panama, 
Paraguay, Peru, Saint Barthelemy, Uruguay, Venezuela 

* Includes High and Comprehensive coverage (see next page), data for some countries does not include truck attributes. 
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NOTE: When calculating routes using Streets data sets in regions outside North America, 
note that routes cannot be run within or across countries not included in the selected data 
set.  The Worldwide Highway data set must be used to run routes to/from countries that 
are not covered in the Streets data set. 

 
PC*MILER|Worldwide 31 Data Coverage - Overview 
 
The map and table below shows a high level overview of the map data coverage offered in 
PC*MILER|Worldwide 31.  For more information, please contact ALK at pcmsupport@alk.com.   

 

 
 

Coverage Level* Road Coverage Locations Truck-Specific 
Attributes 

Comprehensive Comprehensive Street Level  Cities, postal codes, addresses  Yes 

High Comprehensive Street Level  Cities, postal codes, addresses  No 

Intermediate  Complete Highway + Street Level  Cities, some postal codes,                        
some addresses  No 

Entry Basic Highway + Some Streets  Cities, some postal codes  No 

Basic City to City Road Network Cities No 

* Coverage levels are assigned based on road coverage.  Postal code attributes  
generally correspond to the level of road coverage, with some exceptions 

 

mailto:pcmsupport@alk.com
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Appendix J: 
Weather Alert Types Included  

in Alert Categories 
 

The categories in PC*MILER’s Weather Alerts Display dialog and Alerts map legend include 
the weather alert types listed below.  All weather alerts data is provided by the U.S. National 
Weather Service/National Oceanic and Atmospheric Administration and Environment Canada. 
 
Winter/Snow Alerts 

• Avalanche Advisory 
• Avalanche Warning 
• Avalanche Watch 
• Blizzard Warning 
• Blizzard Watch 
• Extreme Cold Warning 
• Extreme Cold Watch 
• Freeze Warning 
• Freeze Watch 
• Freezing Fog Advisory 
• Freezing Rain Advisory 
• Freezing Spray Advisory 
• Frost Advisory 
• Hard Freeze Warning 
• Heavy Freezing Spray Warning 
• Heavy Freezing Spray Watch 
• Ice Storm Warning 
• Lake Effect Snow Advisory 
• Lake Effect Snow Warning 
• Lake Effect Snow Watch 
• Winter Storm Warning 
• Winter Storm Watch 
• Winter Weather Advisory 

Storm Alerts 

• Evacuation – Immediate 
• Hazardous Weather Outlook 
• Hurricane Local Statement 
• Hurricane Warning 
• Hurricane Watch 
• Severe Thunderstorm Warning 
• Severe Thunderstorm Watch 
• Severe Weather Statement 
• Shelter In Place Warning 
• Short Term Forecast 
• Special Weather Statement 
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• Storm Warning 
• Storm Watch 
• Tornado Warning 
• Tornado Watch 
• Tropical Depression Local Statement 
• Tropical Storm Local Statement 
• Tropical Storm Warning 
• Tropical Storm Watch 
• Typhoon Local Statement 
• Typhoon Warning 
• Typhoon Watch 
• Volcano Warning 

Heat Alerts 

• Excessive Heat Warning 
• Extreme Fire Danger 
• Heat Advisory 

Hazmat Alerts 

• Hazardous Materials Warning 
• Nuclear Power Plant Warning 
• Radiological Hazard Warning 

Flood/Water Alerts 

• Arroyo and Small Stream Flood Advisory  
• Beach Hazards Statement  
• Coastal Flood Advisory  
• Coastal Flood Statement  
• Coastal Flood Warning  
• Coastal Flood Watch  
• Flash Flood Statement  
• Flash Flood Warning  
• Flash Flood Watch  
• Flood Advisory  
• Flood Statement  
• Flood Warning  
• Flood Watch  
• Hazardous Seas Warning  
• Hazardous Seas Watch  
• High Surf Advisory  
• High Surf Warning  
• Hydrologic Advisory  
• Hydrologic Outlook  
• Lakeshore Flood Advisory 
• Lakeshore Flood Statement  
• Lakeshore Flood Warning  
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• Lakeshore Flood Watch  
• Low Water Advisory  
• Marine Weather Statement  
• Rip Current Statement 
• Small Craft Advisory  
• Small Craft Advisory For Hazardous Seas  
• Small Craft Advisory For Rough Bar  
• Small Stream Flood Advisory  
• Special Marine Warning  
• Tsunami Advisory  
• Tsunami Warning  
• Tsunami Watch  
• Urban and Small Stream Flood Advisory 

 Fire Alerts 

• Fire Warning 
• Fire Weather Watch 
• Red Flag Warning 

Earthquake Alerts 

• Earthquake Warning 

Civil Alerts 

• 911 Telephone Outage  
• Administrative Message 
• Child Abduction Emergency  
• Civil Danger Warning  
• Civil Emergency Message  
• Law Enforcement Warning  
• Local Area Emergency  
• Test  

Air Quality Alerts 

• Air Quality Alert  
• Air Stagnation Advisory  
• Ashfall Advisory  
• Ashfall Warning  
• Blowing Dust Advisory  
• Dense Fog Advisory  
• Dense Smoke Advisory  
• Dust Storm Warning  
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Wind Alerts  

• Brisk Wind Advisory  
• Small Craft Advisory for Winds  
• Extreme Wind Warning  
• Gale Warning  
• Gale Watch 
• High Wind Warning 
• High Wind Watch 
• Hurricane Force Wind Warning 
• Hurricane Force Wind Watch 
• Lake Wind Advisory 
• Wind Advisory 
• Wind Chill Advisory 
• Wind Chill Warning 
• Wind Chill Watch 
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Index 
 
 
53 Foot access policies, 249 
53 Foot Trailer or Twins routing, 12, 15, 16, 

166 
 
A 
abbreviations in addresses, 55 
accented letters, 54 
access routes and policies, 16, 249 
Add Comments box, 189 
address entry, 54, 167 
address entry, 55 
address entry, 273 
ALK Cloud Services, 225 
Application Settings, 151 
arrival/departure, 115, 170 
AS400 installation, 39 
automobile routing, 175 
avoid route segments, 189 
Avoid/Favor Manager, 191 
avoid/favors, 167 
axles, 131, 132 
 
B 
backing up custom files, 210 
border crossings, 62 
borders open/closed, 167 
 
C 
Canadian counties, 260 
Canadian place names, 54 
Canadian postal codes, 54, 61 
CAT Scale weigh stations, 68 
CICS installation, 39 
Citrix and Terminal Services installs, 38 
city names, entering, 52 
clean up distance, 167 
closures, 180 
cloud account, 225 
column adjustments, 77 
Comment box, 152, 189 
Comparison report, 148 

confidence level, custom place importing, 
106 

Copy Latitude/Longitude command, 187 
copying a map, 188 
copying a stop, 73 
cost and time estimates, 89, 109, 114, 117, 

118, 156 
country abbreviations, 263 
country code formats, 57, 160, 266 
currency conversion rate, 158 
Custom Place Manager, 98 
custom places 

adding, 96 
converting from previous version, 108 
exporting, 108 
importing, 100, 108 
managing, 98 
search along a route, 85 
search within a radius, 83 
sharing, 225, 230 

custom road file conversion, 199 
custom roads, 167 
Custom Roads report, 196 
custom routing, 189 

adjust for hazmat permits, 217 
avoid/favor route segments, 189 
drag route, 202 
geofences, 202 
hazmat permits, 217 
override restrictions, 192 
sets of road preferences, 194 
via points, 199 

 
D 
Data Installation Reminder, 152 
data matching, 100 
data set, changing, 57 
database for PC*MILER, 10 
deactivating a PC*MILER license, 42 
decimal places in mileage, 159 
default city match, 58 
default route options, 162 
default vehicle dimensions, 175 
designated truck routes, 180 



  

 
 Index 301 

Detailed Route report, 143 
discount programs for tolls, 158 
distance calculation, 11 
distance precision, 159 
dock window pane, 48 
Drag Routing option, 202 
dragging a stop, 73 
Driver’s report, 146 
driving directions, 146 
duplicate city names, 71 
duplicate route, 79 
duration of stops, 89 
 
E 
editing stops, 72 
empty stop, 70 
Energy dataset, 221 
error messages, 71 
estado abbreviations, 265 
ETA/ETD, 113 
Export All button, 196 
 
F 
Fastest routing, 14 
favor route segments, 189 
ferry distances, 154 
ferry distances allowed, 166 
File application menu, 44 
file conversion from earlier versions, 40 
FIPS codes, 57, 160 
float window pane, 48 
font size in reports, 149 
frame options, 177 
frame stop, 74 
framing routes, 77 
fuel cost per gallon/liter, 157 
fuel cost per mile/kilometer, 157 
fuel in gallons/liters, 159 
fuel price search, 87 
fuel prices, 152 
fuel stops search, 87 
fuel tax reporting, 13 
full-size van, 175 
 
G 
gallons/liters, 159 

GENC codes, 57, 160 
geofences, 202 

conversion utility, 210 
creating, 203 
report, 208 

governor speed limit, 166 
greenhouse gas emissions, 157 
 
H 
hazardous material routing, 212 
hazmat routing 

adjust for permits, 217 
hide window pane, 48 
highway junctions, 63 
Highway Only option, 167 
Highway Only routing, 167 
HOS rules summary, 94 
Hours of Service, 89 
hub routing, 169 
 
I 
importing custom places, 100 
importing saved settings, 40 
installation, 25 
installing to a mapped drive, 35 
international borders, 167 
ISO codes, 57, 160 
 
L 
labor cost per hour, 158 
land survey addresses, 221 
latitude/longitude points 

using with addresses, 66 
Least Cost routing, 19, 109 
liters/gallons, 159 
loaded stop, 70 
local mileage, 167 
location radius, 81 
 
M 
map data set, changing, 57 
map window. See Map window 
Map window, 45, 176 

copying, 188 
frame options, 177 
lat/long tracking in, 64, 65 
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map styles in, 183 
picking stops from, 70, 187 
points of interest, 187 
printing, 188 
right mouse menu, 185 
route distance tooltip, 185 
satellite image layer, 183 
scroll bars, 179 
zoom options, 178 

maximum speed limit, 166 
Mexican postal codes, 53, 153 
Mileage report, 78, 142 
miles/kilometers per gallon/liter, 157 
military time, 159 
multiple trailer, 175 
 
N 
National Network access policies, 249 
National Network designation, 180 
National Network routing, 15, 166 
new route, 49 
NL abbreviation option, 54, 153 
 
O 
open a saved trip, 79 
optimizing routes, 80 
other route costs, 158 
override hazmat restrictions, 217 
override truck restrictions, 192 
oversize permits, 174 
Oversized Access designation, 180 
oversized vehicle access policies, 249 
 
P 
PC*MILER Sales, 242 
PC*MILER|Energy, 220 
PC*MILER|Energy installation, 33 
PC*MILER|TripDirect. See TripDirect 
PC*MILER|Worldwide installation, 33 
permits for oversize, 174 
pick list for stop entry, 53, 55, 58, 153 
picking stops from the map, 70, 187 
POI search 

along a route, 85 
fuel prices, 87 
fuel stops, 87 

radial around a location, 83 
points of interest icons, 187 
postal code formats worldwide, 291 
postal code help, 60 
postal code preference option, 153 
postal codes, entering, 59 
Practical route, 13 
printing a map, 188 
printing reports, 150 
Provide Pick List option, 58 
province abbreviations, 263 
proxy setup, 40 
 
Q 
Quick Access Toolbar, 46 
 
R 
ramp speed, 155 
region 

default, 152 
region-to-region routing, 57 
report location, 142 
report memo, 170 
Report Memo, 170 
reports 

Comparison, 148 
copying, 150 
Detailed Route, 143 
Driver’s, 146 
font size, 149 
Geofence, 208 
Least Cost comparison, 112 
memo field in, 170 
Mileage, 78, 142 
printing, 150 
Road Type, 148 
saving, 150 
State/Country, 145 

requirements, 20 
resizing a route window, 76 
restricted roads, 180, 192, 217 
restriction overrides, 168 
restrictions, 168 
reversing the stop order, 75 
Ribbon toolbars, 45 
right mouse map menu, 185 
road classifications, 155 
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road closure, 180 
road network, 166 
road speeds, 115, 155, 170 
road surface conditions, 141 
Road Type report, 148 
route 

cost and time estimates, 76, 114, 117, 118 
entry, 50 
new, 49 
optimization, 80 
running, 75 
type descriptions, 11 

route costs, 156 
route distance tooltip, 185 
route framing, 77 
route name, 170 
route options, 151, 165, 169 

hazmat routing, 212 
Streets mode, 167 
use ferry distance, 154 

route options display, 49 
route profile, 161, 172 

creating, 162 
editing, 163 
favorites, 163 
managing, 163 
options, 165 
selecting, 164 

route window features, 49, 75 
route window resizing, 76 
routing types, 11 
 
S 
satellite image map layer, 183 
save routes as text files, 79 
saved custom roads - importing, 199 
saving trips, 79 
seasonal routing, 194 
sets of road preferences, 194 
Settings Importer, 40 
shortcut keys, 48 
Shortest Route, 14 
size restrictions, 168 
spelling help, 59 
SPLC 

as stops, 61 
SPLC help, 62 

State + National Network routing, 15, 166 
state abbreviations, 263 
State Oversized designation, 180 
State/Country report, 145 
state/country report order, 154 
States/Roads Manager, 197 
stop duration, 90 
stop durations, 89 
stop entry, 50 

accented letters, 54 
HOS rest stops, 89 
lat/long formats, 64 
picking stops from the map, 70 
Zoom to Stop feature, 178 

stop list 
copy a stop, 73 
deleting stops, 72 
drag a stop, 73 
editing stops, 72 
moving stops, 72 
optimization, 72 
reversing the stop order, 72 

stop times, 114 
sync data, 230 
system requirements, 20 
 
T 
technical support, 242 
time format, 159 
time zone display, 114 
time zones, 159 
time-based routing, 113 
time-based toll cost reporting, 121, 132 
toll barriers omission, 144 
toll costs 

by state, 134 
by trip leg, 76 
by weight and axle, 131 
calculation, 126 
cashless toll plazas, 128, 280 
currency conversion rate, 158 
currency for, 129 
discount information in reports, 134, 158 
discount programs, 158 
in reports, 133 
number of axles for, 174 
plaza names, 133 
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totals for trip, 134, 135 
vehicle weight for, 131 

Toll Discouraged routing, 18, 165 
toll plaza names in reports, 279 
toll plazas, electronic only, 280 
tooltips 

for weather alerts, 138 
route distance, 185 

traffic data 
map display, 122 
use by default, 117 

Traffic subscription upgrade, 31 
travel speeds, 115, 155, 170 
travel time, 113 
TripDirect, 231 

adding drivers, 233 
managing vehicles, 239 
sending routes to CoPilot, 236 
vehicle display on map, 240 

truck stops, 66 
picking from the map, 70 

truck-discouraged roads, 192 
truck-inaccessible roads, 192 
truck-restricted roads, 180, 192 
 
U 
uninstalling PC*MILER, 42 
units of measure, 159 
 
V 
vehicle dimensions, 172, 173 

defaults, 175 
vehicle type, 172 
via points, 199 
 
W 
warning - Highway Only, 54 
warnings in the Detailed Route report, 144 
waypoints, 199 
weather 

alert categories, 160, 296 
alerts, 139 
features, 136 
reporting, enabling, 160 
reports, 139 

weight restrictions, 168 

window options, 47 
 
Z 
ZIP Code help, 60 
ZIP codes, entering, 59 
zoom options, 178 
zoom to stop, 73, 74 
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